Practical Programs – Hand Book

Instructions:

1. One exercise from **Writer, Calc** and **CSS**, Three exercises from **HTML**, and Four exercises from **JavaScript** are to be practiced in the practical classes.

2. Answer to any one question from Practical Book with internal choice

3. Distribution of Marks

<table>
<thead>
<tr>
<th>I. Internal Assessment:</th>
<th>5 Marks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Record Book</td>
<td>5 Marks</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>II. External Assessment:</th>
<th>15 Marks</th>
</tr>
</thead>
<tbody>
<tr>
<td>(a) Writer or Calc</td>
<td>Procedure</td>
</tr>
<tr>
<td>HTML or CSS or JavaScript</td>
<td>Coding</td>
</tr>
<tr>
<td>(b) Execution &amp; Output</td>
<td>5 Marks</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Total</th>
<th>20 Marks</th>
</tr>
</thead>
</table>
## INDEX

<table>
<thead>
<tr>
<th>Sl. No.</th>
<th>Question Number</th>
<th>Program Name</th>
<th>Page Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>CA1</td>
<td>Open Office Writer - Formatting Invoice</td>
<td>3</td>
</tr>
<tr>
<td>2</td>
<td>CA2</td>
<td>Open Office Calc – Interest Calculation</td>
<td>5</td>
</tr>
<tr>
<td>3</td>
<td>CA3</td>
<td>HTML – Form Design</td>
<td>6</td>
</tr>
<tr>
<td>4</td>
<td>CA4</td>
<td>HTML – Height and Weight Table</td>
<td>8</td>
</tr>
<tr>
<td>5</td>
<td>CA5</td>
<td>HTML – Nested List</td>
<td>10</td>
</tr>
<tr>
<td>6</td>
<td>CA6</td>
<td>CSS – Formatting Webpage</td>
<td>12</td>
</tr>
<tr>
<td>7</td>
<td>CA7</td>
<td>JavaScript – Display Text</td>
<td>15</td>
</tr>
<tr>
<td>8</td>
<td>CA8</td>
<td>JavaScript – Multiplication Table</td>
<td>16</td>
</tr>
<tr>
<td>9</td>
<td>CA9</td>
<td>JavaScript – Display Weekdays in Words</td>
<td>18</td>
</tr>
<tr>
<td>10</td>
<td>CA10</td>
<td>JavaScript – Login Form</td>
<td>20</td>
</tr>
</tbody>
</table>
Type the following Invoice in OpenOffice Writer and apply the formatting features as given below:

Invoice
SAIRAM MEDICAL STORES
Mobile No : 9002416000
Mail Address : sairam@gmail.com
P.B.No: 617
70, New Avadi Road,
Chennai 600 010.

No: 70/162
M/s. Eswari Medical Stores,
No: 72, N.S.C. Bose Road,
Puduchery - 6210110

23rd Nov 2017

No: 70/162
M/s. Eswari Medical Stores,
No: 72, N.S.C. Bose Road,
Puduchery - 6210110

<table>
<thead>
<tr>
<th>Quantity (Nos)</th>
<th>Particulars</th>
<th>Rate</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>20</td>
<td>Johnson Baby Powder</td>
<td>25</td>
<td>500</td>
</tr>
<tr>
<td>10</td>
<td>Nestle Milk Powder</td>
<td>100</td>
<td>1000</td>
</tr>
<tr>
<td>5</td>
<td>Wood Wards Gripe Water</td>
<td>70</td>
<td>350</td>
</tr>
<tr>
<td></td>
<td><strong>Total</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Add: GST @ 3%</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Net Payable</strong></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

For Sriram Medical Stores
Sales Manager

- Use formula to calculate Total and Net Payable

**Procedure**

**Step-1.** OpenOffice Writer and choose Text document or **File → New → Text Document**.

**Step-2.** Type the text and apply the format as per the given format.

**Note:** Select the required text before formatting.

<table>
<thead>
<tr>
<th>Text</th>
<th>Format</th>
<th>Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>INVOICE</td>
<td>Center and apply red</td>
<td>Ctrl + E and choose Red color from font color palette or any method.</td>
</tr>
<tr>
<td>SAIRAM MEDICAL STORES</td>
<td>Center and apply blue</td>
<td>Ctrl + E and Blue color from font color palette or any method.</td>
</tr>
</tbody>
</table>
Step-3. Create a table using any one of the method Ctrl + F12 or Insert → Table or Table → Insert → Table or Insert Table icon from toolbar. with 4 columns and 7 rows.

Step-4. Enter the data as per the given format.

Step-5. Select first three columns in 5th Row and Right Click → Cell → Merge and type as "Total"

Step-6. Repeat Step-5 for 7th Row, and type as "Net payable"

Step-7. To find the Total, Enter the following formula at Total → Amount Column as =<D2>+<D3>+<D4> OR = Sum (<D2:D4>)

Step-8. To find the GST @ 3% Enter the formula as = <B> *0.03

Step-9. To calculate Netpayable amount, Enter the formula as =<B5>+<D6>

**Output**

---

**Invoice**

**SAIRAM MEDICAL STORES**

Mobile No : 9002416000
Mail Address : sairam@gmail.com

P.B.No: 617
70, New Avadi Road,
Chennai 600 010.

No: 70/162

M/s. **Eswari Medical Stores,**
No: 72, N.S.C. Bose Road,
Puduchery - 6210110

23rd Nov 2017

<table>
<thead>
<tr>
<th>Quantity (Nos)</th>
<th>Particulars</th>
<th>Rate</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>20</td>
<td>Johnson Baby Powder</td>
<td>25</td>
<td>500</td>
</tr>
<tr>
<td>10</td>
<td>Nestle Milk Powder</td>
<td>100</td>
<td>1000</td>
</tr>
<tr>
<td>5</td>
<td>Wood Wards Gripe Water</td>
<td>70</td>
<td>350</td>
</tr>
<tr>
<td></td>
<td><strong>Total</strong></td>
<td></td>
<td>1850</td>
</tr>
<tr>
<td></td>
<td>Add: GST @ 3%</td>
<td></td>
<td>55.5</td>
</tr>
<tr>
<td></td>
<td><strong>Net Payable</strong></td>
<td></td>
<td>1905.5</td>
</tr>
</tbody>
</table>

For Sriram Medical Stores

Sales Manager
Create statement of interest using OpenOffice Calc with the following particulars:

Sara Ltd., sells goods. Their policy is to charge interest @ 2% p.a., for the number of days. From the following data, find out the amount to be collected from each customer. Assume 365 days in the year.

<table>
<thead>
<tr>
<th>Customer</th>
<th>Sales</th>
<th>Date of Sale</th>
<th>NO. of days</th>
<th>Date of settlement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tharani</td>
<td>25000</td>
<td>10/04/2017</td>
<td>60</td>
<td></td>
</tr>
<tr>
<td>Mahalakshmi</td>
<td>14000</td>
<td>28/05/2017</td>
<td>30</td>
<td></td>
</tr>
<tr>
<td>Kumar</td>
<td>28000</td>
<td>14/07/2017</td>
<td>45</td>
<td></td>
</tr>
<tr>
<td>Arulmozhi</td>
<td>54000</td>
<td>03/08/2017</td>
<td>90</td>
<td></td>
</tr>
</tbody>
</table>

Procedure

Step 1. Open OpenOffice Calc and choose Spreadsheet or File → New → Spreadsheet.

Step 2. Type the Headings in cell A1 to E1 (Customer, Sales, Date of Sale, Number of days and Date of settlement) as per the given data.

Step 3. In cell F1 and G1 type (Interest Amt and Amount to be paid) respectively.

Step 4. In cell E2 enter the formula = C2 + D2 to arrive the date of settlement and to the remaining cells (E3 to E5). Use Edit → Fill → Down command.

Step 5. In cell F2 enter the formula =ROUND((B2*2/100)*D2/365) to arrive the Interest amount to the remaining cells (F3 to F5). Use Edit → Fill → Down command.

Step 6. In cell G2 enter the formula = B2 + F2 to arrive the Amount to be paid to the remaining cells (G3 to G5). Use Edit → Fill → Down command.

Output
Write an HTML code to design a form like the one shown below.

Registration Form

User Name: [input type=text name=uname]
Password: [input type=password name=pword1]
Re-type Password: [input type=password name=pword2]
Gender: [input type=radio name=male value="M"] Male

Additional Information

Optional Subject: [select name=subject value="Computer Technology"]

[checkbox] Put me on mail list

[button] Reset [button] Submit

Coding

<html>
<head>
<title>User Registration </title>
</head>
<body>
<h1 align=center>Registration Form </h1>
<form id=reg_form method=post action="">
User Name: <input type=text name=uname />
Password: <input type=password name=pword1 />
Re-type Password: <input type=password name=pword2 />
Gender: 
<input type=radio name=male value="M" /> Male
Female

Optional Subject:

- Computer Technology
- Painting
- Sports and Games

Put me on mail list

Put me on mail list

Output
Write an HTML code to display the following.

<table>
<thead>
<tr>
<th>Name</th>
<th>Class</th>
<th>Height</th>
<th>Weight</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mani</td>
<td>XII - G</td>
<td>5'0”</td>
<td>45</td>
</tr>
<tr>
<td>Vasu</td>
<td>XI - H</td>
<td>5'4”</td>
<td>49</td>
</tr>
<tr>
<td>Murali</td>
<td>XI - B</td>
<td>5'1”</td>
<td>51</td>
</tr>
<tr>
<td>Pallavai</td>
<td>XII - D</td>
<td>4'5”</td>
<td>50</td>
</tr>
</tbody>
</table>

**Coding**

```html
<html>
<head>
<title>Height and Weight Table</title>
</head>
<body>
<table border=10>
<caption>Height and Weight</caption>
<tr>
<th width=40%>Name</th>
<th width=20%>Class</th>
<th width=20%>Height</th>
<th width=20%>Weight</th>
</tr>
<tr>
<td>Mani</td>
<td>XII – G</td>
<td>5’0”</td>
<td>45</td>
</tr>
<tr>
<td>Vasu</td>
<td>XI - H</td>
<td>5’4”</td>
<td>49</td>
</tr>
<tr>
<td>Murali</td>
<td>XI - B</td>
<td>5’1”</td>
<td>51</td>
</tr>
<tr>
<td>Pallavai</td>
<td>XII - D</td>
<td>4’5”</td>
<td>50</td>
</tr>
</table>
</body>
</html>
```
<table>
<thead>
<tr>
<th>Name</th>
<th>Class</th>
<th>Height</th>
<th>Weight</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mani</td>
<td>XII - G</td>
<td>5'0&quot;</td>
<td>45</td>
</tr>
<tr>
<td>Vasu</td>
<td>XI - H</td>
<td>5'4&quot;</td>
<td>49</td>
</tr>
<tr>
<td>Murali</td>
<td>XI - B</td>
<td>5'1&quot;</td>
<td>51</td>
</tr>
<tr>
<td>Pallavai</td>
<td>XII - D</td>
<td>4'5&quot;</td>
<td>50</td>
</tr>
</tbody>
</table>
Write an HTML code to create a webpage to display the following sets of lists:

<table>
<thead>
<tr>
<th>1. Tamilnadu</th>
<th>• Languages</th>
</tr>
</thead>
<tbody>
<tr>
<td>a. Chennai</td>
<td>o Tamil</td>
</tr>
<tr>
<td>b. Madurai</td>
<td>o Malayalam</td>
</tr>
<tr>
<td></td>
<td>o Telugu</td>
</tr>
<tr>
<td>2. Andhra Pradesh</td>
<td>• Science</td>
</tr>
<tr>
<td>a. Amaravathi</td>
<td>o Physics</td>
</tr>
<tr>
<td>b. Vijayawada</td>
<td>o Chemistry</td>
</tr>
<tr>
<td></td>
<td>o Zoology</td>
</tr>
<tr>
<td>3. Kerala</td>
<td>• Humanities</td>
</tr>
<tr>
<td>a. Thiruvananthapuram</td>
<td>o History</td>
</tr>
<tr>
<td>b. Cochin</td>
<td>o Commerce</td>
</tr>
<tr>
<td></td>
<td>o Economics</td>
</tr>
</tbody>
</table>

**Coding**

```html
<html>
<head>
<title> Sets of Lists </title>
</head>
<body>
<OL>
    <LI> Tamilnadu
        <OL type=a>
            <LI> Chennai
            <LI> Madurai
        </OL>
    <LI> Andhra Pradesh
        <OL type=a>
            <LI> Amaravathi
            <LI> Vijayawada
        </OL>
    <LI> Kerala
        <OL type=a>
            <LI> Thiruvananthapuram
            <LI> Cochin
        </OL>
</OL>
<UL>
    <LI> Languages
```
<UL type=circle>
  <LI> Tamil
  <LI> Malayalam
  <LI> Telugu
</UL>
<LI> Science
  <UL type=circle>
    <LI> Physics
    <LI> Chemistry
    <LI> Zoology
  </UL>
<LI> Humanities
  <UL type=circle>
    <LI> History
    <LI> Commerce
    <LI> Economics
  </UL>
</UL>
</body>
</html>

Output

1. Tamilnadu
   a. Chennai
   b. Madurai
2. Andhra Pradesh
   a. Amaravathi
   b. Vijayawada
3. Kerala
   a. Thiruvananthapuram
   b. Cochin
• Languages
  o Tamil
  o Malayalam
  o Telugu
• Science
  o Physics
  o Chemistry
  o Zoology
• Humanities
  o History
  o Commerce
  o Economics
Tamil

Tamil is a Dravidian language predominantly spoken by the Tamil people of India and Sri Lanka, and by the Tamil diaspora, Sri Lankan Moors, Burghers, Douglas, and Chindians. Tamil is an official language of two countries: Sri Lanka and Singapore.

It has official status in the Indian state of Tamil Nadu and the Indian Union Territory of Puducherry. It is used as one of the languages of education in Malaysia, along with English, Malay and Mandarin.

Tamil is spoken by significant minorities in the four other South Indian states of Kerala, Karnataka, Andhra Pradesh and Telangana and the Union Territory of the Andaman and Nicobar Islands. It is one of the 22 scheduled languages of India.

Description:

<table>
<thead>
<tr>
<th>Element</th>
<th>Font</th>
<th>Style</th>
<th>Alignment</th>
<th>Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>H1</td>
<td>Arial Black</td>
<td>-</td>
<td>Center</td>
<td>Border 2px solid blue</td>
</tr>
<tr>
<td>P1</td>
<td>Century</td>
<td>Bold</td>
<td>-</td>
<td>Red</td>
</tr>
<tr>
<td>P2</td>
<td>Boockman Old Style</td>
<td>Italic</td>
<td>-</td>
<td>Blue</td>
</tr>
<tr>
<td>P3</td>
<td>Century Gothic</td>
<td>-</td>
<td>-</td>
<td>Green</td>
</tr>
</tbody>
</table>

Note: Create two files. 1. Mystyle.css and 2. CA6.html

Coding -1

Mystyle.css

H1
{
  font-family: "Arial Black";
  text-align:center;
  border : 2px solid blue;
}
Tamil is a Dravidian language predominantly spoken by the Tamil people of India and Sri Lanka, and by the Tamil diaspora, Sri Lankan Moors, Burghers, Douglas, and Chindians. Tamil is an official language of two countries: Sri Lanka and Singapore.
It has official status in the Indian state of Tamil Nadu and the Indian Union Territory of Puducherry. It is used as one of the languages of education in Malaysia, along with English, Malay and Mandarin.

Tamil is spoken by significant minorities in the four other South Indian states of Kerala, Karnataka, Andhra Pradesh and Telangana and the Union Territory of the Andaman and Nicobar Islands. It is one of the 22 scheduled languages of India.
CA7 - DISPLAY TEXT

CA-7 Create a webpage using JavaScript to display the following text.

Welcome to JavaScript
State Council of Educational Research and Training (SCERT),
Tamilnadu, Chennai.

Coding

<html>
<head>
<title> Display text using JavaScript </title>
</head>
<body align=center>
<p>
<script>
document.write("<h1 align=center>Welcome to JavaScript <br>
State Council of Educational Research and Training (SCERT), <br>
Tamilnadu, Chennai.</h1>");
</script>
</p>
</body>
</html>

Output

Welcome to JavaScript
State Council of Educational Research and Training (SCERT),
Tamilnadu, Chennai.
Create a webpage using JavaScript to display multiplication table by prompting number of rows and columns.

Coding

```html
<html>
<head>
<title>Multiplication Table</title>
<script type="text/javascript">
var rows = prompt("How many rows for your multiplication table?");
var cols = prompt("How many columns for your multiplication table?");
if(rows == "" || rows == null)
    rows = 10;
if(cols== "" || cols== null)
    cols = 10;
createTable(rows, cols);
function createTable(rows, cols)
{
    var j=1;
    var output ="<table border='1' width='500' cellspacing='0' cellpadding='5'>";
    for(i=1;i<=rows;i++)
    {
        output = output + "<tr>";
        while(j<=cols)
        {
            output = output + "<td>" + i*j + "</td>";
            j = j+1;
        }
        output = output + "</tr>";
        j = 1;
    }
    output = output + "</table>";
</script>
</head>
<body>
</body>
</html>
```
document.write(output);
}
</script>
</head>
<body>
</body>
</html>
CA9 - DISPLAY WEEKDAYS IN WORDS

CA-9
Create a webpage using JavaScript to display Weekday in words by getting input as a number using switch.

Coding

<html>
<head>
<title>Weekday</title>
<script type="text/javascript">
var n=prompt("Enter a number between 1 and 7");
switch (n)
{
case (n="1"):
document.write("Sunday");
break;
case (n="2"):
document.write("Monday");
break;
case (n="3"):
document.write("Tuesday");
break;
case (n="4"):
document.write("Wednesday");
break;
case (n="5"):
document.write("Thursday");
break;
case (n="6"):
document.write("Friday");
break;
case (n="7"):
document.write("Saturday");
</script>
</head>
</html>
break;
default:
document.write("Invalid Weekday");
break;
}
</script>
</head>
</html>
Create a Form using JavaScript to get username, password and address, validate the inputs.

### Coding

```html
<html>
<head>
<script type="text/javascript">
function sub()
{
    if(document.getElementById("t1").value == "")
        alert("Please enter your name");
    else if(document.getElementById("t2").value == "")
        alert("Please enter a password");
    else if(document.getElementById("t2").value != document.getElementById("t3").value)
        alert("Please enter correct password");
    else if(document.getElementById("t4").value == "")
        alert("Please enter your address");
    else
        alert("Form has been submitted");
}
</script>
</head>
<body>
<form>
<p align="center">
User Name:<input type="text" id="t1"><br><br>
Password:<input type="text" id="t2"><br><br>
Confirm Password:<input type="text" id="t3"><br><br>
Address:<textarea rows="2" cols="25" id="t4"></textarea><br><br>
<input type="button" value="Submit" onclick="sub()"
><input type="reset" value="Clear All">
</p>
</form>
</body>
</html>
```
Output
## Internal Choice For The Programs

<table>
<thead>
<tr>
<th>Qno.</th>
<th>Question</th>
<th>Qno.</th>
<th>Question</th>
<th>Choice</th>
</tr>
</thead>
<tbody>
<tr>
<td>CA1</td>
<td>Writer - Formatting Invoice</td>
<td>CA6</td>
<td>CSS – Formatting Webpage</td>
<td>CA1 or CA10</td>
</tr>
<tr>
<td>CA2</td>
<td>Calc – Interest Calculation</td>
<td>CA7</td>
<td>JavaScript – Display Text</td>
<td>CA2 or CA8</td>
</tr>
<tr>
<td>CA3</td>
<td>HTML – Form Design</td>
<td>CA8</td>
<td>JavaScript – Multiplication Table</td>
<td>CA3 or CA9</td>
</tr>
<tr>
<td>CA4</td>
<td>HTML – Height and Weight Table</td>
<td>CA9</td>
<td>JavaScript – Display Weekdays in Words</td>
<td>CA4 or CA6</td>
</tr>
<tr>
<td>CA5</td>
<td>HTML – Nested List</td>
<td>CA10</td>
<td>JavaScript – Login Form</td>
<td>CA5 or CA7</td>
</tr>
</tbody>
</table>