Untouchability is Inhuman and a Crime

A publication under Free Textbook Programme of Government of Tamil Nadu

Department of School Education
Human civilization achieved the highest peak with the development of computer known as “Computer era”. Literate are those who have the knowledge in using the computer whereas others are considered illiterate inspite of the other degrees obtained.

The growth of the nation at present lies in the hands of the youth, hence the content of this book is prepared in such a way so as to attain utmost knowledge considering the future needs of the youth.

- This book does not require prior knowledge in computer Technology
- Each unit comprises of simple activities and demonstrations which can be done by the teacher and also students.
- Technical terminologies are listed in glossary for easy understanding
- The “Do you know?” boxes enrich the knowledge of reader with additional information
- Workshops are introduced to solve the exercises using software applications
- QR codes are used to link supporting additional materials in digital form

**How to get connected to QR Code?**
- Download the QR code scanner from the google play store/apple app store into your smartphone
- Open the QR code scanner application
- Once the scanner button in the application is clicked, camera opens and then bring it closer to the QR code in the textbook.
- Once the camera detects the QR code, a URL appears in the screen. Click the URL and go to the content page.
# CAREER GUIDANCE AFTER 12TH

<table>
<thead>
<tr>
<th>COURSES</th>
<th>COLLEGES/UNIVERSITIES</th>
<th>PROFESSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>B.E / B.Tech</td>
<td>All University and their affiliated Colleges and Self financing Colleges in India and Abroad.</td>
<td>Software Engineer, Hardware Engineer, Software Development, Healthcare Section, IT &amp; ITEs</td>
</tr>
</tbody>
</table>

### Science and Humanities

<table>
<thead>
<tr>
<th>Courses</th>
<th>Fields</th>
<th>Universities</th>
<th>Professions</th>
</tr>
</thead>
<tbody>
<tr>
<td>B.Sc (Computer Science) BCA</td>
<td>Science and Humanities</td>
<td>All University and their affiliated Colleges and Self financing Colleges in India and Abroad.</td>
<td>Government Job and Private Company BPO, Geologist, Journalist</td>
</tr>
</tbody>
</table>

## LAW

<table>
<thead>
<tr>
<th>Courses</th>
<th>Universities</th>
<th>Professions</th>
</tr>
</thead>
<tbody>
<tr>
<td>LLB</td>
<td>All University and their affiliated Colleges and Self financing Colleges in India and Abroad.</td>
<td>Lawyer, Legal Officer, Govt Job</td>
</tr>
<tr>
<td>B.A+LLB</td>
<td></td>
<td></td>
</tr>
<tr>
<td>B.Com</td>
<td></td>
<td></td>
</tr>
<tr>
<td>BBM+LLB</td>
<td></td>
<td></td>
</tr>
<tr>
<td>BBA+LLB</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CA</td>
<td>The Institute of Chartered Accountant of India (ICAI)</td>
<td>CA Private and Govt.</td>
</tr>
<tr>
<td>Diploma</td>
<td>Government Polytechnic and Self-financing colleges</td>
<td>Junior Engineer (Government and Private)</td>
</tr>
</tbody>
</table>

## Commerce Courses

<table>
<thead>
<tr>
<th>Courses</th>
<th>Universities</th>
<th>Professions</th>
</tr>
</thead>
<tbody>
<tr>
<td>COURSES/ UNIVERSITIES</td>
<td>PROFESSION</td>
<td></td>
</tr>
<tr>
<td>------------------------</td>
<td>------------</td>
<td></td>
</tr>
<tr>
<td>Management Courses</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Business Management</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Bank Management</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Event Management</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Hospital Management</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Human Resource Management</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Logistics Management</td>
<td></td>
<td></td>
</tr>
<tr>
<td>All University and their affiliated Colleges and Self financing Colleges in India and Abroad.</td>
<td>Private Organization , Government, Banking sectors and prospects for self – employment.</td>
<td></td>
</tr>
<tr>
<td>LAW</td>
<td></td>
<td></td>
</tr>
<tr>
<td>LLB</td>
<td></td>
<td></td>
</tr>
<tr>
<td>B.A+LLB</td>
<td></td>
<td></td>
</tr>
<tr>
<td>B.Com</td>
<td></td>
<td></td>
</tr>
<tr>
<td>BBM+LLB</td>
<td></td>
<td></td>
</tr>
<tr>
<td>BBA+LLB</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CA-Chartered Accountant</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CMA-Cost Management Accountant.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CS-Company Secretary (Foundation)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>The Institute of Chartered Accountant of India (ICAI)</td>
<td>CA, Private Organization, Government, Banking sectors and prospects for self – employment.</td>
<td></td>
</tr>
<tr>
<td>Science and Humanities</td>
<td></td>
<td></td>
</tr>
<tr>
<td>B.Sc.Botany</td>
<td></td>
<td></td>
</tr>
<tr>
<td>B.Sc.Zoology</td>
<td></td>
<td></td>
</tr>
<tr>
<td>B.Sc.Dietician &amp; Nutritionist</td>
<td></td>
<td></td>
</tr>
<tr>
<td>B.Sc.Home Science</td>
<td></td>
<td></td>
</tr>
<tr>
<td>B.Sc.Food Technology</td>
<td></td>
<td></td>
</tr>
<tr>
<td>B.Sc.Dairy Technology</td>
<td></td>
<td></td>
</tr>
<tr>
<td>B.Sc. Hotel Management</td>
<td></td>
<td></td>
</tr>
<tr>
<td>B.Sc. Fashion Design</td>
<td></td>
<td></td>
</tr>
<tr>
<td>B.Sc. Mass Communication</td>
<td></td>
<td></td>
</tr>
<tr>
<td>B.Sc. Multimedia</td>
<td></td>
<td></td>
</tr>
<tr>
<td>B.Sc. -3D Animation</td>
<td></td>
<td></td>
</tr>
<tr>
<td>All University and their affiliated Colleges and Self financing Colleges in India and Abroad</td>
<td>Government Job and Private Company BPO, Geologist, Journalist</td>
<td></td>
</tr>
<tr>
<td>LAW</td>
<td></td>
<td></td>
</tr>
<tr>
<td>LLB</td>
<td></td>
<td></td>
</tr>
<tr>
<td>B.A+LLB</td>
<td></td>
<td></td>
</tr>
<tr>
<td>B.Com</td>
<td></td>
<td></td>
</tr>
<tr>
<td>BBM+LLB</td>
<td></td>
<td></td>
</tr>
<tr>
<td>BBA+LLB</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CA</td>
<td></td>
<td></td>
</tr>
<tr>
<td>The Institute of Chartered Accountant of India (ICAI)</td>
<td>CA Private and Govt.</td>
<td></td>
</tr>
<tr>
<td>Diploma</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Government Polytechnic and Self-financing colleges</td>
<td>Junior Engineer (Government and Private)</td>
<td></td>
</tr>
</tbody>
</table>
# Table of Contents

<table>
<thead>
<tr>
<th>Chapter No.</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>UNIT I - FUNDAMENTALS OF COMPUTER AND WORKING WITH A TYPICAL OPERATING SYSTEMS (WINDOWS &amp; LINUX)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>Introduction to Computers</td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>Number Systems</td>
<td>18</td>
</tr>
<tr>
<td>3</td>
<td>Computer Organization</td>
<td>40</td>
</tr>
<tr>
<td>4</td>
<td>Operating Systems</td>
<td>53</td>
</tr>
<tr>
<td>5</td>
<td>Working with Typical Operating System (Windows &amp; Linux)</td>
<td>67</td>
</tr>
<tr>
<td>UNIT II - OFFICE AUTOMATION TOOLS (WORD PROCESSOR, SPREADSHEET AND PRESENTATION)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Word Processor Basics (OpenOffice Writer)</td>
<td>106</td>
</tr>
<tr>
<td>7</td>
<td>Spreadsheet-Basics (OpenOffice Calc)</td>
<td>155</td>
</tr>
<tr>
<td>8</td>
<td>Presentation-Basics (OpenOffice Impress)</td>
<td>223</td>
</tr>
</tbody>
</table>
Goals of the Course

What you have learned in this chapter, the students will be able to:

1. To know about Computers
2. To learn about various generations of computers
3. To understand the basic operations of computers
4. To know the components and their functions.
5. To know about booting of a computer

Father of Computer

Charles Babbage is considered to be the father of computer, for his invention and the concept of Analytical Engine in 1837. The Analytical Engine contained an Arithmetic Logic Unit (ALU), basic flow control, and integrated memory; which led to the development of first general-purpose computer concept.

Introduction to Computers

1.1 Introduction to Computers

Computers are seen everywhere around us, in all spheres of life, in the field of education, research, travel and tourism, weather forecasting, social networking, e-commerce etc. Computers have now become an indispensable part of our lives. Computers have revolutionized our lives with their accuracy and speed of performing a job, it is truly remarkable. Today, no organization can function without a computer. In fact, various organizations have become paperless. Computers have evolved over the years from a simple calculating device to high speed portable computers.

The growth of computer industry started with the need for performing fast calculations. The manual method of computing was slow and prone to errors. So, attempts were made to develop fast calculating devices, the journey started from the first known calculating device (Abacus) which has led us today to an extremely high speed calculating devices.

1.2 Generations of Computers

Growth in the computer industry is determined by the development in technology.

Based on various stages of development, computers can be categorized into different generations.
<table>
<thead>
<tr>
<th>SN</th>
<th>Generation</th>
<th>Period</th>
<th>Main Component used</th>
<th>Merits/Demerits</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>First Generation</td>
<td>1942-1955</td>
<td>Vacuum tubes</td>
<td>• Big in size&lt;br&gt;• Consumed more power&lt;br&gt;• Malfunction due to overheat&lt;br&gt;• Machine Language was used</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>First Generation Computers - ENIAC, EDVAC, UNIVAC 1&lt;br&gt;ENIAC weighed about 27 tons, size 8 feet × 100 feet × 3 feet and consumed around 150 watts of power</td>
</tr>
<tr>
<td>2</td>
<td>Second Generation</td>
<td>1955-1964</td>
<td>Transistors</td>
<td>• Smaller compared to First Generation&lt;br&gt;• Generated Less Heat&lt;br&gt;• Consumed less power compared to first generation&lt;br&gt;• Punched cards were used&lt;br&gt;• First operating system was developed - Batch Processing and Multiprogramming Operating System&lt;br&gt;• Machine language as well as Assembly language was used</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Second Generation Computers - IBM 1401, IBM 1620, UNIVAC 1108</td>
</tr>
<tr>
<td>3</td>
<td>Third Generation</td>
<td>1964-1975</td>
<td>Integrated Circuits (IC)</td>
<td>• Computers were smaller, faster and more reliable&lt;br&gt;• Consumed less power&lt;br&gt;• High Level Languages were used</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Third Generation Computers - IBM 360 series, Honeywell 6000 series</td>
</tr>
<tr>
<td>4</td>
<td>Fourth Generation</td>
<td>1975-1980</td>
<td>Microprocessor Very Large Scale Integrated Circuits (VLSI)</td>
<td>• Smaller and Faster&lt;br&gt;• Microcomputer series such as IBM and APPLE were developed&lt;br&gt;• Portable Computers were introduced</td>
</tr>
</tbody>
</table>
### Table 1.1 Generations of Computers

<table>
<thead>
<tr>
<th>Generation</th>
<th>Date</th>
<th>Characteristics</th>
</tr>
</thead>
</table>
| Fifth      | 1980 - till date | - Parallel Processing  
- Super conductors  
- Computers size was drastically reduced.  
- Can recognize Images and Graphics  
- Introduction of Artificial Intelligence and Expert Systems  
- Able to solve high complex problems including decision making and logical reasoning |
| Sixth      | In future     | - Parallel and Distributed computing  
- Computers have become smarter, faster and smaller  
- Development of robotics  
- Natural Language Processing  
- Development of Voice Recognition Software |

#### The first digital computer

The ENIAC (Electronic Numerical Integrator And Calculator) was invented by J. Presper Eckert and John Mauchly at the University of Pennsylvania and began construction in 1943 and was not completed until 1946. It occupied about 1,800 square feet and used about 18,000 vacuum tubes, weighing almost 50 tons. ENIAC was the first digital computer because it was fully functional.

#### 1.3 Sixth Generation Computing

In the Sixth Generation, computers could be defined as the era of intelligent computers, based on Artificial Neural Networks. One of the most dramatic changes in the sixth generation will be the explosive growth of Wide Area Networking. Natural Language Processing (NLP) is a component of Artificial Intelligence (AI). It provides the ability to develop the computer program to understand human language.
Optical Character Recognition (Optical Grapheme Recognition) engine for the Indus Scripts has been developed using Deep Learning Neural Networks (a sub-field of Artificial Intelligence).

Given photographs, scans, or any image feed of an Indus Valley Civilization artifact, the system will be able to recognize the inscriptions (the symbol/grapheme sequences) from the image. There are totally 417 Symbols/Graphemes/Characters in the Indus Scripts and just 3700+ text inscriptions of data for the machine to learn and attain expert-level status.

1.4. Data and Information

We all know what a computer is? It is an electronic device that processes the input according to the set of instructions provided to it and gives the desired output at a very fast rate. Computers are very versatile as they do a lot of different tasks such as storing data, weather forecasting, booking airlines, railway or movie tickets and even playing games.

Computer - man or machine?

Before 19th century, the term “Computer” was referred to humans who performed calculations using Abacus and Slide Rule and not to machine.

The term “computer” is derived from the word “compute” which means to calculate. The person who performs calculation is called as Computer. This term was later given to mechanical device as they began replacing the human computers.

Today’s computers are electronic devices that accept data as input, process it, produce output and stores it for future reference.

Data: Data is defined as an unprocessed collection of raw facts, suitable for communication, interpretation or processing.

For example, 134, 16 ‘Kavitha’, ‘C’ are data. This will not give any meaningful message.

Information: Information is a collection of facts from which conclusions may be drawn. In simple words we can say
that data is the raw facts that is processed to give meaningful, ordered or structured information. For example Kavitha is 16 years old. This information is about Kavitha and conveys some meaning. This conversion of data into information is called data processing.

"A Computer is an electronic device that takes raw data (unprocessed) as an input from the user and processes it under the control of a set of instructions (called program), produces a result (output), and saves it for future use."

1.5 Components of a Computer

The computer is the combination of hardware and software. Hardware is the physical component of a computer like motherboard, memory devices, monitor, keyboard etc., while software is the set of programs or instructions. Both hardware and software together make the computer system to function.

Let us first have a look at the functional components of a computer. Every task given to a computer follows an Input- Process- Output Cycle (IPO cycle). It needs certain input, processes that input and produces the desired output. The input unit takes the input, the central processing unit does the processing of data and the output unit produces the output. The memory unit holds the data and instructions during the processing.

1.5.1 Input Unit

Input unit is used to feed any form of data to the computer, which can be stored in the memory unit for further processing. Example: Keyboard, mouse, etc.

1.5.2 Central Processing Unit

CPU is the major component which interprets and executes software instructions. It also control the operation of all other components such as memory, input and output units. It accepts binary data as input, process the data according to the instructions and provide the result as output.

The CPU has three components
which are Control unit, Arithmetic and logic unit (ALU) and Memory unit.

1.5.2.1 Arithmetic and Logic Unit

The ALU is a part of the CPU where various computing functions are performed on data. The ALU performs arithmetic operations such as addition, subtraction, multiplication, division and logical operations. The result of an operation is stored in internal memory of CPU. The logical operations of ALU promote the decision-making ability of a computer.

1.5.2.2 Control Unit

The control unit controls the flow of data between the CPU, memory and I/O devices. It also controls the entire operation of a computer.

1.5.3. Output Unit

An Output Unit is any hardware component that conveys information to users in an understandable form. Example: Monitor, Printer etc.

1.5.4. Memory Unit

The Memory Unit is of two types which are primary memory and secondary memory. The primary memory is used to temporarily store the programs and data when the instructions are ready to execute. The secondary memory is used to store the data permanently.

The Primary Memory is volatile, that is, the content is lost when the power supply is switched off. The Random Access Memory (RAM) is an example of a main memory. The Secondary memory is non volatile, that is, the content is available even after the power supply is switched off. Hard disk, CD-ROM and DVD ROM are examples of secondary memory.

1.5.5. Input and Output Devices

Input Devices:

(1) Keyboard: Keyboard (wired / wireless, virtual) is the most common input device used today. The individual keys for letters, numbers and special characters are collectively known as character keys. This keyboard layout is derived from the keyboard of original typewriter. The data and instructions are given as input to the computer by typing on the keyboard. Apart from alphabet and numeric keys, it also has Function keys for performing different functions. There are different set of keys available in the keyboard such as character keys, modifier keys, system and GUI keys, enter and editing keys, function keys, navigation keys, numeric keypad and lock keys.

(2) Mouse: Mouse (wired/wireless) is a pointing device used to control the movement of the cursor on the display screen. It can be used to select icons, menus, command buttons or activate something on a computer. Some mouse
actions are move, click, double click, right click, drag and drop.

Different types of mouse available are: Mechanical Mouse, Optical, Laser Mouse, Air Mouse, 3D Mouse, Tactile Mouse, Ergonomic Mouse and Gaming Mouse.

<table>
<thead>
<tr>
<th>SN</th>
<th>Type of Mouse</th>
<th>Mechanism</th>
<th>Developed and Introduced</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Mechanical Mouse</td>
<td>• A small ball is kept inside and touches the pad through a hole at the bottom of the mouse.</td>
<td>Telefunken, German Company, 02/10/1968</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• When the mouse is moved, the ball rolls.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• This movement of the ball is converted into signals and sent to the computer.</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Optical Mouse</td>
<td>• Measures the motion and acceleration of pointer.</td>
<td>• In 1988, Richard Lyon, Steve Krish independently invented different versions of Optical Mouse.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• It uses light source instead of ball to judge the motion of the pointer.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Optical mouse has three buttons.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Optical mouse is less sensitive towards surface.</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Laser Mouse</td>
<td>• Measures the motion and acceleration of pointer.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Laser Mouse uses Laser Light</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Laser Mouse is highly sensitive and able to work on any hard surface.</td>
<td></td>
</tr>
</tbody>
</table>

Table 1.2 Commonly used Mouse
Who invented Mouse?

The computer mouse as we know it today was invented and developed by Douglas Engelbart, with the assistance of Bill English, during the 1960's and was patented on November 17, 1970.

(3) Scanner: Scanners are used to enter the information directly into the computer's memory. This device works like a Xerox machine. The scanner converts any type of printed or written information including photographs into a digital format, which can be manipulated by the computer.

(4) Fingerprint Scanner: Fingerprint Scanner is a fingerprint recognition device used for computer security, equipped with the fingerprint recognition feature that uses biometric technology. Fingerprint Reader / Scanner is a very safe and convenient device for security instead of using passwords, which is vulnerable to fraud and is hard to remember.

(5) Track Ball: Track ball is similar to the upside-down design of the mouse. The user moves the ball directly, while the device itself remains stationary. The user spins the ball in various directions to navigate the screen movements.

(6) Retinal Scanner: This performs a retinal scan which is a biometric technique that uses unique patterns on a person's retinal blood vessels.

(7) Light Pen: A light pen is a pointing device shaped like a pen and is connected to
a monitor. The tip of the light pen contains a light-sensitive element which detects the light from the screen enabling the computer to identify the location of the pen on the screen. Light pens have the advantage of ‘drawing’ directly onto the screen, but this becomes hard to use, and is also not accurate.

(8) Optical Character Reader: It is a device which detects characters printed or written on a paper with OCR, a user can scan a page from a book. The Computer will recognize the characters in the page as letters and punctuation marks and stores. The Scanned document can be edited using a wordprocessor.

(9) Bar Code / QR Code Reader: A Bar code is a pattern printed in lines of different thickness. The Bar code reader scans the information on the bar codes transmits to the Computer for further processing. The system gives fast and error free entry of information into the computer.

QR (Quick response) Code: The QR code is the two dimension bar code which can be read by a camera and processed to interpret the image

(10) Voice Input Systems: Microphone serves as a voice Input device. It captures the voice data and send it to the Computer. Using the microphone along with speech recognition software can offer a completely new approach to input information into the Computer.

(11) Digital Camera: It captures images / videos directly in the digital form. It uses a CCD (Charge Coupled Device) electronic chip. When light falls on the chip through the lens, it converts light rays into digital format.
(12) **Touch Screen:** A touch screen is a display device that allows the user to interact with a computer by using the finger. It can be quite useful as an alternative to a mouse or keyboard for navigating a Graphical User Interface (GUI). Touch screens are used on a wide variety of devices such as computers, laptops, monitors, smart phones, tablets, cash registers and information kiosks. Some touch screens use a grid of infrared beams to sense the presence of a finger instead of utilizing touch-sensitive input.

(13) **Keyer:** A Keyer is a device for signaling by hand, by way of pressing one or more switches. Modern keyers have a large number of switches but not as many as a full size keyboard. Typically, this number is between 4 and 50. A keyer differs from a keyboard, which has "no board", but the keys are arranged in a cluster.

Output Devices:

(1) **Monitor:** Monitor is the most commonly used output device to display the information. It looks like a TV. Pictures on a monitor are formed with picture elements called PIXELS. Monitors may either be Monochrome which display text or images in Black and White or can be color, which display results in multiple colors. There are many types of monitors available such as CRT (Cathode Ray Tube), LCD (Liquid Crystal Display) and LED (Light Emitting Diodes). The monitor works with the VGA (Video Graphics Array) card. The video graphics card helps the keyboard to communicate with the screen. It acts as an interface between the computer and display monitor. Usually the recent motherboards incorporate built-in video card.

The first computer monitor was part of the Xerox Alto computer system, which was released on March 1, 1973.
(2) **Plotter:** Plotter is an output device that is used to produce graphical output on papers. It uses single color or multi color pens to draw pictures.

(3) **Printers:** Printers are used to print the information on papers. Printers are divided into two main categories:

- Impact Printers
- Non Impact printers

**Impact Printers**

These printers print with striking of hammers or pins on ribbon. These printers can print on multi-part (using carbon papers) by using mechanical pressure. For example, Dot Matrix printers and Line matrix printers are impact printers.

A Dot matrix printer that prints using a fixed number of pins or wires. Each dot is produced by a tiny metal rod, also called a “wire” or “pin”, which works by the power of a tiny electromagnet or solenoid, either directly or through a set of small levers. It generally prints one line of text at a time. The printing speed of these printers varies from 30 to 1550 CPS (Character Per Second).

**Line matrix printers** use a fixed print head for printing. Basically, it prints a page-wide line of dots. But it builds up a line of text by printing lines of dots. Line printers are capable of printing much more than 1000 Lines Per Minute, resulting in thousands of pages per hour. These printers also use mechanical pressure to print on multi-part (using carbon papers).

**Non-Impact Printers**

These printers do not use striking mechanism for printing. They use electrostatic or laser technology. Quality and speed of these printers are better than Impact printers. For example, Laser printers and Inkjet printers are non-impact printers.

**Laser Printers**

Laser printers mostly work with similar technology used by photocopiers. It makes a laser beam scan back and
forth across a drum inside the printer, building up a pattern. It can produce very good quality of graphic images. One of the chief characteristics of laser printer is their resolution – how many Dots per inch (DPI). The available resolution range around 1200 dpi. Approximately it can print 100 pages per minute (PPM).

**Figure 1.19 Laser Printer**

**Inkjet Printers:**

Inkjet Printers use colour cartridges which combined Magenta, Yellow and Cyan inks to create color tones. A black cartridge is also used for monochrome output. Inkjet printers work by spraying ionised ink at a sheet of paper. The speed of Inkjet printers generally range from 1–20 PPM (Page Per Minute).

**Figure 1.20 Inkjet Printer**

They use the technology of firing ink by heating it so that it explodes towards the paper in bubbles or by using piezoelectricity in which tiny electric currents controlled by electronic circuits are used inside the printer to spread ink in jet speed. An Inkjet printer can spread millions of dots of ink at the paper every single second.

**Speakers:** Speakers produce voice output (audio). Using speaker along with speech synthesize software, the computer can provide voice output. This has become very common in places like airlines, schools, banks, railway stations, etc..

**Figure 1.21 Speakers**

**Multimedia Projectors:**

Multimedia projectors are used to produce computer output on a big screen. These are used to display presentations in meeting halls or in classrooms.

**Figure 1.22 Multimedia Projector**

1.6 Booting of computer

An Operating system (OS) is a basic software that makes the computer
to work. When a computer is switched on, there is no information in its RAM. At the same time, in ROM, the pre-written program called POST (Power on Self Test) will be executed first. This program checks if the devices like RAM, keyboard, etc., are connected properly and ready to operate. If these devices are ready, then the BIOS (Basic Input Output System) gets executed. This process is called Booting. Thereafter, a program called “Bootstrap Loader” transfers OS from hard disk into main memory. Now the OS gets loaded (Windows/Linux, etc.,) and will get executed. Booting process is of two types.

1) Cold Booting

2) Warm Booting

**Cold Booting:** When the system starts from initial state i.e. it is switched on, we call it cold booting or Hard Booting. When the user presses the Power button, the instructions are read from the ROM to initiate the booting process.

**Warm Booting:** When the system restarts or when Reset button is pressed, we call it Warm Booting or Soft Booting. The system does not start from initial state and so all diagnostic tests need not be carried out in this case. There are chances of data loss and system damage as the data might not have been stored properly.

---

### Points to Remember:

- Computers are seen everywhere around us, in all spheres of life.
- It is an electronic device that processes the input according to the set of instructions provided to it and gives the desired output at a very fast rate.
- Based on various stages of development, computers can be divided into six different generations.
- The computer is the combination of hardware and software.
- Hardware is the physical component of a computer.
- Input unit is used to feed any form of data to the computer.
- CPU interprets and executes software instructions.
- The ALU is a part of the CPU where various computing functions are performed on data.
- The control unit controls the flow of data between the CPU, memory and I/O devices.
- An Output Unit is any hardware component that conveys information to one or more people in user understandable form.
- The Memory Unit is of two kinds which are primary memory and secondary memory.
- Booting Process is of two types – Cold and Warm
STUDENT ACTIVITY

1. Explain the classification of computers.


3. Mention two new input and output devices that are not given in this chapter.

TEACHER ACTIVITY

1. Open a CPU and explain the components of it to students.

2. To connect and disconnect the various components of a computer.

Evaluation

SECTION – A

Choose the correct answer:

1. First generation computers used
   (a) Vacuum tubes        (b) Transistors
   (c) Integrated circuits  (d) Microprocessors

2. Name the volatile memory
   (a) ROM                  (b) PROM
   (c) RAM                  (d) EPROM

3. Identify the output device
   (a) Keyboard             (b) Memory
   (c) Monitor              (d) Mouse

4. Identify the input device
   (a) Printer              (b) Mouse
   (c) Plotter              (d) Projector

5. .............. Output device is used for printing building plan, flex board, etc.
   (a) Thermal printer      (b) Plotter
   (c) Dot matrix           (d) inkjet printer
6. In ATM machines, which one of the following is used to
   (a) Touch Screen       (b) speaker
   (c) Monitor            (d) Printer

7. When a system restarts ............... which type of booting is used.
   (a) Warm booting       (b) Cold booting
   (c) Touch boot         (d) Real boot.

8. Expand POST
   (a) Post on self Test  (b) Power on Software Test
   c) Power on Self Test  (d) Power on Self Test

9. Which one of the following is the main memory?
   (a) ROM               (b) RAM
   (c) Flash drive       (d) Hard disk

10. Which generation of computer used IC’s?
    (a) First             (b) Second
    (c) Third             (d) Fourth

SECTION-B

Short Answers

1. What is a computer?

2. Distinguish between data and information.

3. What are the components of a CPU?

4. What is the function of an ALU?

5. Write the functions of control unit.

6. What is the function of memory?

7. Differentiate Input and output unit.

8. Distinguish Primary and Secondary memory.
SECTION-C

Explain in Brief

1. What are the characteristics of a computer?
2. Write the applications of computer.
3. What is an input device? Give two examples.
4. Name any three output devices.
5. Differentiate optical and Laser mouse
6. Write shortnote on impact printer
7. Write the characteristics of sixth generation.
8. Write the significant features of monitor.

SECTION - D

Explain in detail

1. Explain the basic components of a computer with a neat diagram.
2. Discuss the various generations of computers.
3. Explain the following
   a. Inkjet Printer       b. Multimedia projector    c. Bar code / QR code Reader

References

(2) Computer Science text book – NCERT, New Delhi

Internet Resources

(1) www.wikipedia.org
(2) https://www.computerhope.com/jargon/c/computer.htm

Prepare a comparative study of various computers of past and present with respect to speed, memory, size, power consumption and other features
| **Computer** | It is an electronic device that processes the input according to the set of instructions provided to it and gives the desired output at a very fast rate. |
| **Vacuum tube** | Vacuum tubes contain electrodes for controlling electron flow and were used in early computers as a switch or an amplifier. |
| **Transistors** | The transistor ("transfer resistance") is made up of semiconductors. It is a component used to control the amount of current or voltage used for amplification/modulation of an electronic signal. |
| **Punched cards** | Punch cards also known as Hollerith cards are paper cards containing several punched or perforated holes that were punched by hand or machine to represent data. |
| **Machine Language** | Machine language is a collection of binary digits or bits that the computer reads and interprets. |
| **Assembly language** | An assembly language is a low-level programming language. |
| **Integrated Circuits** | The IC is a package containing many circuits, pathways, transistors, and other electronic components all working together to perform a particular function or a series of functions. |
| **Microcomputer** | Micro computer is used to describe a standard personal computer. |
| **High-level languages** | A high-level language is a computer programming language that isn't limited by the computer, designed for a specific job, and is easier to understand. |
| **Natural Language Processing (NLP)** | Natural Language Processing is a method used in artificial intelligence to process and derive meaning from the human language. |
| **Robotics** | Robot is a term coined by Karel Capek in the 1921 to play RUR (Rossum's Universal Robots). It is used to describe a computerized machine designed to respond to input received manually or from its surroundings. |
| **Nanotechnology** | Nanotechnology is an engineering, science, and technology that develops machines or works with one atom or one molecule that is 100 nanometers or smaller. |
| **Bioengineering** | A discipline that applies engineering principles of design and analysis to biological systems and biomedical technologies. |
Learning Objectives

• To know how the computer interprets and stores data in the memory.

• To learn various data representations and binary arithmetic.

• To learn conversion between various Number Systems.

2.1 Introduction

The term data comes from the word datum, which means a raw fact. The data is a fact about people, places or some objects.

Example:

Let ‘Name’, ‘Age’, ‘Class’, ‘Marks’ and ‘Subject’ be some defined variables. Now, let us assign a value to each of these variables.

<table>
<thead>
<tr>
<th>Name</th>
<th>Rajesh</th>
</tr>
</thead>
<tbody>
<tr>
<td>Age</td>
<td>16</td>
</tr>
<tr>
<td>Class</td>
<td>XI</td>
</tr>
<tr>
<td>Mark</td>
<td>65</td>
</tr>
<tr>
<td>Subject</td>
<td>Computer Science</td>
</tr>
</tbody>
</table>

In the above example, the values assigned to the five different variables are called data. When the above data is processed, we get an information “Rajesh is 16 years old, studying in Class XI, has scored 65 marks in Computer Science subject”.

2.2 Data Representations

Computer handles data in the form of ‘0’(Zero) and ‘1’ (One). Any kind of data like number, alphabet, special character should be converted to ‘0’ or ‘1’ which can be understood by the Computer. ‘0’ and ‘1’ that the Computer can understand is called Machine language. ‘0’ or ‘1’ are called ‘Binary Digits’(BIT). Therefore, the study of data representation in the computer is important.

• A bit is the short form of Binary digit which can be ‘0’ or ‘1’. It is the basic unit of data in computers.

• A nibble is a collection of 4 bits (Binary digits).

• A collection of 8 bits is called Byte. A byte is considered as the basic unit of measuring the memory size in the computer.

• Word length refers to the number of bits processed by a Computer’s CPU. For example, a word length can have 8 bits, 16 bits, 32 bits and 64 bits (Present day Computers use 32 bits or 64 bits)
Figure 2.2 Data Representation

Computer memory (Main Memory and Secondary Storage) is normally represented in terms of KiloByte (KB) or MegaByte (MB). In decimal system, 1 Kilo represents 1000, that is, $10^3$. In binary system, 1 KiloByte represents 1024 bytes that is $2^{10}$. The following table represents the various memory sizes:

Table 2.1 Memory Size (Read $2^{10}$ as 2 power 10)

<table>
<thead>
<tr>
<th>Name</th>
<th>Abbr.</th>
<th>Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>Kilo</td>
<td>K</td>
<td>$2^{10} = 1,024$</td>
</tr>
<tr>
<td>Mega</td>
<td>M</td>
<td>$2^{20} = 1,048,576$</td>
</tr>
<tr>
<td>Giga</td>
<td>G</td>
<td>$2^{30} = 1,073,741,824$</td>
</tr>
<tr>
<td>Tera</td>
<td>T</td>
<td>$2^{40} = 1,099,511,627,776$</td>
</tr>
<tr>
<td>Peta</td>
<td>P</td>
<td>$2^{50} = 1,125,899,906,842,624$</td>
</tr>
<tr>
<td>Exa</td>
<td>E</td>
<td>$2^{60} = 1,152,921,504,606,846,976$</td>
</tr>
<tr>
<td>Zetta</td>
<td>Z</td>
<td>$2^{70} = 1,180,591,620,717,411,303,424$</td>
</tr>
<tr>
<td>Yotta</td>
<td>Y</td>
<td>$2^{80} = 1,208,925,819,614,629,174,706,173$</td>
</tr>
</tbody>
</table>

Bytes are used to represent characters in a text. Different types of coding schemes are used to represent the character set and numbers. The most commonly used coding scheme is the American Standard Code for Information Interchange (ASCII). Each
A numbering system is a way of representing numbers. The most commonly used numbering system in real life is Decimal number system. Other number systems are Binary, Octal, Hexadecimal number system. Each number system is uniquely identified by its base value or radix. Radix or base is the count of number of digits in each number system. Radix or base is the general idea behind positional numbering system.

2.3.1 Decimal Number System

It consists of 0,1,2,3,4,5,6,7,8,9(10 digits). It is the oldest and most popular number system used in our day-to-day life. In the positional number system, each decimal digit is weighted relative to its position in the number. This means that each digit in the number is multiplied by 10 raised to a power corresponding to that digit's position.
Example

\[(123)_{10} = 1 \times 10^2 + 2 \times 10^1 + 3 \times 10^0 \]
\[= 100 + 20 + 3 \]
\[= (123)_{10} \]

2.3.2 Binary Number System

There are only two digits in the Binary system, namely, 0 and 1. The numbers in the binary system are represented to the base 2 and the positional multipliers are the powers of 2. The left most bit in the binary number is called as the Most Significant Bit (MSB) and it has the largest positional weight. The right most bit is the Least Significant Bit (LSB) and has the smallest positional weight.

Example

The binary sequence \((1101)_2\) has the decimal equivalent:

\[(1101)_2 = 1 \times 2^3 + 1 \times 2^2 + 0 \times 2^1 + 1 \times 2^0 \]
\[= 8 + 4 + 0 + 1 \]
\[= (13)_{10} \]

2.3.3 Octal Number System

Octal number system uses digits 0,1,2,3,4,5,6 and 7 (8 digits). Each octal digit has its own positional value or weight as a power of 8.

Example

The Octal sequence \((547)_8\) has the decimal equivalent:

\[(547)_8 = 5 \times 8^2 + 4 \times 8^1 + 7 \times 8^0 \]
\[= 5 \times 64 + 4 \times 8 + 7 \times 1 \]
\[= 320 + 32 + 7 \]
\[= (359)_{10} \]

2.3.4 Hexadecimal Number System

A hexadecimal number is represented using base 16. Hexadecimal or Hex numbers are used as a shorthand form of binary sequence. This system is used to represent data in a more compact manner. Since 16 symbols are used, 0 to F, the notation is called hexadecimal. The first 10 symbols are the same as in the decimal system, 0 to 9 and the remaining 6 symbols are taken from the first 6 letters of the alphabet sequence, A to F, where A represents 10, B is 11, C is 12, D is 13, E is 14 and F is 15.

Table 2.2 Binary, Octal, Hexadecimal equivalent of Decimal Numbers
### Table: Decimal, Binary, Octal, Hexadecimal Equivalents

<table>
<thead>
<tr>
<th>Decimal</th>
<th>Binary</th>
<th>Octal</th>
<th>Hexadecimal</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0000</td>
<td>000</td>
<td>0000</td>
</tr>
<tr>
<td>1</td>
<td>0001</td>
<td>001</td>
<td>0001</td>
</tr>
<tr>
<td>2</td>
<td>0010</td>
<td>002</td>
<td>0002</td>
</tr>
<tr>
<td>3</td>
<td>0011</td>
<td>003</td>
<td>0003</td>
</tr>
<tr>
<td>4</td>
<td>0100</td>
<td>004</td>
<td>0004</td>
</tr>
<tr>
<td>5</td>
<td>0101</td>
<td>005</td>
<td>0005</td>
</tr>
<tr>
<td>6</td>
<td>0110</td>
<td>006</td>
<td>0006</td>
</tr>
<tr>
<td>7</td>
<td>0111</td>
<td>007</td>
<td>0007</td>
</tr>
<tr>
<td>8</td>
<td>1000</td>
<td>010</td>
<td>0008</td>
</tr>
<tr>
<td>9</td>
<td>1001</td>
<td>011</td>
<td>0009</td>
</tr>
<tr>
<td>10</td>
<td>1010</td>
<td>012</td>
<td>A</td>
</tr>
<tr>
<td>11</td>
<td>1011</td>
<td>013</td>
<td>B</td>
</tr>
<tr>
<td>12</td>
<td>1100</td>
<td>014</td>
<td>C</td>
</tr>
<tr>
<td>13</td>
<td>1101</td>
<td>015</td>
<td>D</td>
</tr>
<tr>
<td>14</td>
<td>1110</td>
<td>016</td>
<td>E</td>
</tr>
<tr>
<td>15</td>
<td>1111</td>
<td>017</td>
<td>F</td>
</tr>
</tbody>
</table>

### Example

The hexadecimal sequence \((25)_{16}\) has the decimal equivalent:

\[
(25)_{16} = 2 \times 16^1 + 5 \times 16^0 = 32 + 5 = (37)_{10}
\]

### Workshop

1. Identify the number system for the following numbers:

<table>
<thead>
<tr>
<th>S. No.</th>
<th>Number</th>
<th>Number system</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>((1010)_{10})</td>
<td>Decimal Number system</td>
</tr>
<tr>
<td>2</td>
<td>((1010)_{2})</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>((989)_{16})</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>((750)_{8})</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>((926)_{10})</td>
<td></td>
</tr>
</tbody>
</table>

2. State whether the following numbers are valid or not. If invalid, given reason.

<table>
<thead>
<tr>
<th>S.No.</th>
<th>Statement</th>
<th>Yes / No</th>
<th>Reason (If invalid)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>786 is an Octal number</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2.</td>
<td>101 is a Binary number</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3.</td>
<td>Radix of Octal number is 7</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
2.4 Number System Conversions

2.4.1 Decimal to Binary Conversion

To convert Decimal to Binary “Repeated Division by 2” method can be used. Any Decimal number divided by 2 will leave a remainder of 0 or 1. Repeated division by 2 will leave a sequence of 0s and 1s that become the binary equivalent of the decimal number. Suppose it is required to convert the decimal number N into binary form, dividing N by 2 in the decimal system, we will obtain a quotient N1 and a remainder R1, where R1 can have a value of either 0 or 1. The process is repeated until the quotient becomes 0 or 1. When the quotient is ‘0’ or ‘1’, it is the final remainder value. Write the final answer starting from final remainder value obtained to the first remainder value obtained.

Example

Convert (65)10 into its equivalent binary number

<table>
<thead>
<tr>
<th>2</th>
<th>65</th>
<th>remainder</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>32</td>
<td>0</td>
</tr>
<tr>
<td>2</td>
<td>16</td>
<td>0</td>
</tr>
<tr>
<td>2</td>
<td>8</td>
<td>0</td>
</tr>
<tr>
<td>2</td>
<td>4</td>
<td>0</td>
</tr>
<tr>
<td>2</td>
<td>2</td>
<td>0</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
<td>0</td>
</tr>
</tbody>
</table>

(65)10 = (1 0 0 0 0 0 1)2

2.4.2 Decimal to Octal Conversion

To convert Decimal to Octal, “Repeated Division by 8” method can be used. The method is the same we have learnt in 2.4.1, but in this method, we have to divide the given number by 8.

Example

Convert (65)10 into its equivalent Octal number

<table>
<thead>
<tr>
<th>8</th>
<th>65</th>
<th>LSB</th>
</tr>
</thead>
<tbody>
<tr>
<td>8</td>
<td>8</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td></td>
</tr>
</tbody>
</table>

(65)10 = (101)8

2.4.3 Decimal to Hexadecimal Conversion

To convert Decimal to Hexadecimal, “Repeated division by 16” method can be used. The method is the same as we have learnt in 2.4.1, but in this method, we have to divide the given number by 16.

Example

Convert (31)10 into its equivalent hexadecimal number.

<table>
<thead>
<tr>
<th>16</th>
<th>31</th>
<th>LSB</th>
</tr>
</thead>
<tbody>
<tr>
<td>16</td>
<td>1</td>
<td>15</td>
</tr>
</tbody>
</table>

(31)10 = (1F)16 (Refer Table 2.2 F=15)

1
2.4.4 Conversion of fractional Decimal to Binary

The method of **repeated multiplication by 2** has to be used to convert such kind of decimal fractions.

The steps involved in the method of **repeated multiplication by 2**:

**Step 1:** Multiply the decimal fraction by 2 and note the integer part. The integer part is either 0 or 1.

**Step 2:** Discard the integer part of the previous product. Multiply the fractional part of the previous product by 2. Repeat Step 1 until the same fraction repeats or terminates (0).

**Step 3:** The resulting integer part forms a sequence of 0s and 1s that become the binary equivalent of decimal fraction.

**Step 4:** The final answer is to be written from first integer part obtained till the last integer part obtained.

Write the integer parts from top to bottom to obtain the equivalent fractional binary number. Hence \((0.2)_{10} = (0.00110011\ldots)_2 = (0.00110011)_2\)

### Workshop

3. Convert the following Decimal numbers to its equivalent Binary, Octal, Hexadecimal.

1) 1920
2) 255
3) 126

2.4.5 Binary to Decimal Conversion

To convert Binary to Decimal we can use positional notation method.

**Step 1:** Write down the Binary digits and list the powers of 2 from right to left (Positional Notation)

**Step 2:** For each positional notation written for the digit, now write the equivalent weight.

**Step 3:** Multiply each digit with its corresponding weight

**Step 4:** Add all the values.

**Step 5:** Add the final values.

**Table 2.3 Positional Notation and Weight**

<table>
<thead>
<tr>
<th>Positional Notation</th>
<th>Weight</th>
</tr>
</thead>
<tbody>
<tr>
<td>(2^0)</td>
<td>1</td>
</tr>
<tr>
<td>(2^1)</td>
<td>2</td>
</tr>
<tr>
<td>(2^2)</td>
<td>4</td>
</tr>
<tr>
<td>(2^3)</td>
<td>8</td>
</tr>
<tr>
<td>(2^4)</td>
<td>16</td>
</tr>
<tr>
<td>(2^5)</td>
<td>32</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Positional Notation</th>
<th>Weight</th>
</tr>
</thead>
<tbody>
<tr>
<td>(2^6)</td>
<td>64</td>
</tr>
<tr>
<td>(2^7)</td>
<td>128</td>
</tr>
<tr>
<td>(2^8)</td>
<td>256</td>
</tr>
<tr>
<td>(2^9)</td>
<td>512</td>
</tr>
<tr>
<td>(2^{10})</td>
<td>1024</td>
</tr>
</tbody>
</table>

**Note:** Fraction repeats, the product is the same as in the first step.
Example

Convert \((111011)_2\) into its equivalent decimal number.

<table>
<thead>
<tr>
<th>Weight</th>
<th>32</th>
<th>16</th>
<th>8</th>
<th>4</th>
<th>2</th>
<th>1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Positional Notation</td>
<td>(2^5)</td>
<td>(2^4)</td>
<td>(2^3)</td>
<td>(2^2)</td>
<td>(2^1)</td>
<td>(2^0)</td>
</tr>
<tr>
<td>Given number</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>0</td>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

\[
32 + 16 + 8 + 0 + 2 + 1 = (59)_{10}
\]

\[
(111011)_2 = (59)_{10}
\]

2.4.6 Binary to Octal Conversion

Step 1: Group the given binary number into 3 bits from right to left.

Step 2: You can add preceding 0 to make a group of 3 bits if the left most group has less than 3 bits.

Step 3: Refer Table 2.4 to find the Octal equivalent for each group.

Table 2.4 Octal numbers and their Binary equivalent

<table>
<thead>
<tr>
<th>Octal</th>
<th>Binary Equivalent</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>000</td>
</tr>
<tr>
<td>1</td>
<td>001</td>
</tr>
<tr>
<td>2</td>
<td>010</td>
</tr>
<tr>
<td>3</td>
<td>011</td>
</tr>
<tr>
<td>4</td>
<td>100</td>
</tr>
<tr>
<td>5</td>
<td>101</td>
</tr>
<tr>
<td>6</td>
<td>110</td>
</tr>
<tr>
<td>7</td>
<td>111</td>
</tr>
</tbody>
</table>

Example

Convert \((11010110)_2\) into octal equivalent number

Step 1: Group the given number into 3 bits from right to left.

011 010 110

Note: The left most groups have less than 3 bits, so 0 is added to its left to make a group of 3 bits.

Step 2: Refer Table 2.4 to find Octal equivalent of each group

\[
\begin{array}{c|c|c}
011 & 010 & 110 \\
\hline
3 & 2 & 6 \\
\end{array}
\]

\[
(11010110)_2 = (326)_8
\]

2.4.7 Binary to Hexadecimal Conversion

Step 1: Group the given number into 4 bits from right to left.

Step 2: You can add preceding 0’s to make a group of 4 bits if the left most group has less than 4 bits.

Step 3: Refer Table 2.2 to find the Hexadecimal equivalent of each group.

Example

Convert \((1111010110)_2\) into Hexadecimal number

Step 1: Group the given number into 4 bits from right to left.
Note: 0’s are added to the left most group to make it a group of 4 bits

\[
\begin{array}{ccc}
0011 & 1101 & 0110 \\
\hline
3 & D & 6 \\
\end{array}
\]

\[(1111010110)_2 = (3D6)_{16}\]

2.4.8 Conversion of fractional Binary to Decimal equivalent

Follow the steps to convert fractional Binary number to its Decimal equivalent.

Step 1: Convert integral part of Binary to Decimal equivalent using positional notation method (Procedure is same as discussed in 2.4.5)

Step 2: To convert the fractional part of binary to its decimal equivalent.

Step 2.1: Write down the Binary digits in the fractional part

Step 2.2: For all the digits write powers of 2 from left to right starting from \(2^{-1}, 2^{-2}, 2^{-3}, \ldots, 2^{-n}\), now write the equivalent weight.

Step 2.3: Multiply each digit with its corresponding weight

Step 2.4: Add all the values which you obtained in Step 2.3

<table>
<thead>
<tr>
<th>Weight</th>
<th>Positional notation</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.5</td>
<td>(2^{-1}) (1/2)</td>
</tr>
<tr>
<td>0.25</td>
<td>(2^{-2}) (1/4)</td>
</tr>
<tr>
<td>0.125</td>
<td>(2^{-3}) (1/8)</td>
</tr>
<tr>
<td>0.0625</td>
<td>(2^{-4}) (1/16)</td>
</tr>
<tr>
<td>0.03125</td>
<td>(2^{-5}) (1/32)</td>
</tr>
<tr>
<td>0.015625</td>
<td>(2^{-6}) (1/64)</td>
</tr>
<tr>
<td>0.0078125</td>
<td>(2^{-7}) (1/128)</td>
</tr>
</tbody>
</table>

Step 3: To get final answer write the integral part (after conversion), followed by a decimal point(.) and the answer arrived at Step 2.4

Example

Convert the given Binary number \((11.011)_2\) into its decimal equivalent

Integer part \((11)_2 = 3\) (Refer table 2.2)

\[
\begin{array}{ccc}
2^1 & 2^0 & \frac{1}{2} \\
1 & 1 & 0 \\
\end{array}
\]

3 \+ \(0 \times 0.5 + 1 \times 0.25 + 1 \times 0.125\)

\[
= 3.325 \quad (11.011)_2 = (3.325)_{10}
\]

Workshop

4. Convert the given Binary number into its equivalent Decimal, Octal and Hexadecimal number.

1) 101110101
2) 1011010
3) 101011111
2.4.9 Octal to Decimal Conversion

To convert Octal to Decimal, we can use positional notation method.

1. Write down the Octal digits and list the powers of 8 from right to left (Positional Notation).
2. For each positional notation of the digit write the equivalent weight.
3. Multiply each digit with its corresponding weight.
4. Add all the values.

**Example**

Convert \((1265)_8\) to equivalent Decimal number

<table>
<thead>
<tr>
<th>Weight</th>
<th>(512)</th>
<th>(64)</th>
<th>(8)</th>
<th>(1)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Positional Notation</td>
<td>(8^3)</td>
<td>(8^2)</td>
<td>(8^1)</td>
<td>(8^0)</td>
</tr>
<tr>
<td>Given number</td>
<td>1</td>
<td>2</td>
<td>6</td>
<td>5</td>
</tr>
</tbody>
</table>

\[
(1265)_8 = 512 \times 1 + 64 \times 2 + 8 \times 6 + 1 \times 5
= 512 + 128 + 48 + 5
= (693)_{10}
\]

2.4.10 Octal to Binary Conversion

For each Octal digit in the given number refer Table 2.4 and write its Binary equivalent (3 digits).

**Example**

Convert \((6213)_8\) to equivalent Binary number

\[
(6213)_8 = (11001001011)_2
\]

2.4.11 Hexadecimal to Decimal Conversion

To convert Hexadecimal to Decimal, we can use positional notation method.

1. Write down the Hexadecimal digits and list the powers of 16 from right to left (Positional Notation).
2. For each positional notation written for the digit, now write the equivalent weight.
3. Multiply each digit with its corresponding weight.
4. Add all the values to get one final value.

**Example**

Convert \((25F)_{16}\) into its equivalent Decimal number.
2.4.12 Hexadecimal to Binary Conversion

Refer Table 2.2 and write the Binary equivalent (4 bits) for each Hexadecimal digit for the given number

**Example**

Convert \((8BC)_{16}\) into equivalent Binary number

\[
\begin{array}{ccc}
8 & B & C \\
1000 & 1011 & 1100 \\
(8BC)_{16} & (100010111100)_{2}
\end{array}
\]

2.5 Binary Representation for Signed Numbers

Computers can handle both positive (unsigned) and negative (signed) numbers. The simplest method to represent negative binary numbers is called **Signed Magnitude**. In signed magnitude method, the left most bit is Most Significant Bit (MSB), is called **sign bit or parity bit**.

The numbers are represented in computers in different ways:

- Signed Magnitude representation
- 1’s Complement
- 2’s Complement

2.5.1 Signed Magnitude representation

The value of the whole numbers can be determined by the sign used before it. If the number has ‘+’ sign or no sign it will be considered as positive. If the number has ‘-’ sign it will be considered as negative.

**Example:**

+43 or 43 is a positive number

-43 is a negative number

In signed binary representation, the left most bit is considered as sign bit. If this bit is 0, it is a positive number and if it 1, it is a negative number. Therefore a signed binary number has 8 bits, only 7 bits used for storing values (magnitude) and the 1 bit is used for sign.

+43 is represented in memory as follows:

\[
\begin{array}{cccccccc}
0 & 0 & 0 & 0 & 1 & 0 & 1 & 1
\end{array}
\]

(‘0’ represent that the number is positive)
-43 can be represented in memory as follows.

<table>
<thead>
<tr>
<th>Sign bit</th>
<th>Magnitude (Value)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1010101</td>
</tr>
</tbody>
</table>

Least Significant Bit (LSB)

Most Significant Bit (MSB) ('1' represent that the number is negative)

2.5.2 1’s Complement representation

This is an easier approach to represent signed numbers. This is for negative numbers only i.e. the number whose MSB is 1.

The steps to be followed to find 1’s complement of a number:

Step 1: Convert given Decimal number into Binary

Step 2: Check if the binary number contains 8 bits, if less add 0 at the left most bit, to make it as 8 bits.

Step 3: Invert all bits (i.e. Change 1 as 0 and 0 as 1)

Example

Find 1’s complement for \((-24)_{10}\)

<table>
<thead>
<tr>
<th>Given Number</th>
<th>Binary Number</th>
<th>1’s Compliment</th>
</tr>
</thead>
<tbody>
<tr>
<td>((-24)_{10})</td>
<td>00011000</td>
<td>11100111</td>
</tr>
</tbody>
</table>

2.5.3 2’s Complement representation

The 2’s-complement method for negative number is as follows:

a. Invert all the bits in the binary sequence (i.e., change every 0 to 1 and every 1 to 0 i.e., 1’s complement)

b. Add 1 to the result to the Least Significant Bit (LSB).

Example

2’s Complement represent of \((-24)_{10}\)

<table>
<thead>
<tr>
<th>Binary equivalent of +24:</th>
<th>11000</th>
</tr>
</thead>
<tbody>
<tr>
<td>8bit format:</td>
<td>00011000</td>
</tr>
<tr>
<td>1’s complement:</td>
<td>11100111</td>
</tr>
<tr>
<td>Add 1 to LSB:</td>
<td>+1</td>
</tr>
<tr>
<td>2’s complement of -24:</td>
<td>11101000</td>
</tr>
</tbody>
</table>

Workshop

7. Write the 1’s complement number and 2’s complement number for the following decimal numbers:

(A) 22  (B) -13  (C) 65  (D) -46  (E) 255

2.6 Binary Arithmetic

As decimal numbers, the binary numbers also permit computations like addition, subtraction, multiplication and division. The following session deals only with binary addition and subtraction.

2.6.1 Binary Addition

The following table is useful when adding two binary numbers.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>SUM (A + B)</th>
<th>Carry</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>0</td>
<td>-</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
<td>1</td>
<td>-</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>1</td>
<td>-</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>0</td>
<td>1</td>
</tr>
</tbody>
</table>
In $1 + 1 = 10$, is considered as sum 0 and the 1 as carry bit. This carry bit is added with the previous position of the bit pattern.

**Example** Add: $1011_2 + 1001_2$

(Carry Bit) → $1 \rightarrow 1$

\[
\begin{array}{c}
1 & 0 & 1 & 1 \\
+ & 1 & 0 & 0 & 0 \\
\hline
1 & 0 & 1 & 0 & 0
\end{array}
\]

$1011_2 + 1001_2 = 10100_2$

**Example** Perform Binary addition for the following: $23_{10} + 12_{10}$

Step 1: Convert 23 and 12 into binary form

<table>
<thead>
<tr>
<th>$23_{10}$</th>
<th>2's power</th>
<th>Binary Number</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>16 8 4 2 1</td>
<td>1 0 1 1 1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$23_{10} = 00010111_2$</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>$12_{10}$</th>
<th>2's power</th>
<th>Binary Number</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>8 4 2 1</td>
<td>1 1 0 0</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$12_{10} = 00001100_2$</td>
</tr>
</tbody>
</table>

Step 2: Binary addition of 23 and 12:

<table>
<thead>
<tr>
<th>Carry Bit</th>
<th>$23_{10}$ = 0 0 0 1 0 1 1 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>$12_{10}$ = 0 0 0 1 1 0 0 0</td>
<td></td>
</tr>
<tr>
<td>$35_{10}$ = 0 0 1 0 0 0 1 1</td>
<td></td>
</tr>
</tbody>
</table>

2.6.2 Binary Subtraction

The table for Binary Subtraction is as follows:

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>Difference (A-B)</th>
<th>Borrow</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

When subtracting 1 from 0, borrow 1 from the next Most Significant Bit, when borrowing from the next Most Significant Bit, if it is 1, replace it with 0. If the next Most Significant Bit is 0, you must borrow from a more significant bit that contains 1 and replace it with 0 and 0s up to that point become 1s.

**Example** Subtract $1001010_2 - 10100_2$

<table>
<thead>
<tr>
<th>$(-)$</th>
<th>0 1 1 0 1 0 0</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>0 0 0 1 1 0 0</td>
</tr>
<tr>
<td></td>
<td>1 0 1 1 0 1 0</td>
</tr>
</tbody>
</table>

**Example** Perform binary addition for the following: $(-21)_{10} + (5)_{10}$

Step 1: Change -21 and 5 into binary form

<table>
<thead>
<tr>
<th>$21_{10}$</th>
<th>2's power</th>
<th>Binary Number</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>16 8 4 2 1</td>
<td>1 0 1 0 1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$21_{10} = 00010101_2$</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>$5_{10}$</th>
<th>2's power</th>
<th>Binary Number</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>4 2 1</td>
<td>1 0 1</td>
</tr>
<tr>
<td>$5_{10} = 0000101_2$</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Step 2:

<table>
<thead>
<tr>
<th>21_{10}</th>
<th>0 0 0 1 0 1 0 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>1's Compliment</td>
<td>1 1 1 0 1 0 1 0</td>
</tr>
<tr>
<td>2's Compliment</td>
<td>1 1 1 0 1 0 1 1</td>
</tr>
</tbody>
</table>

Step 3:

Binary Addition of -21 and 5:

<table>
<thead>
<tr>
<th>Carry bit</th>
<th>1 1 1 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>-21_{10}</td>
<td>1 1 1 0 1 0 1 1</td>
</tr>
<tr>
<td>5_{10}</td>
<td>0 0 0 0 0 1 0 1</td>
</tr>
<tr>
<td>-16_{10} (Result)</td>
<td>1 1 1 1 0 0 0 0</td>
</tr>
</tbody>
</table>

2.7 Representing Characters in Memory

As represented in introduction, all the input data given to the computer should be in understandable format. In general, 26 uppercase letters, 26 lowercase letters, 0 to 9 digits and special characters are used in a computer, which is called character set. All these character set are denoted through numbers only. All Characters in the character set needs a common encoding system. There are several encoding systems used for computer. They are

- BCD – Binary Coded Decimal
- EBCDIC – Extended Binary Coded Decimal Interchange Code
- ASCII – American Standard Code for Information Interchange
- Unicode
- ISCII - Indian Standard Code for Information Interchange

2.7.1 Binary Coded Decimal (BCD)

This encoding system is not in the practice right now. This is $2^6$ bit encoding system. This can handle $2^6 = 64$ characters only.

2.7.2 American Standard Code for Information Interchange (ASCII)

This is the most popular encoding system recognized by United States. Most of the computers use this system. Remember this encoding system can handle English characters only. This can handle $2^7$ bit which means 128 characters.

In this system, each character has individual number (Refer Appendix).

The new edition (version) ASCII -8, has $2^8$ bits and can handle 256 characters are represented from 0 to 255 unique numbers.

The ASCII code equivalent to the uppercase letter ‘A’ is 65. The binary representation of ASCII (7 bit) value is 1000001. Also 01000001 in ASCII-8 bit.
2.7.3 Extended Binary Coded Decimal Interchange Code (EBCDIC)

This is similar to ASCII Code with 8 bit representation. This coding system is formulated by International Business Machine (IBM). The coding system can handle 256 characters. The input code in ASCII can be converted to EBCDIC system and vice versa.

2.7.4 Indian Standard Code for Information Interchange (ISCII)

ISCII is the system of handling the character of Indian local languages. This as a 8-bit coding system. Therefore it can handle 256 \( (2^8) \) characters. This system is formulated by the department of Electronics in India in the year 1986-88 and recognized by Bureau of Indian Standards (BIS). Now this coding system is integrated with Unicode.

2.7.5 Unicode

This coding system is used in most of the modern computers. The popular coding scheme after ASCII is Unicode. ASCII can represent only 256 characters. Therefore English and European Languages alone can be handled by ASCII. Particularly there was a situation, when the languages like Tamil, Malayalam, Kannada and Telugu could not be represented by ASCII. Hence, the Unicode was generated to handle all the coding system of Universal languages. This is 16 bit code and can handle 65536 characters.

Unicode scheme is denoted by hexadecimal numbers. The Unicode table of Tamil, Malayalam, Telugu and Kannada is shown Table 2.6
<table>
<thead>
<tr>
<th>Unicode Table of Tamil</th>
<th>Unicode Table of Malayalam</th>
</tr>
</thead>
<tbody>
<tr>
<td>0B8 0B9 0BA 0BB 0BC 0BD 0BE 0BF</td>
<td>0D0 0D1 0D2 0D3 0D4 0D5 0D6 0D7</td>
</tr>
<tr>
<td>0</td>
<td>0000</td>
</tr>
<tr>
<td>1</td>
<td>0001</td>
</tr>
<tr>
<td>2</td>
<td>0002</td>
</tr>
<tr>
<td>3</td>
<td>0003</td>
</tr>
<tr>
<td>4</td>
<td>0004</td>
</tr>
<tr>
<td>5</td>
<td>0005</td>
</tr>
<tr>
<td>6</td>
<td>0006</td>
</tr>
<tr>
<td>7</td>
<td>0007</td>
</tr>
<tr>
<td>8</td>
<td>0008</td>
</tr>
<tr>
<td>9</td>
<td>0009</td>
</tr>
</tbody>
</table>

**Notes:**
- The table shows the Unicode characters for Tamil and Malayalam scripts.
- Each column represents a hexadecimal value for the corresponding character.
- The table is organized in a grid format with rows and columns for each character.
- The characters are represented in their respective scripts.

**Additional Information:**
- The table is from a comprehensive source on Unicode, providing a detailed view of the Tamil and Malayalam character sets.
- This information is crucial for developers working with scripts that utilize these languages, ensuring compatibility and correct representation in digital and printed media.
<table>
<thead>
<tr>
<th>Unicode Table of Telugu</th>
<th>Unicode Table of Kannada</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>0C0</strong></td>
<td><strong>0C8</strong></td>
</tr>
<tr>
<td><strong>0C1</strong></td>
<td><strong>0C9</strong></td>
</tr>
<tr>
<td><strong>0C2</strong></td>
<td><strong>0CA</strong></td>
</tr>
<tr>
<td><strong>0C3</strong></td>
<td><strong>0CB</strong></td>
</tr>
<tr>
<td><strong>0C4</strong></td>
<td><strong>0CC</strong></td>
</tr>
<tr>
<td><strong>0C5</strong></td>
<td><strong>0CD</strong></td>
</tr>
<tr>
<td><strong>0C6</strong></td>
<td><strong>0CE</strong></td>
</tr>
<tr>
<td><strong>0C7</strong></td>
<td><strong>0CF</strong></td>
</tr>
</tbody>
</table>

Table 2.6
### Appendix
American Standard Code for Information Interchange (ASCII)
(Few specific characters only)

#### Alphabets

<table>
<thead>
<tr>
<th>Alphabets</th>
<th>Decimal number</th>
<th>Binary number (8 bit)</th>
<th>Octal number</th>
<th>Hexadecimal number</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>65</td>
<td>01000001</td>
<td>101</td>
<td>41</td>
</tr>
<tr>
<td>B</td>
<td>66</td>
<td>01000010</td>
<td>102</td>
<td>42</td>
</tr>
<tr>
<td>C</td>
<td>67</td>
<td>01000011</td>
<td>103</td>
<td>43</td>
</tr>
<tr>
<td>D</td>
<td>68</td>
<td>01000100</td>
<td>104</td>
<td>44</td>
</tr>
<tr>
<td>E</td>
<td>69</td>
<td>01000101</td>
<td>105</td>
<td>45</td>
</tr>
<tr>
<td>F</td>
<td>70</td>
<td>01000110</td>
<td>106</td>
<td>46</td>
</tr>
<tr>
<td>G</td>
<td>71</td>
<td>01000111</td>
<td>107</td>
<td>47</td>
</tr>
<tr>
<td>H</td>
<td>72</td>
<td>01001000</td>
<td>110</td>
<td>48</td>
</tr>
<tr>
<td>I</td>
<td>73</td>
<td>01001001</td>
<td>111</td>
<td>49</td>
</tr>
<tr>
<td>J</td>
<td>74</td>
<td>01001010</td>
<td>112</td>
<td>4A</td>
</tr>
<tr>
<td>K</td>
<td>75</td>
<td>01001011</td>
<td>113</td>
<td>4B</td>
</tr>
<tr>
<td>L</td>
<td>76</td>
<td>01001100</td>
<td>114</td>
<td>4C</td>
</tr>
<tr>
<td>M</td>
<td>77</td>
<td>01001101</td>
<td>115</td>
<td>4D</td>
</tr>
<tr>
<td>N</td>
<td>78</td>
<td>01001110</td>
<td>116</td>
<td>4E</td>
</tr>
<tr>
<td>O</td>
<td>79</td>
<td>01001111</td>
<td>117</td>
<td>4F</td>
</tr>
<tr>
<td>P</td>
<td>80</td>
<td>01010000</td>
<td>120</td>
<td>50</td>
</tr>
<tr>
<td>Q</td>
<td>81</td>
<td>01010001</td>
<td>121</td>
<td>51</td>
</tr>
<tr>
<td>R</td>
<td>82</td>
<td>01010010</td>
<td>122</td>
<td>52</td>
</tr>
<tr>
<td>S</td>
<td>83</td>
<td>01010011</td>
<td>123</td>
<td>53</td>
</tr>
<tr>
<td>T</td>
<td>84</td>
<td>01010100</td>
<td>124</td>
<td>54</td>
</tr>
<tr>
<td>U</td>
<td>85</td>
<td>01010101</td>
<td>125</td>
<td>55</td>
</tr>
<tr>
<td>V</td>
<td>86</td>
<td>01010110</td>
<td>126</td>
<td>56</td>
</tr>
<tr>
<td>W</td>
<td>87</td>
<td>01010111</td>
<td>127</td>
<td>57</td>
</tr>
<tr>
<td>X</td>
<td>88</td>
<td>01011000</td>
<td>130</td>
<td>58</td>
</tr>
<tr>
<td>Y</td>
<td>89</td>
<td>01011001</td>
<td>131</td>
<td>59</td>
</tr>
<tr>
<td>Z</td>
<td>90</td>
<td>01011010</td>
<td>132</td>
<td>5A</td>
</tr>
<tr>
<td>a</td>
<td>97</td>
<td>01100001</td>
<td>141</td>
<td>61</td>
</tr>
<tr>
<td>b</td>
<td>98</td>
<td>01100010</td>
<td>142</td>
<td>62</td>
</tr>
<tr>
<td>c</td>
<td>99</td>
<td>01100011</td>
<td>143</td>
<td>63</td>
</tr>
<tr>
<td>d</td>
<td>100</td>
<td>01100100</td>
<td>144</td>
<td>64</td>
</tr>
<tr>
<td>e</td>
<td>101</td>
<td>01100101</td>
<td>145</td>
<td>65</td>
</tr>
<tr>
<td></td>
<td>Decimal</td>
<td>Binary number (8 bit)</td>
<td>Octal number</td>
<td>Hexadecimal number</td>
</tr>
<tr>
<td>-------</td>
<td>---------</td>
<td>-----------------------</td>
<td>--------------</td>
<td>--------------------</td>
</tr>
<tr>
<td>0</td>
<td>48</td>
<td>00100000</td>
<td>40</td>
<td>30</td>
</tr>
<tr>
<td>1</td>
<td>49</td>
<td>00100001</td>
<td>41</td>
<td>31</td>
</tr>
<tr>
<td>2</td>
<td>50</td>
<td>00100010</td>
<td>42</td>
<td>32</td>
</tr>
<tr>
<td>3</td>
<td>51</td>
<td>00100011</td>
<td>43</td>
<td>33</td>
</tr>
<tr>
<td>4</td>
<td>52</td>
<td>00100100</td>
<td>44</td>
<td>34</td>
</tr>
<tr>
<td>5</td>
<td>53</td>
<td>00100101</td>
<td>45</td>
<td>35</td>
</tr>
<tr>
<td>6</td>
<td>54</td>
<td>00100110</td>
<td>46</td>
<td>36</td>
</tr>
<tr>
<td>7</td>
<td>55</td>
<td>00100111</td>
<td>47</td>
<td>37</td>
</tr>
<tr>
<td>8</td>
<td>56</td>
<td>00101000</td>
<td>48</td>
<td>38</td>
</tr>
<tr>
<td>9</td>
<td>57</td>
<td>00101001</td>
<td>49</td>
<td>39</td>
</tr>
</tbody>
</table>

**Numerals**

<p>| | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>48</td>
<td>00110000</td>
<td>60</td>
<td>30</td>
</tr>
<tr>
<td>1</td>
<td>49</td>
<td>00110001</td>
<td>61</td>
<td>31</td>
</tr>
<tr>
<td>2</td>
<td>50</td>
<td>00110010</td>
<td>62</td>
<td>32</td>
</tr>
<tr>
<td>3</td>
<td>51</td>
<td>00110011</td>
<td>63</td>
<td>33</td>
</tr>
<tr>
<td>4</td>
<td>52</td>
<td>00110100</td>
<td>64</td>
<td>34</td>
</tr>
<tr>
<td>5</td>
<td>53</td>
<td>00110101</td>
<td>65</td>
<td>35</td>
</tr>
<tr>
<td>6</td>
<td>54</td>
<td>00110110</td>
<td>66</td>
<td>36</td>
</tr>
<tr>
<td>7</td>
<td>55</td>
<td>00110111</td>
<td>67</td>
<td>37</td>
</tr>
<tr>
<td>8</td>
<td>56</td>
<td>00111000</td>
<td>70</td>
<td>38</td>
</tr>
<tr>
<td>9</td>
<td>57</td>
<td>00111001</td>
<td>71</td>
<td>39</td>
</tr>
</tbody>
</table>

<p>| | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>48</td>
<td>00110000</td>
<td>60</td>
<td>30</td>
</tr>
<tr>
<td>1</td>
<td>49</td>
<td>00110001</td>
<td>61</td>
<td>31</td>
</tr>
<tr>
<td>2</td>
<td>50</td>
<td>00110010</td>
<td>62</td>
<td>32</td>
</tr>
<tr>
<td>3</td>
<td>51</td>
<td>00110011</td>
<td>63</td>
<td>33</td>
</tr>
<tr>
<td>4</td>
<td>52</td>
<td>00110100</td>
<td>64</td>
<td>34</td>
</tr>
<tr>
<td>5</td>
<td>53</td>
<td>00110101</td>
<td>65</td>
<td>35</td>
</tr>
<tr>
<td>6</td>
<td>54</td>
<td>00110110</td>
<td>66</td>
<td>36</td>
</tr>
<tr>
<td>7</td>
<td>55</td>
<td>00110111</td>
<td>67</td>
<td>37</td>
</tr>
<tr>
<td>8</td>
<td>56</td>
<td>00111000</td>
<td>70</td>
<td>38</td>
</tr>
<tr>
<td>9</td>
<td>57</td>
<td>00111001</td>
<td>71</td>
<td>39</td>
</tr>
</tbody>
</table>
## Special Characters

<table>
<thead>
<tr>
<th>Special symbols</th>
<th>Decimal number</th>
<th>Binary number (8 bit)</th>
<th>Octal number</th>
<th>Hexadecimal number</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blank</td>
<td>32</td>
<td>00100000</td>
<td>40</td>
<td>20</td>
</tr>
<tr>
<td>!</td>
<td>33</td>
<td>00100001</td>
<td>41</td>
<td>21</td>
</tr>
<tr>
<td>&quot;</td>
<td>34</td>
<td>00100010</td>
<td>42</td>
<td>22</td>
</tr>
<tr>
<td>#</td>
<td>35</td>
<td>00100011</td>
<td>43</td>
<td>23</td>
</tr>
<tr>
<td>$</td>
<td>36</td>
<td>00100100</td>
<td>44</td>
<td>24</td>
</tr>
<tr>
<td>%</td>
<td>37</td>
<td>00100101</td>
<td>45</td>
<td>25</td>
</tr>
<tr>
<td>&amp;</td>
<td>38</td>
<td>00100110</td>
<td>46</td>
<td>26</td>
</tr>
<tr>
<td>'</td>
<td>39</td>
<td>00100111</td>
<td>47</td>
<td>27</td>
</tr>
<tr>
<td>(</td>
<td>40</td>
<td>00101000</td>
<td>50</td>
<td>28</td>
</tr>
<tr>
<td>)</td>
<td>41</td>
<td>00101001</td>
<td>51</td>
<td>29</td>
</tr>
<tr>
<td>*</td>
<td>42</td>
<td>00101010</td>
<td>52</td>
<td>2A</td>
</tr>
<tr>
<td>+</td>
<td>43</td>
<td>00101011</td>
<td>53</td>
<td>2B</td>
</tr>
<tr>
<td>,</td>
<td>44</td>
<td>00101100</td>
<td>54</td>
<td>2C</td>
</tr>
<tr>
<td>-</td>
<td>45</td>
<td>00101101</td>
<td>55</td>
<td>2D</td>
</tr>
<tr>
<td>.</td>
<td>46</td>
<td>00101110</td>
<td>56</td>
<td>2E</td>
</tr>
<tr>
<td>/</td>
<td>47</td>
<td>00101111</td>
<td>57</td>
<td>2F</td>
</tr>
<tr>
<td>:</td>
<td>58</td>
<td>00110110</td>
<td>72</td>
<td>3A</td>
</tr>
<tr>
<td>;</td>
<td>59</td>
<td>00111011</td>
<td>73</td>
<td>3B</td>
</tr>
<tr>
<td>&lt;</td>
<td>60</td>
<td>00111100</td>
<td>74</td>
<td>3C</td>
</tr>
<tr>
<td>=</td>
<td>61</td>
<td>00111101</td>
<td>75</td>
<td>3D</td>
</tr>
<tr>
<td>&gt;</td>
<td>62</td>
<td>00111110</td>
<td>76</td>
<td>3E</td>
</tr>
<tr>
<td>?</td>
<td>63</td>
<td>00111111</td>
<td>77</td>
<td>3F</td>
</tr>
<tr>
<td>@</td>
<td>64</td>
<td>01000000</td>
<td>100</td>
<td>40</td>
</tr>
<tr>
<td>[</td>
<td>91</td>
<td>01011011</td>
<td>133</td>
<td>5B</td>
</tr>
<tr>
<td>\</td>
<td>92</td>
<td>01011100</td>
<td>134</td>
<td>5C</td>
</tr>
<tr>
<td>]</td>
<td>93</td>
<td>01011101</td>
<td>135</td>
<td>5D</td>
</tr>
<tr>
<td>^</td>
<td>94</td>
<td>01011110</td>
<td>136</td>
<td>5E</td>
</tr>
<tr>
<td>_</td>
<td>95</td>
<td>01011111</td>
<td>137</td>
<td>5F</td>
</tr>
<tr>
<td>`</td>
<td>96</td>
<td>01100000</td>
<td>140</td>
<td>60</td>
</tr>
<tr>
<td>{</td>
<td>123</td>
<td>01111011</td>
<td>173</td>
<td>7B</td>
</tr>
<tr>
<td></td>
<td></td>
<td>124</td>
<td>01111100</td>
<td>174</td>
</tr>
<tr>
<td>}</td>
<td>125</td>
<td>01111101</td>
<td>175</td>
<td>7D</td>
</tr>
<tr>
<td>~</td>
<td>126</td>
<td>01111110</td>
<td>176</td>
<td>7E</td>
</tr>
</tbody>
</table>
I Choose the best answer

1. Which refers to the number of bits processed by a computer’s CPU?
   A) Byte  B) Nibble  C) Word length  D) Bit

2. How many bytes does 1 KiloByte contain?
   A) 1000  B) 8  C) 4  D) 1024

3. Expansion for ASCII
   A) American School Code for Information Interchange
   B) American Standard Code for Information Interchange
   C) All Standard Code for Information Interchange
   D) American Society Code for Information Interchange

4. $2^{50}$ is referred as
   A) Kilo  B) Tera  C) Peta  D) Zetta

5. How many characters can be handled in Binary Coded Decimal System?
   A) 64  B) 255  C) 256  D) 128

6. For $1101_2$ what is the Hexadecimal equivalent?
   A) F  B) E
   C) D  D) B

7. What is the 1’s complement of 00100110?
   A) 00100110  B) 11011001
   C) 11010001  D) 00101001
8. Which amongst this is not an Octal number?

A) 645  B) 234  
C) 876  D) 123

II  Very Short Answers

1. What is data?

2. Write the 1’s complement procedure.

3. Convert $(46)_{10}$ into Binary number

4. We cannot find 1’s complement for $(28)_{10}$. State reason.

5. List the encoding systems for characters in memory.

III  Short Answers

1. What is radix of a number system? Give example

2. Write note on binary number system.

3. Convert $(150)_{10}$ into Binary, then convert that Binary number to Octal

4. Write short note on ISCII

5. Add  a) $-22_{10} + 15_{10}$  b) $20_{10} + 25_{10}$

IV  Detail Answers

1. a) Write the procedure to convert fractional Decimal to Binary  

   b) Convert $(98.46)_{10}$ to Binary

2. Find 1’s Complement and 2’s Complement for the following Decimal number

   a) -98  b) -135

3. a) Add $1101010_{2} + 101101_{2}$

   b) Subtract $1101011_{2} - 111010_{2}$
Learning Objectives

- To know the organization of the computer components and their interconnections.
- To know the processors and their characteristics.
- To know the importance of memory devices and their roles in a computer.
- To explore RAM, ROM and differentiate each of them.
- To know about cache memory and how it improves the performance of a computer.
- To know the secondary devices and their usage.
- To know about the ports and interfaces so that external devices can be connected.

3.1 Introduction

Computer organization deals with the hardware components of a computer system. It includes Input / Output devices, the Central Processing Unit, storage devices and primary memory. It is concerned with how the various components of computer hardware operate. It also deals with how they are interconnected to implement an architectural specification. The term computer organization looks similar to the term computer architecture. But, computer architecture deals with the engineering considerations involved in designing a computer. On the other hand, Computer Organization deals with the hardware components that are transparent to the programmer.

3.2. Basics of Microprocessors

The CPU is the major component of a computer, which performs all tasks. This is realized by the microprocessor which is an Integrated Circuit. Microprocessors were first introduced in early 1970s. The first general purpose microprocessor, 4004 was developed by Intel Inc.

The microprocessor is a programmable multipurpose silicon chip. It is driven by clock pulses. It accepts input as a binary data and after processing, it provides the output data as per the
instructions stored in the memory. A block diagram of a microprocessor based system is shown in Figure 3.1.

Figure 3.1 A Microprocessor - Based System

The microprocessor is made up of 3 main units. They are:

- **Arithmetic and Logic unit (ALU):** To perform arithmetic and logical instructions based on computer instructions.

- **Control unit:** To control the overall operations of the computer through signals.

- **Registers (Internal Memory):** They are used to hold the instruction and data for the execution of the processor.

The microprocessor is able to communicate with the memory units and the Input / Output devices as in Figure 3.2. The system bus is a bunch of wires which is the collection of address bus, data bus and control bus that serves as communication channels between the Microprocessor and other devices.

Figure 3.2 Interconnecting the Microprocessor with Other Devices

**Characteristics of Microprocessors**

A Microprocessor's performance depends on the following characteristics:

a) Clock speed

b) Instruction set

c) Word size

**Speed Measurement**

**Hertz** – abbreviated as Hz is the standard unit of measurement used for measuring frequency. Since frequency is measured in cycles per second, one hertz equals one cycle per second.

Hertz is commonly used to measure wave frequencies, such as sound waves, light waves, and radio waves. For example, the average human ear can detect sound waves between 20 and 20,000 Hz. Sound waves close to 20 Hz have a low pitch and are called "bass" frequencies. Sound waves above 5,000 Hz have a high pitch and are called "treble" frequencies.

While hertz can be used to measure wave frequencies, it is also used to measure the speed of computer processors. For example, each CPU is rated at a specific clock speed. This number indicates how many instruction cycles the processor can perform in every second. Since modern processors can perform millions or even billions of instructions per second, clock speeds are typically measured in megahertz or gigahertz.
a) Clock Speed

Every microprocessor has an internal clock that regulates the speed at which it executes instructions. The speed at which the microprocessor executes instructions is called the clock speed. Clock speed is measured in MHz (Mega Hertz) or in GHz (Giga Hertz).

b) Instruction Set

A command which is given to a computer to perform an operation on data is called an instruction. Basic set of machine level instructions that a microprocessor is designed to execute is called as an instruction set. This instruction set carries out the following types of operations:

- Data transfer
- Arithmetic operations
- Logical operations
- Control flow
- Input/output

c) Word Size

The number of bits that can be processed by a processor in a single instruction is called its word size. Word size determines the amount of RAM that can be accessed by a microprocessor at one time and the total number of pins on the microprocessor. Total number of input and output pins in turn determines the architecture of the microprocessor.

The first commercial microprocessor, Intel 4004 is a 4 bit processor. It has 4 input pins and 4 output pins. Number of output pins is always equal to the number of input pins. It can process 4 bits at a time. So it is called as a 4 bit processor.

Intel 4004

Produced From late 1971 to 1981
Manufacturer Intel Inc.
Clock Speed 740 kHZ
Size 10 Micrometer (μm)
Transistors 2300
Data width 4 bits
Package 16 pin

Intel Inc. released many microprocessors like Intel 8085 which is an 8 bit processor, Intel 8086 which is a 16 bit processor and so on. Currently most of the microprocessors use 32 bit or 64 bit architecture.

3.3 Data communication between CPU and memory

The Central Processing Unit (CPU) has a Memory Data Register (MDR) and a Memory Address Register (MAR). The Memory Data Register (MDR) keeps the data which is transferred between the Memory and the CPU. The Program
Counter (PC) is a special register in the CPU which always keeps the address of the next instruction to be executed. The Arithmetic and Logic unit of CPU places the address of the memory to be fetched, into the Memory Address Register.

A bus is a collection of wires used for communication between the internal components of a computer. The address bus is used to point a memory location. A decoder, a digital circuit is used to point to the specific memory location where the word can be located. The address register is connected with the address bus, which provides the address of the instruction. A data bus is used to transfer data between the memory and the CPU. The data bus is bidirectional and the address bus is unidirectional. The control bus controls both read and write operations. The read operation fetches data from memory and transfers to MDR. A single control line performs two operations like Read/Write using 1 or 0. Also, the write operation transfers data from the MDR to memory. This organization is shown in Figure 3.3.

Figure 3.3 Bus connectivity between CPU and Memory

The word in the RAM has the same size (no. of bits) as the Memory Data Register (MDR). If the processor is an 8-bit processor like Intel 8085, its MDR and the word in the RAM both have 8 bits.

If the size of the MDR is eight bits, which can be connected with a word in the memory which is also eight bits size. The data bus has eight parallel wires to transfer data either from MDR to word or word to MDR based on the control (Read or write). This control line is labeled as R/W, which becomes 1 means READ operation and 0 means WRITE operation. Figure 3.4 shows the content of MDR and the word before the READ operation. Also, Figure 3.5 shows the content of MDR and the word after the READ operation.

The read operation transfers the data (bits) from word to memory data register. The write operation transfers the data (bits) from memory data register to word.
3.4 Types of Microprocessors

Microprocessors can be classified based on the following criteria:

- The width of data that can be processed
- The instruction set

3.4.1 Classification of Microprocessors based on the Data Width

Depending on the data width, microprocessors can process instructions. The microprocessors can be classified as follows:

- 8-bit microprocessor
- 16-bit microprocessor
- 32-bit microprocessor
- 64-bit microprocessor

3.4.2 Classification of Microprocessors based on Instruction Set

The size of the instruction set is another important consideration while categorizing microprocessors. Initially, microprocessors had very small instruction sets because complex hardware was expensive as well as difficult to build. As technology had developed to overcome these issues, more and more complex instructions were added to increase the functionality of microprocessors. Let us learn more about the two types of microprocessors based on their instruction sets.

3.4.2.1 Reduced Instruction Set Computers (RISC)

RISC stands for Reduced Instruction Set Computers. They have a small set of highly optimized instructions. Complex instructions are also implemented using simple instructions, thus reducing the size of the instruction set.

Examples of RISC processors are Pentium IV, Intel P6, AMD K6 and K7.

3.4.2.2 Complex Instruction Set Computers (CISC)

CISC stands for Complex Instruction Set Computers. They support hundreds of instructions. Computers supporting CISC can accomplish a wide variety of tasks, making them ideal for personal computers.

Examples of CISC processors are Intel 386 & 486, Pentium, Pentium II and III, and Motorola 68000.

3.5 Memory Devices

A memory is just like a human brain. It is used to store data and instructions. Computer memory is the storage space in the computer, where data...
and instructions are stored. There are two types of accessing methods to access (read or write) the memory. They are sequential access and random access. In sequential access, the memory is accessed in an orderly manner from starting to end. But, in random access, any byte of memory can be accessed directly without navigating through previous bytes. Different memory devices are arranged according to the capacity, speed and cost as shown in Figure 3.6.

![Figure 3.6 Memory Hierarchy](image)

**3.5.1 Random-Access Memory (RAM)**

The main memory is otherwise called as Random Access Memory. This is available in computers in the form of Integrated Circuits (ICs). It is the place in a computer where the Operating System, Application Programs and the data in current use are kept temporarily so that they can be accessed by the computer’s processor. The smallest unit of information that can be stored in the memory is called as a bit. The memory can be accessed by a collection of 8 bits which is called as a byte. The bytes are referred by ‘B’. If a computer has 1 megabyte of memory, then it can store 10,48,576 bytes (or characters) of information. [Hence 1MB is 1024KB and 1 KB is 1024 Bytes, So 1024X1024 =10,48,576 Bytes]

RAM is a volatile memory, which means that the information stored in it is not permanent. As soon as the power is turned off, whatever data that resides in RAM is lost. It allows both read and write operations.

**3.5.2 Types of RAM**

There are two basic types of RAM

- Dynamic RAM (DRAM)
- Static RAM (SRAM)

These two types differ in the technology they use to hold data. Dynamic RAM being a common type needs to be refreshed frequently. Static RAM needs to be refreshed less often, which makes it faster. Hence, Static RAM is more expensive than Dynamic RAM.

**3.5.3 Read Only Memory (ROM)**

Read only memory refers to special memory in a computer with pre-recorded data at manufacturing time which cannot be modified. The stored programs that start the computer and perform diagnostics are available in ROMs. ROM stores critical programs such as the program that boots the computer. Once the data has been written onto a ROM chip, it cannot be modified or removed and can only be read. ROM retains its contents even when the computer is turned off. So, ROM is called as a non-volatile memory.

**3.5.3.1 Programmable Read Only Memory (PROM)**

Programmable read only memory is also a non-volatile memory on which data can be written only once. Once a
program has been written onto a PROM, it remains there forever. Unlike the main memory, PROMs retain their contents even when the computer is turned off.

The PROM differs from ROM. PROM is manufactured as a blank memory, whereas a ROM is programmed during the manufacturing process itself. PROM programmer or a PROM burner is used to write data to a PROM chip. The process of programming a PROM is called burning the PROM.

3.5.3.2 Erasable Programmable Read Only Memory (EPROM)

Erasable Programmable Read Only Memory is a special type of memory which serves as a PROM, but the content can be erased using ultraviolet rays. EPROM retains its contents until it is exposed to ultraviolet light. The ultraviolet light clears its contents, making it possible to reprogram the memory.

An EPROM differs from a PROM, PROM can be written only once and cannot be erased. EPROMs are used widely in personal computers because they enable the manufacturer to change the contents of the PROM to replace with updated versions or erase the contents before the computer is delivered.

Most of the EPROM chips have a transparent area at the top surface which is covered by stickers. If it gets removed, the ultraviolet light in the sunlight may erase the contents.

3.5.3.3 Electrically Erasable Programmable Read Only Memory (EEPROM)

Electrically Erasable Programmable Read Only Memory is a special type of PROM that can be erased by exposing it to an electrical charge. Like other types of PROM, EEPROM retains its contents even when the power is turned off. Comparing with all other types of ROM, EEPROM is slower in performance.

3.5.4 Cache Memory

The cache memory is a very high speed and expensive memory, which is used to speed up the memory retrieval process. Due to its higher cost, the CPU comes with a smaller size of cache memory compared with the size of the main memory. Without cache memory, every time the CPU requests the data, it has to be fetched from the main memory which will consume more time. The idea of introducing a cache is that, this extremely fast memory would store data that is frequently accessed and if possible, the data that is closer to it. This helps to achieve the fast response time, Where response Time, (Access Time) refers to how quickly the memory can respond to a read / write request. Figure 3.8 shows the arrangement of cache memory between the CPU and the main memory.
3.6 Secondary Storage Devices

A computer generally has limited amount of main memory which is expensive and volatile. To store data and programs permanently, secondary storage devices are used. Secondary storage devices serve as a supportive storage to main memory and they are non-volatile in nature, secondary storage is also called as Backup storage.

3.6.1 Hard Disks

Hard disk is a magnetic disk on which you can store data. The hard disk has the stacked arrangement of disks accessed by a pair of heads for each of the disks. The hard disks come with a single or double sided disk.

3.6.2 Compact Disc (CD)

A CD or CD-ROM is made from 1.2 millimeters thick, polycarbonate plastic material. A thin layer of aluminum or gold is applied to the surface. CD data is represented as tiny indentations known as "pits", encoded in a spiral track moulded into the top of the polycarbonate layer. The areas between pits are known as "lands". A motor within the CD player rotates the disk. The capacity of an ordinary CD-ROM is 700MB.

3.6.3 Digital Versatile Disc (DVD)

A DVD (Digital Versatile Disc or Digital Video Disc) is an optical disc capable of storing up to 4.7 GB of data, more than six times what a CD can hold. DVDs are often used to store movies at a better quality. Like CDs, DVDs are read with a laser.

The disc can have one or two sides, and one or two layers of data per side; the number of sides and layers determines how much it can hold. A 12 cm diameter disc with single sided, single layer has 4.7 GB capacity, whereas the single sided, double layer has 8.5 GB capacity. The 8 cm DVD has 1.5 GB capacity. The capacity of a DVD-ROM can be visually determined by noting the number of data sides of the disc. Double-layered sides are usually gold-coloured, while single-layered sides are usually silver-coloured, like a CD.

3.6.4 Flash Memory Devices

Flash memory is an electronic (solid-state) non-volatile computer
storage medium that can be electrically erased and reprogrammed. They are either EEPROM or EPROM. Examples for Flash memories are pendrives, memory cards etc. Flash memories can be used in personal computers, Personal Digital Assistants (PDA), digital audio players, digital cameras and mobile phones. Flash memory offers fast access times. The time taken to read or write a character in memory is called access time. The capacity of the flash memories vary from 1 Gigabytes (GB) to 2 Terabytes (TB). A sample of flash memory is shown in Figure 3.11.

3.6.5 Blu-Ray Disc

Blu-Ray Disc is a high-density optical disc similar to DVD. Blu-ray is the type of disc used for PlayStation games and for playing High-Definition (HD) movies. A double-layer Blu-Ray disc can store up to 50GB (gigabytes) of data. This is more than 5 times the capacity of a DVD, and above 70 times of a CD. The format was developed to enable recording, rewriting and playback of high-definition video, as well as storing large amount of data. DVD uses a red laser to read and write data. But, Blu-ray uses a blue-violet laser to write. Hence, it is called as Blu-Ray.

3.7 Ports and Interfaces

The Motherboard of a computer has many I/O sockets that are connected to the ports and interfaces found on the rear side of a computer (Figure 3.13). The external devices can be connected to the ports and interfaces. The various types of ports are given below:

Serial Port: To connect the external devices, found in old computers.

Parallel Port: To connect the printers, found in old computers.

USB Ports: To connect external devices like cameras, scanners, mobile phones, external hard disks and printers to the computer.

USB 3.0 is the third major version of the Universal Serial Bus (USB) standard to connect computers with other electronic gadgets as shown in Figure 3.13. USB 3.0 can transfer data up to 5 Giga byte/second. USB3.1 and USB 3.2 are also released.
VGA Connector: To connect a monitor or any display device like LCD projector.

Audio Plugs: To connect sound speakers, microphone and headphones.

PS/2 Port: To connect mouse and keyboard to PC.

SCSI Port: To connect the hard disk drives and network connectors.

High Definition Multimedia Interface (HDMI)

High-Definition Multimedia Interface is an audio/video interface which transfers the uncompressed video and audio data from a video controller, to a compatible computer monitor, LCD projector, digital television etc.

Activity

Student Activity

- Identify the components of a computer
- Connecting external devices like printer/LCD projector.

Teacher Activity

- Show the components of a computer
- Display different ROM ICs
- Display the flash memory
- Demonstrate various ports and their usage
Part – I

Choose the correct answer

1. Which of the following is said to be the brain of a computer?
   (a) Input devices  (b) Output devices
   (c) Memory device  (d) Microprocessor

2. Which of the following is not the part of a microprocessor unit?
   (a) ALU  (b) Control unit
   (c) Cache memory  (d) register

3. How many bits constitute a word?
   (a) 8  (b) 16
   (c) 32  (d) determined by the processor used.

4. Which of the following device identifies the location when address is placed in the memory address register?
   (a) Locator  (b) encoder
   (c) decoder  (d) multiplexer

5. Which of the following is a CISC processor?
   (a) Intel P6  (b) AMD K6  (c) Pentium III  (d) Pentium IV

6. Which is the fastest memory?
   (a) Hard disk  (b) Main memory  (c) Cache memory  (d) Blue-Ray dist

7. How many memory locations are identified by a processor with 8 bits address bus at a time?
   (a) 28  (b) 1024  (c) 256  (d) 8000

8. What is the capacity of 12cm diameter DVD with single sided and single layer?
   (a) 4.7 GB  (b) 5.5 GB  (c) 7.8GB  (d) 2.2 GB
9. What is the smallest size of data represented in a CD?
   (a) blocks  (b) sectors  (c) pits  (d) tracks

10. Display devices are connected to the computer through.
    (a) USB port  (b) Ps/2 port  (c) SCSI port  (d) VGA connector

**Part – II**

(1) What are the parameters which influence the characteristics of a microprocessor?
(2) What is an instruction?
(3) What is a program counter?
(4) What is HDMI?
(5) Which source is used to erase the content of a EPROM?

**Part – III**

(1) Differentiate Computer Organization from Computer Architecture.
(2) Classify the microprocessor based on the size of the data.
(3) Write down the classifications of microprocessors based on the instruction set.
(4) Differentiate PROM and EPROM.
(5) Write down the interfaces and ports available in a computer.
(6) Differentiate CD and DVD
(7) How will you differentiate a flash memory and an EEPROM?

**Part – IV**

(1) Explain the characteristics of a microprocessor.
(2) How the read and write operations are performed by a processor? Explain.
(3) Arrange the memory devices in ascending order based on the access time.
(4) Explain the types of ROM.
<table>
<thead>
<tr>
<th><strong>Computer hardware</strong></th>
<th>The physical parts or components of a computer, such as the CPU, motherboard, monitor, keyboard, etc.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Intel</strong></td>
<td>Intel Corporation is an American multinational corporation and technology company involving in hardware manufacturing, especially motherboard and processors</td>
</tr>
<tr>
<td><strong>Silicon chip</strong></td>
<td>Silicon chip is an integrated, set of electronic circuits on one small flat piece of semiconductor material, silicon.</td>
</tr>
<tr>
<td><strong>Multipurpose</strong></td>
<td>Multipurpose is several purposes</td>
</tr>
<tr>
<td><strong>Address bus</strong></td>
<td>Address bus is a collection of wires that carry the address as bits</td>
</tr>
<tr>
<td><strong>Data bus</strong></td>
<td>Data bus is a collection of wires to carry data in bits</td>
</tr>
<tr>
<td><strong>Control bus</strong></td>
<td>Control bus is a control line/collection of wires to control the operations/functions</td>
</tr>
<tr>
<td><strong>Arithmetic operations</strong></td>
<td>Arithmetic operations are the mathematical operations on data like add, subtract etc</td>
</tr>
<tr>
<td><strong>Data Transfer</strong></td>
<td>Data Transfer means moving data from one component to another</td>
</tr>
<tr>
<td><strong>Logical operations</strong></td>
<td>Logical operations are the operations on binary/Boolean data like AND, OR, NOT</td>
</tr>
<tr>
<td><strong>Bidirectional</strong></td>
<td>Bidirectional means both the directions/ways</td>
</tr>
<tr>
<td><strong>Unidirectional</strong></td>
<td>Unidirectional means only one direction</td>
</tr>
<tr>
<td><strong>Access time</strong></td>
<td>Access time is the time delay or latency between a request to an electronic system, and the access being completed or the requested data returned</td>
</tr>
</tbody>
</table>
Learning objectives

✓ To know the concept of Operating Systems and their types.

✓ To acquire the basic Knowledge of Operating Systems and its functions.

4.1 Introduction to Software

A software is set of instructions that perform specific task. It interacts basically with the hardware to generate the desired output.

4.1.1 Types of Software

Software is classified into two types:
1) Application Software
2) System Software

Application Software:

Application software is a set of programs to perform specific task. For example MS-word is an application software to create text document and VLC player is familiar application software to play audio, video files and many more.

System Software:

System software is a type of computer program that is designed to run the computer’s hardware and application programs. For example Operating System and Language Processor

4.2 Introduction to Operating System (OS):

An Operating System (OS) is a system software which serves as an interface between a user and a computer.

This controls input, output and other peripheral devices such as disk drives, printers and electronic gadgets. The functions of an Operating System include file management, memory management, process management and device management and many more.

Figure: 4.1 Operating System

Without an Operating System, a computer cannot effectively manage all the resources. When a computer is switched on, the operating system is loaded in to
the memory automatically. A user cannot communicate directly with the computer hardware, unless an operating system is loaded.

Some of the popular Operating Systems used in personal computers and laptops are **Windows**, **UNIX** and **Linux**. The mobile devices mostly use Android and iOS as mobile **OS**.

### 4.2.1 Need for Operating System

Operating System has become essential to enable the users to design applications without the knowledge of the computer's internal structure of hardware. Operating System manages all the Software and Hardware. Most of the time there are many different computer programmes running at the same time, they all need to access the Computers, CPU, Memory and Storage. The need of Operating System is basically - it is the interface between the user and hardware.

### 4.3 Types of Operating System

Operating System are classified into the following types depending on their processing capabilities.

#### 4.3.1 Single User Operating Systems

An operating system allows only a single user to perform a task at a time. It is called as a Single user and single Task operating system. For a user, a task is a function such as printing a document,
writing a file to disk, editing a file or downloading a file etc. MS-DOS is an example for a single user and single task Operating System.

4.3.2 Multi-user Operating Systems

It is used in computers and laptops that allow same data and applications to be accessed by multiple users at the same time. The users can also communicate with each other. Windows, Linux and UNIX are examples for multi-user Operating System.

Build a cheap computer with raspbion OS and a Raspberry Pi. raspbion OS is a platform that's designed to teach how to build a computer, what every part of a circuit board does, and finally how to code apps or games. The platform is available in pre-designed kits.

4.4 Key features of the Operating System

The various key features are given below.

4.4.1 User Interface (UI)

User interface is one of the significant feature in Operating System. The only way that user can make interaction with a computer. If the computer interface is not user-friendly, the user slowly reduces the computer usage from their normal life. This is a main reason for key success of GUI (Graphical User Interface) based Operating System. The GUI is a window based system with a pointing device to direct I/O, choose from menus, make selections and a keyboard to enter text. Its vibrant colours attract the user very easily. Beginners are impressed by the help and pop up window message boxes. Icons are playing vital role of the particular application.

Now Linux distribution is also available as GUI based Operating System. The following points are considered when User Interface is designed for an application.

1. The user interface should enable the user to retain this expertise for a longer time.

2. The user interface should also satisfy the customer based on their needs.

3. The user interface should save user's precious time. Create graphical elements like Menus, Window, Tabs, Icons and reduce typing work will be an added advantage of the Operating System.

4. The ultimate aim of any product is to satisfy the customer. The User Interface is also to satisfy the customer.
5. The user interface should reduce number of errors committed by the user with little practice the user should be in a position to avoid errors (Error Log File)

4.4.2 Memory Management

Memory Management is the process of controlling and coordinating computer's main memory and assigning memory block (space) to various running programs to optimize overall computer performance. The Memory management involves the allocation of specific memory blocks to individual programs based on user demands. At the application level, memory management ensures the availability of adequate memory for each running program at all times.

The objective of Memory Management process is to improve both the utilization of the CPU and the speed of the computer’s response to its users via main memory. For these reasons the computers must keep several programs in main memory that associates with many different Memory Management schemes.

The Operating System is responsible for the following activities in connection with memory management:

- Keeping track of which portion of memory are currently being used and who is using them.
- Determining which processes (or parts of processes) and data to move in and out of memory.
- Allocation and de-allocation of memory blocks as needed by the program in main memory. (Garbage Collection)

4.4.3 Process management

Process management is function that includes creating and deleting processes and providing mechanisms for processes to communicate and synchronize with each other.

A process is the unit of work (program) in a computer. A word-processing program being run by an individual user on a computer is a process. A system task, such as sending output to a printer or screen, can also be called as a Process.

A computer consists of a collection of processes, they are classified as two categories:

- Operating System processes which is executed by system code
- User Processes which is execute by user code

All these processes can potentially execute concurrently on a single CPU.

A process needs certain resources including CPU time, memory, files and I/O devices to finish its task.

The Operating System is responsible for the following activities associated with the process management:

- Scheduling processes and threads on the CPUs
• Creating and deleting both user and system processes
• Suspending and resuming processes
• Providing mechanisms for process synchronization
• Providing mechanisms for process communication

The following algorithms are mainly used to allocate the job (process) to the processor.

1. FIFO  2. SJF  3. Round Robin
4. Based on Priority

FIFO (First In First Out) Scheduling:

This algorithm is based on queuing technique. Assume that a student is standing in a queue (Row) to get grade sheet from his/her teacher. The other student who stands first in the queue gets his/her grade sheet first and leaves from the queue (Row). Followed by the next student in the queue gets it corrected and so on. This is the basic logic of the FIFO algorithm.

Technically, the process that enters the queue first is executed first by the CPU, followed by the next and so on. The processes are executed in the order of the queue (row).

SJF (Shortest Job First) Scheduling:

This algorithm works based on the size of the job being executed by the CPU.

Consider two jobs A and B.

1)  A = 6 kilo bytes  2)  B = 9 kilo bytes

First the job “A” will be assigned and then job “B” gets its turn.

Round Robin Scheduling

The Round Robin (RR) scheduling algorithm is designed especially for time sharing systems. Jobs (processes) are assigned and processor time in a circular method. For example take three jobs A, B, C. First the job A is assigned to CPU then job B and job C and then again A, B and C and so on.

Based On Priority

The given job (process) is assigned based on a Priority. The job which has higher priority is more important than other jobs. Take two jobs A and B. Let the priority of A be 5 and priority B be 7.

Job B is assigned to the processor before job A.

4.4.4 Security Management

The major challenge in computer and software industry is to protect user’s legitimate data from hackers. The Operating System provides three levels of securities to the user end. They are

(1) File access level
(2) System level
(3) Network level

In order to access the files created by other people, you should have the access permission. Permissions can either
be granted by the creator of the file or by the administrator of the system.

System level security is offered by the password in a multi-user environment.

Both windows and Linux offer the password facility.

Network security is an indefinable one. So people from all over the world try to provide such a security.

All the above levels of security features are provided only by the Operating System.

4.4.5 Fault Tolerance

The Operating Systems should be robust. When there is a fault, the Operating System should not crash, instead the Operating System have fault tolerance capabilities and retain the existing state of system.

4.4.6 File Management

File management is an important function of OS which handles the data storage techniques. The operating System manages the files, folders and directory systems on a computer. Any type of data in a computer is stored in the form of files and directories/folders through File Allocation Table (FAT). The FAT stores general information about files like filename, type (text or binary), size, starting address and access mode (sequential/indexed / indexed-sequential/direct/relative). The file manager of the operating system helps to create, edit, copy, allocate memory to the files and also updates the FAT. The OS also takes care of the files that are opened with proper access rights to read or edit them. There are few other file management techniques available like Next Generation File System (NTFS) and ext2(Linux).

4.4.7 Multi-Processing

This is one of the features of Operating System. It has two or more processors for a single running process (job). Processing takes place in parallel is known as parallel processing. Each processor works on different parts of the same task or on two or more different tasks. Since the execution takes place in parallel, this feature is used for high speed execution which increases the power of computing.

4.4.8 Time-sharing

This is one of the features of Operating Systems. It allows execution of multiple tasks or processes concurrently. For each task a fixed time is allocated. This division of time is called Time-sharing. The processor switches rapidly between various processes after a time is elapsed or the process is completed.

For example assume that there are three processes called P1, P2, P3 and time allocated for each process 30, 40, 50 minutes respectively. If the process P1 completes within 20 minutes then processor takes the next process P2 for the execution. If the process P2 could not complete within 40 minutes, then the current process P2 will be paused and switch over to the next process P3.
4.4.9 Distributed Operating Systems

This feature takes care of the data and application that are stored and processed on multiple physical locations across the world over the digital network (internet/intranet). The Distributed Operating System is used to access shared data and files that reside in any machine around the world. The user can handle the data from different locations. The users can access as if it is available on their own computer.

The advantages of distributed Operating System are as follows:

- A user at one location can make use of all the resources available at another location over the network.
- Many computer resources can be added easily in the network
- Improves the interaction with the customers and clients.
- Reduces the load on the host computer.

Figure: 4.4 Distributed Operating Systems

4.5 Prominent Operating Systems

Prominent OS are as follows:

- UNIX
- Microsoft Windows
- Linux
- iOS
- Android

Modern operating systems use a Graphical User Interface (GUI). A GUI lets you use your mouse to click icons, buttons, menus and everything is clearly displayed on the screen using a combination of graphics and text elements.

OS can be either proprietary with a commercial license or can be open source.

Each Operating System's GUI has a different look and feel, so if you switch to a different Operating System, it may seem unfamiliar at first. However, modern Operating Systems are designed to be ease of use and most of the basic principles are the same.

Figure: 4.5 Various Operating Systems
Figure: 4.6 Classification of Operating Systems according to availability

4.5.1 UNIX

UNIX is a family of multitasking, multi-user operating systems that derive originally from AT&T Bell Labs, where the development began in the 1970s by Ken Thompson and Dennis Ritchie.

4.5.2 Linux

Linux is a family of open-source operating systems. It can be modified and distributed by anyone around the world. This is different from proprietary software like Windows, which can only be modified by the company that owns it. The main advantage of Linux operating system is that it is open source. There are many versions and their updates. Most of the servers run on Linux because it is easy to customize.

Figure: 4.7 LINUX Ubuntu Operating System
There are a few different distributions of Linux, like Ubuntu, Mint, Fedora, RedHat, Debian, Google’s Android, Chrome OS, and Chromium OS which are popular among users.

The Linux operating system was originated in 1991, as a project of “Linus Torvalds” from a university student of Finland. He posted information about his project on a news group for computer students and programmers. He received support and assistance from a large pool of volunteers who succeeded in creating a complete and functional Operating System. Linux is similar to the UNIX operating system.

Unix and the C programming language were developed by AT&T and distributed to government and academic institutions, which led to both being ported to a wider variety of machine families than any other operating system.

4.5.3 Microsoft Windows

Microsoft Windows is a family of proprietary operating systems designed by Microsoft Corporation and primarily targeted to Intel and AMD architecture based computers.

ReactOS is a Windows-alternative open source operating system, which is being developed on the principles of Windows - without using any of Microsoft’s code.
4.5.4 Operating systems for mobile devices

Mobile devices such as phones, tablets and MP3 players are different from desktop and laptop computers and hence they need special Operating Systems. Examples of mobile Operating Systems are Apple iOS and Google Android. The iOS running on an iPad is shown in Figure 4.12.

Operating systems for mobile devices generally are not as fully featured as those made for desktop and laptop computers and they are not able to run all software.
4.5.5 Android

Android is a mobile operating system developed by Google, based on Linux and designed primarily for touch screen mobile devices such as smartphones and tablets. Google has further developed Android TV for televisions, Android Auto for cars and Android Wear for wrist watches, each with a specialized user interface. Variants of Android are also used on game consoles, digital cameras, PCs and other electronic gadgets.

![Android Version Chart]

**Figure: 4.12 Android Mobile Open Source versions**

4.5.6 iOS - iPhone OS

iOS (formerly iPhone OS) is a mobile Operating System created and developed by Apple Inc., exclusively for its hardware. It is the Operating System that presently powers many of the company's mobile devices, including the iPhone, iPad and iPod Touch. It is the second most popular mobile Operating System globally after Android.

![iOS Home Screen]

**Figure: 4.13 iOS - iPhone Home Screen**
4.6 Student Activity

Activity 1: Draw a line between the operating system logo and the correct description.

- A command-line operating system is an example of Open Source software development and Free Operating System
- Is an Operating System that is very popular in universities, companies, bigenterprises etc
- A popular Operating System for mobile phone technology which is not linked with Apple products.
- Used with Apple computers and works well with cloud computing.
- Designed to be used for the Apple iPhone
- The most popular GUI Operating System for personal computers.

**Activity 2:** Discuss and provide the suitable answers for the questions below.

One of the functions of an Operating System is multi-tasking

1) Explain one reason why multi-tasking is needed in an operating system
2) State two other function of an Operating System

4.7 Teacher Activity:

1. Install two different Operating Systems in a single computer.
2. Create a virtual Operating System using virtualization software.
Part I

1) Operating system is a
   A) Application Software   B) Hardware   C) System Software   D) Component

2) Identify the usage of Operating Systems
   A) Easy interaction between the human and computer
   B) Controlling input & output Devices
   C) Managing use of main memory
   D) All the above

3) Which of the following is not a function of an Operating System?
   A) Process Management   B) Memory Management
   C) Security management   D) Compiler Environment

4) Which of the following OS is a Commercially licensed Operating system?
   A) Windows   B) UBUNTU   C) FEDORA   D) REDHAT

5) Which of the following Operating systems support Mobile Devices?
   A) Windows 7   B) Linux   C) BOSS   D) iOS

6) File Management manages
   A) Files   B) Folders   C) Directory systems   D) All the Above

7) Interactive Operating System provides
   A) Graphics User Interface (GUI)   B) Data Distribution
   C) Security Management   D) Real Time Processing

8) Android is a
   A) Mobile Operating system   B) Open Source
   C) Developed by Google   D) All the above
9) Which of the following refers to Android operating system's version?
A) JELLY BEAN  B) UBUNTU  C) OS/2  D) MITTIKA

Part II
1) What are the advantages of memory management in Operating System?
2) What is the multi-user Operating system?
3) What is a GUI?
4) List out different distributions of Linux operating system.
5) What are the security management features available in Operating System?
6) What is multi-processing?
7) What are the different Operating Systems used in computer?

Part III
8) What are the advantages and disadvantages of Time-sharing features?
9) Explain and List out examples of mobile operating system.
10) What are the differences between Windows and Linux Operating system?
11) Explain the process management algorithms in Operating System.

Part IV
12) Explain the concept of a Distributed Operating System.
13) Explain the main purpose of an operating system.
14) Explain advantages and disadvantages of open source operating systems.

References

1) Silberschatz, galvin gagne, Operating System concepts – john wiley&sons,inc
2) Andrew s. Tanenbaum, modern Operating Systems – pearson publication
3) Andrew s. Tanenbaum , Operating Systems design and implementation, prentice hall publication
4) Tom anderson, Operating Systems: principles and practice, recursive books
5) Thomas w. Doeppner, Operating Systems in depth: design and programming, john wiley & sons, inc
Learning Objectives

After learning the concepts in this chapter, the students will be able

- To know the concepts of Operating System.
- To know the versions of the windows operating system.
- To know the concepts like desktop and the elements of window.
- To explore the document window.
- To compare the different types of icons.
- To explore the windows directory structure.
- To practice creating files and folders in specific drives.
- To manage the files and folders.
- To know the procedure to start and shutdown the computer.

5.1. Introduction to Operating System

An Operating System (OS) is a system software (Figure 5.1) that enables the hardware to communicate and operate with other software. It also acts as an interface between the user and the hardware and controls the overall execution of the computer.

Following are some of the important functions of an Operating System as discussed in the previous chapter:

- Memory Management
- Process Management
- Device Management
- File Management
• Security Management
• Control overall system performance
• Error detecting aids
• Coordination between other software and users

The most popular Operating System are as follows:

• Windows Series - for desktop and laptop computers.
• Android - for smart phones.
• iOS - for Apple phones, i-Pad and i-Pod.
• Linux - Open source Operating System for desktop and server.

5.2. Introduction to Windows Operating System

Every computer needs an Operating System to function. Microsoft Windows is one of the most popular Graphical User Interface (GUI). Multiple applications can execute simultaneously in Windows, and this is known as “Multitasking”.

5.3. Various versions of Windows

<table>
<thead>
<tr>
<th>Versions</th>
<th>Logo</th>
<th>Year</th>
<th>Specific features</th>
</tr>
</thead>
</table>
| Windows 1.x | ![Logo](image1.png) | 1985 | • Introduction of GUI in 16-bit processor  
• Mouse was introduced as an input device. |
| Windows 2.x | ![Logo](image2.png) | 1987 | • Supports to minimize or maximize windows.  
• Control panel feature was introduced with various system settings and customising options. |
| Windows 3.x | ![Logo](image3.png) | 1992 | • Introduced the concept of multitasking.  
• Supported 256 colours which brought a more modern, colourful look to the interface. |

Windows Operating System uses both Keyboard and mouse as input devices. Mouse is used to interact with Windows by clicking its icons. Keyboard is used to enter alphabets, numerals and special characters.

Some of the functions of Windows Operating System are:

• Access applications (programs) on the computer (word processing, games, spread sheets, calculators and so on).
• Load any new program on the computer.
• Manage hardware such as printers, scanners, mouse, digital cameras etc.,
• File management activities (For example creating, modifying, saving, deleting files and folders).
• Change computer settings such as colour scheme, screen savers of your monitor, etc.

With reference to the Table 5.1, let us see the versions of Windows Operating System.
<table>
<thead>
<tr>
<th>Windows OS</th>
<th>Year</th>
<th>Key Features</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 95</td>
<td>1995</td>
<td>• Introduced Start button, the taskbar, Windows Explorer and Start menu. • Introduced 32-bit processor and focused more on multitasking.</td>
</tr>
<tr>
<td>Windows 98</td>
<td>1998</td>
<td>• Integration of the Web browser (Internet Explorer) with the Operating System. • DOS gaming began to disappear as Windows based games improved. • Plug and play feature was introduced.</td>
</tr>
<tr>
<td>Windows NT</td>
<td></td>
<td>• Designed to act as servers in network.</td>
</tr>
<tr>
<td>Windows Me</td>
<td>2000</td>
<td>• It introduced automated system diagnostics and recovery tools.</td>
</tr>
<tr>
<td>Windows 2000</td>
<td>2000</td>
<td>• Served as an Operating System for business desktop and laptop systems. • Four versions of Windows 2000 were released: Professional (for business desktop and laptop systems), Server (both a Web server and an office server), Advanced Server (for line-of-business applications) and Data Centre Server (for high-traffic computer networks).</td>
</tr>
<tr>
<td>Windows XP</td>
<td>2001</td>
<td>• Introduced 64-bit Processor. • Improved Windows appearance with themes and offered a stable version.</td>
</tr>
<tr>
<td>Windows Vista</td>
<td>2006</td>
<td>• Updated the look and feel of Windows.</td>
</tr>
</tbody>
</table>
Table 5.1 Versions of Windows Operating System.

<table>
<thead>
<tr>
<th>Version</th>
<th>Year</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 7</td>
<td>2009</td>
<td>• Booting time was improved, introduced new user interfaces like Aero Peek, pinning programs to taskbar, handwriting recognition etc. and Internet Explorer 8.</td>
</tr>
</tbody>
</table>
| Windows 8   | 2012 | • Windows 8 was faster than previous versions of Windows.  
• Start button was removed.  
• Windows 8 takes better advantage of multi-core processing, solid state drives (SSD), touch screens and other alternate input methods.  
• Served as common platform for mobile and computer. |
| Windows 10  | 2015 | • Start Button was added again.  
• Multiple desktop.  
• Central Notification Center for App notification and quick actions.  
• Cortana voice activated personal assistant. |

5.4. Handling the mouse

Before learning Window Operating System, you should know more about mouse and its actions.

The following are the mouse actions:

<table>
<thead>
<tr>
<th>Action</th>
<th>Reaction</th>
</tr>
</thead>
<tbody>
<tr>
<td>Point to an item</td>
<td>Move the mouse pointer over the item.</td>
</tr>
<tr>
<td>Click</td>
<td>Point to the item on the screen, press and release the left mouse button.</td>
</tr>
<tr>
<td>Right click</td>
<td>Point to the item on the screen, press and release the right mouse button. Clicking the right mouse button displays a pop up menu with various options.</td>
</tr>
<tr>
<td>Double-click</td>
<td>Point to the item on the screen, quickly press twice the left mouse button.</td>
</tr>
<tr>
<td>Drag and drop</td>
<td>Point to an item then hold the left mouse button as you move the pointer and when you have reached the desired position, release the mouse button.</td>
</tr>
</tbody>
</table>

*Figure 5.2. Mouse actions*
5.5. Windows Desktop

The opening screen of Windows is called “Desktop”.

The desktop of your computer may look different from what is seen in Figure 5.3.

This is because Windows allows you to change the appearance of the desktop.

In Figure 5.3, the desktop shows the Start button, Taskbar, Notification Area and date and time.

5.5.1. The Icons

Icon is a graphic symbol representing the window elements like files, folders, shortcuts etc., Icons play a vital role in GUI based applications.

5.5.1.1. Standard Icons

The icons which are available on desktop by default while installing Windows OS are called standard icons. The standard icons available in all Windows OS are My Computer, Documents and Recycle Bin.

You can move to the Desktop any time by pressing the Winkey + D or using Aero Peek while working in any application. You can see Figure 5.4 to know where Aero peek lies in the Taskbar.

![Figure 5.3. Microsoft Windows 7 Desktop](image)

![Figure 5.4. Aero peek button](image)
5.5.1.2. Shortcut Icons:

Shortcut icons can be created for any application or file or folder. By double clicking the icon, the related application or file or folder will open. This represents the shortcut to open a particular application. (Figure 5.5)

5.5.1.3. Disk drive icons:

The disk drive icons graphically represent five disk drive options. (i) Hard disk (ii) CD-ROM/DVD Drive (iii) Pen drive (iv) Other removable storage such as mobile, smart phone, tablet etc., (v) Network drives if your system is connected with other system. (Figure 5.6)

5.6. The Window

Window is a typical rectangular area in an application or a document. It is an area on the screen that displays information for a specific program.
5.7. Application Window

It is an area on a computer screen with defined boundaries, and within which information is displayed. Such windows can be resized, maximized, minimized, placed side by side, overlap, and so on.

An Application Window contains an open application i.e. current application such as Word or Paint. When two or more windows are open, only one of them is active and the rest are inactive. Figures 5.7 and 5.8 display the Application Window of OpenOffice Writer and the appearance of the Multiple Windows opened (overlapped) in the Desktop.

5.8. Document Window

A document window is a section of the screen used to display the contents of a document. Figure 5.9 is an example of a document window.

When you open any application, such as OpenOffice Writer, OpenOffice Impress or OpenOffice Calc etc., you will find two Windows on the screen. The larger Window is called the Application Window. This Window helps the user to communicate with the Application program. The smaller window, which is inside the Application Window, is called the Document window. This Window is used for typing, editing, drawing, and formatting the text and graphics.

Figure 5.7. Application Window
Figure 5.8. Multiple Windows opened in Desktop

Figure 5.9. Document Window
5.9. Elements of a window

Figure 5.10 helps to understand the elements of a window.

5.9.1. Title Bar – The title bar will display the name of the application and the name of the document opened. It will also contain minimize, maximize and close button.

5.9.2. Menu Bar

The menu bar is seen under the title bar. Menus in the menu bar can be accessed by pressing Alt key and the letter that appears underlined in the menu title. Additionally, pressing Alt or F10 brings the focus on the first menu of the menu bar.

In Windows 7, in the absence of the menu bar, click Organize and from the drop down menu, click the Layout option and select the desired item from that list.

Figure 5.10 The elements of a window.

Figure 5.11. To display Menu Bar

Figure 5.11 helps to understand how to make menu bar visible in its absence.
5.9.3. The Workspace

The workspace is the area in the document window to enter or type the text of your document. Figure 5.10 shows the workspace area in the document window.

5.9.4. Scroll bars

- The scroll bars are used to scroll the workspace horizontally or vertically. Figure 5.10 shows the Scroll bars.

5.9.5. Corners and borders

The corners and borders of the window helps to drag and resize the windows. The mouse pointer changes to a double headed arrow when positioned over a border or a corner. Drag the border or corner in the direction indicated by the double headed arrow to the desired size as shown in Figure 5.10. The window can be resized by dragging the corners diagonally across the screen.

5.10. Explore the Computer

5.10.1. Start Menu

In the lower left-hand corner of the windows screen is the Start button. When you click on the button, the Start menu will appear. Using the start menu, you can start any application.

![Start Menu](image)

**Figure 5.12 - Start Menu**

**Taskbar**

At the bottom of the screen is a horizontal bar called the taskbar. This bar contains (from left to right) the Start button, shortcuts to various programs, minimized programs and in the extreme right corner you can see the system tray which consist of volume...
control, network, date and time etc. Next to the Start button is the quick Launch Toolbar which contains task for frequently used applications.

Figure 5.13. Taskbar

5.10.2. Computer Icon

By clicking this icon, the user can see the disk drivers mounted in the system. In Windows XP, Vista, this icon is called "My computer" in Windows 8 and 10, it is called "This PC". The functionality of computer icon remains the same in all versions of Windows as shown in Figure 5.14.

5.10.3. Starting and Closing Applications

Most of the applications installed on your computer are available through the start menu. Depending on the system setup, the applications in the Start menu varies. To start an application:

1. Click the Start button and then point to All Programs. The Program menu appears. (Figure 5.15)

2. Point to the group that contains the application you want to start, and then click the application name.

Figure 5.14. Computer icon in versions of Windows OS
3. You can also open an application by clicking Run on the Start menu, and the name of the application. (Figure 5.16)

4. To quit a application, click the Close button in the upper right corner of the application window. (Figure 5.17)
5. You can also quit an application by clicking on File → Exit and File → Close option in Windows 7. (Figure 5.17)

- Start the application Wordpad using Start menu and Run option.
- Close the Wordpad application using File menu.

5.11. Managing Files and Folders

In Windows 7, you can organize your documents and programs in the form of files and folders. You can move, copy, rename, delete and search the files and folders.

5.11.1. Creating files and Folders

5.11.1.1 Creating Folders

You can store your files in many locations – on the hard disk or in other devices. To better organise your files, you can store them in folders.
There are two ways in which you can create a new folder:

Method I:

Step 1: Open Computer Icon.

Step 2: Open any drive where you want to create a new folder. (For example select D:)

Step 3: Click on File → New → Folder.

Step 4: A new folder is created with the default name “New folder”. (Figure 5.19)

Step 5: Type in the folder name and press Enter key. (Figure 5.20 shows the newly created Folder named “Test Folder”). 
Method II:

In order to create a folder in the desktop:

Step 1: In the Desktop, right click → New → Folder. (Figure 5.21 Shown the procedure)

Step 2: A Folder appears with the default name “New folder” and it will be highlighted as shown in the Figure 5.22.

Step 3: Type the name you want and press Enter Key.

Step 4: The name of the folder will change.

2. Create a Folder in My Documents with your name using any one of the methods discussed.

5.11.1.2 Creating Files (Wordpad)

Wordpad is an in-built word processor application in Windows OS to create and manipulate text documents.

In order to create files in wordpad you need to follow the steps given below.
1. Click Start → All Programs → Accessories → Wordpad or Run → type Wordpad, click OK. Wordpad window will be opened as shown in Figure 5.23.

2. Type the contents in the workspace and save the file using File → Save or Ctrl + S.

3. Save As dialog box will be opened.

4. In the dialog box, select the location where you want to save the file by using look in drop down list box.

5. Type the name of the file in the file name text box.

6. Click save button.

Workshop

3. Open the Wordpad application and save it under a folder created with your name in My Documents.

5.11.2. Finding Files and Folders

You can use the search box on the Start menu to quickly search a particular folder or file in the computer or in a specific drive.

To find a file or folder:

1. Click the Start button, the search box appears at the bottom of the start menu.

2. Type the name of the file or the folder you want to search. Even if you give the part of the file or folder name, it will display the list of files or folders starting with the specified name. (Figure 5.24)

3. The files or the folders with the specified names will appear, if you click that file, it will directly open that file or the folder.
4. There is another option called “See more results” which appears above the search box.

5. If you click it, it will lead you to a Search Results dialog box where you can click and open that file or the folder.

Searching Files or folders using Computer icon

1. Click Computer Icon from desktop or from Start menu.

2. The Computer disk drive screen will appear and at the top right corner of that screen, there is a search box option. (Figure 5.25)

3. Type the name of the file or the folder you want to search. Even if you give the part of the file or folder name, it will display the list of files or folders starting with the specified name.
4. Just click and open that file or the folder.

4. Find the file created in Workshop-3 using the above procedure.

5.11.3. Opening existing Files or Folders

The most common way of opening a file or a Folder is to double click on it.

5.11.4. Renaming Files or Folders

There are number of ways to rename files or folders. You can rename using the File menu, left mouse button or right mouse button.

**Method 1**

Using the FILE Menu

1. Select the File or Folder you wish to Rename.

2. Click File→ Rename.

3. Type in the new name.

4. To finalise the renaming operation, press Enter as in Figure 5.26.
Figure 5.26. Renaming File/Folders using the File menu

Figure 5.27. Folder renamed

Figure 5.27, you can see that the folder is renamed as SCERT-DPI from SCERT.
Method 2

Using the Right Mouse Button

1. Select the file or folder you wish to rename.

2. Click the right mouse button over the file or folder. (Figure 5.28)

3. Select Rename from the pop-up menu.

4. Type in the new name.

5. To finalise the renaming operation, press Enter.

6. Figure 5.29. Shows that the folder "New Folder" is renamed as C++.

Method 3

Using the Left Mouse Button

1. Select the file or folder you wish to rename.

2. Press F2 or click over the file or folder. A surrounding rectangle will appear around the name.

3. Type in the new name.

4. To finalise the renaming operation, press Enter.

5. Rename the file created by you using the File menu, left mouse button or right mouse button.

Workshop

5.11.5. Moving/Copying Files and Folders

You can move your files or folders to other areas using variety of methods.
Moving Files and Folders

Method I-CUT and PASTE

To move a file or folder, first select the file or folder and then choose one of the following:

- Click on the Edit → Cut or Ctrl + X or right click → cut from the pop-up menu.

- To move the file(s) or folder(s) in the new location, navigate to the new location and paste it using Click Edit → Paste from edit menu or Ctrl + V using keyboard.

- Or Right click → Paste from the pop-up menu. The file will be pasted in the new location.

Method II – Drag and Drop

In the disk drive window, we have two panes called left and right panes. In the left pane, the files or folders are displayed like a tree structure. In the right pane, the files inside the specific folders in the left pane are displayed with various options.

- In the right pane of the Disk drive window, select the file or folder you want to move.

- Click and drag the selected file or folder from the right pane, to the folder list on the left pane.

- Release the mouse button when the target folder is highlighted (active).

- Your file or folder will now appear in the new area. Figure 5.30 shows how to move files or folders using drag and drop method.

![Image of disk drive window]

Figure 5.30. Moving the File/Folder using drag and drop

Copying Files and Folders

There are variety of ways to copy files and folders:

Method I - COPY and PASTE

To copy a file or folder, first select the file or folder and then choose one of the following:

- Click Edit → Copy or Ctrl + C or right click → Copy from the pop-up menu.

- To paste the file(s) or folder(s) in the new location, navigate to the target location then do one of the following:

  - Click Edit → Paste or Ctrl + V.

  - Or Right click → Paste from the pop-up menu.
Method II – Drag and Drop

- In the RIGHT pane, select the file or folder you want to copy.
- Click and drag the selected file and/or folder to the folder list on the left, and drop it where you want to copy the file and/or folder.
- Your file(s) and folder(s) will now appear in the new area.

Note
If you want to select multiple files or folders, use Ctrl + Click.

5.11.6. Copying Files and Folders to removable disk

There are several methods of transferring files to or from a removable disk.

- Copy and Paste
- Send To

METHOD I - Copy and Paste

- Plug the USB flash drive directly into an available USB port.
- If the USB flash drive or external drive folder does NOT open automatically, follow these steps:
- Click Start→Computer. (Figure 5.31)

Figure 5.31. Selecting Computer option from Start menu

- Double-click on the Removable Disk associated with the USB flash drive. (Figure 5.32)

Figure 5.32. Double Clicking Removable Disk
• Navigate to the folders in your computer containing files you want to transfer.

Right-click on the file you want to copy, then select Copy. (Figure 5.33)

**Figure 5.33. Copying File using right click**

• Return to the Removable Disk window, right-click within the window, then select Paste. (Figure 5.34)

**Figure 5.34. Pasting File using right click**

**METHOD II - Send To**

• Plug the USB flash drive directly into an available USB port.

• Navigate to the folders in your computer containing files you want to transfer.

• Right-click on the file you want to transfer to your removable disk.

• Click Send To and select the Removable Disk associated with the USB flash drive. (Figure 5.35)

Workshop

6. • Move the file created by you in My Documents to Drive D:.

• Copy the file created by you from drive D: to a removable disk.

5.11.7. Deleting Files and Folders

• When you delete a file or folder, it will move into the Recycle Bin.

**To delete a file or folder:**

Select the file or folder you wish to delete.
1. Right-click the file or folder, select **Delete** option from the pop-up menu or Click **File** → **Delete** or press **Delete** key from the keyboard.

2. The file will be deleted and moved to the Recycle bin.

**Workshop**

7. Delete the file created by you after duplicating the same under My Documents.

**Note**

To permanently delete a file or folder (i.e. to avoid sending a file or folder to the Recycle Bin), hold down the SHIFT key, and press **delete** on the keyboard.

---

**Recycle Bin**

Recycle bin is a special folder to keep the files or folders deleted by the user, which means you still have an opportunity to recover them. The user cannot access the files or folders available in the Recycle bin without restoring it. To restore file or folder from the Recycle Bin:

- Open Recycle bin.
- Right click on a file or folder to be restored and select **Restore** option from the pop-up menu.
- To restore multiple files or folders, select **Restore all items**.
- To delete all files in the Recycle bin, select **Empty the Recycle Bin**.
5.12. Creating Shortcuts on the Desktop

Shortcuts to your most often used folders and files may be created and placed on the Desktop to help automate your work.

- Select the file or folder that you wish to have as a shortcut on the Desktop.
- Right click on the file or folder.
- Select **Send to** from the shortcut menu, then select Desktop (create shortcut) from the sub-menu.
- A shortcut for the file or folder will now appear on your desktop and you can open it from the desktop in the same way as any other icon. Figure 5.36.

![Figure 5.36 Creating Shortcut](image)

5.13. Shutting down or Logging off a Computer

Once you have closed all open applications, you can either log off your computer or shut down the computer.
Log Off

To Log off/Shut down the computer:

- Click **start → log off** (click the arrow next to Shut down) or **Start → Shutdown**. (Figure 5.37.)

- If you have any open programs, then you will be asked to close them or windows will Force shut down, you will lose any un-saved information if you do this.

- **Switch User**: Switch to another user account on the computer without closing your open programs and Windows processes.

- **Log Off**: Switch to another user account on the computer after closing all your open programs and Windows processes.

- **Lock**: Lock the computer while you're away from it.

- **Restart**: Reboot the computer. (This option is often required as part of installing new software or Windows update.)

- **Sleep**: Puts the computer into a low-power mode that retains all running programs and open Windows in computer memory for a super-quick restart.

- **Hibernate** (found only on laptop computers): Puts the computer into a low-power mode after saving all running programs and open Windows on the machine's hard drive for a quick restart.
Learning Objectives

• To compare Windows Operating System with Ubuntu.

• To differentiate the Window elements or icons from Ubuntu Launcher.

• To explore how to copy, delete and rename files or folders in Ubuntu.

• To explore the differences in Windows 7, Windows 8 and Windows 10.

• To compare the Windows elements between Windows 7, Windows 8 and Windows 10.

• To format Files and folders in Windows 7, Windows 8 and Windows 10.

5.14. Open Source Operating System

Open Source refers to a program or software in which the source code is available in the web to the general public free of cost.

Open Source code is typically created as a collaborative effort in which programmers continuously improve upon the source code in the web and share the changes within the community.

5.15. Linux

Linux is one of the popular Open Source versions of the UNIX Operating System. It is Open Source as its source code is freely available.

The most popular Linux server distributors are:

• Ubuntu Linux

• Linux Mint

• Arch Linux

• Deepin

• Fedora

• Debian

• CentOS

5.16. Ubuntu

Ubuntu is a Linux-based operating system. It is designed for computers, smartphones, and network servers. The system is developed by a UK based company called Canonical Ltd.

Ubuntu was conceived in 2004 by Mark Shuttleworth, a successful South African entrepreneur, and his company Canonical Ltd.
5.16.1. Significant features of Ubuntu

- The desktop version of Ubuntu supports all normal software like Windows such as Firefox, Chrome, VLC, etc.

- It supports the office suite called LibreOffice.

- Ubuntu has in-built email software called Thunderbird, which gives the user access to email such as Exchange, Gmail, Hotmail, etc.

- There are free applications for users to view and edit photos, to manage and share videos.

- It is easy to find content on Ubuntu with the smart searching facility.

- The best feature is, it is a free operating system and is backed by a huge open source community.

5.17. Ubuntu desktop

There are many similarities between Ubuntu and other operating systems, such as Microsoft Windows, Apple. This is because they are all based on the concept of a Graphical User Interface (GUI).

The following are the names of the icons in the Ubuntu OS.

- Search your Computer
- Files
- Firefox Webbrowser

![Ubuntu Desktop](image)

*Figure 5.38. The Ubuntu 16.04 default desktop.*
Figure 5.40 explains the icons in the Ubuntu operating system and their equivalent ones in the Windows operating system.

**Menu bar** The menu bar is located at the top of the screen. The menu bar incorporates common functions used in Ubuntu. The frequently used icons in the menu bar are found on the right. The most common indicators in the Menu bar are located in the indicator or notification area (Figure 5.39)

![Figure 5.39 Indicators in the Menu bar](image)

**Network indicator** - This manages network connections, allowing you to connect to a wired or wireless network.

**Text entry settings** - This shows the current keyboard layout (such as En, Fr,Ku, and so on) . If more than one keyboard layout is shown, it allows you to select a keyboard layout out of those choices. The keyboard indicator menu contains the following menu items: Character Map, Keyboard Layout Chart, and Text Entry Settings.

**Messaging indicator** - This incorporates your social applications. From here, you can access instant messenger and email clients.

**Sound indicator** - This provides an easy way to adjust the volume as well as access your music player.

**Clock** - This displays the current time and provides a link to your calendar and time and date settings.

**Session indicator** - This is a link to the system settings, Ubuntu Help, and session options (like locking your computer, user/guest session, logging out of a session, restarting the computer, or shutting down completely).

**Title bar** - The title bar shows the name of the currently selected directory. It also contains the Close, Minimize, and Maximize buttons.

**Toolbar** - The toolbar displays your directory browsing history (using two arrow buttons), your location in the file system, a search button, and options for your current directory view.

5.18. The desktop background

Below the menu bar at the top of the screen is an image covering the entire desktop. This is the default desktop background, or wallpaper, belonging to the default Ubuntu 16.04 theme known as Ambiance. (Figure 5.38)
5.19. The Launcher (Equivalent to Task bar)

The vertical bar of icons on the left side of the desktop is called the Launcher. The Launcher provides easy access to applications, mounted devices, and the Trash. All current applications on your system will place an icon in the Launcher. (Figure 5.40)

5.20. Elements of Ubuntu

5.20.1. Search your Computer Icon

This icon is equal to search button in Windows OS. Here, you have to give the name of the File or Folder for searching them. (Figure 5.40)

5.20.2. Files

This icon is equivalent to My Computer icon. From here, you can directly go to Desktop, Documents and so on. (Figure 5.40)
5.20.3. Firefox Web Browser

By clicking this icon, you can directly browse the internet. This is equivalent to clicking the Web Browser in Task bar in Windows. (Figure 5.40)

5.20.4. LibreOffice Writer

This icon will directly take you to document preparation application like MS Word in Windows. (Figure 5.41)

5.20.5. LibreOffice Calc

This icon will open LibreOffice Calc application. It is similar to MS Excel in Windows. (Figure 5.42)
5.20.6 LibreOffice Impress

By clicking this icon, you can open LibreOffice Impress to prepare any presentations in Ubuntu like MS PowerPoint. (Figure 5.43)

5.20.7. Ubuntu Software Icon

This icon will let you add any additional applications you want. This can be done by clicking the Update option at the top right corner of that screen. (Figure 5.40)

5.20.8. Online Shopping icon

Using this icon user can buy and sell any products online. (Figure 5.40)

Figure 5.43  LibreOffice Impress Window

5.20.9. System Settings Icons

Figure 5.44  System Settings Icons
This icon is similar to the Control panel in the Windows Operating System. But here, you need to authenticate the changes by giving your password. You cannot simply change as you do in Windows. (Figure 5.44)

5.20.10 Trash

This icon is the equivalent of Recycle bin of windows OS. All the deleted Files and Folders are moved here. (Figure 5.40)

5.21 Creating, Deleting Files/Folders

Similar to Windows OS, you can create, delete the files and folders with the same procedure by clicking Files icon. Figure 5.46 shows the method of creating File or Folder by right clicking in the Desktop. A new File or new Folder can also be created by using File menu (Figure 5.47)

![VBox_GAs_5.2.2 Icons](image1)

*Figure 5.45 VBox_GAs_5.2.2 Icons*

![Creating a File or Folder by right clicking](image2)

*Figure 5.46 Creating a File or Folder by right clicking*
Deleting a File/Folder

A file / folder created by you can be moved to trash by using right click or by using menu. (Figure 5.48 & Figure 5.49)
5.22 Shutting down Ubuntu using Session options

When you have finished working on your computer, you can choose to Log Out, Suspend or Shut down through the Session Indicator on the far right side of the top panel.

Figure 5.50 Session Options

Activity

Student Activity

1. Create files and folders using Windows and Ubuntu and compare them.

2. Prepare an Assignment on the topic “Popular Linux distributions”.

3. Customise few applications using Ubuntu. Write the procedure.


5. Prepare a table on the difference in views of Windows 7, Windows 8 and Windows 10 operating system.
Teacher Activity

The teacher can adopt the following methodologies to incorporate inside the classroom.

1. Laboratory method – the teacher can take the entire class to the computer lab and demonstrate the concept using projector.

2. Demonstration using laptop and projector – The teacher can demonstrate the same inside the classroom using a laptop and projector.

Evaluation

PART I

Choose the Best Answer

1. From the options given below, choose the operations managed by the operating system.
   a. Memory
   b. Processes
   c. Disks and I/O devices
   d. all of the above

2. Which is the default folder for many Windows Applications to save your file?
   a. My Document
   b. My Pictures
   c. Documents and Settings
   d. My Computer

3. Under which of the following OS, the option Shift + Delete – permanently deletes a file or folder?
   a. Windows 7
   b. Windows 8
   c. Windows 10
   d. None of the OS
4. What is the meaning of "Hibernate" in Windows XP/Windows 7?
   a. Restart the Computer in safe mode
   b. Restart the Computer in hibernate mode
   c. Shutdown the Computer terminating all the running applications
   d. Shutdown the Computer without closing the running applications

5. Which of the following OS is not based on Linux?
   a. Ubuntu   b. Redhat   c. CentOS   d. BSD

6. Which of the following in Ubuntu OS is used to view the options for the devices installed?
   a. Settings   b. Files   c. Dash   d. VBox_GAs_5.2.2

7. Identify the default email client in Ubuntu.
   a. Thunderbird   b. Firefox   c. Internet Explorer   d. Chrome

8. Which is the default application for spreadsheets in Ubuntu? This is available in the software launcher.
   a. LibreOffice Writer   b. LibreOffice Calc
   c. LibreOffice Impress   d. LibreOffice Spreadsheet

9. Which is the default browser for Ubuntu?
   a. Firefox   b. Internet Explorer
   c. Chrome   d. Thunderbird

10. Where will you select the option to log out, suspend, restart, or shut down from the desktop of Ubuntu OS?
    a. Session Indicator   b. Launcher   c. Files   d. Search

PART II

1. Differentiate cut and copy options.

2. What is the use of a file extension?

3. Differentiate Files and Folders.

4. Differentiate Save and save As option.

5. What is Open Source?
6. What are the advantages of open source?

7. Mention the different server distributions in Linux OS.

8. How will you log off from Ubuntu OS?

PART III

1. Analyse: Why the drives are segregated?

2. If you are working on multiple files at a time, sometimes the system may hang. What is the reason behind it. How can you reduce it?

3. Are drives such as hard drive and floppy drives represented with drive letters? If so why, if not why?

4. Write the specific use of Cortana.

5. List out the major differences between Windows and Ubuntu OS.

6. Are there any difficulties you face while using Ubuntu? If so, mention it with reasons.

7. Differentiate Thunderbird and Firefox in Ubuntu OS.

8. Differentiate Save, Save As and Save a Copy in Ubuntu OS.

PART IV

1. Explain the versions of Windows Operating System.

2. Draw and compare the icon equivalence in Windows and Ubuntu.

3. Complete the following matrix

<table>
<thead>
<tr>
<th>Navigational method</th>
<th>Located on</th>
<th>Ideally suited for</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start button</td>
<td>Task bar</td>
<td>Exploring your disk drives and using system tools</td>
</tr>
<tr>
<td>Windows Explorer</td>
<td>Desktop</td>
<td>Seeing hierarchy of all computer contents and resources in one window.</td>
</tr>
<tr>
<td>Quick Launch</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
4. Observe the figure and mark all the window elements. Identify the version of the Windows OS.

5. Write the procedure to create, rename, delete and save a file in Ubuntu OS. Compare it with Windows OS.

<table>
<thead>
<tr>
<th><strong>Operating System (OS)</strong></th>
<th>System software that enables the hardware to communicate and operate with other software.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mouse</td>
<td>Handheld hardware input device that control a cursor in a GUI and can move and select text, icons, files, and folders.</td>
</tr>
<tr>
<td>Windows</td>
<td>Familiar operating system developed by Microsoft corp.</td>
</tr>
<tr>
<td>Desktop</td>
<td>Opening screen of Windows operating system.</td>
</tr>
<tr>
<td>Icon</td>
<td>Tiny image represent a command.</td>
</tr>
<tr>
<td>Folder</td>
<td>Container of files</td>
</tr>
<tr>
<td>Linux</td>
<td>An operating system.</td>
</tr>
<tr>
<td>Ubuntu</td>
<td>A flavour of Linux operating System.</td>
</tr>
<tr>
<td>Firefox</td>
<td>One of the familiar web browser.</td>
</tr>
<tr>
<td>LibreOffice</td>
<td>Office automation tool available with Ubuntu by default.</td>
</tr>
<tr>
<td>Trash</td>
<td>A special folder contains deleted files.</td>
</tr>
</tbody>
</table>
Learning Objectives

• To understand the importance of a word processor.
• To understand the application in Open Office.
• To understand the windows and working in OpenOffice writer.
• To know the editing operations in OpenOffice writer.
• To know the text formatting and page formatting in OpenOffice writer.
• To know spell check features of OpenOffice writer.

6.1 Introduction to Word Processor

Word processor is a computer software to create, edit, manipulate, transmit, store and retrieve a text document. The above said activities are called as “Word Processing”. In other words, Word processing is an activity carried out by a computer with suitable software to create, edit, manipulate, transmit, store and retrieve text documents.

There are lots of word processing software available as proprietary source as well as open source. The familiar word processing packages are given in the following Table.

<table>
<thead>
<tr>
<th>Table 6.1 - Proprietary Software &amp; Open Source Software</th>
</tr>
</thead>
<tbody>
<tr>
<td>Proprietary source Word processing software</td>
</tr>
<tr>
<td>Package</td>
</tr>
<tr>
<td>Microsoft Word</td>
</tr>
<tr>
<td>WPS Word</td>
</tr>
<tr>
<td>WordPro</td>
</tr>
<tr>
<td>Open Source</td>
</tr>
<tr>
<td>Package</td>
</tr>
<tr>
<td>OpenOffice Writer</td>
</tr>
<tr>
<td>LibreOffice Writer</td>
</tr>
<tr>
<td>Abiword</td>
</tr>
</tbody>
</table>

Tamil Word Processors

Tamil openoffice writer, Tamil LibreOffice Writer, Kamban 3.0, Mentamizh2017 – These are familiar word processors exclusively for Tamil Language. Microsoft also provides full Tamil interface to its office suits.

In this chapter, you are going to learn about OpenOffice Writer word processor.

6.2 An Introduction to OpenOffice Writer

OpenOffice is the leading open-source office software suite for word
processing, spreadsheets, presentations, graphics, databases and more. It is available in many languages and works on all common computers. It stores all your data in an International open standard format and can also read and write files from other common office software packages. OpenOffice is easy to learn. OpenOffice is a productive office suite with a collection of different software packages such as

- **OpenOffice Writer** - Word Processor to create text documents
- **OpenOffice Calc** - Spreadsheet to create worksheets
- **OpenOffice Base** - Database
- **OpenOffice Impress** - Presentation software
- **OpenOffice Draw** - Drawing Software
- **OpenOffice Formula** - Create formula and equations

OpenOffice Writer is the word processor component of OpenOffice. In addition to the usual features of a word processor (spelling check, thesaurus, hyphenation, autocorrect, find and replace, automatic generation of tables of contents and indexes, mail merge and others), Writer provides these important features:

- Templates and styles.
- Page layout methods, including frames, columns, and tables.
- Embedding or linking of graphics, spreadsheets, and other objects.
- Built-in drawing tools.
- Master documents-to group a collection of documents into a single document.
- Change tracking during revisions.
- Database integration, including a bibliography database.
- Export to PDF.

6.2.1 Download and Install openoffice

Download and Install the latest version of OpenOffice suite from http://www.openoffice.org/download at free of cost.

6.2.2 Creating a new document in OpenOffice Writer

A new OpenOffice Writer document can be created by various methods. From windows, select Start → All Programs → OpenOffice → OpenOffice Writer

(or)

From Star Center (Welcome Screen):

- Double-click on “OpenOffice” icon the desktop
- Now, a welcome screen appears as shown in **Figure 6.1**

The opening screen is called as “Star Center”. Writer is one of the components of OpenOffice. So, it may be invoked from the “Star Center” by simply clicking on the “Text Document” icon. (or)

A new text document can also be created by selecting **File** → **New** → **Text Document** from any OpenOffice Application. **Ctrl + N** keyboard shortcut can also be used to open a new text document as shown in the **Figure 6.2**
Figure 6.1 Opening Screen (Star Center) of OpenOffice

Figure 6.2 A new OpenOffice Writer Window
6.2.3 Parts of Writer Window:

The Figure 6.3 shows the contents of OpenOffice Writer window such as Title bar, Menu bar, Standard Toolbar, Formatting Tool bar, Ruler, Work space and Status bar. The components of a openoffice writer window are explained below in Figure 6.3.

**Title Bar**

The title bar is displayed at the top most part of the window, which displays the name of the document and the name of the application. By default, the initial document is given the name as Untitled1.

**Control Buttons:**

In the right corner of title bar, (1) minimize, (2) maximize/restore and (3) close control buttons are available as shown in Figure 6.4.

![Figure 6.3 Components of Writer Window](image)

![Figure 6.4 Control Buttons](image)
(1) Minimize button:

When you click minimize button, it shrinks your document window smaller in size and shows it as a small button on the task bar. To restore it in its original size, place your mouse pointer on the OpenOffice button which is available in the Taskbar, you can view your document as miniature and when you click on the button, your document is restored to its original size.

Figure 6.5 - Window Showing Minimize button

(2) Maximize button:

When you click maximize button, your document window is displayed in full screen. When it is in full screen, the maximize button is changed as “Restore”.

Figure 6.7 - Sizing Buttons
When you click restore button, the document window regains its original size.

(3) Close button:

This button is called as “Close” button, when you click this button, the application is closed and OpenOffice returns back to the desktop. So, the red colored close button may be called as “Exit” or “Quit”.

Exit / Close openoffice

Close document

Figure 6.8 - Close Button

There is another X mark on the right most corner of the menu bar. This is actually used to close your document. When you click this X mark, your document will be closed, OpenOffice will be still opened.

Menu Bar

The menu bar is just below the title bar which comprises of various menus consisting of various options.

File Edit View Insert Format Table Tools Window Help

Figure 6.9 - Menu Bar

File – The File menu contains various option for file management tasks: New, Open, Close, Save, Save As, Print, Export etc.

Edit – The Edit menu contains the editing options like, cut, copy, paste, Undo, Redo etc.

View – The View menu contains the options which are used to modify the environment of writer like display of toolbars, web layout, print layout, navigator etc.

Insert – The Insert menu contains commands for inserting various elements such as pictures, tables, charts, comments, headers, footers, special characters etc.

Format – The Format menu contains the options of various text and page formatting features like page size, layout, font characteristics, bullets and numbering etc.

Tables – The Table menu contains various tools to manage and manipulate tables such as create table, insert rows, insert columns, split cells, merge cells etc.

Tools – The Tools menu contains various tools and functions such as spell check, macros, mail merge, end notes/footnotes etc.

Window – The window menu shows display options such as New Window, Close Windows, Split and Freeze.

Help – The Help menu lists out the inbuilt help features available with OpenOffice.

Tool Bar:

Under the menu bar, there are two toolbars available by default. They are:
(1) Standard Toolbar

(2) Formatting Toolbar

**Standard Tool Bar**– This tool bar is just below the menu bar which consists of shortcut icons for frequently performed tasks. There are many shortcut icons like cut, copy, paste, undo etc...

![Standard Toolbar](image)

**Figure 6.10- Standard Toolbar**

**Formatting Tool Bar**– The formatting tool bar is below the standard tool bar which consists of icons used for formatting the text like bold, underline, italics, font type, font color etc.

![Formatting Toolbar](image)

**Figure 6.11- Formatting Toolbar**

**Ruler**

The ruler is a scale below the formatting tool bar which shows the margins. There are two set of rulers (1) Horizontal ruler and (2) Vertical ruler. Horizontal ruler is used to set left and right margins of a page and vertical ruler for top and bottom setting.

![Ruler](image)

**Figure 6.12 - Ruler**

**Work Space**

The work space is the blank area which is used to type the content of the file. A flashing vertical bar appears at the beginning of the screen which is called as “Insertion pointer”.

**Status Bar**

The status bar is at the bottom of the window which shows the current status of the document such as number of pages, current page number, default language etc.

6.2.4 Entering the Text

Once a new document is open, the text can be typed in blank area of the screen. To create a document the user can start typing straight away. As the text is typed they appear
on the screen and the **flashing vertical bar called the insertion pointer** moves to the right. When the text reaches the end of the line, the word is automatically wrapped to the next line. This feature in any word processor is known as “**Word Wrap**”.

The **Enter** key must not be pressed at the end of the each line. The **Enter** key should be pressed only at the end of a paragraph or when a blank line is to be inserted. When a page is filled up, OpenOffice Writer automatically creates a new page.

### 6.2.5 Moving within a document

There are different ways of moving within a document. There are many shortcut keys given in Table 6.2 which are used to move easily within a document.

**Table 6.2 Keyboard shortcut Keys**

<table>
<thead>
<tr>
<th>KEY</th>
<th>ACTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>→</td>
<td>To move a character right</td>
</tr>
<tr>
<td>←</td>
<td>To move a character left</td>
</tr>
<tr>
<td>↑</td>
<td>To move one line up</td>
</tr>
<tr>
<td>↓</td>
<td>To move one line down</td>
</tr>
<tr>
<td>Ctrl + →</td>
<td>One word right</td>
</tr>
<tr>
<td>Ctrl + ←</td>
<td>One word left</td>
</tr>
<tr>
<td>Ctrl + ↑</td>
<td>One paragraph up</td>
</tr>
<tr>
<td>Ctrl + ↓</td>
<td>One paragraph down</td>
</tr>
<tr>
<td>Home</td>
<td>To the beginning of line</td>
</tr>
<tr>
<td>End</td>
<td>To the end of line</td>
</tr>
<tr>
<td>Ctrl + Home</td>
<td>To the beginning of document</td>
</tr>
<tr>
<td>Ctrl + End</td>
<td>To the end of document</td>
</tr>
<tr>
<td>Tab</td>
<td>To move one cell to right</td>
</tr>
<tr>
<td>Shift + Tab</td>
<td>To move one cell to left</td>
</tr>
<tr>
<td>Pg up(Page Up)</td>
<td>To scroll one screen up</td>
</tr>
<tr>
<td>Pg Down(Page Down)</td>
<td>To scroll one screen down</td>
</tr>
</tbody>
</table>

### 6.2.6 Saving the Document

The first time the document is saved, OpenOffice Writer prompts for a name. Naming the file enables the user to find and open that file again. One can select the drive and folder where the file will be stored. To save a document for a first time, the following steps are used:
• Click *File → Save* → (or) *File → Save As* (or) *Ctrl + S*

• The “Save As” dialog box appears as on Figure 6.13.

![Image of Save As dialog box](image)

*Figure 6.13 Save As dialog box*

• Select location to store your document. The default location to store all documents is “Documents” folder in Windows.

• Type your document name in the *File Name* box.

• All documents in OpenOffice writer will be stored with .odt extension. You can store your OpenOffice document as Microsoft Word document or pdf. To do so, select file type from Save as type list box. This list box shows variety of formats to be saved.

• Finally, Click “Save” button.

• Once the file is saved, your document name will be displayed on the title bar.
Saving with password

Enter Your Password here

Click Ok to Finalise

Enter the same Password once again

Figure 6.14 – Password dialog box

In OpenOffice writer, a document can be protected with a password. You can set a password to protect your document while saving a file. To save a file with password, click on “Save with Password” check box and then click “Save” button. Immediately it shows “Set Password” dialog box as given the Figure 6.14.

In this dialog box, Enter a password in “Enter Password to open” text box and retype the same password in “Confirm Password” box for confirmation. Finally click “OK” button.

“More Options” button provides some more features to your protected document such as “Read only” and change password.

6.2.7 Closing a Document

After your document is saved, it is still open. So, you can continue typing your document. When the work is finished, you should save the document and then close document using File → Close command (or) Press Ctrl + W.

Closing Unsaved Document:

When you close an unsaved file using the close control button, Writer shows a warning message as shown in Figure 6.15.

If you accept the warning message, click the “Save” button. When you click the “Save” button, it proceeds to save the file. If you are not willing to save the file, then click “Discard”, or if you want to cancel this warning and continue working in the same document, click “Cancel”.

6.2.8 Opening an existing document

Once a document is saved, it can be opened at any time. To open an existing document, Click on the File → Open or Ctrl + O, the Open dialog box appears, enter the name of the file in the File Name text box and click on OPEN button as in Figure 6.16.
6.3 Tamil Typing Interface

Typing in Tamil has different methods.

- Using Tamil Font
- Using Tamil Interface.

In the first method specific Tamil fonts are available which has to be downloaded and installed and should be included in the font folder of the control panel. But this method has some drawbacks:

- The user must be aware of Tamil typing.
- The particular font must be available in the system.
- It does not support other languages including English.
- The computer accepts characters as symbols not as language.
- It is not portable, i.e. if the document is sent to another computer, if the same font is not available, it is recognized as symbols not as original characters.

To overcome the drawbacks in the first method, the interface method provides the following advantages:
• It follows Unicode technique. Hence knowledge of Tamil typing is not necessary.

• It is easy to type documents in Tamil in any word processor.

• Some of the Unicode fonts like “Arial Unicode” supports all Indian languages including Tamil and English using respective language interface.

6.3.1 Download and Install Tamil Typing Interface

Many Tamil Typing Interfaces are available as open source such as “Murasu”(it is exclusively for Tamil), “NHM Writer”(It is universal to all Indian languages) etc.

To download and install:

• “Murasu” use the link : http://anjal.net/download

• “NHM writer” use the link : http://software.nhm.in

6.4 Editing a document

Once a document is typed, it can be edited in many ways. If there is some insertions or deletions, it can be done while typing or after typing also. Corrections can be made in two different ways :

Backspace Key: Deletes the character left of the insertion pointer.

Delete Key : Deletes the character right of the insertion pointer.

To insert a text in between if something is left out, the insertion can be made by taking the insertion pointer to the current location and Press the Insert Key the newly typed text is inserted, so that the existing text moves to the right. This is Insert mode. Press the Insert Key again, the text is over written on the existing text. This is called Type over mode. You can toggle between the insert mode and type over mode by pressing the Insert key.

6.5 Select, Move and Copy text

6.5.1 Selecting Text

In any word processor, the text has to be selected for performing any operation like copying, moving, formatting etc. This text selection can be done by two methods:

i) Selecting the continuous text.

ii) Selecting the non continuous text.

Selecting the continuous text - To select the text continously take the insertion pointer to the starting of the text.

• hold the SHIFT key and drag the mouse across until the required text is selected and then release the SHIFT key.

• The selected text can be used for any operation.

Selecting the non continuous text. - To select the text not continuously, take the insertion pointer to the starting of the text,
• hold the **CTRL** key and drag across it till the required text is selected and release the **CTRL** key

• The required text is selected for any operation

**Selection by Different methods:**

**Selection using Mouse:**

To select the text using mouse:

i) Take the insertion pointer to the start of the text

ii) Hold down the **Leftmouse** button and drag it across the text

iii) Release the mouse button when the required portion of text is selected

iv) The selected text will be highlighted.

**Selection using Keyboard:**

To select the text using keyboard:

i) Take the insertion pointer to the start of the text

ii) Hold the **Shift** key and use the **movement keys** to drag across the required portion.

iii) When the required portion is selected release the **Shift** key

iv) The selected text will be highlighted.

**Selection using Shortcut keys:**

Shortcut keys help to select the text quickly and easily.

• To select a word - Double click on the word

• To select the entire document - Press **Ctrl + A**

6.5.2 Moving and Coping text

**Moving text**

To move a text from one location to another

• Select the text to be moved

• Click **Ctrl + X** or **Cut Icon** or **Edit → Cut**

• The text is removed from the source location and placed in the clipboard

• Take the insertion pointer to the new location to be moved and

• Click **Ctrl + V** or **Paste Icon** or **Edit → Paste**

The required text is moved to the required location.

**Coping text**

To copy a text from one location to another

• select the text to be copied

• Click **Ctrl + C** or **Copy Icon** or **Edit → Copy**

• A duplicate copy of the text is made and sent to the clipboard

• Take the insertion pointer to the new location to be copied and

• Click **Ctrl + V** or **Paste Icon** or **Edit → Paste**
The required text is copied to the required location.

The Editing shortcut keys are as given in Table 6.3

<table>
<thead>
<tr>
<th>Operation</th>
<th>Action</th>
<th>Icons</th>
<th>Shortcut Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>CUT</td>
<td>Cuts the selected text</td>
<td>![Cut Icon]</td>
<td>Ctrl +X</td>
</tr>
<tr>
<td>COPY</td>
<td>To make a duplication of the text.</td>
<td>![Copy Icon]</td>
<td>Ctrl +C</td>
</tr>
<tr>
<td>PASTE</td>
<td>To paste the text to a new location after cut or copy process.</td>
<td>![Paste Icon]</td>
<td>Ctrl +V</td>
</tr>
<tr>
<td>UNDO</td>
<td>Cancels the previous operation that was performed</td>
<td>![Undo Icon]</td>
<td>Ctrl +Z</td>
</tr>
</tbody>
</table>

### 6.5.3 Paste Special

When you move or copy information, the paste option is used to send the information as a whole. But, to move or copy only some aspects of the data, like only its formatting or only value, the Paste Special option is used.

To use the paste special, select the text and apply move or copy, then at the destination location,

- Click Edit → Paste Special (or) press Ctrl+Shift+V, or Alt+E+S the Paste Special dialog box opens as displayed on Figure 6.17.

- The Paste Special menu varies depending upon the origin and formatting of the text (or object) to be pasted.

- Select DDE (Dynamic Data Exchange) link from the Paste special dialog box.

![Figure 6.17 - Paste Special dialog box](image)

- Select the type of application and click on the OK button.

- The copied data is pasted into the document with a link.
Dynamic Data Exchange is a mechanism whereby the source data can be pasted into the destination as a linked, 'live' copy of the original. Any changes made in the source will immediately reflect into the destination.

6.6 Help System in Writer

Open Office Writer provides several forms of help. By pressing F1 or select Help from the menu bar the help window appears as shown in Figure 6.18.

- To activate tooltips, extended tips, and the help Agent, click Tools → Options → OpenOffice

- For a more detailed explanation, select Help → What's This? and hold the mouse pointer over the icon where you want more help with. Figure 6.19 shows the General settings window.
6.1
- Open a new document in Open office writer.
- Type the following paragraph.
“The ignited minds of the youth is the most powerful resource on the earth. The power
of the youth, if properly directed, will bring about transformed humanity by meeting
its challenges and bring peace and prosperity.”
- Save and close the document.
- Exit from Open office writer.

6.2
- Open the document created in Workshop-6.1.
- Append the following paragraph.
“We are as young as our faith and as old as our doubts. We are also as young as our self-
confidence and as old as our fears. We are as young as our hopes and as old as our despairs”.
- Save the document
- Using Delete or Backspace key remove the last line of the first paragraph.
- Type the following lines after the second paragraph and create it as a new paragraph.
“It doesn’t matter who you are, if you have a and determination to achieve that vision,
you will certainly do so.”
- In the third paragraph insert the word “vision” between “a” and “and”.

6.3
- Open the document created in workshop-6.1.
- Copy and paste the following words into a new document either using keyboard
or mouse shortcuts. (i) Ignited (ii) powerful (iii) humanity (iv) challenges (v) prosperity
- Save the new document
- In the first document, move the following words either using keyboard or mouse
shortcuts. (i) Ignited (ii) Challenges (iii) Prosperity
6.7 Text formatting

A text without any special formatting gives a monotonous appearance. OpenOffice Writer offers a number of choices for formatting such as Bold, Italics and defining the font, type, and font size. Bold, Italic or underlined are the most common types of text formatting. Almost all the formatting options are available under Format menu.

6.7.1 Changing font style, size and colour

A font is a set of characters in a particular style. Changing the default appearance of the text like changing the font type, size, color, style etc., are called as Text formatting. To make the text attractive and more appealing, various formatting's like bold, italic and underline can be done by using the following commands given in Table 6.4.

<table>
<thead>
<tr>
<th>OPERATION</th>
<th>ACTION</th>
<th>ICON</th>
<th>SHORTCUT KEY</th>
</tr>
</thead>
<tbody>
<tr>
<td>BOLD</td>
<td>Makes the text bold</td>
<td>B</td>
<td>Ctrl + B</td>
</tr>
<tr>
<td>ITALICS</td>
<td>Italicizes the text</td>
<td>I</td>
<td>Ctrl + I</td>
</tr>
<tr>
<td>UNDERLINE</td>
<td>Underlines the text</td>
<td>U</td>
<td>Ctrl + U</td>
</tr>
</tbody>
</table>

The default font type is Times New Roman and the type of font can be changed by clicking on the Font Type icon.

The default size of font is 12 points which can be changed by clicking on the Font Size icon.

![Font Tab](image)

![Preview window](image)

The default font color is black and the font color can be changed by clicking on the Font colour icon which shows the color palette from which the required color can be selected.

Besides the regular formatting Bold, Italics and underline, many other formatting can be done by using the dialog box. The other formatting options can be selected by using Format → Character. The Character dialog box is displayed as shown in the Figure 6.20 using which all the formatting can be done at a single stretch with an online preview.

6.7.2 Changing Case

Normally any text can be typed in upper or lower case. The text can be changed to different cases like:

- Uppercase (Capital letters)
- toggle case (reverse case),
- sentence case (first letter of each sentence Capital),
• **Capital**a**lize every word** (first letter of each word capital),

• **lower case.** (Small letters)

This can be done by:

• Select the text to change case

• Select **Format → Change case.**

6.7.3 **Highlighting text**

Highlighting is used to draw attention to important information in a text. Highlighting is beneficial because it first asks the reader to pick out the important parts, and then gives an effective way to review that information later.

Highlighting can be applied by selecting the text and click Highlighting icon , the color palette is displayed, select the required color, and the text is highlighted. Highlighting can be removed by selecting the text and click **No Fill** from the color palette.

6.7.4 **Clearing the formatting**

Normally text is monotonous without any formatting, so we can format in different ways, after the formatting is applied, it can be removed by

• Selecting the entire document by **Ctrl + A** or **Edit → Select All**

• Clear applied formatting by **Ctrl + M**

6.8 **Paragraph formatting**

6.8.1 **Paragraph Alignment**

A paragraph is any text that ends with a hard return. A hard return is accomplished anytime you press the **Enter** key. Paragraph Alignment or justification refers to the way in which the lines of a paragraph are aligned. Paragraph alignment lets you control the appearance of individual paragraphs. There are **four** types of alignment available in Open office Writer - **left** - alignment, **Right** - alignment, **Center** - alignment, and **Justify** - alignment.

**Left-alignment** - A paragraph's text is LEFT aligned when it is aligned evenly along the left margin and uneven along the right margin. This is the default alignment when a paragraph is typed.

**Right-alignment** - A paragraph's text is RIGHT aligned when it is aligned evenly along the right margin and uneven along the left margin.

**Center-alignment** - All the lines in the paragraph are aligned to the center of the page size.

**Justified-alignment** - All the lines in the paragraph, are arranged evenly both on the left and right margins. This is achieved in writer by automatically inserting additional space between the words.

Paragraph formatting can be applied by **Format → Paragraph**, the paragraph dialog box appears as displayed in Figure 6.21.
Figure 6.21 – Paragraph dialog box

The paragraph formatting can also be done by icons using the formatting tool bar as shown in Figure 6.22 and shortcut keys as shown in Table 6.5

Figure 6.22 Formatting toolbar

Table 6.5 Paragraph Alignment Icons and shortcut Keys

<table>
<thead>
<tr>
<th>ALIGNMENT</th>
<th>ACTION</th>
<th>ICON</th>
<th>SHORT CUT KEY</th>
</tr>
</thead>
<tbody>
<tr>
<td>LEFT</td>
<td>Aligns the paragraph with respect to the left margin</td>
<td><img src="image" alt="Left Icon" /></td>
<td>Ctrl + L</td>
</tr>
<tr>
<td>RIGHT</td>
<td>Aligns the paragraph with respect to the right margin</td>
<td><img src="image" alt="Right Icon" /></td>
<td>Ctrl + R</td>
</tr>
<tr>
<td>CENTER</td>
<td>Aligns the paragraph with respect to the center of the page</td>
<td><img src="image" alt="Center Icon" /></td>
<td>Ctrl + E</td>
</tr>
<tr>
<td>JUSTIFIED</td>
<td>Aligns the paragraph with respect to both the left and right margin</td>
<td><img src="image" alt="Justified Icon" /></td>
<td>Ctrl + J</td>
</tr>
</tbody>
</table>
An example showing all the four paragraph alignment:

**Left Alignment**

All power is with in you take up one idea, make that one idea your life. Think of it dream of it, live on that idea let the brain, muscles, nerves, every part of your body be full of that idea, and just leave avry other idea alone. This is the way to success.

**Right Alignment**

All power is with in you take up one idea, make that one idea your life. Think of it dream of it, live on that idea let the brain, muscles, nerves, every part of your body be full of that idea, and just leave avry other idea alone. This is the way to success.

**Center Alignment**

All power is with in you take up one idea, make that one idea your life. Think of it dream of it, live on that idea let the brain, muscles, nerves, every part of your body be full of that idea, and just leave avry other idea alone. This is the way to success.

**Justified Alignment**

All power is with in you take up one idea, make that one idea your life. Think of it dream of it, live on that idea let the brain, muscles, nerves, every part of your body be full of that idea, and just leave avry other idea alone. This is the way to success.

---

**Example 6.1 Paragraph Alignment**

6.8.2 Line Spacing:

Line spacing determines the amount of *vertical space* between lines of text in a paragraph. By default, the lines are single-spaced, that is the spacing accommodates the largest font in that line, plus a small amount of extra space. In Open Office, setting line spacing is quite easy through the context menu, select the line or word or phrase, *right-click* → *line spacing*, select the type single, 1.5 or double. There are seven different types of line spacing as seen in the dialog box given below in Fig.6.23.

- Select the entire document by *Edit* → *Select All*
- *Format* → *paragraph*
- The paragraph dialog box appears, click *Indents & Spacing tab*
- In the *line spacing option*, select the type and click *OK* button.
6.8.3 Indenting text

Indent is the distance from the left and right margin of a paragraph. It is used to improve the efficiency and readability of the paragraph and makes the paragraph look more attractive. In paragraphs, an easy way to apply indent for the first line of text can be created by moving the cursor to the front of the line and pressing the tab key on the keyboard. There are four types of indents:

- **Left Indent**
- **Right Indent**
- **First Line Indent** and **Hanging Indent**.

**Left indent** - The Left indent controls the space between the paragraph and the left margin. This is the default indent. Each click on the Increase indent icon moves the paragraph ½ inch away from the left margin.

The left indent can also be applied by Format → Paragraph → Indents & Spacing tab, enter a value in the “before text” spin box. This results in a left indent.
Right Indent - The Right indent controls the space between the paragraph and the right margin. Each click on the decrease indent icon removes the indent applied by the Increase indent. The Right indent can be applied by the dialog box method.

Select Format → Paragraph → Indents & Spacing tab, enter a value in “after text” spin box. This results in a right indent.

First Line Indent - A first-line indentation indents the first line of the paragraph. It is the most common way to start a new paragraph.

This indent can be applied by Format → Paragraph → Indents & Spacing tab, select first line option in the Indent group, enter a positive value which results in first line indent.

Hanging indent - This is a special kind of indent where the first line of the paragraph alone hangs outside leaving the rest of the text. To apply Hanging indent, a negative value is given in the “first line” option of the paragraph dialog box.

6.8.4 Bullets and Numbering

Bullets and numbering are used to emphasize list of things and make list easy to read and follow. It provides an excellent way to segregate, list and organize information for a reader. You can control the appearance, or format a bulleted or numbered list.

Bullets – This is a paragraph level attribute that applies a bullet character to the start of the paragraph. In bulleted lists, each paragraph begins with a bullet character. This is suitable when the text has to be presented as a list of items preceded by a bullet symbol and no sequence has to be followed. Bullets are quickly created by clicking on the bullet icon.

Numbering – This attribute applies a numeral to the start of the paragraph. Numbering is more suitable when the text has to be presented as a sequence. In numbered list, each paragraph begins with an expression that includes a number or letter and a separator such as a period or parenthesis. The numbers in a numbered list are updated automatically when you add or remove paragraphs in the list. Numbering is quickly created by clicking on the numbering icon.

6.8.5 Style of Bullets and Numbering

The default type of bullet is (.) and the default type of numbering is (1, 2, 3 …….). The style of bullets and numbering can be changed by applying the following steps:

• Select the text to be bulleted
• Format → Bullets and Numbering
• Select Bullets Tab
• The Bullets and Numbering dialog box appears where different styles of bullets are displayed
• Click on the required style
• Click Ok button
• The selected text is bulleted.

The bullets and numbering dialog box with the bullets tab is displayed in Figure 6.24.
To apply Numbering

1. Select the text to be numbered

2. **Format** → **Bullets and Numbering**

3. Select **Numbering Type** Tab

4. The **Bullets and Numbering** dialog box appears where different styles of numbering are displayed

5. Click on the particular style

6. Click **Ok** button

7. The selected text is numbered.

The bullets and numbering dialog box with the numbering type tab is displayed in Figure 6.25.
Bullets and numbered lists provide an excellent way to segregate, list and organize information for a reader. You can control the appearance or format, of a bulleted or numbered list.

Note

If the text is not typed, then apply the steps above and then type the text, the newly entered text will appear in numbered form.

Turning off Bullets and Numbering

As you can quickly add bullets or numbers to existing text by clicking on the icons, the bullets and numbers can be removed easily.

- Select the text where the bullets and numbers are to be removed.
- Click on the bullets icon again to remove bullets.
- Click on the numbering icon again to remove numbering.

Figure 6.25 Bullet and Numbering dialog box
6.9 Page formatting

The most important thing in a word processor is how to format the page with elements such as margins, numbering, page layout, headers and footers. Formatting your pages makes them look more attractive and makes them easier to read.

6.9.1 Setting the page size and margins

Changing page size

The default page size in writer is 8.5 x 11", the same as that of a standard A4 printing paper. However, for different types of documents, you may need to change the page size. To change the paper size:

- Select the page whose page size is to be changed
- Select Format → Page, the page style dialog box appears as shown in Figure 6.26.
- Select Page Tab
- In the paper format group, select the format like A4, legal ....
- Or the width and height option can be used to set the page size.

Changing page margins

Page margins are the white space around the top, bottom, left, and right of your document. Margins let Writer know where to start placing the text at the top of a document, when to move on to the next page at the bottom, where to start typing text on the left side, and where to stop and move to the next line on the right.

![Page style dialog box](image)

*Figure 6.26 Page style dialog box*
Changing or setting page margins in Openoffice writer can be done in two ways:

1. Using the **Rulers** - quick and easy, but does not have precise values.

2. Using the **Page Style dialog box** - can specify precise values for the margins.

### 1. Changing page margins - using Ruler

1. The shaded sections of the rulers are the margins.

2. Hold the mouse pointer over the line between the gray and white sections.

3. The mouse pointer turns into a double-headed arrow.

4. Hold down the left mouse button and drag the mouse to move the margin and release it at the required point.

5. The new margin is set.

### 2. Using the Page Style dialog box

To change margins using the Page Style dialog box

1. **Right-click** anywhere on the page and select **Page** from the popup menu and select **page tab of page style dialog box**.

2. In the **Margins** boxes, specify the values for left, right, top and bottom margins.

3. Click on **ok button**.

### 6.9.2 Orientation

Page orientation refers to how the document will be displayed on screen and printed. There are two different orientations:

- **Landscape** - The width of the document is more than the height. This is best suited for displaying professional photos, invitations, albums, tables etc.

- **Portrait** - This is the most common and default orientation. Here, the height of the document is more than the width. Normally books, newspapers will be displayed in this format.

To change the orientation:

- Select the page whose orientation is to be changed

- In the **Page style dialog box**, under the **Orientation** group,

- **Select Portrait** or **Landscape** button.
6.9.3 Page colour and borders

Changing the page color is not quite common. To do so, in the **Page style dialog box**, select **Background** tab, In **As** option click on **color** and select the “color” from the color palette or select **graphic** to apply an image as a page background, as shown in Figure 6.27.

Borders can be applied to an entire document, an entire page, paragraph, or just to certain sections of the document. From the **page style dialog box**, select the **Border tab**, the user defined area helps to define the area of borders, the line style of borders, color of borders can be selected. The dialog box in Figure 6.28 shows the borders setting in the page style dialog box.
6.10 Working with Headers and Footers

The header is a section of the document that appears in the top margin, which displays the title or chapter name, author name of a document.

The footer is a section of the document that appears in the bottom margin of the page which displays the page number, date, time etc. which gets displayed on all the pages automatically.

6.10.1 Inserting Header and Footer

- Select from the main menu **Insert → Header → Default**
- The header text area is separated from the normal text area.
- In the header area, Enter the text that is to be repeated in all pages or Select **Insert → Fields → Title**.

Similarly to insert a Footer, the steps are as given below:

- Select from the main menu **Insert → Footer → Default**
- Place the insertion pointer in the footer part of the page.
- Select **Insert → Fields → Date** to insert date in all the pages.
Once the headers and footers are given in the first page, the same text appears in all the pages.

6.10.2 Inserting and Formatting page numbers

Once the Header / footer area is enabled, the page numbers can be inserted by performing the following steps:

1. Position the insertion pointer where you want to insert the page number
2. Choose Insert → Fields → Page Number
3. The page number appears with a gray background

Normally, the page numbers appear as 1, 2, 3……. To change the numbering style, the following sequence of steps can be performed:

1. Position the cursor where the page number has to appear
2. Select Format → page, which will bring the page style dialog box as on Figure 6.29.
3. Select page Tab
4. In the Layout settings, select the format drop down combo box
5. Select the desired style and click OK button.

![Figure 6.29 Page style dialog box](image)
6.4
1. Open a new document in OpenOffice writer.
   • Type the following paragraph
     “Learning gives creativity, creativity leads to thinking, thinking provides knowledge, and knowledge makes you great”
   • Save the document
   • Perform text formatting features like Bold, Italics, Underline, Change font, change Size, Color and change case (Upper case to lower case, lower to upper) for the words (in the paragraph and make the paragraph more appealing to read.
   • Highlight the text “Knowledge makes you great”
   • Undo all formatting options using keyboard shortcut.

6.5
• Open the document created in the workshop 6.1
• Type the following lines below the first paragraph
   “When one door closes, another opens, but we often look so long and so regretfully upon the closed door that we do not see the one that has opened for us – Alexander Graham Bell”
• Using any one of the paragraph alignment icons or keyboard shortcuts (left, right, center, or justified) align the first paragraph.
• Change the line spacing of second paragraph to any one of the type.
• Create bullets for the first paragraph and numbering for the second paragraph using icon or menu choice.
• Save and close this documents.

6.6
• Open the document created in workshop-6.2.
• Change page size, margin and orientation, change border and background color.
• Apply suitable header and footer for the table.
Part - III : Find & Replace and Spell check

6.11 Find & Replace

OpenOffice Writer has a Find and Replace feature that helps to locate for a text inside a document and replace it with another word. In addition to finding and replacing words and phrases, you can also use wildcards and regular expressions to perform advanced search. To search a word

- Click **Edit** → **Find & Replace** (or) **Ctrl + F**

- The Find & Replace dialog box appears as shown in Figure 6.30

**Steps to find & replace a text**

1. Type the text you want to find in the **Search for** box

   For Example: To search a word "Bombay" in a document and replace with "Mumbai", enter the word "Bombay" in the **Search for** box.

2. To replace the text with different text, type the new text in the **Replace with** box

   Enter the word "Mumbai" in the **Replace with** box and Click **Find** button, to start the search, the found word is highlighted and the first occurrence of "Bombay" is highlighted.

![Find & Replace dialog box](image)

*Figure 6.30 Find & Replace dialog box*
3. To replace text, click **Replace** button.

The highlighted word is replaced with the word given in the Replace with box.

4. Click **Find All**, Writer selects all instances of the search text in the document.

All occurrences of Bombay are highlighted.

5. Click **Replace All** button, Writer replaces all matches.

This will replace all occurrences of "Bombay" with "Mumbai".

6. Enable **Match case** to perform the search case sensitively so that uppercase and lower cases are distinguished separately.

7. Enable **Whole Words only** to make the search more specific to words used separately alone.

6.12 Spell Check

The documents prepared using word processing software should be without any spelling mistake. For this purpose OpenOffice Writer includes a dictionary and spell check program. OpenOffice Writer can identify the spelling mistakes as the document is typed or after the entire document is typed.

6.12.1 Auto spell check

Auto spell check option checks each word as it is typed and displays a wavy red line under any misspelled words. Once the word is corrected, the red wavy line disappears. This can be done through clicking the icon.

To perform a separate spelling check on the document (or a text selection) click the Spelling and Grammar button. This checks the document or selection and opens the Spelling dialog box (Figure 6.31) if any misspelled words are found. This can be achieved by clicking the icon.

![Fig: 6.31 The Spelling dialog box](image)

Here are some more features of the spelling tool:

- **Right-click** on a word with a wavy underline, to open a powerful context menu. Correct words can be selected from the suggested words on the menu. The selection will replace the misspelled word with correct word. Other menu options are discussed below.

- The dictionary language can be changed (for example, Spanish, French, or German) from the Spelling dialog box.

- The new words can be added to a dictionary. Click **Add** in the Spelling dialog box and pick the dictionary to add it to.
The Options dialog box of the Spelling tool has a number of different options such as whether to check uppercase words or words with numbers. Words can be added or deleted through this option. Dictionaries also can be added or deleted through custom directories.

6.12.2 Automatic correction

Auto Correct function has the facility to correct the common misspellings and typing errors, automatically. For example, “hte” will be changed to “the”, which can be done through the menu option, Tools → AutoCorrect to open the AutoCorrect dialog box which provides the chance to change the misspelled word by a default name.

- To stop the Writer to replace specific spellings, use Tools → AutoCorrect, highlight the word pair and click Delete.
- To add a new spelling to correct, type it into the Replace and With boxes and click New.

![Figure 6.32 AutoCorrect wizard](image)

AutoCorrect is automatically turned on. To turn it off, uncheck Format → Autocorrect → While Typing.

AutoCorrect can be used as a quick way to insert special characters. For example, (c) will be autocorrected to ©. You can add your own special characters.
Activity 1:

Do the necessary steps to correct the word “comupter” into “computer” automatically

1. Goto **Tools** → **Autocorrect Options**

2. Click the **Replace tab** and type “computer” in Replace text box and “computer” in with textbox. Then Click OK.

3. The word “Comupter” is replaced with “Computer” and displayed in the list.

4. After entering this, when you type “comupter” in the document, it will be automatically changed to the correct spelling “computer”.

---

**Spelling Check**

Spell check is a software program that corrects spelling errors in word processing, email and documents. Spell check identifies and corrects misspelled words and the grammatical error is displayed with a green wavy line under the wrong word.

---

**Workshop**

- Open a new document and type the following paragraph
  “All birds find shelter during a rain. But Egles avoid rain by flying above the clouds. Problems are common, but attitude make the difference.”
- Apply spelling check and find the word “Egles” and replace it with “Eagles”.
- Save the document with password.
6.13 Inserting Tables

A table is a grid with a specified number of **rows** and **columns**. Tables can often be used as an alternative to spreadsheet to organize materials. A well-designed table can help readers understand better what you are trying to convey.

6.13.1 Different techniques to insert tables

To insert a new table, position the insertion pointer where you want the table to appear, then use any of the following methods to open the Insert Table dialog box as shown in Figure 6.36.

There are two methods to create a table:

1. **Table Icon**
   
   To insert a table quickly from the standard tool bar:
   
   1. Place the insertion pointer where you want the table to appear.
   2. Click the **arrow** to the **right side** of the Table icon.
   3. In the drop down grid, select the number of **rows** and **columns** for the table.
   4. The table will appear at the location of your insertion pointer.

2. **Insert table dialog box**

   To insert a table with more control over the settings and properties, use the Insert Table dialog box.

   To open the dialog box: Select **Table → Insert → Table** or **Ctrl +F12** or **left-click** the Table icon. From this dialog box, you can:

![Figure 6.36 Insert Table Dialog Box](image-url)
• Select the number of rows and columns of the table

• Give a Name to the table to later distinguish it in the Navigator

• Select the Heading option to define the first row in the table as the heading

• Select the Repeat heading option to repeat the heading row if the table spans more than one page

• Select the Don't split table option to prevent the table from spanning more than one page

• Select the Border option to surround each cell of the table with a border

From here, it is possible to choose among different predefined formats.

If none of the predefined auto formats have the desired characteristics for your table, you can tune the format of the table or a particular cell with the contextual Table toolbar. Open the toolbar by placing the insertion pointer inside a table cell or select View → Toolbars → Table. This will bring the table formatting toolbar which helps to format the table in the desired format.

6.14 Formatting table

Formatting a table involves formatting of the table layout, formatting of the table text, adjusting the size of the table, its position on the page, adding or removing rows or columns, merging and splitting cells, changing borders and the background.

Figure 6.37 Auto format Dialog Box

Figure 6.38 Table Formatting Toolbar
6.14.1 Inserting rows and columns

To insert rows or columns inside a table:

1. Place the insertion pointer in the row or in the column where you would like to add new rows or columns and **right-click**.

2. Choose **Row → Insert** – to insert a row or **Column → Insert** – to insert a column. A dialog box will appear, from which you can select the number of rows or columns to insert. You can also set the position of the new rows or columns to **Before** or **After** as shown in Figure - 6.39.

3. Click OK to close the dialog box.

![Insert Row Dialog Box](image1.png)

**Figure 6.39 Insert Row Dialog Box**

6.14.2 Deleting rows and columns

To delete rows or columns inside a table:

1. Place the insertion pointer in the row or column to be deleted and **right-click**.

2. Choose **Row → Delete** – to delete a row or **Column → Delete** – to delete a column.

3. The selected row / column is deleted.

![Split Cells Dialog Box](image2.png)

**Figure 6.40 Split cells Dialog Box**

6.14.3 Merging and Splitting cells

To merge a group of cells:

1. Select the cells to merge.

2. **Right click** and choose **Cell → Merge** or choose **Table → Merge Cells** from the menu bar.

To split a cell:

1. Place the insertion pointer inside the cell.

2. **Right click** and choose **Cell → Split**, or choose **Table → Split Cells** from the menu bar.

3. Select the direction of the split, horizontally (for rows), or vertically (for columns), as well as the total number of cells to create.

4. The dialog box on Figure 6.40 displays the split cells.
6.7
- Open a new document.
- Using icon or table menu create the given table with required of 5 rows and 6 columns with the labels S.No., Name, Maths, Phy, Che and Total.
- After the sixth row add a new row and type suitable data for the new row.
- Delete the second row using icon or command.
- Using icon or command after the second column add a new column and type suitable data for the new column.
- Delete any one column using icon or command.
- Save and close the document.

6.8
- Open the document created in workshop-6.7.
- Do the following options:
  - Change the border style and border line width for one table.
  - Change height and width for the row and column respectively.
- Save and close the document.
- Create a new document.
- Create a 4 x 4 table using icons in toolbars or using commands.
- Split any one row/column in one given table into more than one cell using icon or command.
- Merge any two or more row/column in the given table using icon or command.

6.9
- Open the document created in workshop-6.8.
- Delete the table contents.
- Perform all table formatting options for this table.
- Add two more rows and columns and also delete the rows and columns.
- Save and close the document.
6.15 Enhancing a Document

6.15.1 Inserting pictures

Open office Writer has the ability to insert and edit images in a more simple way. The picture gallery of the writer consists of a collection of images from which the desired image can be selected and inserted into the document. To insert an image from a file, the steps are as follows:

- Place the insertion pointer where you want the image to appear
- Select Insert → Picture → From file
- The insert picture dialog box appears where the picture gallery opens from which the desired picture can be selected.
- If the picture is not in the gallery, then browse the pictures from the folder, choose the desired one and
- Click on the Open button
- The selected picture is inserted into the document

6.15.2 Inserting Special Characters

Many symbols which are used in a mathematical equation like alpha(∞), beta(β), pi(π) etc., are not available on the standard keyboard. However, representing these characters are very much essential in mathematical equations. To insert such characters, the procedure given below is followed:

- Place the insertion pointer in your document where you want the character to appear
- Click on the Insert → Special characters
- The Special characters dialog box appears from which the desired symbol can be selected by clicking on the character.
- As you select each character, it is shown on the lower right, along with the numerical code for that character
- If you do not find a particular special character you want, try changing the font selection.
• Click the **OK** button and the character is inserted at the current location.

The insert special characters dialog box is displayed in Figure 6.41.

![Figure 6.41 Insert Symbol Dialog box](image)

6.15.3 Inserting Shapes

OpenOffice writer uses the drawing tools, to create various shapes by using the Drawing toolbar. To use the drawing tools repeatedly, you can move this toolbar to a convenient place on the window. The drawing tool bar can be obtained by clicking **View → Toolbars → Drawing** as displayed on Figure 6.42.

![Figure 6.42 Drawing toolbar](image)

To use a drawing tool, the steps are as given below:

• Click in the document where you want the drawing to be anchored.

• Select the **tool** from the **Drawing toolbar** as shown in Figure 6.44. The mouse pointer changes to a drawing-functions pointer.

• Move the **cross-hair pointer** to the place in the document where you want the graphic to appear and then click-and-drag to create the drawing object.
• Release the mouse button. The selected drawing function remains active, so you can draw another object of the same type.

• To cancel the selected drawing function, press the Esc key or click on the Select icon on the Drawing toolbar.

• You can now change the properties (fill color, line type and weight, anchoring, and others) of the drawing object using either the Drawing Object Properties toolbar or the choices in the dialog box.

6.15.4 Inserting AutoText

AutoText allows you to assign text, tables, graphics and other items to a key or key combination. For example, rather than typing "TamilNadu" every time you use that phrase, you might just type "tn" and press F3. You can also save a formatted Tip as AutoText and then insert a copy by typing "tip" and pressing F3.

To assign AutoText shortcut to some text, the steps are as follows:

1. Type the text into your document.
2. Select the text so that it is highlighted.
3. Select Edit → AutoText (or press Ctrl+F3).
4. Enter a name for your shortcut. Writer will suggest a one-letter shortcut, which you can change.
5. Click on the inverted arrow of the AutoText button on the right and select New (text only) from the menu.
6. Click Close to return to your document.
7. Once the entry is created, to insert the auto text into the document, place the cursor where the text is to be inserted and click Ctrl+F3.
8. Select the name from the list of entries and click Insert button.
9. The auto text is inserted into your text.

Note

If the only option under the AutoText button is Import, either you have not entered a name for your AutoText or there is no text selected in the document.

6.16 Page Preview, Setting the printer and Printing a document

6.16.1 Preview the document to be printed

It is a good practice to preview the document before taking the print out. The steps to be followed to preview the document:

1. Click File → Page Preview, or click the Page Preview button. The Writer displays the Page Preview toolbar.
2. In the page preview tool bar click Multiple Pages icon to display multiple pages.
3. To close the preview click the Close Preview button.
6.16.2 Setting the Printer and Printing

The following are the steps to change the printer setting:

1. Click File → Print or Ctrl + P or Print File Icon which opens the Print dialog box as shown in Figure 6.43.

![Print Dialog box](image)

*Figure 6.43 Print Dialog box*

2. Click General Tab.

3. Select the required printer from the list of printers.

4. Under Range and copies section: select All Pages option to print all pages, select Pages option to specify the particular page or page range.

5. Specify Number of Copies using spin arrows.

6. Click Print button.
6.10
- Open the document created in Part-1 workshop-6.1
- Download images related to Dr. A.P.J ABDUL KALAM From net and insert the images in the document at required place using command or icon.
- Open the document in Part-III – workshop-1 , download images related to the content from net and insert the images at required place.
- Save the document and close.

6.11
- Open a new document.
- Using the commands to insert special characters, special symbols
- Type the following equations (i) $A\alpha+B\beta+c\beta$ (ii) $\pi r^2h$.
- Using drawing toolbar insert various drawings/ shapes in your document
- Save and close the document.

6.12
- Open the document created in workshop-6.2
- Using Autotext command or keyboard shortcut create shortcut for
  “Vital Information Under Seize” as “VIRUS” and make it appear in one document.
- Using Print icon change printing attributes, preview and print the document.

6.13
- Open the document created in workshop-6.4
- Insert suitable picture of a circle.
- Type the formula for the circumference of a circle using insert special character option.
- Using drawing tools draw the following in the document.
- Print the document using print command.
<table>
<thead>
<tr>
<th>Shortcut Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+A</td>
<td>Select the whole document.</td>
</tr>
<tr>
<td>Ctrl+B</td>
<td>Makes text bold.</td>
</tr>
<tr>
<td>Ctrl+C</td>
<td>Copy the text.</td>
</tr>
<tr>
<td>Ctrl+D</td>
<td>Double Underline text.</td>
</tr>
<tr>
<td>Ctrl+E</td>
<td>Text is center aligned.</td>
</tr>
<tr>
<td>Ctrl+F</td>
<td>Find and Replace.</td>
</tr>
<tr>
<td>Ctrl+I</td>
<td>Makes text Italics.</td>
</tr>
<tr>
<td>Ctrl+J</td>
<td>Text is Justified.</td>
</tr>
<tr>
<td>Ctrl+L</td>
<td>Text is left aligned.</td>
</tr>
<tr>
<td>Ctrl+R</td>
<td>Text is right aligned.</td>
</tr>
<tr>
<td>Ctrl+U</td>
<td>Underlines text.</td>
</tr>
<tr>
<td>Ctrl+V</td>
<td>Paste the text.</td>
</tr>
<tr>
<td>Ctrl+X</td>
<td>Move the text.</td>
</tr>
<tr>
<td>Ctrl+Y</td>
<td>Redo last action.</td>
</tr>
<tr>
<td>Ctrl+Z</td>
<td>Undo last action.</td>
</tr>
<tr>
<td>Left Arrow</td>
<td>Move cursor one character left.</td>
</tr>
<tr>
<td>Right Arrow</td>
<td>Move cursor one character right.</td>
</tr>
<tr>
<td>Up Arrow</td>
<td>Move cursor one line up.</td>
</tr>
<tr>
<td>Down Arrow</td>
<td>Move cursor one line down.</td>
</tr>
<tr>
<td>Shift+ Left Arrow</td>
<td>Move cursor with selection to the left.</td>
</tr>
<tr>
<td>Shift+ Right Arrow</td>
<td>Move cursor with selection to the right.</td>
</tr>
<tr>
<td>Ctrl+ Left Arrow</td>
<td>Go to beginning of word.</td>
</tr>
<tr>
<td>Ctrl+ Right Arrow</td>
<td>Go to end of word.</td>
</tr>
<tr>
<td>Home</td>
<td>Go to beginning of line.</td>
</tr>
<tr>
<td>End</td>
<td>Go to end of line.</td>
</tr>
<tr>
<td>Ctrl+Home</td>
<td>Go to start of document.</td>
</tr>
<tr>
<td>Ctrl+End</td>
<td>Go to end of document.</td>
</tr>
<tr>
<td>Shift+Home</td>
<td>Go and select from the beginning of line.</td>
</tr>
<tr>
<td>Shift+End</td>
<td>Go and select till end of line.</td>
</tr>
<tr>
<td>Insert</td>
<td>Insert mode on/off.</td>
</tr>
<tr>
<td>Page Up</td>
<td>Move one screen up.</td>
</tr>
<tr>
<td>Page Down</td>
<td>Move one screen down.</td>
</tr>
<tr>
<td>Ctrl+Shift+B</td>
<td>Subscript.</td>
</tr>
<tr>
<td>Ctrl+Shift+P</td>
<td>Superscript.</td>
</tr>
</tbody>
</table>
### Unicode Tamil Keyboard Typing Chart

<table>
<thead>
<tr>
<th>a</th>
<th>க</th>
<th>கில்</th>
<th>கணா</th>
<th>கெ</th>
<th>குடி</th>
</tr>
</thead>
<tbody>
<tr>
<td>aa</td>
<td>ஆ</td>
<td>ஆங்கில்</td>
<td>ஆங்கணா</td>
<td>ஆங்கெ</td>
<td>ஆங்குடி</td>
</tr>
<tr>
<td>i</td>
<td>ஐ</td>
<td>ஐண்ணு</td>
<td>ஐண்ணா</td>
<td>ஐண்ணெ</td>
<td>ஐண்ணுடி</td>
</tr>
<tr>
<td>ii</td>
<td>ஐங்க</td>
<td>ஐங்கணா</td>
<td>ஐங்கெ</td>
<td>ஐங்குடி</td>
<td></td>
</tr>
<tr>
<td>u</td>
<td>ஐ d / t</td>
<td>ஐ d / ta</td>
<td>ஐ kau</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>uu</th>
<th>ஐன்</th>
<th>ஐணா</th>
<th>ஐணா</th>
<th>ஐணுடி</th>
</tr>
</thead>
<tbody>
<tr>
<td>e</td>
<td>ஐ</td>
<td>ஐண்ணு</td>
<td>ஐண்ணா</td>
<td>ஐண்ணெ</td>
</tr>
<tr>
<td>ee</td>
<td>ஐ</td>
<td>ஐண்ணு</td>
<td>ஐண்ணா</td>
<td>ஐண்ணெ</td>
</tr>
<tr>
<td>ai</td>
<td>ஐ</td>
<td>ஐண்ணு</td>
<td>ஐண்ணா</td>
<td>ஐண்ணெ</td>
</tr>
<tr>
<td>o</td>
<td>ஐ</td>
<td>ஐண்ணு</td>
<td>ஐண்ணா</td>
<td>ஐண்ணெ</td>
</tr>
<tr>
<td>oo</td>
<td>ஐ</td>
<td>ஐண்ணு</td>
<td>ஐண்ணா</td>
<td>ஐண்ணெ</td>
</tr>
<tr>
<td>au</td>
<td>ஐ</td>
<td>ஐண்ணு</td>
<td>ஐண்ணா</td>
<td>ஐண்ணெ</td>
</tr>
<tr>
<td>q</td>
<td>ஐ</td>
<td>ஐண்ணு</td>
<td>ஐண்ணா</td>
<td>ஐண்ணெ</td>
</tr>
<tr>
<td>v</td>
<td>ஐ</td>
<td>ஐண்ணு</td>
<td>ஐண்ணா</td>
<td>ஐண்ணெ</td>
</tr>
<tr>
<td>z</td>
<td>ஐ</td>
<td>ஐண்ணு</td>
<td>ஐண்ணா</td>
<td>ஐண்ணெ</td>
</tr>
<tr>
<td>L</td>
<td>ஐ</td>
<td>ஐண்ணு</td>
<td>ஐண்ணா</td>
<td>ஐண்ணெ</td>
</tr>
<tr>
<td>R</td>
<td>ஐ</td>
<td>ஐண்ணு</td>
<td>ஐண்ணா</td>
<td>ஐண்ணெ</td>
</tr>
</tbody>
</table>

| n | ஐந் | ஐநா | ஐநா | ஐநுடி |

<table>
<thead>
<tr>
<th>j</th>
<th>ja</th>
<th>jaa</th>
<th>je</th>
<th>jee</th>
<th>jo</th>
<th>joo</th>
<th>ji</th>
<th>jii</th>
<th>ju</th>
<th>juu</th>
</tr>
</thead>
<tbody>
<tr>
<td>ஜ</td>
<td>தா</td>
<td>தாா</td>
<td>தே</td>
<td>தோ</td>
<td>தொ</td>
<td>தொா</td>
<td>தி</td>
<td>தியா</td>
<td>து</td>
<td>துா</td>
</tr>
<tr>
<td>sh</td>
<td>sh</td>
<td>shaa</td>
<td>she</td>
<td>shee</td>
<td>shoo</td>
<td>shoo</td>
<td>shii</td>
<td>shu</td>
<td>shuu</td>
<td></td>
</tr>
</tbody>
</table>

WorkShop -6.14 : Type the following content in Tamil using any interface (Murasu / NHM / Azhagi).

<table>
<thead>
<tr>
<th>kaNNan - கண்ணன்</th>
<th>joothpur - ஜூத்புர்</th>
</tr>
</thead>
<tbody>
<tr>
<td>sennai - சென்நை</td>
<td>juulai - ஜூலை</td>
</tr>
<tr>
<td>thamizwaadu - தமிழ் வாது</td>
<td>shiiradi - வீரதி</td>
</tr>
<tr>
<td>thaajmahaal - தாஜ்மாகல்</td>
<td>hamadu - ஹாமாடு</td>
</tr>
<tr>
<td>shaajakaan - சாஜகான்</td>
<td>vaashingtan - வாசிங்டன்</td>
</tr>
</tbody>
</table>

மேம்பட்ட வழக்கங்களுடன் போர்க்குறிஞர் பாட்டுக்குறிஞர் சென்னை குடியுரிமைப் பகுதியில் (Chennai Schools) இந்த அனுபாதகம் வேளைக்குறிப்பிட்டியது. போர்க்குறிஞர் பாட்டுக்குறிஞர் சென்னை குடியுரிமைப் பகுதியில் கல்லூரிகளை (Education Department) ஒன்று வருகிறது. தற்கால ஆசியப் பொருள் (IAS) அறிமுகமானார், கல்லூரியில் அதிகாரிகள் (Educational Officer) மற்றும் 10 கல்லூரியில் அதிகாரிகள் (Assistant Educational Officers - AEO) தமிழ்க் எழுத்தாளராக விளங்கிகின்றார். |
Student Activity

1. Make the students prepare an invitation for school annual day.

2. Let the students prepare their class timetable in table format and format it in an attractive manner.

3. Make the students create a greeting card in landscape format with a picture and a birthday message and distribute to students on their birthday.

Teacher Activity

1. To show a demo to the students how to type a question paper by using formulas and special characters, changing the margins and printing in the practical session.

2. To show the students a demo of inserting a picture and applying crop, color changes, background and others features to modify it and make more attractive.

Evaluation

I. Choose the best answer

1. Which is the opening screen of OpenOffice?
   - a. Star desktop  
   - b. Star center  
   - c. Star screen  
   - d. Star window

2. Which option allows you to assign text, tables, graphics and other items to a key or key combination
   - a. Autoformat  
   - b. Automatic  
   - c. Auto text  
   - d. Autographics

3. Which menu contains the Numbering option.
   - a. File  
   - b. Edit  
   - c. Tools  
   - d. Format

4. Which is displayed at the top most part of the window?
   - a. Menu bar  
   - b. Tool bar  
   - c. Title bar  
   - d. Format bar
5. Which is changing the default appearance of the text called?

6. The Find & Replace option is available in which menu?
   a. File   b. Edit   c. Format   d. Tools

7. Which button selects all instances of the search text in the document?
   a. Find   b. Find All   c. Replace   d. Replace All

8. What is the shortcut key to go to the start of the document?

9. What is the shortcut key for finding and replacing text in a document?

10. What is the short cut key for Undo?

II VERY SHORT ANSWERS(TWO MARKS)
1. How do you insert pictures in to your document?
2. What are the different packages in OpenOffice writer?
3. What is auto text in writer?
4. How do you merge cells in a table?
5. State the difference between proprietary software and open source software?

III SHORT ANSWERS (THREE MARKS)
1. What is the difference between moving and copying text?
2. What are the different types of orientation?
3. How do you insert rows and columns?
4. What are the different ways to save a document?
5. Write the steps to change the line spacing of text.
IV EXPLAIN (FIVE MARKS)

1. What are the different methods to change margin in writer?

2. What are Header and Footer? How do you insert page numbers?

3. Write the steps to Find and Replace a word with another word in OpenOffice writer?

4. Explain Page formatting in writer.

<table>
<thead>
<tr>
<th>WORD</th>
<th>MEANING</th>
</tr>
</thead>
<tbody>
<tr>
<td>Word processor</td>
<td>A software used to create, edit, view, manipulate, transmit, store, print and retrieve a text document.</td>
</tr>
<tr>
<td>OpenOffice writer</td>
<td>A word processor component of open office.</td>
</tr>
<tr>
<td>Proprietary</td>
<td>Owner or ownership.</td>
</tr>
<tr>
<td>Embedding</td>
<td>To surround tightly or firmly.</td>
</tr>
<tr>
<td>Highlighting</td>
<td>Highlighting is used to draw attention to important information in a text.</td>
</tr>
<tr>
<td>Indents</td>
<td>Indents is the distance from the margin that is used to improve the efficiency and readability of the paragraph.</td>
</tr>
<tr>
<td>DDE</td>
<td>Dynamic Data Exchange – a mechanism where source data can be pasted into a destination with a link of the original.</td>
</tr>
<tr>
<td>Paste Special</td>
<td>The pasteSpecial option is used when only some aspects of the data, like only its formatting or only value is send while moving or copying.</td>
</tr>
<tr>
<td><strong>Headsers</strong></td>
<td>This is the section at the top of the page where any references like title, chapter name, author name can be given which gets repeated on all pages.</td>
</tr>
<tr>
<td><strong>Footers</strong></td>
<td>This is the section at the bottom of the page where any references like page number can be given which gets repeated on all pages.</td>
</tr>
<tr>
<td><strong>AutoText</strong></td>
<td>This helps to assign shortcuts to some text which are frequently used.</td>
</tr>
<tr>
<td><strong>Auto spell check</strong></td>
<td>This feature automatically checks the spelling while typing and underlines the misspelt words with wavy lines which can be corrected later.</td>
</tr>
<tr>
<td><strong>Automatic Correction</strong></td>
<td>This feature automatically corrects the common misspellings and typing errors automatically.</td>
</tr>
</tbody>
</table>
Chapter 7

Part – I Working with OpenOffice Calc

7.1 Introduction to spreadsheet

Spreadsheet is a very useful office automation tool to organise, analyse and store data in a tabular form. Spreadsheet was developed as computerized equivalent to paper-based accounting worksheets.

Spreadsheet users can adjust any of the stored values and can observe the effects on the calculated values. This is called “What if” analysis. Modern spreadsheet can have multiple interacting sheets and can display data either as text or numerals or in a graphical form.

7.1.1 Evolution of Spreadsheet

Daniel Bricklin and Bob Frankston developed the first spreadsheet called “VisiCalc” in 1979 for Apple II. In 1982, Lotus Corporation introduced “Lotus 1-2-3”; Lotus 1-2-3 was the first to introduce cell names and macros. In 1987, Microsoft Corporation introduced Excel. Excel implemented a Graphical User Interface (GUI) and the ability to point and click using a mouse. There are lots of other spreadsheet applications; Microsoft Excel continues to be the most popular spreadsheet software.

Daniel Singer "Dan" Bricklin
The Father of Spreadsheet

Daniel Singer "Dan" Bricklin (born 16 July 1951), often referred to as “The Father of the Spreadsheet”, is the American co-creator, with Bob Frankston, of the VisiCalc spreadsheet. He also founded Software Garden, Inc., of which he is currently President of Trellix Corporation, which is currently owned by Web.com. He currently serves as the Chief Technology Officer of Alpha Software.

OpenOffice Calc is a popular open source spreadsheet application maintained by Apache Foundation. StarOffice calc was the parent application of OpenOffice Calc which was developed by a German Company namely, Star Division in 1985.

7.2 Working with OpenOffice Calc

Calc is the spreadsheet component of OpenOffice. You can enter any kind of data in a spreadsheet and then manipulate this data to produce certain results. Alternatively, you can enter data and then use Calc in a ‘What If..’ manner by changing some of the data and observing the results without having to retype the entire spreadsheet.
VisiCalc (“Visible Calculator”) was the first spreadsheet for personal computers, originally released for the Apple II by VisiCorp. It is considered that VisiCalc turned the microcomputer from a hobby for computer enthusiasts into a serious business tool, prompting IBM to introduce the IBM PC, two years later. It was sold over 700,000 copies in six years, and as many as 1 million copies over its history.

7.2.1 Features of OpenOffice Calc:

- **Connecting with Excel** - Ability to open, edit, and save Microsoft Excel spreadsheets
- **AutoSum** - helps you to add the contents of a cluster of adjacent cells.
- **List AutoFill** - automatically extends cell formatting when a new item is added to the end of a list.
- **AutoFill** - allows you to quickly fill cells with repetitive or sequential data such as chronological dates or numbers, and repeated text. AutoFill can also be used to copy functions. You can also alter text and numbers with this feature.
- **Charts** - helps you in presenting a graphical representation of your data in the form of Pie, Bar, Line charts and more.
- **Functions**: which can be used to create formula to perform complex calculations on data
- **Database functions**: to arrange, store, and filter data

7.3 Creating a new worksheet

A new spreadsheet can be created through various methods. From windows, select

Start → All Programs → OpenOffice → OpenOffice Calc (or)

**From Star Center (Welcome Screen):**

Double-click on “OpenOffice” icon the desktop

Now, a welcome screen appears as shown in Figure 7.1.

This open screen is called as “Star Center”. Calc is one of the component of OpenOffice. So, it may be invoked from the “Star Center” by simply clicking on the “Spreadsheet” icon. (or)

A new spreadsheet can also be created by selecting **File → New → Spreadsheet** from any OpenOffice Application. After using any one of the above said methods, OpenOffice Calc window appears as shown in Figure 7.2. The outline of the window is very similar to other application windows of OpenOffice. The main area of the Calc window is called as “Work area” or “Worksheet”.

A worksheet is a grid of cells with a programmable calculator attached to each cell. When you open a new spreadsheet, there are three worksheets available by default. You can include more sheets and organize them.
Figure 7.1 Opening Screen (Star Center) of OpenOffice

Fig 7.2 OpenOffice Calc Window
7.3.1 Parts of the OpenOffice Calc Window

Appearance of the Calc window is very similar to that of the Writer window. The workspace of writer is a big blank area. But, in calc, the grid of cells is the workspace.

7.3.1.1 Title Bar

Top of the window is called the “Title Bar”. It is used to show the name of the file and name of the application. In OpenOffice calc, the default name for the first unsaved worksheet is “Untitled1”. When you save the file, Untitled will change to the name in which you saved.

7.3.1.2 Control Buttons:

In the right corner of title bar, (1) minimize, (2) maximize / restore and (3) close control buttons are available.

7.3.1.3 Menu Bar

Below the title bar is menu bar. Most of the menus are very similar to what you learnt in OpenOffice Writer.

**File** - menu contains the commands of all file management tasks like, Create a new file, Open an existing file, Close the current file, Save a file, Save a file in another name, print file, Export file etc.

**Edit** - menu contains the editing commands like, cut, copy, paste, Undo, Redo, Fill etc., Most of the menu items are similar to Writer Edit menu. But, for Calc, some special editing options are available under this menu.

**View** - menu contains the commands which are used to modify the environment of calc.

**Insert** – menu contains commands for inserting various calc elements such as cells, columns, rows, functions, charts etc.,

**Format** – menu contains the commands of various text and cell formatting features.

**Tools** – menu contains various tools and functions such as spell check, protect document, insert pictures, macros, etc.,

**Data** – menu contains the commands to manipulate data in a spreadsheet such as sort, filter, subtotal, validity etc.,

**Window** – menu shows display options such as New Window, Close Windows, Split and Freeze.

**Help** – menu lists in-built help features available with OpenOffice.

7.3.1.4 Tools Bar

Under the menu bar, there are three toolbars available by default. They are:
Standard Toolbar – contains frequently used File, Edit and Data menu commands as icons such as New, Open, Save, Send, print, print preview, Cut, Copy, Paste, Sorting, inserting chart etc.,

Formatting Toolbar – contains frequently used text and cell formatting commands as such as changing font style, font size, font colour, alignments, cell formatting etc.,

Formula bar – This is a very important element in a spreadsheet. It contains Name box, Function Wizard, Sum button, Function button and Input line (Refer Figure 7.4).

Name box: It display the current cell address

Function Wizard: It is used to insert function

Sum button: It is used to quickly insert sum function.

Input Line: This is used to show the contents of the current cell. It always shows actually what you typed in a cell. It is also used to edit the contents.

7.3.1.5 Scroll bar

Spreadsheet window also has two sets of scrolling bars (1) Vertical Scrollbar and (2) Horizontal Scrollbar (Refer Figure 7.5)

Vertical Scroll bar: It is used to move the screen up and down.

Horizontal Scroll bar: It is used move the screen left and right.

Scroll buttons: used to move the screen to the relative distance.
7.3.1.6 Row, Column, Cell and Cell Pointer

Below the formula bar contains the worksheet of work area which consists of grid cells. The worksheet has a number of rows and columns, where each column is labelled as A, B, C, D .... AA, AB, AC .... and the rows are numbered from 1, 2, 3 .... (Figure 7.6).

OpenOffice Calc version 4.1.5 contains 1024 columns and 10,48,576 rows. Column heading starts from A and end with AMJ. In the case of Microsoft Excel 2016, there are 16,384 columns (A to XFD) and 10,48,576 rows available.

Cell

Intersection of each row and column makes a box which is called as “Cell”. Each cell has its unique address. Cell address is the combination of column heading and row number. For example, the intersection of column B and row 4 makes a cell B4. (Figure 7.7). Every cell is thus identified by its unique cell address.

Cell pointer is a rectangle box which can be moved around the worksheet. The cell in which the cell pointer is currently located is known as “Active cell”. When you type any content, it will appear in the active cell. The address of the active cell is displayed in the Name box / Address box. Active cell's column name and row number will be highlighted. Using this visual clue, one can easily identify an active cell. Moreover, the contents of an active cell will be displayed in the formula bar.
7.3.1.7 Worksheet tabs:
At the bottom of the grid of cells are the sheet tabs. By default there are 3 sheets “Sheet1”, “Sheet2” and “Sheet3”, (Figure 7.8). When you open a new worksheet, sheet1 is the default active sheet. Active sheet tab will appear in white colour. If you click on another sheet, it will become active and its colour will turn white. Multiple sheets can also be selected by clicking the sheet and press the Ctrl button (Ctrl + Click). Selected sheets will turn to white colour.

On the left of the sheet tab, four navigation buttons are used to move between worksheets (Figure 7.9).

![Fig. 7.9 Calc Sheet tab and Navigation buttons](image)

(1) Move to the First sheet  
(2) Move to the previous sheet  
(3) Move to Next sheet  
(4) Move to the Last sheet

Fig. 7.9 Calc Sheet tab and Navigation buttons

Left corner of status bar shows the total count of sheets and the present active sheet number. For example, if the status bar shows sheet 3/12; 3 refers to the serial number of the current sheet and 12 refers to the total number of sheets available.

Every sheet name can be renamed. To rename a sheet, just double-click on the sheet, which will show a small box as shown in Figure 7.10.

![Figure. 7.10 Rename Sheet dialog box](image)

It shows the current name; delete or overwrite the existing name and type a new name; click OK button. New name will be displayed on the sheet.

7.3.1.8 Status bar

Below the sheet tabs and horizontal scrolling bar is the “Status Bar”. It shows the current status of the worksheet (Refer Figure 7.11).

**Sheets count:** Displays current serial number of the sheet / total number of sheets available.

**Page Style:** Displays the page style of the current sheet. To make changes, just double-click on “Default” and it will show you the “Page Style” dialog box, which is used to change the margin, orientation, paper size, inserting header, footer, border style etc.,

**Selection Mode:** Displays the selection mode of the current sheet. There are three modes available to select the cells of a worksheet. They are, Standard (STD), Extend (EXT) and Add (ADD).

**Unsaved Changes:** An asterisk ( * ) symbol indicates the changes made in the worksheet but not yet saved. If you have saved your changes, it will disappear.
7.4 Working with Data

When you open a new spreadsheet, the cell pointer is located in cell A1. So, the Cell A1 is known as “Home Cell”. Cell pointer can be moved anywhere in the spreadsheet using the direction keys.

“Tab key” is used to move the cell pointer towards the right side or forward direction. “Shift+Tab” is used to move backward i.e. from right to left in a row. “Enter” key is also used to move the cell pointer. Enter moves the cell pointer to a cell below the current cell i.e. downwards. Four “direction keys” are used to move the cell pointer anywhere in the worksheet.

7.4.1 Entering Data:

Any data can be typed directly in any cell of the worksheet. But, the cell in which you type data should be an active cell. So, move the cell pointer to a particular cell to make it active cell; or click any cell to make it active cell. Then, start typing any data. When you type data, spreadsheet recognises the type of data entered in cells.

Data types:

Data are in different types. Data are made up of alphabets, numbers, Date and time is another data type even though it has numbers and symbols. In general, data types are classified as:

Alphabetic data type – consists of alphabets only Numeric data type – consists only of numbers (whole number or fractional numbers) Alphanumeric data types – consists of a combination of alphabets and numerals Date data type – consists only of date Time data type – consists only time

7.4.1.1 Entering Numbers:

Any numeric data can be entered in a spreadsheet. Entered numbers are aligned to the right side within the cell by default. Negative numbers may be entered with a minus sign or within brackets (Refer Figure 7.12). If you enter any number within the bracket, it will be changed as negative number i.e., number prefixed with minus. If any number starts with 0 (zero); Calc will drop the leading zero.
7.4.1.2 Entering Text:

Unlike numbers, any character can be entered as data in Calc. Entered text will be aligned to the left side within the cell by default. When you enter any numeric value, if it has aligned left, it is understood that the entered content is not a number. If there is any number that starts with a single quote, calc converts that number to text (Refer Figure 7.13).

![Figure 7.13 Entering Text](image)

7.4.1.3 Entering Date and Time:

Before entering date, ensure the format of your system date. Calc accepts date as per the system date format. If your system has American date format i.e. month-date-year; you should enter dates in Calc spreadsheet as mm/dd/yy. If your system follows the Indian date format, date should be entered as dd/mm/yy form in Calc. Only the correct form of date is accepted by Calc as a date.

For example: If your system has American Date format, 18th December 2017 should be entered as 12/18/17. As soon as the date is typed in the correct form, the entered date will be aligned on the right side within the cell, and if you place the cell pointer in that cell, the formula bar shows your date as “12/18/2017” (Figure 7.14). This is a visual clue to know whether the date is accepted or not.

A Date format can be changed to any other valid form using “Cell Formatting” dialog box, and it will be discussed later.

![Fig. 7.14 Entering Date](image)

Like dates, for entering time, calc follows the general format HH:MM:SS. where HH, MM and SS represent hours, minutes and seconds respectively.

### Different Date Formats

<table>
<thead>
<tr>
<th>Order styles</th>
<th>Countries</th>
</tr>
</thead>
<tbody>
<tr>
<td>DD/MM/YYYY</td>
<td>Asia (Central, SE, West), Australia, New Zealand, parts of Europe, Latin America, North Africa, India, Indonesia, Bangladesh and Russia</td>
</tr>
<tr>
<td>YYYY/MM/DD</td>
<td>Bhutan, Canada, China, Koreas, Taiwan, Hungary, Iran, Japan, Lithuania, Mongolia.</td>
</tr>
<tr>
<td>MM/DD/YYYY</td>
<td>United States, Federated States of Micronesia, Marshall Islands</td>
</tr>
<tr>
<td>DD/MM/YYYY and MM/DD/YYYY</td>
<td>Malaysia, Nigeria, Philippines, Saudi Arabia, Somalia</td>
</tr>
</tbody>
</table>
7.5 Creating Formulae

After entering the data in worksheet, you can perform calculations on the data in the worksheet. In order to create formulae, you first need to know the syntax that describes the format for specifying a formula.

In Calc, you can enter formulas in two methods, either directly into the cell or at the input line. Formula in Calc may start with equal (=) or plus(+) or minus(–) sign followed by a combination of values, operators and cell references. But, as a general practice, all formulas should start with an equal sign. If any formula starts with a + or –, the values will be considered as positive or negative respectively.

7.5.1 Operators

Operators are symbols for doing some mathematical, statistical and logical calculations. Combination of values, operators and cell references is called as “Expression”. Calc supports a variety of operators which are categorized as:

1. Arithmetic Operators
2. Relational Operators
3. Reference Operators
4. Text Operator

### 7.5.1.1 Arithmetic Operators

Arithmetic operators are symbols for performing simple arithmetic operations such as addition, subtraction, multiplication, division etc., These operators return a numerical result.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Name</th>
<th>Value in Column B</th>
<th>Value in Column C</th>
<th>Formula in Column D</th>
<th>Result in Column D</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>Addition</td>
<td>98</td>
<td>25</td>
<td>= B3 + C3</td>
<td>123</td>
</tr>
<tr>
<td>-</td>
<td>Subtraction</td>
<td>125</td>
<td>25</td>
<td>= B3 – C3</td>
<td>100</td>
</tr>
<tr>
<td>*</td>
<td>Multiplication</td>
<td>25</td>
<td>5</td>
<td>= B3 * C3</td>
<td>125</td>
</tr>
<tr>
<td>/</td>
<td>Division</td>
<td>90</td>
<td>10</td>
<td>= B3 / C3</td>
<td>9</td>
</tr>
<tr>
<td>^</td>
<td>Exponent</td>
<td>25</td>
<td>2</td>
<td>= B3 ^ C3</td>
<td>625</td>
</tr>
<tr>
<td>%</td>
<td>Percent</td>
<td>600</td>
<td></td>
<td>= B3 * 35%</td>
<td>72</td>
</tr>
</tbody>
</table>

Percentage (%) operator shows percentage of the content.

Table 7.1 List of Arithmetic Operators

Formula bar shows the formula what the user had entered. But, the cell shows the resulted value (Figure 7.15).

![Figure 7.15 Percentage Operator](image)

### 7.5.1.2 Relational Operators

Relational operators are symbols used for comparing two values such as greater than, less than, equal to etc. The relational operators are also called as "Comparative operators". These operators return either a True or a False.
7.5.1.3 Reference Operator

Reference operators are used to refer cell ranges. A continuous group of cells is called as “Range”. There are three types of reference operators that are used to refer cells in calc; they are (1) Range Reference Operator, (2) Range Concatenation (3) Intersection Operator.

Range Reference Operator

Colon (:) is the range reference operator. It is used to group a range of cells. An expression using a range operator has the following syntax:

reference left : reference right

where reference left is the starting cell address of a linear group of cells or upper left corner address of a rectangular group of cell.

Reference right is the last cell address of a linear group or lower right corner address of a rectangular group of cell.

Table 7.2 List of Relational Operators of cells.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Name</th>
<th>Value in Column B</th>
<th>Value in Column C</th>
<th>Formula in Column D</th>
<th>Result in Column D</th>
</tr>
</thead>
<tbody>
<tr>
<td>&gt;</td>
<td>Greater than</td>
<td>98</td>
<td>100</td>
<td>=B3&gt;C3</td>
<td>FALSE</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Greater than or equal to</td>
<td>85</td>
<td>72</td>
<td>=B3&gt;=C3</td>
<td>TRUE</td>
</tr>
<tr>
<td>&lt;</td>
<td>Less than</td>
<td>54</td>
<td>24</td>
<td>=B3&lt;C3</td>
<td>FALSE</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Less than or equal to</td>
<td>55</td>
<td>55</td>
<td>=B3&lt;=C3</td>
<td>TRUE</td>
</tr>
<tr>
<td>=</td>
<td>Equal to</td>
<td>12</td>
<td>12</td>
<td>=B3=C3</td>
<td>TRUE</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>Not equal to</td>
<td>54</td>
<td>45</td>
<td>=B3&lt;&gt;C3</td>
<td>TRUE</td>
</tr>
</tbody>
</table>

Figure 7.16 Entering Relational Operator
Example:

(i) Linear group of cells A1, A2,A3,A4,A5 is referred as A1:A5

(ii) Rectangular group of cells A2, A3, A4, ....., B2, B3, B4,....D5, D6 is referred as A2:D6 (Refer Figure 7.17)

Figure 7.17 Range of selected cells

Name box shows the reference A2:D6 corresponding to the cells included in the drag operation with the mouse to highlight the range.

Reference concatenation operator:

Concatenation means joining together. Tilde (~) symbol is used as a concatenation operator in calc. An expression using a concatenation operator has the following syntax:

reference left ~ reference right

Example:

If you want to find the sum of the values from A1 to A6 and C3 to F3. The formula is =SUM(A1:A6 ~ C3:F3)

SUM is a function to find the sum of a group of values.
Intersection Operator:

Intersection operator is used to join two set of groups. It is very similar to Range concatenation operator. The intersection operator is represented by an exclamation `reference left ! reference right`

Example: \((A2:D3 ! B2:E4)\)

![Intersection Operator Diagram](image)

The result of \((A2:D3 ! B2:E4)\) is referred by the range B2:D3, because these cells are both inside A2:D3 and B2:E4 (Refer Figure 7.19 and 7.20).

![Worksheet with Intersection Operator](image)
7.5.1.4 Text Operator:

In Calc, “&” is a text operator which is used to combine two or more text. Joining two different texts is also known as “Text Concatenation” (Refer Figure 7.23). An expression using the text operator has the following syntax:

\[
\text{text reference1} \& \text{text reference2}
\]

![Figure 7.21 Text operator](image)

When arithmetic operators are used in a formula, Calc calculates the results using the rule of precedence followed in Mathematics. The order is:

I. Exponentiation (\(^\) )  
II. Negation (-)

III. Multiplication and Division (\(*, /\) )  
IV. Addition and Subtraction (+, -)

Here is an example to illustrate how to create a formula:

**Illustration 1:**

Create a Marks worksheet with the following data:

<table>
<thead>
<tr>
<th>Reg. No</th>
<th>Name</th>
<th>Tam</th>
<th>Eng</th>
<th>CS</th>
<th>Com</th>
<th>Acc</th>
</tr>
</thead>
<tbody>
<tr>
<td>12001</td>
<td>Jayashree J</td>
<td>147</td>
<td>136</td>
<td>105</td>
<td>163</td>
<td>162</td>
</tr>
<tr>
<td>12002</td>
<td>Kowsalya T</td>
<td>156</td>
<td>148</td>
<td>149</td>
<td>147</td>
<td>179</td>
</tr>
<tr>
<td>12003</td>
<td>Muskan S</td>
<td>149</td>
<td>165</td>
<td>123</td>
<td>168</td>
<td>179</td>
</tr>
<tr>
<td>12004</td>
<td>Ashia Stepthy R</td>
<td>168</td>
<td>144</td>
<td>146</td>
<td>192</td>
<td>167</td>
</tr>
<tr>
<td>12005</td>
<td>Vennila T P</td>
<td>199</td>
<td>198</td>
<td>150</td>
<td>200</td>
<td>200</td>
</tr>
<tr>
<td>12006</td>
<td>Deepika M</td>
<td>187</td>
<td>141</td>
<td>98</td>
<td>130</td>
<td>178</td>
</tr>
<tr>
<td>12007</td>
<td>Tharani J</td>
<td>165</td>
<td>102</td>
<td>100</td>
<td>192</td>
<td>192</td>
</tr>
<tr>
<td>12008</td>
<td>Thulasi A</td>
<td>143</td>
<td>169</td>
<td>88</td>
<td>176</td>
<td>173</td>
</tr>
<tr>
<td>12009</td>
<td>Ayisha B</td>
<td>120</td>
<td>138</td>
<td>109</td>
<td>182</td>
<td>167</td>
</tr>
<tr>
<td>12010</td>
<td>Jenifer A</td>
<td>145</td>
<td>135</td>
<td>95</td>
<td>180</td>
<td>185</td>
</tr>
</tbody>
</table>

*After completing the data entry, your worksheet will look as shown in Figure 7.22.*
7.5.2 Construction of formula

To construct a formula, follow the steps below:

- Cell pointer should be in the cell in which you want to display the result.
- Formula should begin with an = sign.
- In a formula, use only cell reference (cell addresses) instead of the actual values within the cells.
- While constructing a formula, **BODMAS rule** should be kept in mind.
- General Syntax of constructing a formula is: $= \text{cell reference}_1 \ <\text{operator}>\  \text{cell reference}_2 \ <\text{operator}>\ …\…………\$.
- Cell references are of two types (i) Relative cell reference (ii) Absolute Cell reference.
- If you refer cell addresses directly while constructing formulae, it is called as “Relative Cell reference”.
- Examples of Relative Cell references:

<table>
<thead>
<tr>
<th>Operation</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adding values of A1, B1, C1, D1</td>
<td>$=A1+B1+C1+D1$</td>
</tr>
<tr>
<td>Subtract E4 from H3</td>
<td>$= H3 – E4$</td>
</tr>
<tr>
<td>Multiply A5 and B5</td>
<td>$= A5 * B5$</td>
</tr>
<tr>
<td>Average of G1, G2, G3, G4</td>
<td>$=(G1+G2+G3+G4)/4$</td>
</tr>
</tbody>
</table>
• In the above table, all cell references are “Relative cell references”.

• While writing a formula, if you use the $ symbol in front of a column name and row number, it will become an “Absolute Cell reference”.

• Examples of Absolute cell references:

<table>
<thead>
<tr>
<th>Description</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adding values of A1, B1, C1, D1</td>
<td>=$A$1+$B$1+$C$1+$D$1</td>
</tr>
<tr>
<td>Subtract E4 from H3</td>
<td>=$H$3 – $E$4</td>
</tr>
<tr>
<td>Multiply A5 and B5</td>
<td>=$A$5 * B5</td>
</tr>
<tr>
<td>Average of G1, G2, G3, G4</td>
<td>=($G$1+G2+$G$3+G4)/4</td>
</tr>
</tbody>
</table>

• In an expression, all cells need not necessarily be relative or absolute. You can mix both type of references.

• The following section explains the use of relative cell reference. About “Absolute cell reference”, you will be learn later in this chapter.

Finding Total to the above Illustration:

• Move the cell pointer to H2 (Total column)

• Type the following formula; after entering the formula, press “Enter” key

  \[= C2+D2+E2+F2+G2 \text{ (Refere Figure 7.25)}\]

• Now, you will get the sum of all the values of C2, D2, E2, F2 and G2

• The above-mentioned formula clearly stated that, how worksheets are working with cells.

• While referring to the cell addresses in a formula, the spreadsheet reads the value inside the cell that you refer. This is a good practice of constructing a formula. Because, if you change any value, the spreadsheet recalculates with that new value.

After entering a formula the result is display as in Figure 7.23
Figure 7.23 Constructing formula in Worksheet

7.6 Save, Close and Open the Worksheet:

7.6.1 Saving Worksheet

The process of saving a worksheet is very similar to saving a document. Steps to save a worksheet are as follows:

**Step 1:** File → Save (or) Ctrl + S (or) Click “Save” icon on the standard tool bar.

**Step 2:** If the spreadsheet has not been saved previously, the Save As dialog box will appear.

**Step 3:** Type the name in “File Name” list box. OpenOffice Calc Spreadsheets are stored with extension .ods by default.

**Step 4:** Click “Save” button.

After clicking the save button, the given file name is displayed in the title bar as shown in Figure 7.24.

**File Extension:**

A file extension or file name extension helps to identify the type of file. Following table gives the file extension of commonly used files.
<table>
<thead>
<tr>
<th>Familiar File Type</th>
<th>Extension</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text Files</td>
<td>.txt</td>
</tr>
<tr>
<td>Microsoft Word Documents</td>
<td>.doc / .docx</td>
</tr>
<tr>
<td>OpenOffice Documents</td>
<td>.odt</td>
</tr>
<tr>
<td>Microsoft Excel</td>
<td>.xls / .xlsx</td>
</tr>
<tr>
<td>OpenOffice Calc</td>
<td>.ods</td>
</tr>
<tr>
<td>Microsoft PowerPoint</td>
<td>.ppt / .pptx</td>
</tr>
<tr>
<td>OpenOffice Impress</td>
<td>.odp</td>
</tr>
<tr>
<td>Executable Files / Applications</td>
<td>.exe</td>
</tr>
<tr>
<td>Web Pages</td>
<td>.htm / .html</td>
</tr>
<tr>
<td>Portable Document Format</td>
<td>.pdf</td>
</tr>
<tr>
<td>Photos</td>
<td>.jpg / .jpeg (Joint Photographic Experts Group)</td>
</tr>
<tr>
<td>Animated Images</td>
<td>.gif (Graphical Image Format)</td>
</tr>
<tr>
<td>Audio</td>
<td>.mp3</td>
</tr>
<tr>
<td>Audio / Video</td>
<td>.mp4</td>
</tr>
</tbody>
</table>

Figure 7.24  Saved Spreadsheet
Note: The saved file is stored in the "Document folder" by default.

7.6.2 Auto Save:

The OpenOffice saves a file at regular intervals. This is called as "Auto Save" feature. The default time interval is 15 minutes. It can be reduced even to one minute. If any unexpected shutdown occurs, this feature will recover your file.

7.6.3 Closing a Worksheet

After saving the worksheet; it remains open. So, you can continue to work with the spreadsheet. When the work is finished, you should save using File → Save (or) Click “Save” icon (or) Ctrl + S and then to close the worksheet using File → Close command (or) Press Ctrl + W.

7.6.4 Opening an existing worksheet

7.6.4.1 Using Open dialog box

To reopen an existing worksheet, the File → Open command (or) “Open” icon (or) Ctrl + O can be used. An Open dialog box appears as shown in Figure 7.25 that is similar to “Save As” dialog box.

The name of the file to be opened can be chosen from the list or folder in which worksheet has been saved.
7.6.4.2 Using Recent documents

OpenOffice keeps a list of recently opened files. **File → Recent Documents** option can be used to open an existing worksheet from the list as shown in Figure 7.26

![List of recently used files](image)

Figure 7.26 List of Recent Documents

7.7 Copy, Cut and Paste

7.7.1 Copy and paste Data

- Select the cell or cells you want to copy
- Select **Edit → Copy or Click “Copy”** icon from the standard toolbar or Press Ctrl + C
- Move the cell pointer to the cell in which you want to paste.
- Select **Edit → Paste or Click “Paste”** icon or Press Ctrl + V

7.7.2 Cut and Paste Data

- Select the cell or cells you want to cut
- Select **Edit → Cut or Click “Cut”** icon from the standard toolbar or Press Ctrl + X
- Move the cell pointer to the cell in which you want to paste.
- Select **Edit → Paste or Click “Paste”** icon or Press Ctrl + V

7.7.3 Copy and Paste Formula

- The process of Copy and Paste data is used for copying formula.
- When you copy a formula from one cell to another cell, the address of the pasted formula will change according to its row. This is called “Relative Cell Reference” (Refer Figure 7.27).
- Example:

While pasted it becomes = B3* C3

![Formula copy and paste example](image)

Figure 7.27 Copy and Paste formula to multiple cells
7.7.4 Copy a formula from one cell and paste it in multiple cells:

(For illustration 1 - Refer 7.23)

**Step 1:** Copy the formula from H2 using Ctrl + C or Edit → Copy (or) click “Copy” icon.

![Figure 7.28 Copy and Paste formula to Multiple cells](image)

**Step 2:** Select all cells (i.e. H3 to H11) in which you want to paste this addition formula.

**Step 3:** Paste the copied formula using Ctrl + V or Edit → Paste (or) Click “Paste” icon.

**Self Practice:**

1. Open the spreadsheet which was created in Illustration 1.
2. Add one more column heading “Average” in I1.
3. Create a formula to find the average of all marks in I2.
4. Apply the formula to the remaining cells.
5. Save the changes and close the file.

---

7.8 Auto Fill Feature:

You have learnt how to copy and paste a formula from one cell to other cells in the previous section. The process of Copy and paste can be replaced by a click and drag and it is called as “Auto Fill”. This is an alternate way to copy and paste.

Auto Fill feature fills the contents from one cell to all the dragged cells. The content may be a data or formula. If you fill a relative formula, all the addresses of filled formulae will be changed.
Cell pointer’s “Drag fill handle” is used to auto fill. Just click and drag this handle to fill the contents. It can be dragged towards right or down. Same can be achieved by Edit → Fill → Down (or) Edit → Fill → Right.

7.8.1 Auto Fill Series:

Auto Fill is also used to generate a series of values. For example, if you want to generate 1,2,3……. up to some length; it can be done by a simple click and dragging over.

Generating whole number series: (Refer Figure 7.30)

Step 1: In cell A1, type as 1 (one) and press enter

Step 2: Click A1 to place the cell pointer

Step 3: Click “Drag Fill Handle” of cell pointer; now the mouse pointer becomes a small +

Step 4: Drag over the cells; while dragging, the generated values will be displayed.

Step 5: Release the mouse pointer. Selected cells will be filled with series of values.

7.8.2 Generating series using command

Edit → Fill → Series Command is used to generate different set of series. Before using this feature, a set of cells should be selected. Using Fill Series feature, you can fill series of values at any direction. (Remember that, auto fill only fills either right or down). Refer Figure 7.31

Direction: Down / Right / Up / Left (Selected cell direction will be default)

Series type:

Linear: To generate a sequence of series (Example 2,4,6,8,10…….)

Growth: To generate multiplication series (Example 2,4,8,16,32,64…….)

Date: To generate date series (when you select date as series type; time unit section gets enabled)

AutoFill: To generate a continuous series of values (1,2,3,…….). When you select “AutoFill”, Time unit section, End value and Increment text boxes become disabled.
**Time Unit:** (Enabled only when you select the series type as “Date”)

- **Day** : To generate date series day-wise
- **Weekday** : To generate date series weekday-wise
- **Month** : To generate date series month-wise
- **Year** : To generate date series year-wise

**Start Value:**

- Initial value of the series should be typed

**End Value:**

- End value of the series should be typed
- If you fail to specify the end value, series will be generated upto the selected cells.

![Fill Series dialog box](image)

*Figure 7.31 Fill series dialog box*

- If your selection is less than the specified end value, series will be generated only upto the selected cells.

**Increment:**

- It is a middle value between the first and second value of your series. So, the next value (Third value) of the series will be generated based on this value.
- If you want to generate a decreasing order series, negative value should be specified as an increment value.
Self Practice:

(i) Generate Even number series from 2 to 20
(ii) Generate a series of 5, 10, 15, 20 …… upto selected cells.
(iii) Generate a series of 2,4,8,16,………. 2048
(iv) Generate a series of 33, 30, 27 …… upto 3
(v) Assume, today is Friday and generate next 25 Fridays (Date series).

7.8.3 Date Arithmetic:

Manual date calculations can be tricky because you have to keep track of the number of days in a month. In spreadsheets, date calculations become very simple. Here you can add a number to a date and arrive at a new date, find the difference between two dates and use a wide variety of function and formats to get what you want.

For example, enter a date 02/26/2018 in a cell, say A2. Suppose you want to calculate the date 80 days after this date. To do so, enter the formula, = A2 + 80, in another cell, say A4.

The date 05/17/18 appears in the cell.

Find out how many days you were born?

- Type today’s date in first cell.
- Type your birth date in second cell.
- Type the following formula in third cell = first_cell_reference – second_cell_reference
7.9 Inserting Columns, Rows and Cells

In Calc, Columns, rows and cells can be inserted individually or in groups.

7.9.1 Inserting a Column:

When you insert a new column, it is inserted to the left of the current column. The location of the cell pointer present, is the Current column. In Calc, you can insert a new column anywhere in the worksheet.

**Step 1**: Select the column where a new column should be inserted.

**Step 2**: Right-click on the selected column name that you selected. A pop-up menu appears.

**Step 3**: click the “Insert Columns” option from the menu.

Now, a new column will be inserted to the left of the current column.

A new column can also be inserted using Insert → Columns command. (Refer Figure 7.32)
Click "Insert" menu
Select "columns" option

![Figure 7.33  Insert Column menu bar](image)

**Practical Practice:**

1. Open the spreadsheet which was created in Illustration 1.
2. Insert a new column between column E and F.
3. Give the heading as “Eco” and Enter the Economics marks for all the students.
4. Insert one more column between the columns, Name and Tamil marks.
5. Give the heading as “Date of Birth” and Enter the date of birth for all the students.
6. Save the changes and close the file.

### 7.9.2 Inserting Rows

When you insert a new row, it is inserted above the current row. The location of the cell pointer present is the current row. In Calc, you can insert a new row anywhere in the worksheet.

**Step 1:** Select the row where a new row to be inserted.

**Step 2:** Right-click on the row number, a pop-up menu appears.

**Step 3:** click “Insert Rows” option from the menu.

Now, a new row will be inserted to above the current row.
Insert → Rows command is used to insert a new row. Refer Figure 7.35.
1. Open the spreadsheet which was created in Illustration 1.
2. Insert 8 rows one by one, then insert the following student details.
3. Save the changes and close the file.

<table>
<thead>
<tr>
<th>Reg. No</th>
<th>Name</th>
<th>Date of Birth</th>
<th>Tam</th>
<th>Eng</th>
<th>CS</th>
<th>Eco</th>
<th>Com</th>
<th>Acc</th>
</tr>
</thead>
<tbody>
<tr>
<td>12101</td>
<td>Sarika S</td>
<td>26/05/2001</td>
<td>145</td>
<td>135</td>
<td>145</td>
<td>125</td>
<td>180</td>
<td>196</td>
</tr>
<tr>
<td>12102</td>
<td>Jewees Celcya J</td>
<td>11/04/2001</td>
<td>102</td>
<td>165</td>
<td>134</td>
<td>95</td>
<td>180</td>
<td>134</td>
</tr>
<tr>
<td>12103</td>
<td>Yuvarani T</td>
<td>27/06/1999</td>
<td>172</td>
<td>130</td>
<td>107</td>
<td>155</td>
<td>162</td>
<td>130</td>
</tr>
<tr>
<td>12104</td>
<td>Meharunisha I</td>
<td>30/05/2001</td>
<td>132</td>
<td>146</td>
<td>112</td>
<td>185</td>
<td>192</td>
<td>176</td>
</tr>
<tr>
<td>12105</td>
<td>Priya W</td>
<td>07/03/2000</td>
<td>130</td>
<td>172</td>
<td>100</td>
<td>92</td>
<td>162</td>
<td>155</td>
</tr>
<tr>
<td>12106</td>
<td>Vijaya Vasavi K</td>
<td>03/06/2001</td>
<td>198</td>
<td>175</td>
<td>149</td>
<td>148</td>
<td>158</td>
<td>135</td>
</tr>
<tr>
<td>12107</td>
<td>Deepika B</td>
<td>14/03/2001</td>
<td>120</td>
<td>182</td>
<td>103</td>
<td>144</td>
<td>107</td>
<td>186</td>
</tr>
<tr>
<td>12108</td>
<td>Viji V</td>
<td>19/04/2001</td>
<td>137</td>
<td>173</td>
<td>128</td>
<td>148</td>
<td>125</td>
<td>177</td>
</tr>
</tbody>
</table>

7.9.3 Inserting Cells

- To insert a new cell between two existing cells, just right-click on any existing cell.
- From the pop-up menu, select “Insert” option Figure 7.36 Insert cells.
- The “Insert Cells” dialog box appear with four options:
  i) Shift cells down  ii) Shift cells right  iii) Entire row  iv) Entire Column.
- Any one of the four options is selected.
- Selecting “Shift cells down”, inserts a new cell in the present location and the existing cells are shifted downwards.
- Selecting “Shift cells right”, inserts a new cell in the present location and the existing cells are shifted towards right.
- Selecting the “Entire Row” or “Entire Column” option, inserts a new row or a new column.

![Insert Cells](image)

*Figure 7.36 Insert cells*
7.9.4 Inserting multiple columns or rows

Multiple columns or rows can be inserted at once rather than inserting one at a time.

- Select multiple rows or columns for insertion.
- Follow steps as in 7.9.1 and 7.9.2

7.9.5 Inserting Columns, Rows and Cells using “Insert Cells” Toolbar

- Insert Cells floating toolbar is also used to insert cells, rows and columns
- Click View → Toolbars → Insert Cell
- A tiny floating toolbar appears on the screen with four icons. Using these icons, you can insert cells, rows and columns. Refer Figure 7.37

![Insert cell toolbar](image)

**Figure 7.37 Insert cell toolbar**

7.10 Deleting columns and rows

A single or multiple columns or rows can be deleted.

- Select the column or row to be deleted.
- Choose Edit → Delete Cells from the menu bar.
  (Or)
- Right-click on the column or row header.
- Choose Delete Columns or Delete Rows from the pop-up menu.

7.10.2 Delete multiple columns or rows

Multiple columns or rows can be deleted at a time. Refer Figure 7.38
• Select the required columns or rows for deletion.

• Right-click on the selected columns or row.

• Choose Delete Columns or Delete Rows from the pop-up menu or Edit → Delete Cells.

**Practical Practice:**

1. Open the spreadsheet which was created in Illustration 1.

2. Delete the details of any 3 students. Save the changes and close the file.

---

**Deleting Column or Row is not Possible**

Same as inserting column or row, Deleting a column or row is also not possible. No one can delete any column or row in a spreadsheet. When you delete a column or row, all the contents will be removed from the column or row. Actually, this is also another kind of deleting contents from a column or row.

---

7.11 Formatting Worksheet

Formatting Data in a cell gives additional effect to the text. Additional effect includes changing the font style, font size, automatic wrapping, bold, underline, italic etc. The data in Calc can be formatted in several ways. Using formatting icons can be used.

---

**Figure 7.38 Delete multiple columns**
7.11.1 Text Formatting

Making the cell contents as bold, italics, underlined, changing font style, size, colour etc., comes under text formatting. All text formatting options are available as icons in Formatting toolbar learnt in OpenOffice Writer. Figure 7.39(a) Text Formatting Toolbar

<table>
<thead>
<tr>
<th>Formatting Option</th>
<th>Keyboard Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Font style</td>
<td></td>
<td>Used to change Font style</td>
</tr>
<tr>
<td>Font size</td>
<td></td>
<td>Used to change Font size</td>
</tr>
<tr>
<td>Bold</td>
<td>Ctrl + B</td>
<td>Used to make the data as Bold</td>
</tr>
<tr>
<td>Italic</td>
<td>Ctrl + I</td>
<td>Used to italicize data</td>
</tr>
<tr>
<td>Underline</td>
<td>Ctrl + U</td>
<td>Used to underline the data</td>
</tr>
<tr>
<td>Left Align</td>
<td>Ctrl + L</td>
<td>Left Align data within a cell</td>
</tr>
<tr>
<td>Right Align</td>
<td>Ctrl + R</td>
<td>Right Align data t within a cell</td>
</tr>
<tr>
<td>Center Align</td>
<td>Ctrl + E</td>
<td>Center the data within a cell</td>
</tr>
<tr>
<td>Justify</td>
<td>Ctrl + J</td>
<td>Align the data evenly both on left and right side of a cell</td>
</tr>
<tr>
<td>Merge cell</td>
<td></td>
<td>Makes selected cells as a single cell</td>
</tr>
</tbody>
</table>

7.11.2 Number formatting

Number formatting options are used to visually change the format of a numeric content. These formatting changes are only for visual as, it does not change its original value. For example, To display a number as currency form use Number format: Currency.

Number format: Currency will be used as shown Figure 7.39(b).
1. Open the spreadsheet which was created in Illustration 1.
2. Align all headings as center and make them bold.
3. Align all Register numbers and marks in center
4. Apply different font styles to the entire worksheet.
5. Save the changes and close the file

Part – III Working with Functions and Chart

7.12 Functions

OpenOffice Calc has more than 350 functions under 11 categories. Functions are predefined formulae already available with Calc. They are used to perform several frequently done calculations. Every function has a unique name and a prototype. Functions are categorized according to their functionality. For example, the functions such as Sum, Average, Sin, Cos etc., are categorized as “Mathematical Functions”.

7.12.1 Inserting Functions into Worksheet:

A function can be inserted by (i) Direct Insert Method or (ii) Using Function Wizard method.

7.12.1.1 Direct Insert method:

If you know the function name and its syntax, it can be directly typed in any cell of the worksheet.

For example, SUM is the most frequently used function to add a set of values. The syntax of the SUM ( ) is

\[ = \text{SUM (range 1; range 2; range 3…… range n)} \]

If you want to know the sum of the values in A1, A2, A3, A4 and in A5, Place your cell pointer in A5 and directly type the formulae as follows.

\[ = \text{SUM (A1:A4)} \]

While inserting a function the following points should be kept in mind.

1. A function should begin with an equal sign.
2. Use proper name for the function to be used.
3. Arguments should be given within the brackets as per the syntax. Each function has a unique argument list.
4. Press “Enter” key after typing the function.

= SUM (A1 : A4)

![Figure 7.40 Function Syntax](image)
Self Practice:

1. Open the spreadsheet which was created in Illustration 1.
2. Delete all the formula in Total column.
3. Use SUM function to add all the marks of each student.
4. Save the changes and close the file

7.12.1.2 Using Function Wizard method

A function can be inserted using Function Wizard in Calc. Function Wizard is a dialog box that provides a step-by-step procedure to insert a function. Function wizard can be invoked by clicking the Function Wizard icon on the Formula bar (or) **Insert → Function** (or) **Ctrl + F2**. Refer Figure 7.41

Function category drop down list box:

Function Wizard has two tabs viz. Functions and Shortcuts. In Functions Tab, the list of categories is available in Category drop down list box. In Calc, the functions are categorized into 11 types. They are,

1. Database
2. Date and Time
3. Financial
4. Information
5. Logical
6. Mathematical
7. Array
8. Statistical
9. Spreadsheet
10. Text
11. Add-in

![Figure 7.41 Function wizard](image)
If you select any particular category, the Functions list box shows the functions which belongs to the selected category. If “All” is selected under category all functions in calc is displayed in alphabetical order. Refer Figure 7.42

![Figure 7.42 Function wizard – Function Category list box](image)

**Selected Category**

**List of Functions**

**About POWER ( ) function:**

POWER ( ) is a function which is used to calculate power of an exponent value of a number. This function is categorized as a Mathematical function. There are two inputs needed to find the power value of a number. They are, Base value and exponent value. For example, to find the value of 25 to the power of 2 ($25^2$) where 25 is the base value, 2 is the exponent value.

The syntax of POWER( ) is $= \text{POWER}(\text{Base} ; \text{Exponent})$

Both Base and Exponent are arguments. In Calc, arguments are separated by a semicolon.

**Inserting POWER( ) in a worksheet:**

**Step 1:** In cell A2 type the base value 25

**Step 2:** In cell B2 type the exponent value 2

**Step 3:** Move the cell pointer to C2; in which you want display result.

**Step 4:** Click $fx$ icon from Formula bar (or) choose Insert $\rightarrow$ Functions (or) Press Ctrl + F2.

**Step 5:** Pull down category list box, Choose “Mathematical”

All function under Mathematical category is displayed in the “Functions” list box.

---

The following steps explains to insert POWER( ) function in a cell.

**Function Description**

When you select a function, the function wizard shows the function name, syntax and a small description about the function on the right side of the dialog box. Refer Figure 7.43

**Inserting a function using Function Wizard: (with Cell Reference)**

The following steps explains to insert POWER( ) function in a cell.
Step 6: Scroll the “Functions” list box and select “POWER( )”. The function wizard shows the description about the selected function on the right corner of the dialog box.

Step 7: Click “Next” command button. Now, Function wizard appears as shown in the Figure 7.44.

Step 8: Click on the cell which contains the base value (A2).

Now, the minimized wizard shows the cell address you have selected (A2). Refer Figure 7.45.
Step 9: Click “Maximize” button to display full wizard. Now, Function wizard appears as shown in Figure 7.46

Figure 7.46 Function wizard

Base box shows the cell address which contain base value.

Step 10: Directly type the cell address which contains exponent, in Exponent box; or repeat steps 7, 8 and 9.
After entering Base and Exponent cell references, the function wizard appears as shown in Figure 7.47.

Figure 7.47 Function wizard

The formula box displays the syntax of the function with input values and Result box displays the result value.

Step 11: If the result is correct, click “OK” button else click “Back” button to display the previous page of this wizard.

Inserting a function using Function Wizard: (with direct values)

In the previous example, Cell addresses are used for Base and Exponent values. In Calc, direct values can be used instead of using cell reference (i.e. cell address) to find the same result.

In this case, type base and exponent value instead of cell address. Function wizard displays the result in the current cell. Refer Figure 7.48 shown below.
Self Practice:

1. Open a new worksheet.
2. In cell A1 type as “Value”
3. In cell A2 type as “Square root”
4. In cell B1 type any value
5. In cell B2 insert the function to find the square root of the value in B1
6. After getting square root, change the value in B1, observe changes in result.
7. Use the same function in another sheet directly i.e. without using function wizard.

7.13 Working with Chart

One of the most important features of spreadsheet is the ability to create charts based on numeric data. The charts are used to present data in an easy manner. Creating charts is the key factor for the of success of spreadsheet. OpenOffice Calc provides a “chart wizard” to create and manipulate charts.
7.13.1 Chart Wizard

Chart wizard is used to insert charts in Calc. Chart wizard can be invoked by clicking “chart” icon from standard toolbar or choosing Insert → Chart command. A "Chart wizard" appear as shown in Figure 7.49

Chart wizard dialog box has 4 steps viz. (1) Chart type (2) Data Range (3) Data Series and (4) Chart Elements. The “Next” button is used to move from one step to another step.

**Step 1: Chart type**

The first step of “Chart wizard” is used to select Chart type. All available chart types are listed under the “Choose a chart type” list box. On the right side of the list box shows style of the selected chart; each chart type has different styles.

For example, Column chart has three styles viz. Normal, Stacked and Percent Stacked. Refer Figure 7.49

"3D Look" check box helps to display the selected chart type in an attractive form. 3D Look is applied only for Column, Bar, Pie and Area chart type. Refer Figure 7.50

Click, “Next” button to move to the second step.
Step 2: Data Range

In this step, specify the range of data for which the chart should be created in “Data range” text box or click “Select data range” button which is at the end of the textbox to minimize the wizard.

If the user had selected the data before invoking "chart wizard", the selected range will appear automatically in the textbox as shown in Figure 7.51.

There are two checkboxes used to set the first row or first column or both, as X and Y axis labels to the chart.

Click "Next" button to move to the third step.
Step 3: Data Series

In this step, the user can fine tune the data to be included in the chart. If you don’t want to include any column, click the column names listed in “Data Series” box and click on “Remove” button or if you want to add some more columns click “Add” button. Refer Figure 7.52. This is useful only if you have very specific requirements for data in your chart. Otherwise simply click “Next” button to move the last step.

Step 4: Chart Element

This step is used to insert or change titles and legend. In “Title” box, type the title for the chart, to add a subtitle type it in the “Subtitle” box. Refer Figure 7.53. For example, A chart for showing the highest mark holder in you class, you may enter as “Highest Mark holder” as title and “Class XII F” as subtitle.
User can add or modify the labels of X and Y axis.

To create a chart click “Finish” button.

7.13.2 Demo for creating a chart

Type the following data in a new worksheet as in Figure 7.54. The following steps is followed to create a chart for the given data.

Step 1 – Select Data:
- Select the data from A1 to F11.

Step 2 – To open the chart wizard:
- Click “Chart” icon from Standard toolbar (or) choose Insert → Chart.

Step 3 – Selecting Chart type and shape: (Refer Figure 7.55)

![Figure 7.54 Rainfall (in mm) data of ten districts in 2010](image1)

![Figure 7.55 Chart Wizard – Step 1 Chart Type](image2)
• Select “Chart type” as Column and style as Normal
• Check “3D Look” and click “Cylinder shape”
• Click “Next” button.

• If the user wants change any other type or shape, click on the style image. Preview of the chart displayed on the backgroup of the chart wizard. So, you can view the chart at every stage of design.

**Step 4 – Defining Data range:** (Refer Figure 7.56)

• In this case, the data has been selected earlier. So, the selected data range is displayed in the “Data range” box.

• Other settings are by default. Click “Next” to move to step 5.

![Figure 7.56 Chart Wizard – Step 2 Data Range](image)

**Step 5 – Adding or Removing Data series:** (Refer Figure 7.57)

• “Data Series” list box shows all the columns to be included in the chart.

• Click on the “Total” in the data series box and click “Remove” button to remove the column.

• If you don’t want to add or remove anyother column click “Next” button to move to the last step.
Step 6 – Adding Title, Subtitle, Name of X and Y axis: (Refer Figure 7.58)

- Type the title and subtitle of the chart in “Title” and “Subtitle” box
- Type the name of the X and Y-axis in the respective boxes.
- The Display legend text box is selected to the right which is the default.
- Click “Finish” button.

Now the chart will be displayed as in Figure 7.59.

7.13.3 Editing Chart elements:

After inserting a chart any element of the chart can be modified. To modify the element

(i) Double click on the element

(ii) Right click on the selected element

(iii) Select Format from the popup menu.

For example, To change the display pattern of the X-axis, double-click on the X-axis and then right-click on it. A pop-up menu appears as shown in the Figure 7.60.

- In this popup menu, click “Format Axis…” option.
Now the chart will be displayed as given below

**Rain Fall Details**

**During 2010**

*Figure 7.59 Chart*
Rain Fall Details
During 2010

Figure 7.60 Chart element formatting pop-up menu

- Now, a Format Axis dialog box appears as shown in Figure 7.61

Figure 7.61 Chart Element Properties dialog box
Select “Label” tab.

- In Text Orientation spinbox, type as 90 degree or click and drag the Text direction animated handle.
- Click “OK” button.
- Now, the chart will be as in Figure 7.62

Self Practice:
1. Open the spreadsheet which was created in Illustration 1.
2. Create a column chart with 3D “cone” shape showing the total marks of all students.
7.14 Advanced data analysis tools

A spreadsheet is a “Flat file database”. Thus, database operations such as sorting, filtering can be done on spreadsheet. The “Data” menu of OpenOffice calc provides maximum data analysis tools such as sorting, filtering, validity etc., In this part, the sorting and filtering feature is to be learnt.

7.14.1 Database

A database is a repository of collections of related data or facts. It arranges them in a specific structure. The table given below contains details of students in a class.

<table>
<thead>
<tr>
<th>Sl. No.</th>
<th>Class</th>
<th>Group Code</th>
<th>Student Name</th>
<th>Gender</th>
<th>Comm Date of Birth</th>
<th>Date of Birth</th>
<th>Religion</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>XII - F1</td>
<td>302</td>
<td>GANDHIMATHI N</td>
<td>F</td>
<td>SC</td>
<td>02/10/2000</td>
<td>H</td>
</tr>
<tr>
<td>2</td>
<td>XII - H2</td>
<td>402</td>
<td>SANDHIYA D</td>
<td>F</td>
<td>SC</td>
<td>19/08/2000</td>
<td>H</td>
</tr>
<tr>
<td>3</td>
<td>XII - H2</td>
<td>402</td>
<td>SUMATHI P</td>
<td>F</td>
<td>BC</td>
<td>06/09/1999</td>
<td>H</td>
</tr>
<tr>
<td>4</td>
<td>XII - F1</td>
<td>302</td>
<td>JAYASREE J</td>
<td>F</td>
<td>BC</td>
<td>09/06/2001</td>
<td>H</td>
</tr>
<tr>
<td>5</td>
<td>XII - H1</td>
<td>402</td>
<td>JOTHIKA A</td>
<td>F</td>
<td>SC</td>
<td>07/04/2001</td>
<td>H</td>
</tr>
<tr>
<td>6</td>
<td>XII - H2</td>
<td>402</td>
<td>RAMYA T</td>
<td>F</td>
<td>MBC</td>
<td>23/11/2000</td>
<td>H</td>
</tr>
<tr>
<td>7</td>
<td>XII - F1</td>
<td>302</td>
<td>KOWSALYA T</td>
<td>F</td>
<td>SC</td>
<td>14/12/2000</td>
<td>H</td>
</tr>
<tr>
<td>8</td>
<td>XII - F1</td>
<td>302</td>
<td>ASHA A P</td>
<td>F</td>
<td>SCA</td>
<td>14/09/2000</td>
<td>H</td>
</tr>
<tr>
<td>9</td>
<td>XII - A</td>
<td>102</td>
<td>VENNILA T P</td>
<td>F</td>
<td>BC</td>
<td>14/02/2000</td>
<td>H</td>
</tr>
<tr>
<td>10</td>
<td>XII - F2</td>
<td>302</td>
<td>SANGEETHA G</td>
<td>F</td>
<td>MBC</td>
<td>14/01/2000</td>
<td>H</td>
</tr>
</tbody>
</table>

Table 7.14.1 Student Database

The entire collection or related data in one table is referred to as a File or a Table. Each row in a table represents a Record, which is a set of data for each database entry. Each table column represents a Field, which groups each piece or item of data among the records into specific categories. (Refer Figure 7.63)

7.14.2 Sorting:

Sorting is the process of arranging data in ascending or descending order. There are two types of sorting in OpenOffice Calc. They are,
(1) **Simple Sorting**

Arranging data using single column is known as simple sorting. For sorting the data, calc provide two icons on the standard tool bar viz. (1) Sort Ascending (2) Sort Descending.

- Sort Ascending – Arrange data in alphabetical order (A to Z / Small to Large)
- Sort Descending – Arrange data in reverse order (Z to A / Large to Small)

**Figure 7.63 Spreadsheet Data Table**

**Sorting data**

**Step 1:** Place cell pointer in the field (column) to be sorted

**Step 2:** Click Sort Ascending or Sort Descending icon
OpenOffice Calc, sort the data of selected column and its corresponding values present in other columns are also arranged simultaneously. Refer Figure 7.65

![Sort Ascending](image)

Figure 7.64 Standard Tool Bar with Sort Ascending / Descending

Click "Sort Ascending" icon to arrange ascending order

![Spreadsheet](image)

Place the Cell pointer anywhere in name column

Figure 7.65 Sort Ascending

(2) Multi Sorting

Sorting data based on more than one field (column) is known as multi sorting. For example, the worksheet containing data of 20 students belongs to different groups and classes. To rearrange this data alphabetically by name and group code, multi sorting is used. Refer Figure 7.66.
Multi-sorting data

Step 1: Select Data → Sort

Name are arranged in Ascending order According to names, other data also rearranged

Step 2: Sort dialog box appears. (Refer Figure 7.67)

Step 3: Select the field name (Student name) in which you want to sort from the “sort by” dropdown list box and then choose order of sorting i.e. Ascending or Descending. Ascending is the default selection.

Step 4: Select another field name (Group Code) from the “Then by” dropdown list box and choose the order of sorting to this column.

Step 5: Click “OK” button.

In OpenOffice Calc, multi sort can be done only for three fields.
(3) Sort by selection

In Calc sorting can be done on selected range. But this kind of sorting is generally not recommended, because the other relevant data are also not sorted. Therefore, OpenOffice Calc displays a warning message for this type of sorting. Refer Figure 7.68.

Sorting data by selection:

Step 1: Select any particular field in which you want sort.

Step 2: Click required Sort icon from standard tool bar or Data → Sort command.

Calc, display a “Sort Range” warning message as shown in the Figure 7.68

“Sort Range” message box has two options, viz. (1) Extend selection (2) Current selection.

Step 3: “Extend Selection” – Sort all the data based on the selection.

“Current Selection” – Sort only the selected range of data, remaining data are not sorted.
7.14.3 Filtering

Filter is a way of limiting the information that appears on screen. Filters are a feature for displaying and browsing a selected list or subset of data from a worksheet. The visible records satisfy the condition that the user sets. Those that do not satisfy the condition are only hidden, but not removed.

OpenOffice Calc allows three types of filters. They are AutoFilter, Standard Filter and Advanced Filter.

(1) Auto Filter:

Auto Filter applies a drop-down list box to each field (columns) filled with similar data available in that field. Using the list box item, you can filter the data that matches the criteria of the data concerned.

Using Auto Filter:

- Click Auto Filter icon available on the “Standard tools bar” (or) Click Data → Filter
→ Auto Filter

• The list box contains similar data in the fields. Refer Figure 7.69 and 7.70

• Each list box item will be considered as filter criteria.

![Spreadsheet table with Auto Filter](image1)

![Auto Filter dropdown list box](image2)

- Select the data item from the list box. Now, Calc shows only the records which satisfy the selected criteria.

**Example:**

If you want to apply an auto filter to the contents of the table 7.14.1, follow the following two steps

Step 1: Place cell pointer anywhere in the table

Step 2: Click Auto Filter icon available on the “Standard tools bar” (or) Click Data → Filter → Auto Filter

In the above table, if you want to view only the students belongs to the Group code 402;
• Click the dropdown list box’s drop arrow (a tiny triangle) to get the filter criteria. (Refer Figure 7.70)

• Select group code 402 from the list

• The spreadsheet displays only the student’s details those who are studying in group code 402 (Refer Figure 7.71) and the remaining details are only hidden.

![Figure 7.71 Filtered details](image)

![Figure 7.72 Standard Filter dialog box](image)

**Removing Auto Filter:**

• To remove auto filter, click “Auto filter” icon once again.

• The original table is displayed without filter.

(2) **Standard Filter:** Auto filter is used only for single criteria on a data, whereas the Standard filter is used for multiple criteria to filter.
Step 1:
- Select Data → Filter → Standard Filter.
- Now, the entire data is selected and "Standard Filter" dialog box dispalys as shown in Figure 7.73.

Step 2:
- Select the column heading from the “Filed name” list box for first criteria.
- Select conditional opeator such as >, <, = etc., from “Condition” list box.
- Type or select the value of critera in the “Value” box.

Step 3:
- Select the one of the logical operator (And / Or) from “Operator” list box to fix second criteria.
- Follow the step 2, for the next criteria.

Step 4:
- Click “OK” to finish.

Example for Standard filter:
If you want to filter the records of “BC” students of group code 402 from the table 7.14.1

Step 1: Select Data →Filter → Standard Filter
- Now, “Standard Filter” dialog box appears as in Figure 7.73

Step 2: In “Standard Filter” dialog box, select the first criteria;
- Select Field name as Group code
- Select Condition as =
- Type or select Value as 402

Step 3: To select the second criteria;
- Select Operator as “AND”
- Select Field name as Class
- Select Condition as =
- Type or select Value as XII- H2

Figure 7.73 Standard Filter
Step 4: Click “OK”
- Now, the table displays only the records which are match for the given two criteria. Refer Figure 7.74.

Remove Standard Filter:
- Select Data → Filter → Remove Filter

Figure 7.74 Class XII student of group 402

Figure 11.75 Page Style dialogue box

- “Header” tab is used to create header
- “Footer” tab is used to create footer
### Workshop 1

1. Create a worksheet with following data

<table>
<thead>
<tr>
<th>Emp. No</th>
<th>Name of Emp.</th>
<th>Basic</th>
<th>DA</th>
<th>HRA</th>
<th>CCA</th>
<th>MA</th>
<th>GPF</th>
<th>IT</th>
<th>HF</th>
</tr>
</thead>
<tbody>
<tr>
<td>1001</td>
<td>Manivannan M</td>
<td>25500</td>
<td></td>
<td>600</td>
<td>300</td>
<td></td>
<td></td>
<td></td>
<td>250</td>
</tr>
<tr>
<td>1002</td>
<td>Kannan K</td>
<td>20200</td>
<td></td>
<td>600</td>
<td>300</td>
<td></td>
<td></td>
<td></td>
<td>250</td>
</tr>
<tr>
<td>1003</td>
<td>Gowrishankar N V</td>
<td>24300</td>
<td></td>
<td>600</td>
<td>300</td>
<td></td>
<td></td>
<td></td>
<td>250</td>
</tr>
<tr>
<td>1004</td>
<td>Lenin K</td>
<td>23400</td>
<td></td>
<td>600</td>
<td>300</td>
<td></td>
<td></td>
<td></td>
<td>250</td>
</tr>
<tr>
<td>1005</td>
<td>Suryanarayanan T</td>
<td>24100</td>
<td></td>
<td>600</td>
<td>300</td>
<td></td>
<td></td>
<td></td>
<td>250</td>
</tr>
<tr>
<td>1006</td>
<td>Ramesh K</td>
<td>18500</td>
<td></td>
<td>600</td>
<td>300</td>
<td></td>
<td></td>
<td></td>
<td>250</td>
</tr>
<tr>
<td>1007</td>
<td>Govindasami A</td>
<td>13200</td>
<td></td>
<td>600</td>
<td>300</td>
<td></td>
<td></td>
<td></td>
<td>250</td>
</tr>
<tr>
<td>1008</td>
<td>Kannan S</td>
<td>20250</td>
<td></td>
<td>600</td>
<td>300</td>
<td></td>
<td></td>
<td></td>
<td>250</td>
</tr>
<tr>
<td>1009</td>
<td>Penchil Rao K</td>
<td>28300</td>
<td></td>
<td>600</td>
<td>300</td>
<td></td>
<td></td>
<td></td>
<td>250</td>
</tr>
<tr>
<td>1010</td>
<td>Logeswaran M</td>
<td>30200</td>
<td></td>
<td>600</td>
<td>300</td>
<td></td>
<td></td>
<td></td>
<td>250</td>
</tr>
<tr>
<td>1011</td>
<td>Arumugam E</td>
<td>12000</td>
<td></td>
<td>600</td>
<td>300</td>
<td></td>
<td></td>
<td></td>
<td>250</td>
</tr>
<tr>
<td>1012</td>
<td>Vasu G N</td>
<td>25000</td>
<td></td>
<td>600</td>
<td>300</td>
<td></td>
<td></td>
<td></td>
<td>250</td>
</tr>
</tbody>
</table>

Based on the above data,

1. Calculate the Gross Salary, Total Deductions and Net Salary
2. Insert “IT Cess” column and calculate 3% of cess to all employees
(3) Delete the records of “Govindasami” and “Arumugam”.

(4) Insert four new rows and enter the following employee details.

(5) Calculate the Total amount of GPF, IT and Cess

<table>
<thead>
<tr>
<th>Emp. No</th>
<th>Name of Emp.</th>
<th>Basic</th>
<th>DA</th>
<th>HRA</th>
<th>CCA</th>
<th>MA</th>
<th>GPF</th>
<th>IT</th>
<th>HF</th>
</tr>
</thead>
<tbody>
<tr>
<td>2001</td>
<td>Murali G</td>
<td>24750</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2002</td>
<td>Munirathnam A</td>
<td>23550</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2003</td>
<td>Ramakrishnan V G</td>
<td>25500</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2004</td>
<td>Srinivasan R</td>
<td>27500</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Workshop: 2**

1. Create a new worksheet in OpenOffice Calc.

2. Enter the following stock and sales details of “Chennai whole sale Marketing Pvt. Ltd.” during the month of Jan-2018.

<table>
<thead>
<tr>
<th>Code</th>
<th>Product Name</th>
<th>Weight (gm)</th>
<th>Opening stock</th>
<th>Cost price</th>
<th>Sales in units</th>
<th>Rate of Discount</th>
<th>Amount of Discount</th>
<th>Selling price</th>
<th>Amount of Sale</th>
<th>Closing Stock</th>
</tr>
</thead>
<tbody>
<tr>
<td>100</td>
<td>Marie Gold</td>
<td>120</td>
<td>345</td>
<td>15</td>
<td>147</td>
<td>5%</td>
<td>5%</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>101</td>
<td>Milk Bikis</td>
<td>85</td>
<td>106</td>
<td>10</td>
<td>63</td>
<td>5%</td>
<td>5%</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>102</td>
<td>Dark Fantasy</td>
<td>75</td>
<td>147</td>
<td>25</td>
<td>43</td>
<td>3%</td>
<td>3%</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>103</td>
<td>Nutri Choice</td>
<td>250</td>
<td>98</td>
<td>50</td>
<td>12</td>
<td>10%</td>
<td>10%</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>104</td>
<td>Lays potato chips</td>
<td>52</td>
<td>172</td>
<td>15</td>
<td>152</td>
<td>4%</td>
<td>4%</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>105</td>
<td>Oreo</td>
<td>120</td>
<td>112</td>
<td>25</td>
<td>85</td>
<td>6%</td>
<td>6%</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

3. Calculate the following using formula or function

(i) Amount of Discount, Selling price and Amount of sales for each product

(ii) Total amount of discount and Sales of the month

(iii) Closing stock of each product

4. Draw a Pie chart to show the highest selling product.
1. Create a worksheet in OpenOffice Calc.

2. Enter the following details of loan sanctioned during the month of January 2018 of “Tamil Finance Corporation”.

<table>
<thead>
<tr>
<th>AC No</th>
<th>Name</th>
<th>Amount of Loan</th>
<th>Loan Sanction date</th>
<th>Duration of Loan</th>
<th>Rate of Interest</th>
<th>Interest (Rs)</th>
<th>Total Amount</th>
<th>Due date</th>
</tr>
</thead>
<tbody>
<tr>
<td>2001</td>
<td>Senthil</td>
<td>250000</td>
<td>02/01/2018</td>
<td>120 days</td>
<td>9.5%</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2002</td>
<td>Kumar</td>
<td>175000</td>
<td>15/01/2018</td>
<td>150 days</td>
<td>9.5%</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2003</td>
<td>Ibrahim</td>
<td>550000</td>
<td>16/01/2018</td>
<td>140 days</td>
<td>10.5%</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2004</td>
<td>Valli</td>
<td>375000</td>
<td>21/01/2018</td>
<td>210 days</td>
<td>10%</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2005</td>
<td>Charles</td>
<td>450000</td>
<td>28/01/2018</td>
<td>130 days</td>
<td>10.5%</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

3. Create the formula to calculate

(i) Interest, Total amount and due date.

(ii) Grass total of amount of loan, interest and total amount.

4. Insert 5 new rows between Kumar and Ibrahim and include the following details

<table>
<thead>
<tr>
<th>AC No</th>
<th>Name</th>
<th>Amount of Loan</th>
<th>Loan Sanction date</th>
<th>Duration of Loan</th>
<th>Rate of Interest</th>
<th>Interest (Rs)</th>
<th>Total Amount</th>
<th>Due date</th>
</tr>
</thead>
<tbody>
<tr>
<td>3001</td>
<td>Pari</td>
<td>250000</td>
<td>03/02/2018</td>
<td>125 days</td>
<td>9.5%</td>
<td>5%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3002</td>
<td>Arul</td>
<td>375000</td>
<td>07/02/2018</td>
<td>155 days</td>
<td>9.5%</td>
<td>5%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3003</td>
<td>Raman</td>
<td>350000</td>
<td>10/02/2018</td>
<td>130 days</td>
<td>10.5%</td>
<td>3%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3004</td>
<td>Givind</td>
<td>450000</td>
<td>10/02/2018</td>
<td>100 days</td>
<td>10%</td>
<td>10%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3005</td>
<td>Zeenath</td>
<td>800000</td>
<td>26/02/2018</td>
<td>90 days</td>
<td>10%</td>
<td>4%</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Points to Remember:

- Spreadsheet is a very useful office automation tool for organization, analysis and storage of data in a tabular form.
- Daniel Bricklin and Bob Frankston developed the first spreadsheet software called “VisiCalc” in 1979 for Apple II.
- OpenOffice Calc is popular open source spreadsheet application software presently maintained by Apache Foundation.
- A worksheet is a grid of cells with a programmable calculator attached to each cell.
- OpenOffice Calc version 4.1.5 contains a total of 1024 columns and 10,48,576 rows.
- Intersection of every row and column makes a box which is called as “Cell”.
- Cell pointer is a rectangle element which can be moved around the worksheet.
- The cell in which the cell pointer is currently located is known as “Active cell”.
- All formula should start with an equal sign.
- There are four types operators supported by calc.
- The charts are used to present numerical data in an easy manner.

Activity

Student Activity

1. Based on the concept of calculation using formula / functions, make the students to create various worksheet data.

2. Make the students prepare Charts and manipulate data using sorting and filtering features.

Teacher Activity

1. To show the demo of working with spread sheets using simple example in class room.
Part - A

1. Which is the first electronic spreadsheet?
   (A) Excel   (B) Lotus 1-2-3
   (C) Visicalc  (D) OpenOffice Calc

2. Which of the following applications was the parent to OpenOffice Calc?
   (A) Visicalc  (B) LibreCalc
   (C) Lotus 123   (D) StarOffice Calc

3. Grid of cells with a programmable calculator:
   (A) Spreadsheet    (B) Database
   (C) Word processor    (D) Linux

4. A column heading in Calc is represented using
   (A) Number    (B) Symbol
   (C) Date   (D) Alphabet

5. Which key is used to move the cell pointer in the forward direction within the worksheet?
   (A) Enter   (B) Tab
   (C) Shift + Tab (D) Delete

6. A formula in calc may begin with
   (A) =   (B) +
   (C) -   (D) All the above

7. What will be the result from the following formula (Assume A1=5, B2=2)? + A1^B2
   (A) 7   (B) 25
   (C) 10   (D) 52
8. What will be the result from the following expression (Assume H1=12, H2=12)? = H1<>H2
   (A) True (B) False
   (C) 24 (D) 1212

9. Which of the following symbol is used to make a cell address as an absolute reference?
   (A) + (B) %
   (C) & (D) $

10. Which of the following key combinations is used to increase the width of the current column?
    (A) Alt + Right arrow (B) Ctrl + Right arrow
    (B) Alt + Left arrow (D) Ctrl + Left arrow

Part – B

1. What are the types of toolbars available in OpenOffice calc?

2. What is a Cell pointer?

3. Write about the text operator in OpenOffice Calc.

4. Write the general syntax of constructing a formula in Calc.

5. What are the keyboard shortcuts to cut, copy and paste?

6. Can you edit the contents of a cell? If yes, explain any one of the method of editing the cell content.

7. What are the options available in “Insert Cells” dialog box?

8. Match the following

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
</tr>
</thead>
<tbody>
<tr>
<td>(a) Cut, Copy and Paste</td>
<td>(1) Absolute Cell</td>
</tr>
<tr>
<td>(b) Cell pointer</td>
<td>(2) Status bar</td>
</tr>
<tr>
<td>(c) Selection Mode</td>
<td>(3) Standard Toolbar</td>
</tr>
<tr>
<td>(d) $A5$</td>
<td>(4) Active cell</td>
</tr>
</tbody>
</table>
9. Define the following (i) Text Operator (ii) Rows and Columns of spreadsheet

10. Differentiate between Copy -Paste and Cut-Paste

Part – C

1. Write a short note on OpenOffice Calc.

2. Write about inserting columns and rows in Calc.

3. Differentiate Deleting data using Backspace and Delete

4. Write any three formatting options.

5. In cell A1=34 A2=65 A3=89 write the formula to find the average.

Part – D

1. Explain about changing the column width in Calc.

2. Write the steps to generate the following series. 5, 10, 20 ..... 2560

3. Read the following table

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Year</td>
<td>Chennai</td>
<td>Madurai</td>
<td>Tiruchi</td>
<td>Coimbatore</td>
</tr>
<tr>
<td>2</td>
<td>2012</td>
<td>1500</td>
<td>1250</td>
<td>1000</td>
<td>500</td>
</tr>
<tr>
<td>3</td>
<td>2013</td>
<td>1600</td>
<td>1000</td>
<td>950</td>
<td>350</td>
</tr>
<tr>
<td>4</td>
<td>2014</td>
<td>1900</td>
<td>1320</td>
<td>750</td>
<td>300</td>
</tr>
<tr>
<td>5</td>
<td>2015</td>
<td>1850</td>
<td>1415</td>
<td>820</td>
<td>200</td>
</tr>
<tr>
<td>6</td>
<td>2016</td>
<td>1950</td>
<td>1240</td>
<td>920</td>
<td>250</td>
</tr>
</tbody>
</table>

Above table shows the sales figures for “Air Cooler” sold in four major cities of Tamilnadu from the year 2012 to 2016. Based on this data, write the formula to calculate the following.

(1) Total sales in the year 2015.
(2) Total sales in Coimbatore from 2012 to 2016.
(3) Total sales in Madurai and Tiruchi during 2015 and 2016.
(4) Average sales in Chennai from 2012 to 2016
(5) In 2016, how many “Air Coolers” are sold in Chennai compared to Coimbatore?
<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Spreadsheet</td>
<td>Sheet of paper that shows accounting or other data in rows and columns</td>
</tr>
<tr>
<td>What-if analysis</td>
<td>It is a process of changing the values in a cell to see how those changes will affect output.</td>
</tr>
<tr>
<td>VisiCalc</td>
<td>The first electronic spreadsheet application</td>
</tr>
<tr>
<td>GUI</td>
<td>Graphical User Interface</td>
</tr>
<tr>
<td>Excel</td>
<td>Familiar spreadsheet application developed by Microsoft Corporation.</td>
</tr>
<tr>
<td>Cell</td>
<td>Intersection of rows and column</td>
</tr>
<tr>
<td>Cell Pointer</td>
<td>A rectangular box, highlighting the cell in a spreadsheet.</td>
</tr>
<tr>
<td>Active cell</td>
<td>A cell in which the cell pointer is presently locating</td>
</tr>
<tr>
<td>Formula</td>
<td>A formula is an expression telling the computer what mathematical operation to perform upon a specific value.</td>
</tr>
<tr>
<td>Operator</td>
<td>A symbol that usually represents an action or process</td>
</tr>
<tr>
<td>Range</td>
<td>Group / Collection of cells</td>
</tr>
<tr>
<td>BODMAS Rule</td>
<td>Order of mathematical calculation: Brackets - Orders (powers or square roots) - Division – Multiplication – Addition - Subtraction.</td>
</tr>
<tr>
<td>Drag fill handle</td>
<td>A small black box at the bottom right corner of the cell pointer.</td>
</tr>
<tr>
<td>Function</td>
<td>Predefined formula / A group of instructions to return a single result or a set of results.</td>
</tr>
<tr>
<td>Chart</td>
<td>Graphical representation of data.</td>
</tr>
<tr>
<td>Database</td>
<td>A large quantity of indexed digital information.</td>
</tr>
<tr>
<td>Flat file database</td>
<td>Single table, non relative database</td>
</tr>
<tr>
<td>Sl. No</td>
<td>Function</td>
</tr>
<tr>
<td>-------</td>
<td>----------</td>
</tr>
<tr>
<td>1</td>
<td>Averageif</td>
</tr>
<tr>
<td>2</td>
<td>Celling</td>
</tr>
<tr>
<td>3</td>
<td>Countif</td>
</tr>
<tr>
<td>4</td>
<td>Fact</td>
</tr>
<tr>
<td>5</td>
<td>Floor</td>
</tr>
<tr>
<td>6</td>
<td>Product</td>
</tr>
<tr>
<td>7</td>
<td>Quotient</td>
</tr>
<tr>
<td>8</td>
<td>Round</td>
</tr>
<tr>
<td>9</td>
<td>SQRT</td>
</tr>
<tr>
<td>10</td>
<td>Sum</td>
</tr>
<tr>
<td>11</td>
<td>Sumif</td>
</tr>
<tr>
<td>12</td>
<td>Sumsq</td>
</tr>
<tr>
<td>13</td>
<td>DB</td>
</tr>
<tr>
<td>14</td>
<td>N</td>
</tr>
<tr>
<td>15</td>
<td>Date</td>
</tr>
<tr>
<td></td>
<td>Function</td>
</tr>
<tr>
<td>---</td>
<td>----------</td>
</tr>
<tr>
<td>16</td>
<td>Days</td>
</tr>
<tr>
<td>17</td>
<td>Days360</td>
</tr>
<tr>
<td>18</td>
<td>Average</td>
</tr>
<tr>
<td>19</td>
<td>Count</td>
</tr>
<tr>
<td>20</td>
<td>Concatenate</td>
</tr>
<tr>
<td>21</td>
<td>Len</td>
</tr>
<tr>
<td>22</td>
<td>Lower</td>
</tr>
<tr>
<td>23</td>
<td>Mid</td>
</tr>
<tr>
<td>24</td>
<td>Proper</td>
</tr>
<tr>
<td>25</td>
<td>Upper</td>
</tr>
</tbody>
</table>
Learning Objectives

After learning this chapter, the students will be able to

• Know the open source presentation software

• explore opening a new presentation using Impress

• create a new presentation using various ways using Impress

• Know parts of the main Impress Window

• differentiate five sections of Task pane

• explain Window elements of Impress

• differentiate various views in Workspace

• explore drawing Objects & inserting OLE

• draw freeform shapes

• rotate Objects

• create animation in slides/objects

8.1 Presentation Software - Meaning

• A presentation software is a computer software package used to show information, in the form of a slide show.

It includes three major functions:

• an editor that allows the text to be inserted and formatted,

• a method for inserting and manipulating graphic images and

• a slide-show system to display the content.

• Presentation software is used to create presentations, quizzes, e-learning packages and multimedia products.

• Most presentation software packages will create your multimedia product using a series of slides.

• Text, images, video, animations, links and sound can be combined on each slide to create a final product.

The most commonly known presentation programs are OpenOffice.org Impress, Microsoft PowerPoint and Apple’s Keynote. In this chapter, we are going to explore on OpenOffice.org’s presentation Software Impress.
8.2. Impress

Impress is OpenOffice.org’s presentations (slide show) module. You can create slides using Impress. It contains different elements like text, bulleted and numbered lists, tables, charts, clip art and a range of graphic objects. Impress has access to the spelling checker and thesaurus. Also, it comes with pre-packaged text styles, background styles with online help.

8.3. Opening a new presentation

You can start Impress in several ways:

- In order to open Impress using Start button, click Start button and select All Programs → Open Office → OpenOffice Impress. (Figure 8.1)

- If it is already pinned in the Start menu, just click and open it. (Figure 8.2)

8.4. Creating a new presentation

You can create a presentation by any one of the following methods.

1. By selecting an Empty presentation

2. By selecting From template
3. By selecting from Open existing presentation

8.4.1. Using Empty presentation

1. Select Empty presentation under Type. It creates a presentation from scratch.

2. Click Next. The Presentation Wizard step 2 appears. Figure 8.4 shows the Wizard.

3. Choose a design under Select a slide design. The slide design section gives you two main choices: Presentation Backgrounds and Presentations.

4. Each one has a list of choices for slide designs. If you want to use one of these other than the <Original>, click it to
select it. The preview of the same will be shown in the preview pane.

5. <Original> is an empty background. You can also select among three predefined Presentations: <Original>, Introducing a New Product, and Recommendation of a Strategy. (Figure 8.6).

6. Click an item to see a preview of the slide design in the Preview window.

7. Select how the presentation will be used under Select an output medium. Generally, presentations are created for computer screen display, so select Screen option. (Figure 8.6).

8. Click Next. The Presentation Wizard step 3 appears (Figure 8.7). In this step, you can choose the desired slide transition from the Effect drop-down menu. Select the desired speed for the transition between the different slides in the presentation from the Speed drop-down menu. Medium is a good choice. Click Create. A new presentation is created. (Figure 8.8)
Figure 8.6 Selecting a slide design using Presentations

Figure 8.7 Selecting a slide transition effect
8.4.2. Using Template

- If you choose the option **From template**, it uses a template design already created as the basis for a new presentation. The wizard changes to show a list of available templates. Choose the template that you want. (Figure 8.9).

- Introducing a New Product and Recommendation of a Strategy are pre-packaged presentation templates.

![Figure 8.8 New presentation](image)

**Figure 8.8 New presentation**

![Figure 8.9 Opening a new presentation using From template option](image)

**Figure 8.9 Opening a new presentation using From template option**
8.4.3. Using Open existing presentation

- If you choose the option Open existing presentation, it helps in continuing the work on a previously created presentation.
- You have to open a presentation already prepared by clicking Open button. The wizard changes to show a list of existing presentations, from which you can choose the one that you want. (Figure 8.10).

![Figure 8.10 Opening a new presentation using Open existing presentation option](image1)

![Figure 8.11 Opening a new presentation using New icon](image2)
Various ways of Starting Impress:

You can start Impress in various ways.

1. You can select the presentation from the system menu or the OpenOffice.org Quickstarter.

2. Or you can click the triangle to the right of the New icon on the main toolbar and select Presentation from the drop-down menu (Figure 8.11).

3. Or else, choose **File → New → Presentation.** (Figure 8.12).

8.5. Parts of the main Impress window

The main Impress window (Figure 8.13) has three parts: the Slides pane, the Workspace and the Task pane. Additionally, several toolbars can be displayed or hidden during the creation of a presentation.

Tip Notes

You can remove the Slides pane or Tasks pane from view by clicking the Close (X) option in the upper right corner. You can also show or hide these panes using View → Slide Pane or View → Task Pane/Side bar.
8.5.1. Slides pane

- The Slides pane contains thumbnail pictures of the slides in your presentation, in the order of their insertion of slides.

- Clicking a slide in this pane selects it and places it in the Workspace. While it is there, you can apply any changes that are desired to that particular slide.

Several additional operations can be performed on one or more slides in the Slides pane:

- Add new slides at any place within the presentation after the first slide.

- Mark a slide as hidden so that it will not be shown as part of the slide show.

- Delete a slide from the presentation if it is no longer needed.

- Rename a slide.

- Copy or move the contents of one slide to another (copy and paste, or cut and paste, respectively).

It is also possible to perform the following operations, other than using the Slides pane:

- Change the slide transition following the selected slide or after each slide in a group of slides.

- Change the sequence of slides in the presentation.

- Change the slide design. (A window opens allowing you to load your own design.)

- Change slide layout for a group of slides simultaneously. (This requires using the Layouts section of the Tasks pane.)
8.5.2. Tasks pane

The Tasks pane has five sections:

8.5.2.1. Master Pages

You define the page style for your presentation using Master Pages. Impress contains pre-packaged Master Pages (slide masters). One of them by default is blank, and the rest have a specific background. (Figure 8.14)

8.5.2.2. Layout

Pre-packaged layouts are shown. You can choose the one that you want, use it as it is or modify it to suit your own requirements. At present, it is not possible to create custom layouts. (Figure 8.15)

8.5.2.3. Table Design

Standard table styles are provided in this pane. You can further modify the appearance of a table with the selections to show or hide specific rows and columns, or to apply a banded appearance to the rows and columns. (Figure 8.16)
8.5.2.4. Custom Animation

A variety of animations for selected elements of a slide are listed here. Animation can be added to selected elements of a slide and it can also be changed or removed later. (Figure 8.17)

8.5.2.5. Slide Transition

Transitions are available, including **No Transition**. You can select the transition speed (slow, medium, fast). You can also choose between an automatic or manual transition, and how long you want the selected slide to be shown (automatic transition only). (Figure 8.18)
8.6. Window elements of Impress

Figure 8.19 shows the elements of the Impress Window Open source application.

The window elements of Impress include Title Bar, Menu Bar, Tool Bar, Ruler Bar and the Scroll Bar which are similar to the elements in Open Office writer.

8.6.1. View Buttons:

The Workspace has five tabs: Normal, Outline, Notes, Handout, and Slide Sorter, as seen in Figure 8.19. These five tabs are called View Buttons.

8.6.2. Status Bar:

Status Bar is present at the bottom of your window, which gives you some statistics about the file that you are viewing. It is a good practice to check the information shown there. In case you do not need the information in the Status Bar, you can hide it by selecting View → Status Bar from the main menu.

8.6.3. Navigator

The Navigator (Figure 8.20) displays all objects contained in a document. It provides another convenient way to move around a document and find items in it. The Navigator button is located on the Standard toolbar. You can also display the Navigator by choosing Edit → Navigator on the menu bar or pressing Ctrl+Shift+F5.

The Navigator is more useful if you give your objects (pictures, spreadsheets, and so on) meaningful names, instead of leaving them as the default “Object 1” and “Picture 1” as shown in Figure 8.20.
The Workspace has five tabs: Normal, Outline, Notes, Handout and Slide Sorter, as seen in Figure 8.19. These five tabs are called View Buttons. There are many toolbars that can be used during the slide creation; they are revealed by selecting them with View → Toolbars.

The actual Workspace section is below the View Buttons. This is where you assemble the various parts of your selected slide. Each view is designed to ease the completion of certain tasks.

Normal view is the main view for creating individual slides. Use this view to format and design slides and to add text, graphics and animation effects.

Outline view shows topic titles, bulleted lists and numbered lists for each slide in outline format. Use this view to rearrange the order of slides, edit titles and headings, rearrange the order of items in a list and add new slides.

Notes view lets you add notes to each slide that are not seen when the presentation is shown.

Slide Sorter view shows a thumbnail of each slide in order. Use this view to rearrange the order of slides, produce a timed slide show, or add transitions between selected slides.

Handout view lets you print your slides for a handout. You can choose one, two, three, four, or six slides per page from Tasks pane → Layouts. Thumbnails can be re-arranged in this view by dragging and dropping them.

8.7.1. Normal view

There are two ways to place a slide in the Slide Design area of the Normal view: clicking the slide thumbnail in the Slides pane or using the Navigator.

To open the Navigator, click the Navigator button in the Standard Toolbar or press Ctrl+Shift+F5 and select a slide.
by scrolling down the Navigator list until you find the one that you want and then double-click it. (Figure 8.21)

8.7.2. Outline view

Outline view contains all the slides of the presentation in their numbered sequence. Only the text in each slide is shown. Slide names are not included.

Outline view serves for two purposes.

1) Making changes in the text of a slide:
   • Add or delete text in a slide just as in the Normal view.
   • Move the paragraphs of text in the selected slide up or down by using the up and down arrow buttons (Move Up or Move Down) on the Text Formatting toolbar.

   Change the outline level for any of the paragraphs in a slide using the left and right arrow buttons (Promote or Demote).

   Both move a paragraph and change its outline level using a combination of these four arrow buttons.

2) Comparing the slides with your outline (if you have prepared one in advance). If you notice from your outline that another slide is needed, you can create it directly in the Outline view or you can return to the Normal view to create it, then return to review all the slides against your outline in the Outline view.

![Figure 8.21 Presentation in Normal view](image)
If a slide is not in the correct sequence, you can move it to its proper place:

a) Click the slide icon of the slide that you wish to move, as indicated in Figure 8.22.

b) Drag and drop it where you want.

8.7.3. Notes view

Use the Notes view to add notes to a slide:

1) Click the Notes tab in the Workspace (Figure 8.23).

2) Select the slide to which you will add notes.
• Double-click the slide in the Slide pane, or
• Double-click the slide’s name in the Navigator.

3) In the text box below the slide, click on the words **Click to add notes** and begin typing.

You can resize the notes text box using the green resizing handles and move it by placing the pointer on the border, then click and drag. To make changes in the text style, press the **F11 key** to open the **Styles and Formatting window**.

8.7.4. Slide Sorter view

The Slide Sorter view contains all of the slide thumbnails (Figure 8.24).

Use this view to work with a group of slides or with only one slide.

Change the number of slides per row, if desired:

1) Check **View • Toolbars • Slide View** to show the Slide view toolbar (Figure 8.24).

2) Adjust the number of slides (up to a maximum of 15).

3) After you have adjusted the number of slides per row, **View • Toolbars • Slide View** will remove this toolbar from view.

To select a group of slides, use one of these methods:

• Use the **Control (Ctrl) key**: Click on the first slide and, while pressing Control, select the other desired slides.

**Figure 8.24 Presentation in Slide Sorter view**
• **Use the Shift key:** Click on the first slide, and while pressing the Shift key, select the final slide in the group. This selects all of the other slides in between the first and the last.

• **Use the cursor:** Click on the first slide to be selected. Hold down the left mouse button.

• Drag the cursor to the last slide thumbnail.

A dashed outline of a rectangle forms as you drag the cursor through the slide thumbnails and a thick black border is drawn around the selected slides. Make sure that this rectangle includes all the slides you want to select. (Figure 8.25)

**To move a group of slides:**

1) Select the group of slides.

2) Drag and drop the group to their new location. The same vertical black line appears to show you where the group of slides will go. You can work with slides in the Slide Sorter view as in the Slide pane.

To make changes, right-click a slide and do the following, using the pop-up menu:

- Add a new slide after the selected slide.
- Delete or rename the selected slide.
- Change the Slide Layout.
- Change the Slide Transition.
  - For one slide, click the slide to select it. Then add the desired transition.
  - For more than one slide, select the group of slides and add the desired transition.
- Mark a slide as hidden. Hidden slides will not be shown in the slide show.
- Copy or cut and paste a slide.

(Figure 8.25 To move a slide in a presentation using the Slide Sorter)
8.7.5. Handout view

Handout view is for setting up the layout of your slides for a printed handout. Click the Handout tab in the workspace, then choose Layout in the tasks pane (Figure 8.26). You can then choose to print one, two, three, four, or six slides per page.

To print a handout:

1) Select the slides using the Slide Sorter. (Use the steps listed in selecting a group of slides.)
2) Select File Print or press Ctrl+P to open the Print dialog box.
3) Select Options in the bottom left corner of the Print dialog box.
4) Check Handouts in the Contents section, and then click OK.
5) Click OK to close the Print dialog box.

8.8. Formatting a presentation

8.8.1. Inserting, deleting and rearranging slides

Tip Note: Remember to save frequently while working on the presentation, to prevent any loss of information. You might also want to activate the AutoRecovery function (Tools → Options → Load/Save → General). Make sure that Save AutoRecovery information every is selected and that you have entered a suitable recovery frequency.

8.8.2. Creating the first slide

The first slide is normally a title slide. Decide the layout as per its purpose of presentation. You can use the pre-packaged layouts available in the Layout section of the Tasks pane. Suitable layouts are Title Slide (which also contains a section for a subtitle) or Title Only, Title and Content, Title and two content and so on.

Figure 8.26 Presentation in Handout view
If you do not know the names for the pre-packaged layouts, you can use the tooltip feature. Position the cursor on an icon in the Layout section (or on any toolbar icon) and its name will be displayed in a small rectangle. If the tooltips are not enabled, you can enable them. From the main menu, select Tools • Options • OpenOffice.org • General • Help and mark the Tips checkbox. If the Extended tips checkbox is also marked, you will get more detailed tooltip information, but the tooltip names themselves will not be provided.

- Select a layout in the Layout section of the Tasks pane by clicking on it: it appears in the Workspace. To create the title, click on Click to add title (assuming the Blank Slide layout was not used) and then type the title text.
- Adjustments to the formatting of the title can be done by pressing the F11 key, right-clicking the Title presentation style entry, and selecting Modify from the pop-up menu.
- If you are using the Title Slide layout, click on “Click to add text” to add a subtitle. Proceed as above to make adjustments to the formatting if required. (Figure 8.27)

### 8.8.3. Inserting additional slides

The steps for inserting additional slides are basically the same as for selecting the title page. It is a process that has to be repeated for each slide.

Unless you are using more than one slide master, your only concern is the Layouts section of the Tasks pane (Figure 8.28).

First insert all the slides that are needed as per your outline. Only after this, you should begin adding special effects such as custom animation and slide transitions.

![Image](figure_8.27.png)  
**Figure 8.27 Creating the first slide**
Step 1: Insert a new slide. This can be done in a variety of ways.

- Insert → Slide.
- Right-click on the present slide, and select Slide → New Slide from the pop-up menu. (Figure 8.28).
- Click the empty space after the last slide also to create a new slide by right clicking New Slide. (Figure 8.29)
- Click the Slide icon in the Presentation toolbar.

Step 2: Select the layout slide that best fits your needs. (Figure 8.28).

Step 3: Modify the elements of the slide like removing unneeded elements, adding needed elements (such as pictures), and inserting text.

8.8.4. Deleting a Slide

You can delete a slide at any time using the following procedure.

- Select the slide you want to delete
• Click **Edit** • **Delete** slide (Refer Figure 8.30)

![Figure 8.30 Deleting a slide using Edit menu](image)

• Or else, right click the slide and choose Delete slide from the pop-up menu. (Figure 8.31)

**Tip Notes**

The same procedure can be followed by using the Slide sorter view also to delete a single slide or multiple slides.

8.8.5. Rearranging slides

If you want to rearrange the slides, you need to follow the procedure below.

• Select the slide that you want to rearrange.

![Figure 8.31 Deleting a slide using Right click](image)

• Drag that slide to the desired position by holding the mouse using left click.

• Release the mouse once you drag the slide to the desired place. (Figure 8.32)

**Tip Notes**

The same can be done using the Slide sorter view.

8.9. Running the slide show

To run the slide show, do one of the following:

• Click Slide Show → Slide Show on the main menu bar. (Figure 8.33).
• Click the Slide Show button on the Presentation toolbar or the Slide Sorter toolbar (Figure 8.34).
• Press F5 or F9.
• If the slide transition is Automatically after x seconds, let the slide show run by itself.
• If the slide transition is On mouse click, do one of the following to move from one slide to the next.
  • Use the arrow keys on the keyboard to go to the next slide or to go back to the previous one.
  • Click the mouse button to advance to the next slide.
  • Press the Spacebar on the keyboard to advance to the next slide.
• When you advance past the last slide, the message “Click to exit presentation...” appears. Click the mouse or press any key to exit the presentation.

• To exit the slide show at any time, including at the end, press the Esc key.

8.10. Saving a Presentation
In order to save a presentation
Click File → Save (Figure 8.35)

![Figure 8.35 Saving a presentation using File menu](image)

Figure 8.35 Saving a presentation using File menu

![Figure 8.36 Save dialog box.](image)

Figure 8.36 Save dialog box.

• After giving save option, Impress will open a dialog box asking the name in which this file should be saved (Figure 8.36)

• The default file extension for Impress is .odp.

Tip Notes
You can also use Save As option from the File menu. The difference between Save and Save As is Save option will save the presentation in the folder specified by you. Save As will save another copy of the same file either in the same folder or in a different folder specified by you.

• Type the name of the file you want to give in the text box space after File Name in the dialog box. (Figure 8.36).

• You can save the presentation as a PPT presentation also. (Figure 8.37)
You can also export the presentation directly as pdf. (Figure 8.38)

Figure 8.39 Shows exporting the presentation directly as PDF

8.11. Master slide

A slide master is a slide that is used as the starting point for other slides. It is similar to a page style in Writer: it controls the basic formatting of all slides based on it. A slide show can have more than one slide master.

A slide master has a defined set of characteristics, including the background color, graphic, or gradient; objects (such as logos, decorative lines and other graphics) in the background; headers and footers; placement and size of text frames; and the formatting of text.

All of the characteristics of slide masters are controlled by styles. The styles of any new slide you create are inherited from the slide master from which it was created. In other words, the styles of the slide master are available and applied to all slides created from that slide master. Changing a style in a slide master result in changes to all the slides based on that slide master; it is, however, possible to modify each individual slide without affecting the slide master.

Three terms are used for this concept. Master slide, slide master and master page all refer to a slide which is used to create other slides.

Figure 8.37 Saving a presentation under various File types
Figure 8.38 Export the presentation directly as PDF

Though it is highly recommended to use the slide masters whenever possible, there are occasions where manual changes are needed for a particular slide, for example to enlarge the chart area when the text and chart layout is used.

The pre-packaged presentation styles can be modified, but new presentation styles cannot be created.

Figure 8.39 Shows the Slide Master.

- **Click View → Master → Slide Master**

It is possible to view the Master slides in two styles:

1. Slide Master
2. Notes Master
• A New Master slide can be created either by using the Master View dialog box or by right clicking slides in the Slides pane. (Figure 8.41)

• The renaming of the Master Slide is also done by the same procedure.

• Master Slide will be closed by using the Close Master View in the Master View dialog box.

Figure 8.40 Notes Master View

Figure 8.41 Creating New Master using Master View and right click option
8.12. Creating Graphic Objects

You can create your own graphics using the drawing tools available in Impress. Impress contains a number of advanced drawing functions. To create more advanced graphic objects, you can use OpenOffice.org to draw and import the graphic object created into an Impress slide.

8.12.1. The Drawing toolbar

The Drawing toolbar contains tools that are used to create graphic objects. If this toolbar is not showing, select View → Toolbars Drawing from the main menu bar.

- Select: selects objects. You can select multiple objects by dragging the mouse.
- Line: draws a straight line.
- Arrow: draws a straight line ending with an arrowhead. The arrowhead will be placed where you release the mouse button.
- Rectangle: draws a rectangle. Press the Shift button to draw a square.
- Ellipse: draws an ellipse. Press the Shift button to draw a circle.
- Text: creates a text box with the text aligned horizontally.
- Vertical text: creates a text box with the text aligned vertically.
- Curve: draws a curve.
- Connectors: draws a connector line between two figures. Click the black triangle for additional connectors.

8.13. Inserting images

In order to insert an image in OpenOffice Impress, place the cursor in the place where you want the image to be inserted. Then, Click Insert → select Picture → From File option from the Insert menu. Figure 8.44.

OpenOffice Impress will display the dialog box, where you can select the image from the specific location and select open. The image will be inserted in the specified location. Figure 8.44.
Figure 8.43 Inserting an image using insert menu

Figure 8.44 Selecting the image from a location
8.14 Inserting audio and video

Open Office Impress will let you insert audio files or movie files. The audio and movie files can be inserted by clicking **Insert Movie** and Sounds option from the **Insert** menu. Figure 8.45

Same as inserting images here also, a dialog box will be opened. Select the audio or movie file from the specified location and open. It will be opened in the slide. Figure 8.46. The movie or audio file inserted will be played during the slide show by clicking the mouse over it.

![Figure 8.45 Inserting Movie and Sound](image)

![Figure 8.46 Selecting the Movie / Sound file](image)
**Student Activity**

1. Create a presentation using
   - Empty presentation
   - Template
   - Open Existing Presentation

2. Create a presentation using MS PowerPoint.

3. Identify and write the differences between creating a presentation using Impress and MS PowerPoint.

4. Create a presentation of “My State” using all the types of slide layouts.

5. Run the slideshow of “My State” by fixing durations of time for each slide.

**Teacher Activity**

This entire chapter can be taught with the help of the following methodology.

1. Laboratory Activity – the teacher can make the entire class to go to the lab and can explain the concept using a projector in the lab.

2. Or else, the teacher can demonstrate the concept using a PC and a projector inside the classroom.

3. The teacher apart from this Open source software, can compare the elements of the windows and creating presentations in MS PowerPoint also.
Evaluation

Part I Answer the following questions

1. Which is used to move quickly from one slide to another?
   A) Compass  B) Navigator  C) Fill color  D) Page border

2. Which is the shortcut key to view the slideshow?
   A) F6  B) F9  C) F5  D) F10

3. In Impress, which views shows thumbnail versions of all your slides arranged in horizontal rows.
   A) Notes  B) Outline  C) Handout  D) Slide Sorter

4. Identify the default view in Impress.
   A) Normal  B) Slide Sorter  C) Handout  D) Notes

5. Which menu contains the Slide Transition option?
   A) Slide Show  B) View  C) Tools  D) Format

6. Identify the extension of the Impress presentation.
   A) .odp  B) .ppt  C) .odb  D) .ood

7. In presentation tools, the entry effect as one slide replaces another slide in a slide show. Identify the option that suits after reading the statement.
   A) Animation  B) Slide Transition  C) Custom animation  D) Rehearse Timing

8. Vanya has made a presentation on “Global Warming”. She wants to progress her slide show automatically while speaks on the topic in the class. Which features of Impress would she use?
   A) Custom Animation  B) Rehearse Timing  C) Slide Transition  D) Either (a) or (b).
Part II
1. What is the difference between a slide and a slide show?
2. How many in-built slide layouts does impress consist of?
3. What do you understand by a presentation?
4. Define a template in Impress.
5. What do you understand by the slide layout?

Part III
1. How many types of views are provided by Impress to its users?
2. Who uses the presentation software and why?
3. Define the Slide Sorter view and its significance.
4. What is a Normal view? Explain.
5. How are transition effects helpful in creating an effective presentation in Impress?

Part IV
1. Valarmathi’s teacher asks her to create a presentation in OpenOffice Impress. As Valarmathi has never worked in Impress before, help her to perform the following tasks:
   a. She wants that except for the first slide, all the slides should have the same design. For this, what does she need to do?
   b. To easily communicate with her audience, she wants to provide them with a hard copy of the slides of the presentation. What should she create for it?
   c. She wants to insert some pictures and movie files in some slides. How can she do that?
   d. Suggest her the view that would be the most suitable for showing the presentation to the audience.
   e. To make her presentation more attractive, she wants to add some effects in it. How can she do it? Suggest.
2. Explain how a presentation can help a salesperson to promote his/her products.
3. Sivabalan created a presentation to be shown at his school’s Annual Function. Just 5 minutes before the presentation, he noticed that he has misspelt the name of the school, which is appearing in all the 30 slides of the presentation. How can he rectify this mistake in all the slides in one-shot?
4. List some advantages of using templates.
<table>
<thead>
<tr>
<th><strong>English</strong></th>
<th><strong>Tamil</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Active file</td>
<td>ஆகஸ்ட் வைணல்</td>
</tr>
<tr>
<td>Algorithm</td>
<td>கர்க்கூறுகள்</td>
</tr>
<tr>
<td>Alignment</td>
<td>விலகு</td>
</tr>
<tr>
<td>Anti–virus</td>
<td>சுருக்குலேக தொடரும் நிலையம்</td>
</tr>
<tr>
<td>Application software</td>
<td>பயில்லை வைணல்பாதை நிலையம்</td>
</tr>
<tr>
<td>Artificial intelligence</td>
<td>விளையாட்டு சிகிச்சையாளர்</td>
</tr>
<tr>
<td>Binary number</td>
<td>தொகுதி எண்</td>
</tr>
<tr>
<td>Bit</td>
<td>தொகுதி</td>
</tr>
<tr>
<td>Browser</td>
<td>பி.கூடாது</td>
</tr>
<tr>
<td>Browsing</td>
<td>பி.கூடாது விளையாட்டு</td>
</tr>
<tr>
<td>Buffering</td>
<td>வைணல்பாதை விளையாட்டு நிலையம்</td>
</tr>
<tr>
<td>Central Processing Unit (CPU)</td>
<td>கௌட்டு விளையாட்டு நிலையம்</td>
</tr>
<tr>
<td>Chat</td>
<td>வாசு விளையாட்டு</td>
</tr>
<tr>
<td>Checkbox</td>
<td>கூடாது விளையாட்டு</td>
</tr>
<tr>
<td>Communication</td>
<td>விளையாட்டு கூடாது</td>
</tr>
<tr>
<td>Compact disc (CD)</td>
<td>கௌட்டு விளையாட்டு நிலையம்</td>
</tr>
<tr>
<td>Computer network</td>
<td>விளையாட்டு சேதையம்</td>
</tr>
<tr>
<td>Condition</td>
<td>ஸ்பிந்து விளையாட்டு</td>
</tr>
<tr>
<td>Control key</td>
<td>கௌட்டு விளையாட்டு நிலையம்</td>
</tr>
<tr>
<td>Control structure</td>
<td>கௌட்டு விளையாட்டு நிலையம்</td>
</tr>
<tr>
<td>Control unit</td>
<td>கௌட்டு விளையாட்டு நிலையம்</td>
</tr>
<tr>
<td>Copy</td>
<td>கோப்பு</td>
</tr>
<tr>
<td>Data</td>
<td>தரவு</td>
</tr>
<tr>
<td>Decimal number</td>
<td>தொகுதியான எண்</td>
</tr>
<tr>
<td>Desktop</td>
<td>கௌட்டு விளையாட்டு</td>
</tr>
<tr>
<td>Devices</td>
<td>விளையாட்டு சேதையம்</td>
</tr>
<tr>
<td>Disk drive</td>
<td>கௌட்டு விளையாட்டு நிலையம்</td>
</tr>
<tr>
<td>Distributed Computing</td>
<td>கௌட்டு விளையாட்டு நிலையம்</td>
</tr>
<tr>
<td>Document</td>
<td>கௌட்டு விளையாட்டு நிலையம்</td>
</tr>
<tr>
<td>Download</td>
<td>கௌட்டு விளையாட்டு நிலையம்</td>
</tr>
<tr>
<td>E–mail</td>
<td>பி.கூடாது விளையாட்டு நிலையம்</td>
</tr>
<tr>
<td>Error</td>
<td>பி.கூடாது விளையாட்டு நிலையம்</td>
</tr>
<tr>
<td>Field</td>
<td>பி.கூடாது விளையாட்டு நிலையம்</td>
</tr>
<tr>
<td>File</td>
<td>வைணல்</td>
</tr>
<tr>
<td>File management</td>
<td>வைணல் விளையாட்டு நிலையம்</td>
</tr>
<tr>
<td>Flow chart</td>
<td>வைணல் விளையாட்டு நிலையம்</td>
</tr>
<tr>
<td>Folder</td>
<td>வைணல்</td>
</tr>
<tr>
<td>Font</td>
<td>வைணல்</td>
</tr>
<tr>
<td>Function</td>
<td>வைணல்</td>
</tr>
<tr>
<td>GUI</td>
<td>சுருக்குலேக தொடரும் நிலையம்</td>
</tr>
<tr>
<td>Hard disc</td>
<td>வைணல்</td>
</tr>
<tr>
<td>Hardware</td>
<td>வைணல்</td>
</tr>
<tr>
<td>Icon</td>
<td>வைணல்</td>
</tr>
<tr>
<td>Information</td>
<td>தகவல்</td>
</tr>
<tr>
<td>Insertion point</td>
<td>இருப்பு வழி பாகம்</td>
</tr>
<tr>
<td>Internet</td>
<td>இருப்பு வழி பாகம்</td>
</tr>
<tr>
<td>Internet protocol address</td>
<td>இருப்பு வழி பாகம் வாக்கியம்</td>
</tr>
<tr>
<td>Internet service provider (ISP)</td>
<td>இருப்பு வழி பாகம் வாக்கியம்</td>
</tr>
<tr>
<td>Term</td>
<td>Tamil Translation</td>
</tr>
<tr>
<td>-----------------------------------------</td>
<td>---------------------------</td>
</tr>
<tr>
<td>Interpreter</td>
<td>இரண்டுக்கம்பியோன்றி/கிராம்பொன்றி</td>
</tr>
<tr>
<td>Intranet</td>
<td>இணைக்கம்பியோன்றி</td>
</tr>
<tr>
<td>iOS (iPhone OS)</td>
<td>எனுக்கம்பியோன்றி மற்றும் கிராம்பொன்றி</td>
</tr>
<tr>
<td>Keyboard</td>
<td>இயங்குவொருளாக்கம்/கல்லாலுக்கப்பொருளாக்கம்</td>
</tr>
<tr>
<td>Keyword</td>
<td>தொகுப்பு குறியீடு</td>
</tr>
<tr>
<td>Laptop computer</td>
<td>லேப்னோட்டிக்கிற் பொருளாக்கம்</td>
</tr>
<tr>
<td>Log in</td>
<td>பத்து/தொன்று</td>
</tr>
<tr>
<td>Log out</td>
<td>பத்து/தொன்றுறுப்பொருளாக்கம்</td>
</tr>
<tr>
<td>Machine language</td>
<td>மேசை குறியீடு</td>
</tr>
<tr>
<td>Memory</td>
<td>நெடுஞ்சாட்டம்</td>
</tr>
<tr>
<td>Menu</td>
<td>பட்டடம்</td>
</tr>
<tr>
<td>Micro processor</td>
<td>மிக்கோ பொருளாக்கம்</td>
</tr>
<tr>
<td>Multimedia</td>
<td>மீட்டூரியல்க் பொருளாக்கம்</td>
</tr>
<tr>
<td>Multitasking</td>
<td>மூலக்கூறுகள்</td>
</tr>
<tr>
<td>Navigation</td>
<td>நூறுசுறுகள்</td>
</tr>
<tr>
<td>Network</td>
<td>பொருளாக்கம்/வெளியவொருளாக்கம்</td>
</tr>
<tr>
<td>Notation</td>
<td>நோட்தார்த் பொருளாக்கம்</td>
</tr>
<tr>
<td>Object</td>
<td>பொருள்</td>
</tr>
<tr>
<td>Operating system</td>
<td>மேசை கல்லாலுக்கப்பொருளாக்கம்</td>
</tr>
<tr>
<td>Page layout</td>
<td>படக் வெளியவொருளாக்கம்</td>
</tr>
<tr>
<td>Password</td>
<td>பாலூசுர்சர்</td>
</tr>
<tr>
<td>Peripherals</td>
<td>மூலக்கூறுகள்</td>
</tr>
<tr>
<td>Print</td>
<td>பிட் செம்</td>
</tr>
<tr>
<td>Printer</td>
<td>பிட்செம்படியுரியட்டு</td>
</tr>
<tr>
<td>Program</td>
<td>பாகோக்கும்</td>
</tr>
<tr>
<td>Protocols</td>
<td>வார்ட்ஸ்பொருளாக்கம்</td>
</tr>
<tr>
<td>Reset</td>
<td>முழுக்கம்</td>
</tr>
<tr>
<td>Robotics</td>
<td>றெஸ்ட்ரியாக்கம்</td>
</tr>
<tr>
<td>Scheduling</td>
<td>சேதனர்த் பொருளாக்கம்</td>
</tr>
<tr>
<td>Security</td>
<td>பான்மை பொருளாக்கம்</td>
</tr>
<tr>
<td>Sessions</td>
<td>அமையச்சக்கான்</td>
</tr>
<tr>
<td>Shortcut</td>
<td>காந்திக்கரைகள்/தொழிக்கட்டிகள்</td>
</tr>
<tr>
<td>Shutdown</td>
<td>அகலமை/தோற்ற</td>
</tr>
<tr>
<td>Software</td>
<td>வார்ட்ஸ்பொருளாக்கம்</td>
</tr>
<tr>
<td>Spooling</td>
<td>காந்திக்கான்</td>
</tr>
<tr>
<td>String literals</td>
<td>இன்னொருற ஆங்கிலப் தொடர்கள்</td>
</tr>
<tr>
<td>Structured programming</td>
<td>குறியீடுகண்கள்</td>
</tr>
<tr>
<td>Syntax error</td>
<td>நெடுஞ்சாட்டம்/தூவும் குறியீடு</td>
</tr>
<tr>
<td>Tab</td>
<td>தூக்கை</td>
</tr>
<tr>
<td>Toolbar</td>
<td>தொடர் பொருளாக்கம்</td>
</tr>
<tr>
<td>Trash</td>
<td>மூதுத்தொடர் டைள்பொருளாக்கம்</td>
</tr>
<tr>
<td>URL (Uniform Resource Locator)</td>
<td>(இன்னொருற பொருளாக்கம்) பொருளாக்கம்</td>
</tr>
<tr>
<td>Version</td>
<td>பதின் பொருளாக்கம்</td>
</tr>
<tr>
<td>Virus</td>
<td>டைக்ட்பொருளாக்கம்</td>
</tr>
<tr>
<td>Website</td>
<td>இன்னொருற பொருளாக்கம்</td>
</tr>
<tr>
<td>Wizard</td>
<td>வார்ட்ஸ்பொருளாக்கம்</td>
</tr>
<tr>
<td>Word processor</td>
<td>எசேஸ்பொருளாக்கம்</td>
</tr>
<tr>
<td>Workstation</td>
<td>பொருளாக்கம்/பொருளாக்கம்</td>
</tr>
<tr>
<td>World Wide Web (WWW)</td>
<td>வலைப்பகுதி ஓலையை</td>
</tr>
</tbody>
</table>
List of Authors and Reviewers

**Domain Experts**

- Mrs. Bagyalakshmi P  
  Asst. Professor and Head of the Department, Dept of Computer Applications, Queen Mary’s College, Chennai

- Mrs. Sasikala K  
  Associate Professor, Dept of Computer Science, Queen Mary’s College, Chennai

- Dr. Chitra Babu  
  Professor and Head of the Department, Dept of Computer Science and Engineering, SSN College of Engineering, Chennai

- Dr. Radha P  
  Assistant Professor, Dept of Information Technology, Govt. Arts & Science College (A), Coimbatore

- Dr. Nester Jeyakumar M  
  Associate Professor and Head Of the Department, Dept of Computer Science, Loyola College, Chennai

- Dr. Srinivasan N  
  Professor, Dept of Computer Science and Engineering, Sathyabama Institute of Science & Technology, Chennai

- Dr. Chandra Mohan B  
  Associate Professor, School of Computer Science and Engineering, Vellore Institute of Technology, Vellore

- Mr. Sethuraman R  
  Assistant Professor, Dept of Computer Science and Engineering, Sathyabama Institute of Science & Technology, Chennai

- Mr. Sankar K  
  Assistant Professor, Dept of Computer Science, RKM Vivekananda College, Mylapore, Chennai

**Reviewers**

- Dr. Ranjani Parthasarathi  
  Professor, Dept of Info Sci and Tech, College of Engineering, Guindy, Anna University, Chennai

- Mr. Munivel E  
  Scientist/Engineer ‘C’ IT Group (Information Security), NIELIT Calicut (MeitY, Govt. of India), NIT Campus, Calicut - KL (IN).

**Authors**

- Mr. Kannan K  
  Post Graduate Teacher, Chennai Girls Hr Sec School, Roller street, Chennai

- Mr. Ramakrishnan V G  
  Post Graduate Teacher, Karnataka Sangha Hr Sec School, T Nagar, Chennai

- Mrs. Bindhu Mohandas  
  Post Graduate Teacher, Vidyavanta Model Hr Sec School, H.V.F Estate, Avadi, Chennai

- Mr. Gowrisankar N.V  
  Post Graduate Teacher, Chennai Girls Hr Sec School, Nungambakkam, Chennai

- Mr. Sreenivasan R  
  Post Graduate Teacher, Santhome Hr Sec School, Mylapore, Chennai

- Mr. Lenin K  
  Post Graduate Teacher, Chennai Girls Hr Sec School, Saidapet, Chennai

- Miss. Sangeetha A  
  Post Graduate Teacher, Govt. Hr Sec School, Rajanathangal, Trivandrum, Dt

- Dr. Valarmathi K E  
  Post Graduate Teacher, Velammal Vidhyashram, Surapet, Chennai

- Mrs. Gajalakshmi R  
  Post Graduate Teacher, Jaigopal Ganodia Hindu Vidyalaya Hr Sec School, West Mambalam, Chennai

**Academic Coordinators**

- Mr. A. Palanivel Raj  
  Assistant Professor, SCERT, Chennai

- Mrs. Nevedha Selvaraj  
  Assistant Professor, SCERT, Chennai

- Mrs. Tamil Selvi R  
  B.T. Assistant, Government High School, Poonampalayam, Trichy District

**Art and Design Team**

**Chief Co-ordinator and Creative Head**

Srinivasan Natarajan

**Experts Co-ordinator**

Mr. Ravikumar Arumugam  
Deputy Director, SCERT, Chennai

**Layout**

THY designers and computers  
Chennai

**In-House**

QC - Gopu Rasuvel  
- Rajesh Thangapan  
- Asker Ali, TamilKumaran. C  
- Kathir Arumugham

**Co-ordination**

Ramesh Munisamy

This book has been printed on 80 G.S.M. Elegant Maplitho paper.

Printed by offset at: