Human civilization achieved the highest peak with the development of computer known as “Computer era”. Literate are those who have the knowledge in using the computer whereas others are considered illiterate inspite of the other degrees obtained.

The growth of the nation at present lies in the hands of the youth, hence the content of this book is prepared in such a way so as to attain utmost knowledge considering the future needs of the youth.

This book does not require prior knowledge in computer Technology

Each unit comprises of simple activities and demonstrations which can be done by the teacher and also students.

Technical terminologies are listed in glossary for easy understanding

The “Do you know?” boxes enrich the knowledge of reader with additional information

Workshops are introduced to solve the exercises using software applications

QR codes are used to link supporting additional materials in digital form

How to get connected to QR Code?

- Download the QR code scanner from the google play store/apple app store into your smartphone
- Open the QR code scanner application
- Once the scanner button in the application is clicked, camera opens and then bring it closer to the QR code in the textbook.
- Once the camera detects the QR code, a URL appears in the screen. Click the URL and go to the content page.
# Career Guidance After 12th

<table>
<thead>
<tr>
<th>Courses</th>
<th>Colleges/Universities</th>
<th>Profession</th>
</tr>
</thead>
<tbody>
<tr>
<td>B.E / B.Tech</td>
<td>All University and their affiliated Colleges and Self-financing Colleges in India and Abroad.</td>
<td>Software Engineer, Hardware Engineer, Software Development, Healthcare Section, IT &amp; ITEs</td>
</tr>
<tr>
<td>B.Sc (Computer Science)</td>
<td>All University and their affiliated Colleges and Self-financing Colleges in India and Abroad.</td>
<td>Government Job and Private Company BPO, Geologist, Journalist</td>
</tr>
<tr>
<td>B.CA</td>
<td></td>
<td></td>
</tr>
<tr>
<td>B.Sc (Maths, Physics, Chemistry, Bio-Chemistry, Geography, Journalism, Library Sciences, Political Science, Travel and Tourism)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>LL.B</td>
<td>All University and their affiliated Colleges and Self-financing Colleges in India and Abroad.</td>
<td>Lawyer, Legal Officer, Govt Job</td>
</tr>
<tr>
<td>B.A+LL.B</td>
<td></td>
<td></td>
</tr>
<tr>
<td>B.Com</td>
<td></td>
<td></td>
</tr>
<tr>
<td>BBM+LL.B</td>
<td>The Institute of Chartered Accountant of India (ICAI)</td>
<td>CA Private and Govt.</td>
</tr>
<tr>
<td>BBA+LL.B</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Diploma</td>
<td>Government Polytechnic and Self-financing colleges</td>
<td>Junior Engineer (Government and Private)</td>
</tr>
<tr>
<td>Commerce Courses</td>
<td></td>
<td></td>
</tr>
<tr>
<td>COURSES</td>
<td>COLLEGES/UNIVERSITIES</td>
<td>PROFESSION</td>
</tr>
<tr>
<td>------------------------------</td>
<td>---------------------------------------------------------------------------------------</td>
<td>-------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Management Courses</strong></td>
<td>All University and their affiliated Colleges and Self financing Colleges in India and Abroad.</td>
<td>Private Organization, Government, Banking sectors and prospects for self-employment.</td>
</tr>
<tr>
<td>Business Management</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Bank Management</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Event Management</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Hospital Management</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Human Resource Management</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Logistics Management</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Science and Humanities</strong></td>
<td>All University and their affiliated Colleges and Self financing Colleges in India and Abroad</td>
<td>Government Job and Private Company BPO, Geologist, Journalist</td>
</tr>
<tr>
<td>B.Sc. Botany</td>
<td></td>
<td></td>
</tr>
<tr>
<td>B.Sc. Zoology</td>
<td></td>
<td></td>
</tr>
<tr>
<td>B.Sc. Dietician &amp; Nutritionist</td>
<td></td>
<td></td>
</tr>
<tr>
<td>B.Sc. Home Science</td>
<td></td>
<td></td>
</tr>
<tr>
<td>B.Sc. Food Technology</td>
<td></td>
<td></td>
</tr>
<tr>
<td>B.Sc. Dairy Technology</td>
<td></td>
<td></td>
</tr>
<tr>
<td>B.Sc. Hotel Management</td>
<td></td>
<td></td>
</tr>
<tr>
<td>B.Sc. Fashion Design</td>
<td></td>
<td></td>
</tr>
<tr>
<td>B.Sc. Mass Communication</td>
<td></td>
<td></td>
</tr>
<tr>
<td>B.Sc. Multimedia</td>
<td></td>
<td></td>
</tr>
<tr>
<td>B.Sc. -3D Animation</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
# Table of Contents

<table>
<thead>
<tr>
<th>Chapter No.</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><strong>UNIT III – SPREADSHEET</strong></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>Introduction to Spreadsheet</td>
<td>1</td>
</tr>
<tr>
<td>10</td>
<td>Functions and Chart</td>
<td>42</td>
</tr>
<tr>
<td>11</td>
<td>Data Tools and Printing</td>
<td>74</td>
</tr>
<tr>
<td></td>
<td><strong>UNIT IV – PRESENTATION</strong></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>Presentation Basics</td>
<td>94</td>
</tr>
<tr>
<td>13</td>
<td>Presentation Advanced</td>
<td>116</td>
</tr>
<tr>
<td></td>
<td><strong>UNIT V - COMPUTER NETWORKS, INTERNET AND EMAIL</strong></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>Computer Network</td>
<td>140</td>
</tr>
<tr>
<td>15</td>
<td>Internet and Email</td>
<td>172</td>
</tr>
<tr>
<td>16</td>
<td>Tamil Computing</td>
<td>192</td>
</tr>
</tbody>
</table>

E - book

Assessment

DIGI links

VI
Learning Objectives

Students will be able
- To know the features of OpenOffice Calc.
- Use of different operators.
- Generation of Series.
- Edit Formula in Worksheet.
- Manipulation of Rows/Columns in Worksheet.
- Understand various text format in options.
- Use of Number format in Worksheet.

9.1 Introduction to spreadsheet

Spreadsheet is a very useful office automation tool to organise, analyse and store data in a tabular form. Spreadsheet was developed as computerized equivalent to paper-based accounting worksheets.

Spreadsheet users can adjust any of the stored values and can observe the effects on the calculated values. This is called "What if" analysis. Modern spreadsheet can have multiple interacting sheets and can display data either as text or numerals or in a graphical form.

9.1.1 Evolution of Spreadsheet

Daniel Bricklin and Bob Frankston developed the first spreadsheet called “VisiCalc” in 1979 for Apple II. In 1982, Lotus Corporation introduced “Lotus 1-2-3”; Lotus 1-2-3 was the first to introduce cell names and macros. In 1987, Microsoft Corporation introduced Excel. Excel implemented a Graphical User Interface (GUI) and the ability to point and click using a mouse. There are lots of other spreadsheet applications; Microsoft Excel continues to be the most popular spreadsheet software.

OpenOffice Calc is a popular open source spreadsheet application maintained by Apache Foundation. Star Office calc is the parent application of OpenOffice Calc which was developed by a German Company namely, Star Division in 1985.

9.2 Working with OpenOffice Calc

Calc is the spreadsheet component of OpenOffice. You can enter any kind of data in a spreadsheet and then manipulate this data to produce certain results. Alternatively, you can enter data and then use Calc in a 'What If...' manner by changing some of the data and observing the results without having to retype the entire spreadsheet.
VisiCalc ("Visible Calculator") was the first spreadsheet for personal computers, originally released for the Apple II by VisiCorp. It is considered that VisiCalc turned the microcomputer from a hobby for computer enthusiasts into a serious business tool, prompting IBM to introduce the IBM PC, two years later. It was sold over 700,000 copies in six years, and as many as 1 million copies over its history.

9.2.1 Features of OpenOffice Calc:

- **Connecting with Excel** - Ability to open, edit, and save Microsoft Excel spreadsheets
- **AutoSum** - helps you to add the contents of a cluster of adjacent cells.
- **List AutoFill** - automatically extends cell formatting when a new item is added to the end of a list.
- **AutoFill** - allows you to quickly fill cells with repetitive or sequential data such as chronological dates or numbers, and repeated text. AutoFill can also be used to copy functions. You can also alter text and numbers with this feature.
- **Charts** - helps you in presenting a graphical representation of your data in the form of Pie, Bar, Line charts and more.
- **Functions** - which can be used to create formula to perform complex calculations on data
- **Database functions** - to arrange, store, and filter data

### 9.3 Creating a new worksheet

A new spreadsheet can be created through various methods. From windows, select

**Start → All Programs → OpenOffice → OpenOffice Calc** (or)

**From Star Center (Welcome Screen):**

Double-click on "OpenOffice" icon on the desktop

Now, a welcome screen appears as shown in Figure 9.1.

This open screen is called as "Star Center". Calc is one of the component of OpenOffice. So, it may be invoked from the "Star Center" by simply clicking on the "Spreadsheet" icon. (or)

A new spreadsheet can also be created by selecting **File → New → Spreadsheet** from any OpenOffice Application. After using any one of the above said methods, OpenOffice Calc window appears as shown in Figure 9.2. The outline of the window is very similar to other application windows of OpenOffice. The main area of the Calc window is called as "Work area" or "Worksheet".

A worksheet is a grid of cells with a programmable calculator attached to each cell. When you open a new spreadsheet, there are three worksheets available by default. You can include more sheets and organize them.
Figure 9.1 Opening Screen (Star Center) of OpenOffice

Figure 9.2 OpenOffice Calc Window
9.3.1 Parts of the OpenOffice Calc Window

Appearance of the Calc window is very similar to that of the Writer window. The workspace of writer is a big blank area. But, in calc, the grid of cells is the workspace.

9.3.1.1 Title Bar

At the top of the window is the “Title Bar”. It is used to show the name of the file and name of the application. In OpenOffice calc, the default name for the first unsaved worksheet is “Untitled1”. When you save the file, Untitled will change to the name in which you saved.

9.3.1.2 Control Buttons:

In the right corner of title bar, (1) minimize, (2) maximize / restore and (3) close control buttons are available.

9.3.1.3 Menu Bar

Below the title bar is the menu bar. Most of the menus are very similar to what you learnt in OpenOffice Writer.

File - menu contains the commands of all file management tasks like, Create a new file, Open an existing file, Close the current file, Save a file, Save a file in another name, print file, Export file etc.

Edit - menu contains the editing commands like, cut, copy, paste, Undo, Redo, Fill etc., Most of the menu items are similar to Writer Edit menu. But, for Calc, some special editing options are available under this menu.

View - menu contains the commands which are used to modify the environment of calc.

Insert – menu contains commands for inserting various calc elements such as cells, columns, rows, functions, charts etc.,

Format – menu contains the commands of various text and cell formatting features.

Tools – menu contains various tools and functions such as spell check, protect document, insert pictures, macros, etc.,

Data – menu contains the commands to manipulate data in a spreadsheet such as sort, filter, subtotal, validity etc.,

Window – menu shows display options such as New Window, Close Windows, Split and Freeze.

Help – menu lists in-built help features available with OpenOffice.

9.3.1.4 Tools Bar

Under the menu bar, there are three toolbars available by default. They are:

(1) Standard Toolbar
(2) Formatting Toolbar
(3) Formula bar
Standard Toolbar – contains frequently used menu such as File, Edit, Data etc., commands as icons such as New Open Save, Send, Print, Print Preview, Cut, Copy, Paste, Sorting, Inserting chart etc.,

Formatting Toolbar – contains frequently used text and cell formatting commands as such as changing font style, font size, font colour, alignments, cell formatting etc.,

Formula bar – This is a very important element in a spreadsheet. It contains Name box, Function Wizard, Sum button, Function button and Input line (Refer Figure 9.4).

Name box : It display the current cell address

Function Wizard : It is used to insert function

Sum button : It is used to quickly insert sum function.

Input Line : This is used to show the contents of the current cell. It always shows actually what you typed in a cell. It is also used to edit the contents.

9.3.1.5 Scroll bar

Spreadsheet window also has two sets of scroll bars (1) Vertical Scrollbar and (2) Horizontal Scrollbar (Refer Figure 9.5)

Vertical Scroll bar : It is used to move the screen up and down.

Horizontal Scroll bar : It is used move the screen left and right.

Scroll buttons : used to move the screen to the relative distance.
9.3.1.6 Row, Column, Cell and Cell Pointer

Below the formula bar contains the worksheet of work area which consist of grid cells. The worksheet has number of rows and columns, where each column is labelled as A, B, C, D ...... AA, AB, AC ...... and the rows are numbered from 1, 2, 3 .... (Figure 9.6).

OpenOffice Calc version 4.1.5 contains 1024 columns and 10,48,576 rows. Column heading starts from A and end with AMJ. In the case of Microsoft Excel 2016, there are 16,384 columns (A to XFD) and 10,48,576 rows. (OpenOffice Calc Version 4.1.5).

Cell

Intersection of each row and column makes a box which is called as “Cell”. Each cell has a unique address.

Cell address is the combination of column heading and row number. For example, the intersection of column B and row 4 makes a cell B4. (Figure 9.7). Every cell is thus identified by its unique cell address.

Cell pointer is a rectangular box which can be moved around the worksheet. The cell in which the cell pointer is currently located is known as “Active cell”. When you type any content, it will appear in the active cell. The address of the active cell is displayed in the Name box / Address box. Active cell’s column name and row number will be highlighted. Using this visual clue, one can easily identify an active cell. Moreover, the contents of an active cell will be displayed in the formula bar.
9.3.1.7 Worksheet tabs
At the bottom of the grid of cells are the sheet tabs. By default there are 3 sheets “Sheet1”, “Sheet2” and “Sheet3”, (Figure 9.8). When you open a new worksheet, sheet1 is the default active sheet. Active sheet tab will appear in white colour. If you click on another sheet, it will become active and its colour will turn white. Multiple sheets can also be selected by clicking the sheet and press the $\text{Ctrl}$ button ($\text{Ctrl} + \text{Click}$). Selected sheets will turn to white colour.

On the left of the sheet tab, four navigation buttons are used to move between worksheets (Figure 9.9).

(1) Move to the First sheet
(2) Move to the previous sheet
(3) Move to Next sheet
(4) Move to the Last sheet

Figure 9.9 Calc Sheet tab and Navigation buttons

Left corner of status bar shows the total count of sheets and the present active sheet number. For example, if the status bar shows sheet 3/12; 3 refers to the serial number of the current sheet and 12 refers to the total number of sheets available.

Every sheet name can be renamed. To rename a sheet, just double-click on the sheet, which will show a small box as shown in Figure 9.10.

Figure 9.10 Rename Sheet dialog box

It shows the current name; delete or overwrite the existing name and type a new name; click OK button. New name will be displayed on the sheet.

9.3.1.8 Status bar

Below the sheet tabs and horizontal scrolling bar is the “Status Bar”. It shows the current status of the worksheet (Refer Figure 9.11).

**Sheets count:** Displays current serial number of the sheet / total number of sheets available.

**Page Style:** Displays the page style of the current sheet. To make changes, just double-click on “Default” and it will show you the “Page Style” dialog box, which is used to change the margin, orientation, paper size, inserting header, footer, border style etc.,

**Selection Mode:** Displays the selection mode of the current sheet. There are three modes available to select the cells of a worksheet. They are, Standard (STD), Extend (EXT) and Add (ADD).

**Unsaved Changes:** An asterisk ( * ) symbol indicates the changes made in the worksheet but not yet saved. If you have saved your changes, it will disappear.
9.4 Working with Data

When you open a new spreadsheet, the cell pointer is located in cell A1. So, the Cell A1 is known as “Home Cell”. Cell pointer can be moved anywhere in the spreadsheet using the direction keys.

“Tab key” is used to move the cell pointer towards the right side or forward direction. “Shift+Tab” is used to move backward i.e. from right to left in a row. “Enter” key is also used to move the cell pointer. Enter moves the cell pointer to a cell below the current cell i.e. downwards. Four “direction keys” are used to move the cell pointer anywhere in the worksheet.

9.4.1 Entering Data:

Any data can be typed directly in any cell of the worksheet. But, the cell in which you type data should be an active cell. So, move the cell pointer to a particular cell to make it active cell; or click any cell to make it active cell. Then, start typing any data. When you type data, spreadsheet recognises the type of data entered in cells.

Data types:

Data are of different types. Data are made up of alphabets, numbers, Date and time is another data type even though it has numbers and symbols. In general, data types are classified as:

- **Alphabetic data type** – consists of alphabets only
- **Numeric data type** – consists only of numbers (whole number or fractional numbers)
- **Alphanumeric data types** – consists of a combination of alphabets and numerals
- **Date data type** – consists only of date
- **Time data type** – consists only time

9.4.1.1 Entering Numbers:

Any numeric data can be entered in a spreadsheet. Entered numbers are aligned to the right side within the cell by default. Negative numbers may be entered with a minus sign or within brackets (Refer Figure 9.12). If you enter any number within the bracket, it will be changed as negative number i.e., number prefixed with minus. If any number starts with 0 (zero); Calc will drop the leading zero.

```
5478
-142
```

Figure 9.12 Entering data

9.4.1.2 Entering Text:

Unlike numbers, any character can be entered as data in Calc. Entered text will be
aligned to the left side within the cell by default. When you enter any numeric value, if it is aligned left, it is understood that the entered content is not a number. If there is any number that starts with a single quote, calc converts that number to text (Refer Figure 9.13).

![Figure 9.13 Entering Text](image1)

**9.4.1.3 Entering Date and Time:**

Before entering date, ensure the format of your system date. Calc accepts date as per the system date format. If your system has American date format i.e. month-date-year; you should enter dates in Calc spreadsheet as mm/dd/yy. If your system follows the Indian date format, date should be entered as dd/mm/yy form in Calc. Only the correct form of date is accepted by Calc as a date.

For example: If your system has American Date format, 18th December 2017 should be entered as 12/18/17. As soon as the date is typed in the correct form, the entered date will be aligned on the right side within the cell, and if you place the cell pointer in that cell, the formula bar shows your date as “12/18/2017” (Figure 9.14). This is a visual clue to know whether the date is accepted or not.

A Date format can be changed to any other valid form using “Cell Formatting” dialog box, and it will be discussed later.

![Figure 9.14 Entering Date](image2)

Like dates, for entering time, calc follows the general format HH:MM:SS. where HH, MM and SS represent hours, minutes and seconds respectively.

**Different Date Formats**

<table>
<thead>
<tr>
<th>Order styles</th>
<th>Countries</th>
</tr>
</thead>
<tbody>
<tr>
<td>DD/MM/YYYY</td>
<td>Asia (Central, SE, West), Australia, New Zealand, parts of Europe, Latin America, North Africa, India, Indonesia, Bangladesh and Russia</td>
</tr>
<tr>
<td>YYYY/MM/DD</td>
<td>Bhutan, Canada, China, Koreas, Taiwan, Hungary, Iran, Japan, Lithuania, Mongolia.</td>
</tr>
<tr>
<td>MM/DD/YYYY</td>
<td>United States, Federated States of Micronesia, Marshall Islands</td>
</tr>
<tr>
<td>DD/MM/YYYY and</td>
<td>Malaysia, Nigeria, Philippines, Saudi Arabia, Somalia</td>
</tr>
</tbody>
</table>

**9.5 Creating Formulae**

After entering the data in worksheet, you can perform calculations on the data in the worksheet. In order to create formulae, you first need to know
the syntax that describes the format for specifying a formula.

In Calc, you can enter formulas in two methods, either directly into the cell or at the input line. Formula in Calc may start with equal (=) or plus(+) or minus(−) sign followed by a combination of values, operators and cell references. But, as a general practice, all formulas should start with an equal sign. If any formula starts with a + or −, the values will be considered as positive or negative respectively.

9.5.1 Operators

Operators are symbols for doing some mathematical, statistical and logical calculations. Combination of values, operators and cell references is called as “Expression”. Calc supports a variety of operators which are categorized as:

(1) Arithmetic Operators
(2) Relational Operators
(3) Reference Operators
(4) Text Operator

9.5.1.1 Arithmetic Operators

Arithmetic operators are symbols for performing simple arithmetic operations such as addition, subtraction, multiplication, division etc., These operators return a numerical result.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Name</th>
<th>Value in Column B</th>
<th>Value in Column C</th>
<th>Formula in Column D</th>
<th>Result in Column D</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>Addition</td>
<td>98</td>
<td>25</td>
<td>= B3 + C3</td>
<td>123</td>
</tr>
<tr>
<td>-</td>
<td>Subtraction</td>
<td>125</td>
<td>25</td>
<td>= B3 − C3</td>
<td>100</td>
</tr>
<tr>
<td>*</td>
<td>Multiplication</td>
<td>25</td>
<td>5</td>
<td>= B3 * C3</td>
<td>125</td>
</tr>
<tr>
<td>/</td>
<td>Division</td>
<td>90</td>
<td>10</td>
<td>= B3 / C3</td>
<td>9</td>
</tr>
<tr>
<td>^</td>
<td>Exponent</td>
<td>25</td>
<td>2</td>
<td>= B3 ^ C3</td>
<td>625</td>
</tr>
<tr>
<td>%</td>
<td>Percent</td>
<td>600</td>
<td></td>
<td>= B3 * 35%</td>
<td>72</td>
</tr>
</tbody>
</table>

Table 9.1 List of Arithmetic Operators

Formula bar shows the formula what the user had entered. But, the cell shows the resulted value (Figure 9.15).

9.5.1.2 Relational Operators

Relational operators are symbols used for comparing two values such as greater than, less than, equal to etc. The relational operators are also called as "Comparative operators". These operators return either a True or a False.
Table 9.2 List of Relational Operators of cells.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Name</th>
<th>Value in Column B</th>
<th>Value in Column C</th>
<th>Formula in Column D</th>
<th>Result in Column D</th>
</tr>
</thead>
<tbody>
<tr>
<td>&gt;</td>
<td>Greater than</td>
<td>98</td>
<td>100</td>
<td>=B3&gt;C3</td>
<td>FALSE</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Greater than or equal to</td>
<td>85</td>
<td>72</td>
<td>=B3&gt;=C3</td>
<td>TRUE</td>
</tr>
<tr>
<td>&lt;</td>
<td>Less than</td>
<td>54</td>
<td>24</td>
<td>=B3&lt;C3</td>
<td>FALSE</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Less than or equal to</td>
<td>55</td>
<td>55</td>
<td>=B3&lt;=C3</td>
<td>TRUE</td>
</tr>
<tr>
<td>=</td>
<td>Equal to</td>
<td>12</td>
<td>12</td>
<td>=B3=C3</td>
<td>TRUE</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>Not equal to</td>
<td>54</td>
<td>45</td>
<td>=B3&lt;&gt;C3</td>
<td>TRUE</td>
</tr>
</tbody>
</table>

9.5.1.3 Reference Operator

Reference operators are used to refer cell ranges. A **continuous group of cells is called as “Range”**. There are three types of reference operators that are used to refer cells in Excel: (1) Range Reference Operator, (2) Range Concatenation, (3) Intersection Operator.

**Range Reference Operator**

Colon (:) is the range reference operator. It is used to group a range of cells. An expression using a range operator has the following syntax:

```
reference left : reference right
```

where reference left is the starting cell address of a linear group of cells or upper left corner address of a rectangular group. Reference right is the last cell address of a linear group or lower right corner address of a rectangular group of cells.

**Figure 9.16 Entering Relational Operator**
Example:

(i) Linear group of cells A1, A2,A3,A4,A5 is referred as A1:A5

(ii) Rectangular group of cells A2, A3, A4, ..... B2, B3, B4,....D5, D6 is referred as A2:D6 (Refer Figure 7.17)

Name box shows the reference A2:D6 corresponding to the cells included in the drag operation with the mouse to highlight the range.

**Reference concatenation operator:**

Concatenation means joining together. Tilde (~) symbol is used as a concatenation operator in calc. An expression using a concatenation operator has the following syntax:

```
reference left ~ reference right
```

**Example:**

If you want to find the sum of the values from A1 to A6 and C3 to F3. The formula is

```
=SUM(A1:A6 ~ C3:F3)
```

SUM is a function to find the sum of a group of values. (Refer Figure 9.18)
Intersection Operator:

Intersection operator is used to join two set of groups. It is very similar to Range concatenation operator. The intersection operator is represented by an exclamation reference left ! reference right

Example: (A2:D3 ! B2:E4)

The result of (A2:D3 ! B2:E4) is referred by the range B2:D3, because these cells are both inside A2:D3 and B2:E4 (Refer Figure 9.19 and 9.20).
9.5.1.4 Text Operator:

In Calc, “&” is a text operator which is used to combine two or more text. Joining two different texts is also known as “Text Concatenation” (Refer Figure 9.21). An expression using the text operator has the following syntax:

\text{text reference1} \& \text{text reference2}

When arithmetic operators are used in a formula, Calc calculates the results using the rule of precedence followed in Mathematics. The order is:

I. Exponentiation (\(^\))
II. Negation (-)
III. Multiplication and Division (\(*, /\))
IV. Addition and Subtraction (+, -)

Here is an example to illustrate how to create a formula:
Illustration 1:

Create a Marks worksheet with the following data:

<table>
<thead>
<tr>
<th>Reg. No</th>
<th>Name</th>
<th>Tam</th>
<th>Eng</th>
<th>CS</th>
<th>Com</th>
<th>Acc</th>
</tr>
</thead>
<tbody>
<tr>
<td>12001</td>
<td>Jayashree J</td>
<td>147</td>
<td>136</td>
<td>105</td>
<td>163</td>
<td>162</td>
</tr>
<tr>
<td>12002</td>
<td>Kowsalya T</td>
<td>156</td>
<td>148</td>
<td>149</td>
<td>147</td>
<td>179</td>
</tr>
<tr>
<td>12003</td>
<td>Muskan S</td>
<td>149</td>
<td>165</td>
<td>123</td>
<td>168</td>
<td>179</td>
</tr>
<tr>
<td>12004</td>
<td>Ashia Stephy R</td>
<td>168</td>
<td>144</td>
<td>146</td>
<td>192</td>
<td>167</td>
</tr>
<tr>
<td>12005</td>
<td>Vennila T P</td>
<td>199</td>
<td>198</td>
<td>150</td>
<td>200</td>
<td>200</td>
</tr>
<tr>
<td>12006</td>
<td>Deepika M</td>
<td>187</td>
<td>141</td>
<td>98</td>
<td>130</td>
<td>178</td>
</tr>
<tr>
<td>12007</td>
<td>Tharani J</td>
<td>165</td>
<td>102</td>
<td>100</td>
<td>192</td>
<td>192</td>
</tr>
<tr>
<td>12008</td>
<td>Thulasi A</td>
<td>143</td>
<td>169</td>
<td>88</td>
<td>176</td>
<td>173</td>
</tr>
<tr>
<td>12009</td>
<td>Ayisha B</td>
<td>120</td>
<td>138</td>
<td>109</td>
<td>182</td>
<td>167</td>
</tr>
<tr>
<td>12010</td>
<td>Jenifer A</td>
<td>145</td>
<td>135</td>
<td>95</td>
<td>180</td>
<td>185</td>
</tr>
</tbody>
</table>

After completing the data entry, your worksheet will look as shown in Figure 9.22.

![Worksheet Illustration](image)

9.5.2 Construction of formula

To construct a formula, follow the steps below:

- Cell pointer should be in the cell in which you want to display the result.
- Formula should begin with an = sign.
- In a formula, use only cell reference (cell address) instead of the actual values within the cells.
- While constructing a formula, **BODMAS rule** should be kept in mind.
General Syntax of constructing a formula is: \[ \text{cell reference1} \ <\text{operator}> \ \text{cell reference2} \ <\text{operator}> \ \ldots \ldots \ldots \ldots \]

Cell references are of two types (i) Relative cell reference (ii) Absolute Cell reference.

If you refer cell addresses directly while constructing formulae, it is called as “Relative Cell addressing”.

Examples of Relative Cell addressing:
- Adding values of A1, B1, C1, D1
  \[=A1+B1+C1+D1\]
- Subtract E4 from H3
  \[= H3 – E4\]
- Multiply A5 and B5
  \[= A5 * B5\]
- Average of G1, G2, G3, G4
  \[=(G1+G2+G3+G4)/4\]

In the above table, all cell references are “Relative cell addressing:”.

While writing a formula, if you use the $ symbol in front of a column name and row number, it will become an “Absolute Cell addressing”.

Examples of Absolute cell addressing:
- Adding values of A1, B1, C1, D1
  \[=$A$1+$B$1+$C$1+$D$1\]
- Subtract E4 from H3
  \[=$H$3 – $E$4\]
- Multiply A5 and B5
  \[=$A$5 * B5\]
- Average of G1, G2, G3, G4
  \[=($G$1+G2+$G$3+G4)/4\]

In an expression, all cells need not necessarily be relative or absolute. You can mix both type of references.

The following section explains the use of relative cell addressing. About “Absolute cell addressing”, you will be learn later in this chapter.

Finding Total to the above Illustration:
- Move the cell pointer to H2 (Total column)
- Type the following formula; after entering the formula, press “Enter” key
  \[=C2+D2+E2+F2+G2\] (Refere Figure 9.25)
- Now, you will get the sum of all the values of C2, D2, E2, F2 and G2
- The above-mentioned formula clearly stated that, how worksheets are working with cells.
- While referring to the cell addresses in a formula, the spreadsheet reads the value inside the cell that you refer. This is a good practice of constructing a formula. Because, if you change any value, the spreadsheet recalculates with that new value.
After entering a formula the result is display as in **Figure 9.23**

![Figure 9.23 Constructing formula in Worksheet](image)

### 9.6 Save, Close and Open the Worksheet:

#### 9.6.1 Saving Worksheet

The process of saving a worksheet is very similar to saving a document. Steps to save a worksheet are as follows:

**Step 1:** File → **Save** (or) Ctrl + S (or) Click “Save” icon on the standard tool bar.

**Step 2:** If the spreadsheet has not been saved previously, the Save As dialog box will appear.

**Step 3:** Type the name in “File Name” list box. OpenOffice Calc Spreadsheets are stored with extension `.ods` by default.

**Step 4:** Click “Save” button.

After clicking the save button, the given file name is displayed in the title bar as shown in **Figure 9.24**.
**File Extension:**

A file extension or file name extension helps to identify the type of file. Following table gives the file extension of commonly used files.

<table>
<thead>
<tr>
<th>Familiar File Type</th>
<th>Extension</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text Files</td>
<td>.txt</td>
</tr>
<tr>
<td>Microsoft Word Documents</td>
<td>.doc / .docx</td>
</tr>
<tr>
<td>OpenOffice Documents</td>
<td>.odt</td>
</tr>
<tr>
<td>Microsoft Excel</td>
<td>.xls / .xlsx</td>
</tr>
<tr>
<td>OpenOffice Calc</td>
<td>.ods</td>
</tr>
<tr>
<td>Microsoft PowerPoint</td>
<td>.ppt / .pptx</td>
</tr>
<tr>
<td>OpenOffice Impress</td>
<td>.odp</td>
</tr>
<tr>
<td>Executable Files / Applications</td>
<td>.exe</td>
</tr>
<tr>
<td>Web Pages</td>
<td>.htm / .html</td>
</tr>
<tr>
<td>Portable Document Format</td>
<td>.pdf</td>
</tr>
<tr>
<td>Photos</td>
<td>.jpg / .jpeg (Joint Photographic Experts Group)</td>
</tr>
<tr>
<td>Animated Images</td>
<td>.gif (Graphic Interchange Format)</td>
</tr>
<tr>
<td>Audio</td>
<td>.mp3</td>
</tr>
<tr>
<td>Audio / Video</td>
<td>.mp4</td>
</tr>
</tbody>
</table>
Note: The saved file is stored in the "Document folder" by default.

9.6.2 Auto Save:

The OpenOffice saves a file at regular intervals. This is called as “Auto Save” feature. The default time interval is 15 minutes. It can be reduced even to one minute. If any unexpected shutdown occurs, this feature will recover your file.

9.6.3 Closing a Worksheet

After saving the worksheet; it remains open. So, you can continue to working with the spreadsheet. When the work is finished, you should save using File → Save (or) Click “Save” icon (or) Ctrl + S and then to close the worksheet using File → Close command (or) Press Ctrl + W.

9.6.4 Opening an existing worksheet

9.6.4.1 Using Open dialog box

To reopen an existing worksheet, the File → Open command (or) “Open” icon (or) Ctrl + O can be used. An Open dialog box appears as shown in Figure 9.25 that is similar to “Save As” dialog box.

The name of the file to be opened can be chosen from the list or folder in which worksheet has been saved.

Figure 9.24 Saved Spreadsheet
9.6.4.2 Using Recent documents

OpenOffice keeps a list of recently opened files. File → Recent Documents option can be used to open an existing worksheet from the list as shown in Figure 9.26.

9.7 Copy, Cut and Paste

9.7.1 Copy and paste Data (Coping Data)

- Select the cell or cells you want to copy

- Select Edit → Copy or Click “Copy” icon from the standard toolbar or Press Ctrl + C.

- Move the cell pointer to the cell in which you want to paste.

- Select Edit → Paste or Click “Paste” icon or Press Ctrl + V.

9.7.2 Cut and Paste Data (Moving Data)

- Select the cell or cells you want to cut

- Select Edit → Cut or Click “Cut” icon from the standard toolbar or Press Ctrl + X.

- Move the cell pointer to the cell in which you want to paste.

- Select Edit → Paste or Click “Paste” icon or Press Ctrl + V.

Figure 9.25 Open Dialog box

Figure 9.26 List of Recent Documents
9.7.3 Copy and Paste Formula

- The process of Copy and Paste data is used for copying formula.
- When you copy a formula from one cell to another cell, the address of the pasted formula will change according to its row. This is called “Relative Cell Reference” (Refer Figure 9.27).

Example:

While pasted it becomes = B3 * C3

Figure 9.27 Copy and Paste formula to multiple cells

9.7.4 Copy a formula from one cell and paste it in multiple cells:

(For illustration 1 - Refer Figure 9.23)

Step 1: Copy the formula from H2 using \text{Ctrl} + \text{C} or \text{Edit} \rightarrow \text{Copy} (or) click “Copy” icon.

Step 2: Select all cells (i.e. H3 to H11) in which you want to paste the addition formula.

Step 3: Paste the copied formula using \text{Ctrl} + \text{V} or \text{Edit} \rightarrow \text{Paste} (or) Click “Paste” icon.
Self Practice:
1. Open the spreadsheet which was created in Illustration 1.
2. Add one more column heading “Average” in I1.
3. Create a formula to find the average of all marks in I2.
4. Apply the formula to the remaining cells.
5. Save the changes and close the file.

9.8 Auto Fill Feature:

You have learnt how to copy and paste a formula from one cell to other cells in the previous section. The process of copy and paste can be replaced by a click and drag and it is called as “Auto Fill”. This is an alternate way to copy and paste.

Auto Fill feature fills the contents from one cell to all the dragged cells. The content may be a data or formula. If you fill a relative formula, all the addresses of filled formulae will be changed.

![Drag Fill Handle]

Figure 9.29 Drag fill handle

Cell pointer’s “Drag fill handle” is used to auto fill. Just click and drag this handle to fill the contents. It can be dragged towards right or down. Same can be achieved by Edit → Fill → Down (or) Edit → Fill → Right.

9.8.1 Auto Fill Series:

Auto Fill is also used to generate a series of values. For example, if you want to generate 1,2,3…… up to some length; it can be done by a simply clicking and dragging over.

Generating whole number series: (Refer Figure 9.30).

Step 1: In cell A1, type as 1 (one) and press enter.
Step 2: Click A1 to place the cell pointer.
Step 3: Click “Drag Fill Handle” of cell pointer; now the mouse pointer becomes a small +.
Step 4: Drag over the cells; while dragging, the generated values will be displayed.
Step 5: Release the mouse pointer. Selected cells will be filled with series of values.
9.8.2 Generating series using command

Edit → Fill → Series Command is used to generate different set of series. Before using this feature, a set of cells should be selected. Using Fill Series feature, you can fill series of values at any direction. (Remember that, auto fill only fills either right or down). Refer Figure 9.31.

Direction: Down / Right / Up / Left (Selected cell direction will be default)

Series type:

Linear: To generate a sequence of series (Example 2,4,6,8,10…….)

Growth: To generate multiplication series (Example 2,4,8,16,32,64…….)

Date: To generate date series (when you select date as series type; time unit section gets enabled)

AutoFill: To generate a continuous series of values (1,2,3,…….). When you select “AutoFill”, Time unit section, End value and Increment text boxes become disabled.

Time Unit: (Enabled only when you select the series type as “Date”)

Day: To generate date series day-wise
Weekday: To generate date series weekday-wise
Month: To generate date series month-wise
Year: To generate date series year-wise
Start Value:

- Initial value of the series should be typed

End Value:

- End value of the series should be typed
- If you fail to specify the end value, series will be generated upto the selected cells.

![Fill Series dialog box](image)

*Figure 9.31 Fill series dialog box*

- If your selection is less than the specified end value, series will be generated only upto the selected cells.

Increment:

- It is a middle value between the first and second value of your series. So, the next value (Third value) of the series will be generated based on this value.
- If you want to generate a decreasing order series, negative value should be specified as an increment value.

Self Practice:

(i) Generate Even number series from 2 to 20
(ii) Generate a series of 5, 10, 15, 20 ……. upto selected cells.
(iii) Generate a series of 2,4,8,16,………. 2048
(iv) Generate a series of 33, 30, 27 ……. upto 3
(v) Assume, today is Friday and generate next 25 Fridays (Date series).
9.8.3 Date Arithmetic:

Manual date calculations can be tricky because you have to keep track of the number of days in a month. In spreadsheets, date calculations become very simple. Here you can add a number to a date and arrive at a new date, find the difference between two dates and use a wide variety of function and formats to get what you want.

For example, enter a date 02/26/2018 in a cell, say A2. Suppose you want to calculate the date 80 days after this date. To do so, enter the formula, \( A2 + 80 \), in another cell, say A4.

The date 05/17/18 appears in the cell.

To Find out how many days since your birth?

- Type today’s date in first cell.
- Type your birth date in second cell.
- Type the following formula in third cell = first_cell_reference – second_cell_reference

```
<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>B</td>
<td></td>
<td>C</td>
</tr>
<tr>
<td>---</td>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>Today</td>
<td>01/15/18</td>
<td></td>
</tr>
<tr>
<td>My Birth Date</td>
<td>09/30/03</td>
<td></td>
</tr>
<tr>
<td>No. of days</td>
<td>5221</td>
<td></td>
</tr>
</tbody>
</table>
```

Edit and Formatting Worksheet

9.9 Inserting Columns, Rows and Cells

In Calc, Columns, rows and cells can be inserted individually or in groups.

9.9.1 Inserting a Column:

When you insert a new column, it is inserted to the left of the current column. The location of the cell pointer present, is the Current column. In Calc, you can insert a new column anywhere in the worksheet.

**Step 1:** Select the column where a new column to be inserted.

**Step 2:** Right-click on the selected column name that you selected. A pop-up menu appears.
Step 3: click the “Insert Columns” option from the menu.

Now, a new column will be inserted to the left of the current column.

A new column can also be inserted using Insert → Columns command. (Refer Figure 9.32).

Figure 9.32 Insert Column pop-up menu

Figure 9.33 Insert Column menu bar
Practical Practice:
1. Open the spreadsheet which was created in Illustration 1.
2. Insert a new column between column E and F
3. Give the heading as “Eco” and Enter the Economics marks for all the students
4. Insert one more column between the columns, Name and Tamil marks.
5. Give the heading as “Date of Birth” and Enter the date of birth for all the students.
6. Save the changes and close the file.

9.9.2 Inserting Rows

When you insert a new row, it is inserted above the current row. The location of the cell pointer present is the current row. In Calc, you can insert a new row anywhere in the worksheet.

Step 1: Select the row where a new row to be inserted.

Step 2: Right-click on the row number, a pop-up menu appears

Step 3: click “Insert Rows” option from the menu.

Now, a new row will be inserted to above the current row.

![Figure 9.34 Insert Rows popup menu]

Select "Insert Rows"
**Insert → Rows** command is used to insert a new row. Refer Figure 9.35.

**Figure 9.35 Insert Rows menu bar**

Self Practice:

1. Open the spreadsheet which was created in Illustration 1.
2. Insert 8 rows one by one, then insert the following student details
3. Save the changes and close the file.

<table>
<thead>
<tr>
<th>Reg. No</th>
<th>Name</th>
<th>Date of Birth</th>
<th>Tam</th>
<th>Eng</th>
<th>CS</th>
<th>Eco</th>
<th>Com</th>
<th>Acc</th>
</tr>
</thead>
<tbody>
<tr>
<td>12101</td>
<td>Sarika S</td>
<td>26/05/2001</td>
<td>145</td>
<td>135</td>
<td>145</td>
<td>125</td>
<td>180</td>
<td>196</td>
</tr>
<tr>
<td>12102</td>
<td>Jewees Celcy J</td>
<td>11/04/2001</td>
<td>102</td>
<td>165</td>
<td>134</td>
<td>95</td>
<td>180</td>
<td>134</td>
</tr>
<tr>
<td>12103</td>
<td>Yuvarani T</td>
<td>27/06/1999</td>
<td>172</td>
<td>130</td>
<td>107</td>
<td>155</td>
<td>162</td>
<td>130</td>
</tr>
<tr>
<td>12104</td>
<td>Meharunisha I</td>
<td>30/05/2001</td>
<td>132</td>
<td>146</td>
<td>112</td>
<td>185</td>
<td>192</td>
<td>176</td>
</tr>
<tr>
<td>12105</td>
<td>Priya W</td>
<td>07/03/2000</td>
<td>130</td>
<td>172</td>
<td>100</td>
<td>92</td>
<td>162</td>
<td>155</td>
</tr>
<tr>
<td>12106</td>
<td>Vijaya Vasavi K</td>
<td>03/06/2001</td>
<td>198</td>
<td>175</td>
<td>149</td>
<td>148</td>
<td>158</td>
<td>135</td>
</tr>
<tr>
<td>12107</td>
<td>Deepika B</td>
<td>14/03/2001</td>
<td>120</td>
<td>182</td>
<td>103</td>
<td>144</td>
<td>107</td>
<td>186</td>
</tr>
<tr>
<td>12108</td>
<td>Viji V</td>
<td>19/04/2001</td>
<td>137</td>
<td>173</td>
<td>128</td>
<td>148</td>
<td>125</td>
<td>177</td>
</tr>
</tbody>
</table>
9.9.3 Inserting Cells

- To insert a new cell between two existing cells, just right-click on any existing cell.
- From the pop-up menu, select “Insert” option Figure 7.36 Insert cells.
- The “Insert Cells” dialog box appears with four options:
  i) Shift cells down  
  ii) Shift cells right  
  iii) Entire row  
  iv) Entire Column
- Any one of the four options is selected.
- Selecting “Shift cells down”, inserts a new cell in the present location and the existing cells are shifted downwards.
- Selecting “Shift cells right”, inserts a new cell in the present location and the existing cells are shifted towards right.
- Selecting the “Entire Row” or “Entire Column” option, inserts a new row or a new column.

![Insert Cells dialog box](image)

*Figure 9.36 Insert cells*

9.9.4 Inserting multiple columns or rows

Multiple columns or rows can be inserted at once rather than inserting one at a time.

- Select multiple rows or columns for insertion.
- Follow steps as in 9.9.1 and 9.9.2.

9.9.5 Inserting Columns, Rows and Cells using “Insert Cells” Toolbar

- Insert Cells floating toolbar is also used to insert cells, rows and columns.
- Click View → Toolbars → Insert Cell.
- A tiny floating toolbar appears on the screen with four icons. Using these icons, you can insert cells, rows and columns. Refer Figure 9.37.

30
9.10 Deleting columns and rows

A single or multiple columns or rows can be deleted.

**Technically this is NOT POSSIBLE.**

Additional column, row or even cell cannot be inserted in any spreadsheet. When you insert a column or row, the contents within the column or row will be shifted to the next column or row. But visually it is felt that a new column or row has been inserted.

9.10.1 Delete single column or row

A single column or row can be deleted by using the mouse:

- Select the column or row to be deleted.
- Choose **Edit → Delete Cells** from the menu bar.

(Or)

- **Right-click** on the column or row header.
- Choose **Delete Columns** or **Delete Rows** from the pop-up menu.

9.10.2 Delete multiple columns or rows

Multiple columns or rows can be deleted at a time. Refer **Figure 7.38**.

- Select the required columns or rows for deletion.
- **Right-click** on the selected columns or row.
- Choose **Delete Columns** or **Delete Rows** from the pop-up menu or **Edit → Delete Cells**.

**Practical Practice:**

1. Open the spreadsheet which was created in Illustration 1.
2. Delete the details of any 3 students. Save the changes and close the file.

**Deleting Column or Row is not Possible**

Same as inserting column or row, Deleting a column or row is also not possible. No one can delete any column or row in a spreadsheet. When you delete a column or row, all the contents will be removed from the column or row. Actually, this is also another kind of deleting contents from a column or row.
9.11 Formatting Worksheet

Formatting Data in a cell gives additional effect to the text. Additional effect includes changing the font style, font size, automatic wrapping, bold, underline, italic etc. The data in Calc can be formatted in several ways. Using formatting icons can be used.

9.11.1 Text Formatting

Making the cell contents as bold, italics, underlined, changing font style, size, colour etc., comes under text formatting. All text formatting options are available as icons in Formatting toolbar learnt in OpenOffice Writer. Figure 9.39(a) Text Formatting Toolbar
<table>
<thead>
<tr>
<th>Formatting Option</th>
<th>Keyboard Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Font style</td>
<td>Used to change Font style</td>
<td></td>
</tr>
<tr>
<td>Font size</td>
<td>Used to change Font size</td>
<td></td>
</tr>
<tr>
<td>Bold</td>
<td>Ctrl + B</td>
<td>Used to make the data as Bold</td>
</tr>
<tr>
<td>Italic</td>
<td>Ctrl + I</td>
<td>Used to italicize data</td>
</tr>
<tr>
<td>Underline</td>
<td>Ctrl + U</td>
<td>Used to underline the data</td>
</tr>
<tr>
<td>Left Align</td>
<td>Ctrl + L</td>
<td>Left Align data within a cell</td>
</tr>
<tr>
<td>Right Align</td>
<td>Ctrl + R</td>
<td>Right Align data within a cell</td>
</tr>
<tr>
<td>Center Align</td>
<td>Ctrl + E</td>
<td>Center the data within a cell</td>
</tr>
<tr>
<td>Justify</td>
<td>Ctrl + J</td>
<td>Align the data evenly both on left and right side of a cell</td>
</tr>
<tr>
<td>Merge cell</td>
<td>Makes selected cells as a single cell</td>
<td></td>
</tr>
</tbody>
</table>

9.11.2 Number formatting

Number formatting options are used to visually change the format of a numeric content. These formatting changes are appear for visual as, it does not change the original value. For example, To display a number as currency form use Number format: Currency.

Number format: Currency will be used as shown Figure 9.39(b).

![Figure 9.39 (b) Formatting toolbar](image)

<table>
<thead>
<tr>
<th>Number Format</th>
<th>Keyboard Shortcuts</th>
</tr>
</thead>
<tbody>
<tr>
<td>Currency Symbol</td>
<td>Ctrl+Shift+4</td>
</tr>
<tr>
<td>Percent</td>
<td>Ctrl+Shift+5</td>
</tr>
<tr>
<td>Standard</td>
<td>Ctrl+Shift+6</td>
</tr>
<tr>
<td>Add Decimal Place</td>
<td>Ctrl+Shift+6</td>
</tr>
<tr>
<td>Delete Decimal Place</td>
<td>Ctrl+Shift+6</td>
</tr>
</tbody>
</table>
### Practical Practice:

1. Open the spreadsheet which was created in Illustration 1.
2. Align all headings as center and make them bold.
3. Align all Register numbers and marks in center.
4. Apply different font styles to the entire worksheet.
5. Save the changes and close the file.

### Workshop 1

1. Create a worksheet with following data

<table>
<thead>
<tr>
<th>Emp. No</th>
<th>Name of Emp.</th>
<th>Basic</th>
<th>DA</th>
<th>HRA</th>
<th>CCA</th>
<th>MA</th>
<th>GPF</th>
<th>IT</th>
<th>HF</th>
</tr>
</thead>
<tbody>
<tr>
<td>1001</td>
<td>Manivannan M</td>
<td>25500</td>
<td></td>
<td></td>
<td></td>
<td>600</td>
<td>300</td>
<td></td>
<td></td>
</tr>
<tr>
<td>1002</td>
<td>Kannan K</td>
<td>20200</td>
<td></td>
<td></td>
<td></td>
<td>600</td>
<td>300</td>
<td></td>
<td></td>
</tr>
<tr>
<td>1003</td>
<td>Gowrishankar N V</td>
<td>24300</td>
<td></td>
<td></td>
<td></td>
<td>600</td>
<td>300</td>
<td></td>
<td></td>
</tr>
<tr>
<td>1004</td>
<td>Lenin K</td>
<td>23400</td>
<td></td>
<td></td>
<td></td>
<td>600</td>
<td>300</td>
<td></td>
<td></td>
</tr>
<tr>
<td>1005</td>
<td>Suryanarayanan T</td>
<td>24100</td>
<td></td>
<td></td>
<td></td>
<td>600</td>
<td>300</td>
<td></td>
<td></td>
</tr>
<tr>
<td>1006</td>
<td>Ramesh K</td>
<td>18500</td>
<td></td>
<td></td>
<td></td>
<td>600</td>
<td>300</td>
<td></td>
<td></td>
</tr>
<tr>
<td>1007</td>
<td>Govindasami A</td>
<td>13200</td>
<td></td>
<td></td>
<td></td>
<td>600</td>
<td>300</td>
<td></td>
<td></td>
</tr>
<tr>
<td>1008</td>
<td>Kannan S</td>
<td>20250</td>
<td></td>
<td></td>
<td></td>
<td>600</td>
<td>300</td>
<td></td>
<td></td>
</tr>
<tr>
<td>1009</td>
<td>Penchil Rao K</td>
<td>28300</td>
<td></td>
<td></td>
<td></td>
<td>600</td>
<td>300</td>
<td></td>
<td></td>
</tr>
<tr>
<td>1010</td>
<td>Logeswaran M</td>
<td>30200</td>
<td></td>
<td></td>
<td></td>
<td>600</td>
<td>300</td>
<td></td>
<td></td>
</tr>
<tr>
<td>1011</td>
<td>Arumugam E</td>
<td>12000</td>
<td></td>
<td></td>
<td></td>
<td>600</td>
<td>300</td>
<td></td>
<td></td>
</tr>
<tr>
<td>1012</td>
<td>Vasu G N</td>
<td>25000</td>
<td></td>
<td></td>
<td></td>
<td>600</td>
<td>300</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Based on the above data,

(1) Calculate the Gross Salary, Total Deductions and Net Salary

(2) Insert “IT Cess” column and calculate 3% of cess to all employees
(3) Delete the records of “Govindasami” and “Arumugam”.

(4) Insert four new rows and enter the following employee details.

(5) Calculate the Total amount of GPF, IT and Cess

<table>
<thead>
<tr>
<th>Emp. No</th>
<th>Name of Emp.</th>
<th>Basic</th>
<th>DA</th>
<th>HRA</th>
<th>CCA</th>
<th>MA</th>
<th>GPF</th>
<th>IT</th>
<th>HF</th>
</tr>
</thead>
<tbody>
<tr>
<td>2001</td>
<td>Murali G</td>
<td>24750</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2002</td>
<td>Munirathnam A</td>
<td>23550</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2003</td>
<td>Ramakrishnan V G</td>
<td>25500</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2004</td>
<td>Srinivasan R</td>
<td>27500</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Workshop: 2

1. Create a new worksheet in OpenOffice Calc.

2. Enter the following stock and sales details of “Chennai whole sale Marketing Pvt. Ltd.” during the month of Jan-2018.

<table>
<thead>
<tr>
<th>Code</th>
<th>Product Name</th>
<th>Weight (gm)</th>
<th>Opening stock</th>
<th>Cost price</th>
<th>Sales in units</th>
<th>Rate of Discount</th>
<th>Amount of Discount</th>
<th>Selling price</th>
<th>Amount of Sale</th>
<th>Closing Stock</th>
</tr>
</thead>
<tbody>
<tr>
<td>100</td>
<td>Marie Gold</td>
<td>120</td>
<td>345</td>
<td>15</td>
<td>147</td>
<td>5%</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>101</td>
<td>Milk Bikis</td>
<td>85</td>
<td>106</td>
<td>10</td>
<td>63</td>
<td>5%</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>102</td>
<td>Dark Fantasy</td>
<td>75</td>
<td>147</td>
<td>25</td>
<td>43</td>
<td>3%</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>103</td>
<td>Nutri Choice</td>
<td>250</td>
<td>98</td>
<td>50</td>
<td>12</td>
<td>10%</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>104</td>
<td>Lays potato chips</td>
<td>52</td>
<td>172</td>
<td>15</td>
<td>152</td>
<td>4%</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>105</td>
<td>Oreo</td>
<td>120</td>
<td>112</td>
<td>25</td>
<td>85</td>
<td>6%</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

3. Calculate the following using formula

(i) Amount of Discount, Selling price and Amount of sales for each product

(ii) Total amount of discount and Sales of the month

(iii) Closing stock of each product
Workshop: 3

1. Create a worksheet in OpenOffice Calc.

2. Enter the following details of loan sanctioned during the month of January 2018 of “Tamil Finance Corporation”.

<table>
<thead>
<tr>
<th>AC No</th>
<th>Name</th>
<th>Amount of Loan</th>
<th>Loan Sanction date</th>
<th>Duration of Loan</th>
<th>Rate of Interest</th>
<th>Interest (Rs)</th>
<th>Total Amount</th>
<th>Due date</th>
</tr>
</thead>
<tbody>
<tr>
<td>2001</td>
<td>Senthil</td>
<td>250000</td>
<td>02/01/2018</td>
<td>120 days</td>
<td>9.5%</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2002</td>
<td>Kumar</td>
<td>175000</td>
<td>15/01/2018</td>
<td>150 days</td>
<td>9.5%</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2003</td>
<td>Ibrahim</td>
<td>550000</td>
<td>16/01/2018</td>
<td>140 days</td>
<td>10.5%</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2004</td>
<td>Valli</td>
<td>375000</td>
<td>21/01/2018</td>
<td>210 days</td>
<td>10%</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2005</td>
<td>Charles</td>
<td>450000</td>
<td>28/01/2018</td>
<td>130 days</td>
<td>10.5%</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

3. Create the formula to calculate

(i) Interest, Total amount and due date.

(ii) Grass total of amount of loan, interest and total amount.

4. Insert 5 new rows between Kumar and Ibrahim and include the following details

<table>
<thead>
<tr>
<th>AC No</th>
<th>Name</th>
<th>Amount of Loan</th>
<th>Loan Sanction date</th>
<th>Duration of Loan</th>
<th>Rate of Interest</th>
<th>Interest (Rs)</th>
<th>Total Amount</th>
<th>Due date</th>
</tr>
</thead>
<tbody>
<tr>
<td>3001</td>
<td>Pari</td>
<td>250000</td>
<td>03/02/2018</td>
<td>125 days</td>
<td>9.5%</td>
<td>5%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3002</td>
<td>Arul</td>
<td>375000</td>
<td>07/02/2018</td>
<td>155 days</td>
<td>9.5%</td>
<td>5%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3003</td>
<td>Raman</td>
<td>350000</td>
<td>10/02/2018</td>
<td>130 days</td>
<td>10.5%</td>
<td>3%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3004</td>
<td>Givind</td>
<td>450000</td>
<td>10/02/2018</td>
<td>100 days</td>
<td>10%</td>
<td>10%</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3005</td>
<td>Zeenath</td>
<td>800000</td>
<td>26/02/2018</td>
<td>90 days</td>
<td>10%</td>
<td>4%</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Points to Remember:

- Spreadsheet is a very useful office automation tool for organization, analysis and storage of data in a tabular form.
- Daniel Bricklin and Bob Frankston developed the first spreadsheet software called “VisiCalc” in 1979 for Apple II.
- OpenOffice Calc is popular open source spreadsheet application software presently maintained by Apache Foundation.
- A worksheet is a grid of cells with a programmable calculator attached to each cell.
- OpenOffice Calc version 4.1.5 contains a total of 1024 columns and 10,48,576 rows.
- Intersection of every row and column makes a box which is called as “Cell”.
- Cell pointer is a rectangle element which can be moved around the worksheet.
- The cell in which the cell pointer is currently located is known as “Active cell”.
- All formula should start with an equal sign.
- There are four types operators supported by calc.

Activity

Student Activity

1. Based on the concept of calculation using formula make the students to create various worksheet data.

Teacher Activity

1. To show the demo of working with spread sheets using simple example in class room.
Choose the correct answer

1. Which is the first electronic spreadsheet?
   (A) Excel  (B) Lotus 1-2-3  (C) Visicalc  (D) OpenOffice Calc

2. Which of the following applications was the parent to OpenOffice Calc?
   (A) Visicalc  (B) LibreCalc  (C) Lotus 123  (D) StarOffice Calc

3. Grid of cells with a programmable calculator:
   (A) Spreadsheet  (B) Database  (C) Word processor  (D) Linux

4. A column heading in Calc is a
   (A) Number  (B) Symbol  (C) Date  (D) Alphabet

5. Which key is used to move the cell pointer in the forward direction within the worksheet?
   (A) Enter  (B) Tab  (C) Shift + Tab  (D) Delete

6. A formula in calc may begin with
   (A) =  (B) +  (C) -  (D) All the above

7. What will be the result from the following formula (Assume A1=5, B2=2)? + A1^B2
   (A) 7  (B) 25  (C) 10  (D) 52

8. What will be the result from the following expression (Assume H1=12, H2=12)? = H1<>H2
   (A) True  (B) False  (C) 24  (D) 1212

9. Which of the following symbol is used to make a cell address as an absolute reference?
   (A) +  (B) %  (C) &  (D) $

10. Which of the following key combination is used to increase the width of the current column?
    (A) Alt + Right arrow  (B) Ctrl + Right arrow
    (B) Alt + Left arrow  (D) Ctrl + Left arrow
Part – II

Answer to the following questions (2 Marks)

1. What are the types of toolbars available in OpenOffice calc?
2. What is a Cell pointer?
3. Write about the text operator in OpenOffice Calc.
4. Write the general syntax of constructing a formula in Calc.
5. What are the keyboard shortcuts to cut, copy and paste?
6. Can you edit the contents of a cell? If yes, explain any one of the method of editing the cell content.
7. What are the options available in “Insert Cells” dialog box?
8. Match the following

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
</tr>
</thead>
<tbody>
<tr>
<td>(a) Cut, Copy and Paste</td>
<td>(1) Absolute Cell</td>
</tr>
<tr>
<td>(b) Cell pointer</td>
<td>(2) Status bar</td>
</tr>
<tr>
<td>(c) Selection Mode</td>
<td>(3) Standard Toolbar</td>
</tr>
<tr>
<td>(d) $A$5</td>
<td>(4) Active cell</td>
</tr>
</tbody>
</table>

9. Define the following (i) Text Operator (ii) Rows and Columns of spreadsheet
10. Differentiate between Copy -Paste and Cut-Paste

Part – III

Answer to the following questions (3 Marks)

1. Write a short note on OpenOffice Calc.
2. Write about inserting columns and rows in Calc.
3. Differentiate Deleting data using Backspace and Delete
4. Write any three formatting options.
5. In cell A1=34 A2=65 A3=89 write the formula to find the average.
Part – IV

Answer to the following questions (5 Marks)

1. Explain about changing the column width in Calc.

2. Write the steps to generate the following series. 5, 10, 20….. 2560

3. Read the following table

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th></th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Year</td>
<td>Chennai</td>
<td>Madurai</td>
<td>Tiruchi</td>
<td>Coimbatore</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>2012</td>
<td>1500</td>
<td>1250</td>
<td>1000</td>
<td>500</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>2013</td>
<td>1600</td>
<td>1000</td>
<td>950</td>
<td>350</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>2014</td>
<td>1900</td>
<td>1320</td>
<td>750</td>
<td>300</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>2015</td>
<td>1850</td>
<td>1415</td>
<td>820</td>
<td>200</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>2016</td>
<td>1950</td>
<td>1240</td>
<td>920</td>
<td>250</td>
<td></td>
</tr>
</tbody>
</table>

Above table shows the sales figures for “Air Cooler” sold in four major cities of Tamilnadu from the year 2012 to 2016. Based on this data, write the formula to calculate the following.

(1) Total sales in the year 2015.

(2) Total sales in Coimbatore from 2012 to 2016.

(3) Total sales in Madurai and Tiruchi during 2015 and 2016.

(4) Average sales in Chennai from 2012 to 2016

(5) In 2016, how many “Air Coolers” are sold in Chennai compared to Coimbatore?
| **Glossary** |
|-------------------|------------------------------------------------------------------------------|
| **Spreadsheets**   | Sheet of paper that shows accounting or other data in rows and columns      |
| **What-if analysis** | It is a process of changing the values in a cell to see how those changes will affect output. |
| **VisiCalc**       | The first electronic spreadsheet application                                 |
| **GUI**            | Graphical User Interface                                                     |
| **Excel**          | Familiar spreadsheet application developed by Microsoft Corporation.         |
| **Cell**           | Intersection of rows and columns                                             |
| **Cell Pointer**   | A rectangular box, highlighting the cell in a spreadsheet.                   |
| **Active cell**    | A cell in which the cell pointer is presently locating                      |
| **Formula**        | A formula is an expression telling the computer what mathematical operation to perform upon a specific value. |
| **Operator**       | A symbol that usually represents an action or process                        |
| **Range**          | Group / Collection of cells                                                  |
| **BODMAS Rule**    | Order of mathematical calculation: Brackets - Orders (powers or square roots) - Division – Multiplication – Addition - Subtraction. |
| **Drag fill handle** | A small black box at the bottom right corner of the cell pointer.          |
| **Function**       | Predefined formula / A group of instructions to return a single result or a set of results. |
| **Chart**          | Graphical representation of data.                                           |
| **Database**       | A large quantity of indexed digital information.                            |
| **Flat file database** | Single table, non relative database                                        |
Learning Objectives

Students will be able

- To know how to work with multiple sheets.
- To learn to rename, delete worksheet.
- To know to copy, move and change the order the sheets.
- To understand how to select cells, columns and rows.
- To learn how to format tool bar.
- To understand the types of cell referencing
- To know how to use functions in Open Office calc.
- To learn to create charts in Open Office Calc.

10.1 – Managing Worksheets

10.1.1 – Selecting Worksheets

One or multiple sheets can be selected using a mouse. It can be advantageous to select multiple sheets at times when you want to make changes to many sheets at a time

10.1.2 Selecting single sheet

Click on the sheet tab for the sheet you want to select. The active sheet becomes white and any actions that you perform will now affect the selected cells in the sheet.

![Figure 10.1 Selecting Single Sheet](image-url)
If you want unselect the selection, click on any unselected sheet.

10.1.3. Selecting multiple continuous sheets

The following steps should be followed to select multiple continuous sheets.

- Click on the sheet tab for the first desired sheet.
- Hold down the Shift key and click on the last sheet tab.

All the tabs between these two sheets will be selected and turn white. Any actions that you perform will now affect all highlighted sheets. For example, if you want to select from sheet1 to sheet5. Do the following,

Step 1: Click on Sheet1 to select first sheet
Step 2: Press and held down “Shift” key and Click on the Sheet 5 i.e., last sheet

All the sheets between Sheet1 and Sheet5 will be selected and their sheet colour turns to white as given in the Figure X.X and any actions that you perform will now affect all highlighted sheets.

If you want to unselect the selection, click on any unselected sheet.

10.1.4 Selecting multiple non-continuous sheets.

If you want to select multiple non-continuous sheets the following steps will be followed.

- Click on any sheet,
- Hold down the Ctrl key,
- Click another sheet.

Ctrl + Click on any sheet is used to select multiple sheets. Selected sheets tab colour turns into “White”.

Figure 10.2  Multiple continuous sheets
For example, if you want to select Sheet1, Sheet3 and Sheet 7;

Step 1: Click on **Sheet1** and then

Step 2: Hold down the **Ctrl** key

Step 3: **Click on Sheet3** and then **Sheet 7**.

Selected Sheets colour becomes "**White**" and any actions that you perform will now affect all Selected sheets.

---

**Figure 10.3  Selecting Multiple non-continous sheets**

---

10.2 Selecting all sheets

To select all sheets, **Right-click** any one of the sheet tabs and choose **Select All Sheets** option from the pop-up menu.

---

**Figure 10.4 (a) - Selecting all sheets**

---

**Figure 10.4(b) - Selecting all sheets**
Deselect sheets

Deselect the selected sheet is very simple process. The following table shows you to deselect methods for various selections.

<table>
<thead>
<tr>
<th>SN</th>
<th>Selection Type</th>
<th>Deselect process</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Single Sheet</td>
<td>Click on any unselected sheet</td>
</tr>
<tr>
<td>2</td>
<td>Multiple continuous sheets</td>
<td>Click on any unselected sheet</td>
</tr>
<tr>
<td>3</td>
<td>Multiple non-continuous sheets</td>
<td>Click on any unselected sheet</td>
</tr>
<tr>
<td>4</td>
<td>All sheets</td>
<td>Click on any sheet</td>
</tr>
</tbody>
</table>

To deselect the already selected sheets, **Right-click** → **Deselect All Sheets** option from the pop-up menu is also used.

### 10.3 – Renaming Worksheets

The default name of a new sheet is Sheet-n, where n is a number. There are two methods to give a more meaningful name to a sheet.

Method 1:
- Double-click on a Sheet in which you want rename
- A small “Rename Sheet” box is appears as shown in Figure 10.6

Method 2:
- **Right-click** on a sheet tab and choose **Rename Sheet** option from the pop-up menu now.
- Now **Rename Sheet** dialog box appears and type a new name and then click on **ok** button.

Sheet names must start with either a letter or a number or some special characters like &,!,@ etc. Attempting to rename a sheet with an invalid name will produce an error message.

### 10.3.1 – Inserting and Deleting Worksheets

When you create a new worksheet, three sheets are there by default. If needed, one or more new worksheets can be added or deleted.
10.3.1 – Inserting Worksheets

There are different ways to insert a new sheet with existing worksheets.

Step 1:

- **Right-click** on a sheet tab and choose Insert Sheet option from the pop-up menu now.
  
  (or)
  
- Choose **Insert → Sheet** option from the menu bar.
  
  (or)
  
- Click the **space bar** between last sheet and horizontal scroll bar.

![Figure 10.7 Inserting more sheets](image)

**Figure 10.7** Inserting more sheets

Step 2:

- “Insert Sheets” dialog box appears.
In this dialog box,

- Set position by clicking “Before current sheet” or “After current sheet”. If you select “Before” the new sheet(s) will inserted left side of the active sheet ie., selected sheet. If you select “After”, the new sheet(s) will inserted right side of the active sheet.

- Type or spin the number of sheets you need to insert. If you type or spin one sheet, Name box will be activated, and you can enter new name of the sheet to be inserted. If you set more sheets, Name box will be disabled.

- The minimum number of sheet must be one and maximum will be 253 (OpenOffice Calc 4.1.5).

- Finally, click OK button.

10.3.2 – Deleting Worksheets

In a worksheet sheets can be deleted individually or in groups.

To delete single sheet:

1. Right-click on the tab of the sheet which is to deleted and choose. Delete Sheet from the pop-up menu, or
2. Choose **Edit → Sheet → Delete** from the Menu bar.

![Figure 10.9 Delete Sheet](image)

3. Either way, an alert will ask if you want to delete the sheet permanently. Click **Yes**.

**To delete multiple sheets:**

To delete multiple sheets, select them as mentioned earlier and either right-click over one of the tabs and choose **Delete Sheet** from the pop-up menu, or choose **Edit → Sheet → Delete** from the menu bar. Rest of the procedure are similar to delete a single sheet what you learnt earlier.

**10.4 – Copy, Move and change the order of sheets**

Click and drag the sheet tab is the simple way to move the sheets.

Menu also can be used to move sheets.

1. **Right-click** the sheet you want to move and select **Move/Copy Sheet** from the pop-up menu, or select **Edit → Sheet → Move/Copy** from the main menu.
2. Specify the new position of the sheet in the Move/Copy Sheet dialog box. You can even move the sheet to a different document that is opened in Calc.

3. **Copy** option to be selected to copy sheet.

4. Click **OK**.

---

### 10.5 - Selecting Cells, Columns and Rows

#### 10.5.1 Selecting a single cell:

- Move the mouse pointer to a cell and click to select a cell (or)

- Specify required cell address in the address bar to select a cell.
10.5.2 Selecting Multiple Cells:

Continuous cells can be selected using the keyboard or the mouse.

10.5.2.1 Selecting Multiple cells using mouse:

- Click in a cell.
- Press and hold down the left mouse button.
- Move the mouse around the screen.
- Once the desired block of cells is selected, release the left mouse button.

10.5.2.2 Selecting a multiple cells using keyboard:

- Select the required cell.
- While holding down the Shift key, use the cursor movement arrow keys to select the rest of the range.

10.5.3 Selecting single column or single row:

- To select a single column, click on the column identifier letter
- To select a single row, click on the row identifier number.

Figure 10.12 Selecting Multiple Sheets
10.5.4 Selecting Continuous multiple columns or rows

- Click on the first column or row in the group.
- Hold down the Shift key.

Click the last column or row in the group.

10.5.5 Selecting multiple columns or rows that are not continuous:

- Click on the first column or row in the group.
• Hold down the Ctrl key.

• Click on all of the subsequent columns or rows while holding down the Ctrl key.

To select range of non-continuous cells

• Select the cell or range of cells using one of the methods above.

• Move the mouse pointer to the start of the next range or single cell.

• Hold down the Ctrl key and Click or Click-and-drag to select another range of cells with already selected range.

• Repeat if necessary.

10.6 – Hide/Show Rows and Columns

When elements are hidden, they are neither visible nor printed, but can still be selected for copying if you select the elements around them. For example, if column B is hidden, it is copied when you select columns A and C. When you need a hidden element again, you can reverse the process, and show the element.

• To hide or show rows and columns, use the option in the Format menu or the right-click and choose from pop-up menu.

• To hide a row/column, first select the row/column, and then use menu options,

• Format → Row → Hide or Format → Column → Hide to hide row and column respectively.

• The same can be achieved by choosing “Hide” option from the pop-up menu when you right-click the selected row/column.

• To show the hidden row / column, choose Format → Row → Show or Format → Column → Show (or)

• Right-click and choose Show from pop-up menu.

10.7 - Freezing and Unfreezing rows and columns

Freezing locks number of rows at the top of a spreadsheet or number of columns on the left of a spreadsheet or both. Frozen columns and rows remain the view during scrolling, whereas other rows and columns gets scrolled.

Freezing single rows or columns:

1. Click on the Header for the row below where to the freeze or for the column to the right of where to freeze.

2. Choose the Window → Freeze. A dark line appears, indicating where the freeze is put.

Freezing a row and a column:

1. Click the Cell that is immediately below the row to be frozen and immediately to the right of the column to be frozen.

Figure 10.15 Freezing and Unfreezing rows and columns

Freezing locks number of rows at the top of a spreadsheet or number of columns on the left of a spreadsheet or both. Frozen columns and rows remain the view during scrolling, whereas other rows and columns gets scrolled.
2. Choose **Window -> Freeze**.

3. Two lines appear on the screen, a horizontal line above this cell and a vertical line to the left of this cell. Now as you scroll around the screen, everything above and to the left of these lines will remain in view.

**Unfreeze:**

To unfreeze rows or columns, choose **Window -> Freeze**. The check mark in Freeze will vanish.

---

### 10.8 - Merge Cells

To merge a group of cells into one cell:

Select the cells to merge.

1. Click on **Merge Cell** icon or select **Format -> Merge Cell** option from menu bar.

---

**Figure 10.16 Merge cells**

### 10.9 – Formatting Cells and Protecting Worksheets, locking and hiding cells

Formatting Data in a cell gives additional effect to the text. Additional effect includes changing the Font type, Style, Font size, automatic wrapping, bold, underline, italic etc. The data in Calc can be formatted in several ways.

**Figure 10.17 Formatting Tool bar**

### 10.9.1 - Icons available in the Formatting Tool Bar:

1. **Font Name list box:** Various fonts are available in the list from which required font can be selected.

2. **Font Size list box:** Font size can be selected from this list box.
3. **Bold Icon**: This icon is used to apply bold for selected cell. Key board shortcut **Ctrl + B** can also be used.

4. **Italic Icon**: Italic icon is used to apply italic style to selected cell. **Ctrl + I** can also be used to apply italic.

5. **Under line Icon**: To apply underline for selected cell this icon can be used. **Ctrl + U** can be used for this.

6. **Four alignment Icons**: Using this icon content of a cell can be aligned Left, Center, Right and Justify. The key board short cuts are **Ctrl + L**, **Ctrl + E**, **Ctrl + R** and **Ctrl + J** can also be used respectively to align cell content.

7. **Number Format Icon**: Currency symbol (**Ctrl + Shift + 4**), Percent (**Ctrl + Shift + 5**), Standard (**Ctrl + Shift + 6**), Add Decimal Place, Delete Decimal Place can be applied using this icons.

8. **Increase Indent and Decrease Indent Icons** can be used to indent the cell content.

9. **Borders Icon**, **Background Colour Icon** and **Font Colour Icons** can be used to apply border, to change cell background colour and to change Font colour.

### 10.9.2 - Formatting using Format Cells Dialog Box:

The above formatting options can be applied individually one by one. But to apply and see preview. Format Cells dialog box is used. Select a cell and **Right-click** and select **Format → Cells** or click **Edit → Cells...** or press **Ctrl+1**, now **Format Cells** dialog box appears with seven tabs as follows.

![Format Cells Dialog Box](image)

**Figure 10.18 Format Cells**
Numbers Tab:

Several number formats like Category, Format, Language, Decimal places, leading zeros and Thousands separator. User-defined Format code is also applied. Main advantage is that preview is available.

Protection Tab:

In Open Office Calc, cells are protected against any accidental changes. Protection can be provided by means of a password. Authorization is given through the correct password. It is clear that the cell protection with a **Protected** attribute is only effective when the whole sheet is in protected mode.

![Format Cells dialog box]

*Figure 10.19 Format Cell - Cell Protection*

1. Select the cells that you want to specify the cell protection feature.
2. Choose **Format → Cells** and click the **Cell Protection** tab.
3. Select the protection options that you want. Any option can be applied only after protecting the sheet. This can be done through the menu **Tools->Protect Document->Sheet**. The Protected Sheet Dialog Box appears as below.
Uncheck **Protected** to allow the user to change the currently selected cells in the **Protected Sheet Dialog** box.

4. Select **Protected** to prevent changes to the contents and the format of a cell.
5. Select **Hide formula** to hide and to protect formulae from changes.
6. Select **Hide when printing** to hide protected cells in the printed document. (The cells are not hidden on screen).
7. Click **OK**.
8. Apply the protection options.

8.1 To protect the cells from being changed / viewed / printed according to your settings in the **Format** → **Cells Dialog** box, choose **Tools** → **Protect Document** → **Sheet**.

8.2 Enter a password with of atleast 5 or more characters.

---

**10.10 – Cell Referencing**

10.10.1 Relative Addressing

The cell from **A1** to **A3** is addressed as **A1:A3**. Assume **A4** is =SUM(A1:A3). When the same formulae is copied to column **B4** relative reference automatically change the formulae as **B4** is =SUM(B1:B3). Relative here means that the reference to this area will be changed automatically when you copy the formulae.
10.10.2 Absolute Addressing

Absolute references are the opposite of relative addressing. A dollar sign is placed before each column name and row number in an absolute reference, for example, assume $A5$ is $=\text{SUM}(A1:A3)$ when the same formula is copied to $B5$ reference will not automatically change and formulae for $B5=\text{SUM}(A1:A3)$ same as $A5$.

![Figure: 10.21 Relative Cells Addressing](image1)

![Figure: 10.22 Absolute Cell Addressing](image2)

10.11– Functions in OpenOffice Calc

10.11.1 – Introduction

A function is a predefined calculation entered in a cell to help to analyze or manipulate data in a spreadsheet. These functions simplify help to create the formulas needed to get the expected results. Formulae are equations using numbers and variables to get a result. In a spreadsheet, the variables are cell locations that hold the data needed for the equation to be completed. Open Office Calc includes over 350 functions to analyze and reference data. Many of these functions are used for working on numbers, dates, times, and text.
10.11.2 – Familiarization with the categories of functions

The most commonly used feature input method is built-in functions. The Function Wizard. To open the Function Wizard can be opened through, the menu choose Insert → Function or using the shortcut key press Ctrl+F2.

1. Once open, Select a category of functions to shorten the list, then scroll down through the named functions and select the required one.

2. When you select a function its description appears on the right-hand side of the dialog. Double-click on the required function.

3. The Wizard now displays a textbox where you can enter data manually in text boxes and the result will be displayed in the Result text box.

![Function Wizard Dialogue Box](image)

Figure: 10.23 Function Wizard Dialogue Box

10.11.3 – Working with the functions in Mathematical and Statistical Category

10.11.3.1 - Mathematical functions under Mathematical Category:

Various Mathematical function are readily available under Mathematical category for mathematical calculations.
Figure: 10.24 Mathematical functions

Few mathematical functions are listed below.

**ABS (Number/Cell Address)**

*Number/Cell Address* is the value whose absolute value is to be calculated. The absolute value of a number is its value without +/- sign.

**Example**

=ABS(-76) returns 76, =ABS(74) returns 7, =ABS(0) returns 0.

**ACOS (Number/Cell Address)**

This function returns the inverse trigonometric cosine of Number that is the angle (in radians) whose cosine is Number. The angle returned is in the range 0.0 to +PI. To return the angle in degrees, use the DEGREES function.

**Example**

=ACOS(-1) returns 3.14159265358979 (PI radians)

=DEGREES(ACOS(0.5)) returns 60. The cosine of 60 degrees is 0.5.

**ACOSH (Number/Cell Address)**

This function returns the inverse hyperbolic cosine of Number, whose hyperbolic cosine is Number. Number must be greater than or equal to +1.0.

**Example**

=ACOSH(1) returns 0, =ACOSH(COSH(4)) returns 4.

**ACOT (Number/Cell Address)**

This function returns the inverse trigonometric cotangent of Number i.e. the angle (in radians) whose cotangent is Number. The angle returned is in the range 0.0 to +PI. To return the angle in degrees, use the DEGREES function.

**Example**

=ACOT(1) returns 0.785398163397448 (PI/4 radians).

=DEGREES(ACOT(1)) returns 45. The tangent of 45 degrees is 1.

**ASIN (Number/Cell Address)**

This function returns the inverse trigonometric sine of Number that is the angle (in radians) whose sine is Number. The angle returned is in the range -PI/2 to +PI/2. To return the angle in degrees, use the DEGREES function.
Example

\[\text{=ASIN (0)} \text{ returns } 0. \text{ =ASIN (1) returns } 1.5707963267949 \text{ (}\pi/2\text{ radians).}\]

\[\text{=DEGREES (ASIN (0.5)) returns 30. The sine of 30 degrees is 0.5.}\]

\textbf{ATAN (Number/Cell Address)}

This function returns the inverse trigonometric tangent of Number that is the angle (in radians) whose tangent is Number. The angle returned is in the range \(-\pi/2\) to \(+\pi/2\). To return the angle in degrees, use the DEGREES function.

\textbf{Example}

\[\text{=ATAN (1) returns 0.785398163397448 (}\pi/4\text{ radians).}\]

\[\text{=DEGREES (ATAN (1)) returns 45. The tangent of 45 degrees is 1.}\]

\textbf{CEILING (Number; Significance; Mode)}

This function rounds a number up to the nearest multiple of Significance. \textbf{Number} is the number that is to be rounded up. \textbf{Significance} is the number that the value is to be rounded up to a multiple of. \textbf{Mode} is an optional value. If the Mode parameter is supplied and is not equal to zero and if Number and Significance are negative, rounding up is carried out based on the absolute value of Number. This parameter is omitted when exporting to Microsoft Excel since Excel does not support a third parameter for this function.

\textbf{Example:}

\[\text{=CEILING (15.5;2;2) returns 16,}\]

\[\text{=CEILING(-11;-2) returns -10}\]

\[\text{=CEILING (-11;-2;0) returns -10,}\]

\[\text{=CEILING(-11;-2;1) returns -12}\]

\textbf{COMBIN (Count1; Count2)}

Returns the number of combinations for a given number of objects (without repetition). Count1 is the number of items in the set. Count2 is the number of items to choose from the set. COMBIN returns the number of ordered ways to choose these items. For example if there are 3 items A, B and C in a set, you can choose 2 items in 3 different ways, namely AB, AC and BC. COMBIN implements the formula: \(\text{Count1!/(Count2!*(Count1-Count2))}\)

\textbf{Example:}

\[\text{=COMBIN (3;2) returns 3,}=\text{COMBIN(5;3) returns 10.}\]

\textbf{COMBINA (Count1; Count2)}

Returns the number of combinations of a subset of items including repetitions. Count1 is the number of items in the set. Count2 is the number of items to choose from the set. COMBINA returns the number of unique ways to choose these items, where the order of choosing is irrelevant, and repetition of items is allowed. For example if there are 3 items A, B and C in a set, you can choose 2 items in 6 different ways, namely AB, BA, AC, CA, BC and CB. COMBINA implements the formula: \((\text{Count1+Count2-1})! / (\text{Count2!*(Count1-1)}!))\)
Example

=COMBINA(3;2) returns 6,
=COMBINA(4;3) returns 20

COS (Number)

Returns the (trigonometric) cosine of Number, the angle in radians. To return the cosine of an angle in degrees, use the RADIANS function.

Examples:

=COS(PI()/2) returns 0, the cosine of PI/2 radians.
=COS(RADIANS(60)) returns 0.5, the cosine of 60 degrees.

COUNTBLANK (Range)

Returns the number of empty cells in the cell range.

Example:

=COUNTBLANK (A1:B2) returns 4 if cells A1, A2, B1 and B2 are all empty.

COUNTIF (Range; Criteria)

Range is the range to which the criteria are to be applied.

Example:

Criteria indicates the criteria in the form of a number, an expression or a text string. These criteria determine which cells are counted. You may also enter search text in the form of a regular expression. The command "b.*" for all words that begin with b. If search is for literal text, enclose the text in double quotes.

A1:A10 is a cell range containing the numbers 2000 to 2009. Cell B1 contains the number 2006. In cell B2, you enter a formula:

=COUNTIF (A1:A10;2006) - this returns 1
=COUNTIF (A1:A10;B1) - this returns 1
=COUNTIF (A1:A10;">=2006") - this returns 4
=COUNTIF (A1:A10;"<"&B1) - when B1 contains 2006, this returns 6
=COUNTIF (A1:A10;C2) where cell C2 contains the text >2006 counts the number of cells in the range A1:A10 which are > 2006.

To count only negative numbers:

=COUNTIF (A1:A10;"<0")

10.11.3.2 - Statistical functions

COUNT(Value1; Value2; ... Value30)

Counts how many numbers are in the list of arguments. Text entries are ignored. Value1; Value2; ... Value30 are 1 to 30 arguments. Example:

Example with figures:

A1:A10 is a cell range containing the numbers 2000 to 2009. Cell B1 contains the number 2006. In cell B2, you enter a formula:

=COUNTIF (A1:A10;2006) - this returns 1
=COUNTIF (A1:A10;B1) - this returns 1
=COUNTIF (A1:A10;">=2006") - this returns 4
=COUNTIF (A1:A10;"<"&B1) - when B1 contains 2006, this returns 6
=COUNTIF (A1:A10;C2) where cell C2 contains the text >2006 counts the number of cells in the range A1:A10 which are > 2006.

To count only negative numbers:

=COUNTIF (A1:A10;"<0")

Figure: 10.25 Statistical functions

Example:

A1:A10 is a cell range containing the numbers 2000 to 2009. Cell B1 contains the number 2006. In cell B2, you enter a formula:

=COUNTIF (A1:A10;2006) - this returns 1
=COUNTIF (A1:A10;B1) - this returns 1
=COUNTIF (A1:A10;">=2006") - this returns 4
=COUNTIF (A1:A10;"<"&B1) - when B1 contains 2006, this returns 6
=COUNTIF (A1:A10;C2) where cell C2 contains the text >2006 counts the number of cells in the range A1:A10 which are > 2006.

To count only negative numbers:

=COUNTIF (A1:A10;"<0")

10.11.3.2 - Statistical functions

COUNT(Value1; Value2; ... Value30)

Counts how many numbers are in the list of arguments. Text entries are ignored. Value1; Value2; ... Value30 are 1 to 30 arguments. Example:

Example with figures:

A1:A10 is a cell range containing the numbers 2000 to 2009. Cell B1 contains the number 2006. In cell B2, you enter a formula:
30 values or ranges representing the values to be counted.

**Example**

The entries 2, 4, 6 and eight in the Value 1 ... 4 fields are to be counted.

=COUNT (2;4;6;"eight") = 3. The count of numbers is therefore 3.

**COUNTA(Value1; Value2; ... Value30)**

Counts how many values are in the list. Text entries are also counted, even when they contain an empty string of length 0. Value1; Value2; ... Value30 are 1 to 30 arguments representing the values to be counted.

**Example**

The entries 2, 4, 6 and eight in the Value 1 ... 4 fields are to be counted.

=COUNTA(2;4;6;"eight") = 4. The count of values is therefore 4.

**CORREL(Data1; Data2)**

Returns the correlation coefficient between two data sets. Data1 is the first data set. Data2 is the second data set.

**Example**

=CORREL(A1:A20;B1:B20)

Calculates the correlation coefficient as a measure of the linear correlation of the two data sets.

**SMALL(Data; Rank_C)**

Returns the Rank_c-th smallest value in a data set. Data is the cell range of data. Rank_C is the rank of the value.

**Example**

=SMALL(A1:C50;3) gives the third smallest value in the range A1:C50.

**AVERAGE(Number1; Number2; ... Number20)**

Returns the average of the arguments. Number1; Number2; ... Number20 are 1 to 20 numeric values or ranges.

**Example**

=AVERAGE(A1:A20) Returns average of set of values from the cell range A1:A20

10.11.4 – Working with the functions in Logical Category [w5]

**IF (Test; TrueValue; FalseValue)**

Specifies a logical test to be performed. Test is any value or expression that can be TRUE or FALSE. TrueValue (optional) is the value that is returned if the logical test is TRUE. FalseValue (optional) is the value that is returned if the logical test is FALSE.
Example

=IF(A1>5;"True";"too small") If the value in A1 is higher than 5 then the text “True” is entered in the current cell otherwise the text “False” (without quotes) is entered.

10.11.5 – Working with the functions in Date and Time Category  [w6]

OpenOffice Calc internally handles a date/time value as a numeric value. To change the number format (date or time) accordingly. To do this, select the cell containing the date or time value. Click Format menu and then Cell option in the sub-menu The Numbers tab of the Format Cells Dialog Box contains the functions for defining the number format.

![Format Cells dialog box]

Figure: 10.26 Number format

10.11.6 – Working with the functions in Text Category

CONCATENATE("Text1";"Text2";"Text3";...)

Combines several text strings into one string. Text1; Text2; Text3; ... are 1 to 30 text passages which are to be concatenated together into one string.

Example

=CONCATENATE("Good ","Morning ","Mr. ","Ramki") returns Good Morning Mr. Ramki
DECIMAL("Text"; Radix)

Converts a text string with characters from a number system to a positive integer in the base radix given. Text is the text string to be converted. To differentiate between a hexadecimal number, such as A1 and the reference to cell A1, you must place the number in quotation marks, for example, "A1" or "FACE". Radix indicates the base of the number system. It may be any positive integer in the range 2 to 36.

Example

=DECIMAL("17";10) returns 17.
=DECIMAL("FACE";16) returns 64206.
=DECIMAL("0101";2) returns 5.

10.12 – Charts in OpenOffice Calc

10.12.1 – Introduction

Charts and graphs can be powerful ways to convey information to the reader through a pictorial representation. Open Office Calc offers a variety of different chart and graph formats for data. Using Calc, customization of charts and graphs to a considerable extent. This facility enhances the presentation of data in an effective manner. Many of these options enable to present information in the best and clearest manner.

10.12.2 – Familiarization with the types of charts

There are various charts representing data through relevant pictorial representation. The creation and presentation of charts are discussed in the following sections.

It is important to remember that while data can be presented with a number of different charts, the messages to convey to audience dictates the chart ultimately use. The following sections present examples of the types of charts that Calc provides.

1. Column charts
2. Bar charts
3. Pie charts
4. Area charts
5. Line charts
6. Scatter or XY charts
7. Bubble charts
8. Net charts
9. Stock charts
10. Column and line charts

Column Charts

This type shows a bar chart or bar graph with vertical bars. The height of each bar is proportional to its value. The x-axis shows categories. The y-axis shows the value for each category.

Normal type is a sub-type shows all data values belonging to a category next to each other. Main focus is on the individual absolute values, compared to every other value.

Stacked type is a sub-type shows the data values of each category on top of each other. Main focus is the overall category value and the individual contribution of each value within its category.
Percent is a sub-type shows the relative percentage of each data value with regard to the total of its category. Main focus is the relative contribution of each value to the category’s total.

![Percentage Bar Charts](image)

*Figure: 10.27 Percentage Bar Charts*

This type shows a bar chart or bar graph with horizontal bars. The length of each bar is proportional to its value. The y-axis shows categories. The x-axis shows the value for each category.

![Horizontal Bar](image)

*Figure: 10.28 Horizontal Bar*

Pie Charts

A pie chart shows values as circular sectors of the total circle. The length of the arc, or the area of each sector, is proportional to its value.

**Normal Pie** is a sub-type shows sectors as colored areas of the total pie, for one data column only. In the created chart, you can click and drag any sector to separate that sector from the remaining pie or to join it back.

**Exploded pie** is a sub-type shows the sectors already separated from each other. In the created chart, you can click and drag any sector to move it along a radial from the pie’s center.

Doughnut is a sub-type can show multiple data columns. Each data column is shown as one doughnut shape with a hole inside, where the next data column can be shown. In the created chart, you can click and drag an outer sector to move it along a radial from the doughnut’s center.

Exploded doughnut is a sub-type shows the outer sectors already separated from the remaining doughnut. In the created chart, you can click and drag an outer sector to move it along a radial from the doughnut’s center.

![Doughnut](image)

*Figure: 10.29 Pie Chart*

Area charts

An area chart shows values as points on the y-axis. The x-axis shows categories. The y-values of each data series are connected by a line. The area between each two lines is filled with a colour. The area chart’s focus is to emphasise the changes from one category to the next.

**Normal** - this sub-type plots all values as absolute y-values. It first plots the area of the last column in the data range, then the next to last, and so on, and finally the first column of data is drawn. Thus, if the values in the first column are higher than other values, the last drawn area will hide the other areas.

**Stacked** - this sub-type plots values cumulatively stacked on each other. It ensures that all values are visible, and no data set is hidden by others. However, the
y-values no longer represent absolute values, except for the last column which is drawn at the bottom of the stacked areas.

**Percent** - this sub-type plots values cumulatively stacked on each other and scaled as percentage of the category total.

**Figure: 10.30 Area Chart Percentage**

**Line charts**

A line chart shows values as points on the y-axis. The x-axis shows categories. The y-values of each data series can be connected by a line.

**Points only** - this sub-type plots only points.

**Points and lines** - this sub-type plots points and connects points of the same data series by a line.

**Lines only** - this sub-type plots only lines.

**3-D lines** - this sub-type connects points of the same data series by a 3-D line.

**Figure: 10.31 Line Chart - Points Only**

**Scatter or XY charts**

An **X-Y** chart in its basic form is based on one data series consisting of a name, a list of x values, and a list of y values. Each value pair (x|y) is shown as a point in a coordinate system. The name of the data series is associated with the y values and shown in the legend.

The chart is created with default settings. After the chart is finished, you can edit its properties to change the appearance. Line styles and icons can be changed on the **Line** tab page of the data series properties dialogue box.

Double-click any data point to open the **Data Series** dialogue box. In this dialogue box, you can change many properties of the data series.

For 2-D charts, you can choose **Insert - y-Error Bars** to enable the display of error bars.

You can enable the display of mean value lines and trend lines using commands on the Insert menu.

**Points only**

Each data point is shown by an icon. OpenOffice uses default icons with different forms and colours for each data series. The default colours are set in **Tools - Options - Charts - Default Colours**.

**Lines Only**

This variant draws straight lines from one data point to the next. The data points are not shown by icons.

The drawing order is the same as the order in the data series. Mark **Sort by x-values** to draw the lines in the order of the x-values. This sorting applies only to the chart, not to the data in the table.

**Points and Lines**

This variant shows points and lines at the same time.
3-D Lines

The lines are shown like tapes. The data points are not shown by icons. In the finished chart choose 3-D View to set properties like illumination and angle of view.

Figure: 10.32  3D Points Only

Bubble charts

A bubble chart shows the relations of three variables. Two variables are used for the position on the x-axis and y-axis, while the third variable is shown as the relative size of each bubble.

The Data Series dialog box for a bubble chart has an entry to define the data range for the Bubble Sizes.

Net charts

A Net chart displays data values as points connected by some lines, in a grid net that resembles a spider net or a radar tube display.

For each row of chart data, a radial is shown on which the data is plotted. All data values are shown with the same scale, so all data values should have about the same magnitude.

Figure: 10.33  Bubble Chart Points Only

Column and line charts

A Column and Line chart is a combination of a Column chart with a Line chart.

Select one of the variants

• Columns and Lines. The rectangles of the column data series are drawn side by side so that you can easily compare their values.
• Stacked Columns and Lines. The rectangles of the column data series are drawn stacked above each other, so that the height of a column visualises the sum of the data values.

You can insert a second y-axis with Insert - Axes after you finish the wizard.

10.12.3 – Creating and formatting charts

1. Select the cells that contain the data that you want to present in your chart.

2. Click the Insert->Chart option or click Insert Chart icon on the Standard toolbar.

3. The Chart Wizard has three main parts:
   • List of steps involved in setting up the chart,
   • List of chart types, and
   • The options for each chart type.

At any time you can go back to a previous step and change selections.
4. Choose a Chart type and its option type. Then click Next button.

5. In Step 2, Data Range, manually correct any mistakes made in selecting the data. Click one of the options for data series in rows or in columns. Check whether the data range has labels in the first row or in the first column or both. Then click the Finish button, or click Next to change some more details of the chart.
Figure: 10.35d Data Series

6. In the Data Series list box contains a list of all data series in the current chart.
   - To organize the data series, select an entry in the list.
   - Click Add to add another data series below the selected entry. The new data series has the same type as the selected entry.
   - Click Remove to remove the selected entry from the Data Series list.
   - Use the Up and Down arrow buttons to move the selected entry in the list up or down. This does not change the order in the data source table, but changes only the arrangement in the chart.
   - Then click Next button

Figure: 10.35e Chart Elements
7. On the **Chart Elements** page, chart a title and, if desired, a subtitle. Use a title that draws the viewers' attention to the purpose of the chart: what you want them to see. For example, a better title for this chart might be Mark Statement. Then click Finish to create chart.

![Final Chart](image1.png)

*Figure: 10.35f Final Chart*

**Case Study:** Create a spreadsheet file to store sales data of a particular product and present as Chart.

### Evaluation

**Part - A**

Choose the best answer:

1. The active sheet colour will be of which colour?
   - A) Grey
   - B) Green
   - C) White
   - D) Yellow

2. To select multiple continuous sheet which key is used?
   - A) Ctrl
   - B) Shift
   - C) Alt
   - D) tab

3. To delete a single sheet which command is to be selected?
   - A) File → Sheet → Delete
   - B) Delete → Sheet → Delete
   - C) Sheet → Delete
   - D) Edit → Sheet → Delete
4. Which command is used to show the hidden row in OpenOffice Calc?
   A) Format → Row → Show
   B) Format → Show → Row
   C) Format → Display → Row
   D) Format → Row → Display

5. To protect cell in OpenOffice Calc Format → Cells and click which tab?
   A) Protect Cell
   B) Protection Cell
   C) Cell Protection
   D) Cell Protect

6. To make which cell address absolute we use sign?
   A) Absolute
   B) Relative
   C) Comparative
   D) Reference

7. Which function sounds a number upto the nearest multiple of significance?
   A) COMBINA
   B) CEILING
   C) Floor
   D) ABS

8. If cell A5 contains value 18, then if (A26>5; “True”, “False”) will return
   A) True
   B) False
   C) Blasse
   D) Error

9. Which can be powerful way to convey information to the reader through a pictorial representation?
   A) Charts and images
   B) graphs and images
   C) Charts and graphs
   D) Images and Pictures

10. What will be value returned by = DECIMAL (“16;”1101)
    A) 12
    B) 13
    C) D
    D) E
Part-II

Answer the following questions (2 Marks)

1. How to select continuous and non-continuous sheets in OpenOffice Calc?
2. Write the method to rename sheet.
3. What is the use of freezing a sheet?
4. What are the types of Cell addressing?
5. What is Chart?

Part-III

Answer the following questions (3 Marks)

1. Differentiate relative Cell addressing from absolute cell addressing
2. What are functions in OpenOffice Calc?
3. How to hide/show rows and columns in sheet?
4. Write briefly about ASIN function in Open Office Calc.
5. What is range? Give example.

Part-IV

Answer the following questions (5 Marks)

1. Create a Worksheet to contain student database with following fields.
   Rollno., Name, English, Tamil, Maths, Science, Social, Total, average.
2. Explain how to format worksheet
3. Discuss in detail about steps to create chart in OpenOffice calc.
4. How to use function in Open Office Calc? Explain with suitable example.
Learning Objective

- To Learn various tools on data processing in the spread-sheet
- To Learn about page formatting and printing in the spread-sheet

11.1 Data tools

Data Tools are used to manipulate the information in the spreadsheet. The data tools in the spreadsheet are used for automated manipulation. For the new users, these tools may feel like advanced options. But, the user who is experienced in these tools can do complex manipulation in a simpler way.

11.2 Applying conditional format

Important aspect of the data tools lies in the visualization of those data for easy understanding of the user. Conditional formatting gives different font size, font colour and background colour for different data, based on the user requirements.

You can set up cell formats to change font size, font colour, background colour depending on conditions that you specify. For example, in a table of numbers, you can show all the values above the average in green and all those below the average in red.

For example, the marks of the students are entered in the spreadsheet. The marks should be shown in different colours for the different marks ranges.

**Illustration 11.1:** Apply the conditional formatting for Table 11.1 as for the condition given below.

1. Marks less than or equal to 50 in Lightgreen
2. Marks greater than 50 in blue

<table>
<thead>
<tr>
<th>Name</th>
<th>Marks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Kumar</td>
<td>32</td>
</tr>
<tr>
<td>Arun</td>
<td>67</td>
</tr>
<tr>
<td>Gayathri</td>
<td>50</td>
</tr>
<tr>
<td>Chandru</td>
<td>98</td>
</tr>
</tbody>
</table>

Table 11.1 Data with conditional Formatting
Procedure to apply conditional formatting:
1. Select the cells which contain marks
2. Choose Format → Conditional Formatting from the menu bar

![Figure 11.1 Format → Conditional Formatting](image)

3. Conditional formatting dialog box appears as shown in Figure 11.2
![Figure 11.2 Conditional Formatting Dialog Box](image)

4. Select Condition 1, choose cell value is “greater than” and type 50 in the value box.
5. Then click New Style button. The New Style button has various options such as Font Style, Font Size, Font colour, Font alignment, Border Colour, and Background colour.
Now, the cell style dialog box appears as shown in Figure 11.3a will appear. Click Background Tab and choose light green.

![Cell Style Dialog Box](image)

*Figure 11.3a Conditional Formatting → New Style → Background*

6. Similarly, Select Condition 2, choose cell value is “less than” and type 50 in the value box. In the background tab, choose blue colour.

Finally OpenOffice calc shows the result as given below:

![Spreadsheet Example](image)

*Figure 11.3b Background Colour*

11.3 Sorting

Sorting is the process of re-arranging data in ascending or descending order. There are three types of sorting in OpenOffice Calc. They are,

1. Simple Sorting
2. Multi Sorting
3. Sort by selection
11.3.1 Simple Sorting

Arranging data using single column is known as simple sorting. For sorting the data, calc provides two icons on the standard tool bar viz. (1) Sort Ascending (2) Sort Descending.

- Sort Ascending – Arrange data in alphabetical order (A to Z / Small to Large)
- Sort Descending – Arrange data in reverse order (Z to A / Large to Small)

Sorting data

**Step 1:** Place cell pointer in the field (column) to be sorted

**Step 2:** Click Sort Ascending or Sort Descending icon

OpenOffice Calc, sort the data of selected column and its corresponding values present in other columns are also arranged simultaneously. Refer Figure 11.6.
11.3.2 Multi Sorting

Sorting data based on more than one field (column) is known as multi sorting. For example, the worksheet containing data of 20 students belongs to different groups and classes. To rearrange this data alphabetically by name and group code, multi sorting is used. Refer Figure 11.6.
Multi-sorting data

Step 1: Select Data → Sort

![Multi-sorting dialog box]

Select First column in which the data arranged first
Select order of arrangement

Finally Click "Ok"

Step 2: Sort dialog box appears. (Refer Figure 11.7).

Step 3: Select the field name (Student name) in which you want to sort from the “sort by” dropdown list box and then choose order of sorting i.e. Ascending or Descending. Ascending is the default selection.

Step 4: Select another field name (Group Code) from the “Then by” dropdown list box and choose the order of sorting to this column.

Step 5: Click “OK” button.

In OpenOffice Calc, multi sort can be done only for three fields.
11.3.3 Sort by selection

In Calc sorting can be done on selected range. But this kind of sorting is generally not recommended, because the other relevant data are also not sorted. Therefore, OpenOffice Calc displays a warning message for this type of sorting. Refer Figure 11.9.

Sorting data by selection:

Step 1: Select any particular field in which you want sort.

Step 2: Click required Sort icon from standard tool bar or Data → Sort command. Calc, display a “Sort Range” warning message as shown in the Figure 11.9 “Sort Range” message box has two options, viz. (1) Extend selection (2) Current selection.

Step 3: “Extend Selection” – Sort all the data based on the selection. “Current Selection” – Sort only the selected range of data, remaining data are not sorted.

Figure 11.8 Sorted Table

Note: Name are arranged in Ascending order According to names, other data also rearranged
Filter is a way of limiting the information that appears on screen. Filters are a feature for displaying and browsing a selected list or subset of data from a worksheet. The visible records satisfy the condition that the user sets. Those that do not satisfy the condition are only hidden, but not removed.

OpenOffice Calc allows three types of filters. They are **AutoFilter**, **Standard Filter** and **Advanced Filter**.

### 11.4.1 Auto Filter:

Auto Filter applies a drop-down list box to each field (columns) filled with similar data available in that field. Using the list box item, you can filter the data that matches the criteria of the data concerned.

Using Auto Filter:

- Click **Auto Filter** icon available on the “Standard tools bar” (or) Click **Data → Filter → Auto Filter**
The list box contains similar data in the fields. Refer Figure 11.10 and 11.11.

Each list box item will be considered as filter criteria.

Select the data item from the list box. Now, Calc shows only the records which satisfy the selected criteria.

**Example:**

If you want to apply an auto filter to the contents of the Figure 11.4, follow the following two steps

Step 1: Place cell pointer anywhere in the table

Step 2: Click Auto Filter icon available on the “Standard tools bar” (or) Click **Data → Filter → Auto Filter**

In the above table, if you want to view only the students belongs to the **Group Code 402**;

- Click the dropdown list box’s drop arrow (a tiny triangle) to get the filter criteria. (Refer Figure 11.11)
- Select group code 402 from the list

- The spreadsheet displays only the student's details those who are studying in group code 402 (Refer Figure 11.12) and the remaining details are only hidden.

![Figure 11.12 Filtered details](image)

Removing Auto Filter:

- To remove auto filter, click “Auto filter” icon once again.

- The original table is displayed without filter.

11.4.2 Standard Filter:

Auto filter is used only for single criteria on a data, whereas the Standard filter is used for multiple criteria to filter.
Step 1:

- Select **Data → Filter → Standard Filter.**
- Now, the entire data is selected and "Standard Filter" dialog box displays as shown in **Figure 11.14.**

Step 2:

- Select the column heading from the “Filed name” list box for first criteria.
- Select conditional operator such as >, <, = etc., from “Condition” list box.
- Type or select the value of criteria in the “Value” box.

Step 3:

- Select the one of the logical operator (And / Or) from “Operator” list box to fix second criteria.
- Follow the step 2, for the next criteria.

Step 4:

- Click “OK” to finish.

**Example for Standard filter:**

If you want to filter the records of “BC” students of group code 402 from the **Figure 11.4.**

**Step 1:** Select **Data → Filter → Standard Filter**

- Now, “Standard Filter” dialog box appears as in **Figure 11.14.**

**Step 2:** In “Standard Filter” dialog box, select the first criteria;

- Select Field name as Group code
- Select Condition as =
- Type or select Value as 402

**Step 3:** To select the second criteria;

- Select Operator as “AND”
- Select Field name as Class
- Select Condition as =
- Type or select Value as XII- H2
Step 4: Click “OK”

- Now, the table displays only the records which are match for the given two criteria. Refer Figure 11.15.

To Remove Standard Filter:

- Select Data → Filter → Remove Filter

Validation will limit the data to be entered in the selected row/column/cell. For example, in the student database, the maximum roll no is 50. Hence, if the user enters a roll no above 50, it should give an error message.

Step 1: Enter Roll No in a cell A1 and select the entire column (column A)

Step 2: Go to Data → Validity, then a dialogue box will appear. In that, Go to Criteria Tab, Select whole numbers in the Allow field. It means only integer values are allowed. Fractional values are not allowed. In the Data Field, select less than and in the maximum field type 50. Refer Figure 11.16.
Then go to Error Alert Tab, in that select Show error message when invalid values are entered check box. Then select Warning in the Action checklist, Enter title of the error message (such as invalid) in the Title text box. Then Type the error message in the Error message multi line text box. Refer Figure 11.17.

Now, in the Roll No column, if the user types values above 50, the error message will appear as shown in Figure 11.18.
11.6 Creating and using Input Help List

Input Help is used to provide various options such as choosing the gender of a person (Male or Female), Month (Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, Dec).

The following steps will guide to generate the List for Gender.

**Step 1:** In any one cell (ex: A1) type Gender

**Step 2:** Select the next cell (may be in A2 or B1)

**Step 3:** Go to Data \(\rightarrow\) Validity then the dialogue box will appear (refer Figure 11.19)
Step 4: In the Input Help Tab, type title as Gender. Then type, Male and Female in the Input Help Field. Then press “OK”.

Step 5: Goto the selected cell no, the input help message will appear (refer Figure 11.20).

11.8 Printing Spreadsheet

11.8.1 Setting the page size, Orientation and Margins

Step 1: To format the page size, go to Format ➔ Page in the menu bar. The dialogue box will appear which shown in Figure 11.21.
Step 2: Choose Page Tab (refer Figure 11.22)

Step 3: Choose the Page size, Orientation and Page Margin

Before printing the spread-sheet, it is necessary to verify the Print Preview, in order to check the required format.

For print preview, go to File -> Page Preview
If the spread-sheet has required format, press close preview, otherwise choose Format Page and Margin Tab in the top of the screen.

11.8.2 Inserting Header and Footer

Header and Footer are some titles (such as Document Title, Author Name) or references (such as page no, number of pages, date) or remarks to be printed in the top (called as Header) and bottom of the page (called as Footer). The header and footer dialogue boxes are shown in Figure 11.23 and 11.24.

![Figure 11.23 Header Dialogue Box](image)

Figure 11.23 Header Dialogue Box
11.8.3 Repeating Rows / Columns to replace in all pages

If a sheet is printed on multiple pages, you can set up certain rows or columns to repeat on each printed page.

For example, if the top two rows of the sheet as well as column A need to be printed on all pages, do the following steps:

**Step 1:** Choose **Format → Print Ranges → Edit.**
Step 2: On the Edit Print Ranges dialog, type the rows in the text entry box under Rows to repeat. For example, to repeat rows 1 and 2, type $1:$2. This automatically changes Rows to repeat from “- none –” to “- user defined –”.

Points to Remember:

- Data Tools are used to manipulate the information in the spread-sheet
- Conditional format gives different font size, font colour and background colour for different data based on the user requirements.
- Sorting is used to re-arrange the items in ascending or descending order based on alphabets or based on values.
- Filters are used to show only the selected portion of data from a large size database
- Input Help is used to provide various options like week, month etc
- Header and Footer are some titles (such as Document Title, Author Name) or references (such as page no, number of pages, date) or remarks to be printed in the top (called as Header) and bottom of the page (called as Footer).
- If a sheet is printed on multiple pages, we can set up certain rows or columns to repeat on each printed page.

Evaluation

Part I

Choose the correct answer

1. There are 10000 rows in a spread-sheet. The user need to view a particular row of the database. Which of the following tool is used?
   A. Sorting   B. Merging   C. Filtering   D. Formatting

2. The customer required to design the item number between 101 to 200. If the user types above 200 or below 100, the system should give an error message. Which of the following tool is used?
   A. Listing   B. Filtering   C. Formatting   D. Validating

3. In a form, the teacher needs “True or False” as a drop down menu. Which of the following tool is used?
   A. Form   B. Data   C. List   D. Format

4. The size of an A4 paper is 21 cm x 29 cm. If the user chooses Landscape orientation, then the size of the paper is.....?
   A. 21 x 29   B. 29 x 21   C. None of the above   D. All of the above
Part II

Answer to the following questions (2 Marks)
1. What is sorting?
2. What are the type of the filters?
3. What is header and footer?
4. Write the steps to format the margin of the paper as 1” in all sides.

Part III

Answer to the following questions (3 Marks)
1. The user needs page number at the bottom of all pages. Which tool is used? Write the steps to design the needs.
2. Write the steps for sorting the database based on the customer name in ascending order
3. Write the steps to print the title row on every page of the spread-sheet

Part IV

Answer to the following questions (5 Marks)
1. Create a student database with register number, student name, Mark1, Mark2, and Mark3. Calculate the total and average of the students. Show the marks which are below 50 in red colour and marks above 50 is shown in green colour.
2. Explain the applications of Header and Footer with example

Practicals

Type the registration number and name of the student, mark 1 if the student is present and mark 0 if the student is absent on the date. Apply conditional formatting such as if the student is present that should represent in green colour and the absentees should represent in red colour. Then calculate number of present days, number of absent days and attendance percentage of the student. Also calculate number of student present per day and number of student absent per day.

<table>
<thead>
<tr>
<th>Register No</th>
<th>Name</th>
<th>29-Nov</th>
<th>08-Dec</th>
<th>13-Dec</th>
<th>20-Dec</th>
</tr>
</thead>
<tbody>
<tr>
<td>160172</td>
<td>SHIVA. M</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>170001</td>
<td>MONICA. A</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>170002</td>
<td>SUGANYA. D</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>170004</td>
<td>POOJA. P</td>
<td>1</td>
<td>1</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>170005</td>
<td>MANJU. M</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>170006</td>
<td>MOTHILAL. T</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>170007</td>
<td>DIYA N</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>170008</td>
<td>PRAJAKTA S</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>170009</td>
<td>SIRISHA S</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>170010</td>
<td>SUSMITA S</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>170011</td>
<td>DIVYA K</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>170012</td>
<td>THOMAS S</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>170013</td>
<td>SUPRAJA A</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>170014</td>
<td>RAVIRAJ R</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>
Learning Objectives

After learning this chapter, the students will be able to

- Know the OpenSource presentation software
- Explore opening a new presentation using Impress
- Create a new presentation using various ways using Impress
- Know parts of the main Impress Window
- Differentiate five sections of Task pane
- Explain Window elements of Impress
- Differentiate various views in Workspace
- Explore drawing Objects and inserting OLE
- Draw freeform shapes
- Rotate Objects
- Create animation in slides/objects

12.1 Presentation Software - Meaning

- A presentation software is a computer software package used to show information, in the form of a slide show.

It includes three major functions:

- an editor that allows the text to be inserted and formatted,
- a method for inserting and manipulating graphic images,
- a slide-show system to display the content.

Presentation software is used to create presentations, quizzes, e-learning packages and multimedia products.

- Most presentation software packages will create your multimedia product using a series of slides.
- Text, images, video, animation effects, links and sound can be combined on each slide to create a final product.

The most commonly known presentation programs are OpenOffice Impress, Microsoft PowerPoint and Apple's Keynote. In this chapter, we are going to explore on OpenOffice presentation Software Impress.
12.2. Impress

Impress is OpenOffice presentations (slide show) module. You can create slides using Impress. It contains different elements like text, bullets and numbered lists, tables, charts, clipart and a range of graphic objects. Impress has access to the spelling checker and thesaurus. Also, it comes with pre-packaged text styles, background styles with online help.

12.3. Opening a new presentation

You can start Impress in several ways:

- In order to open Impress using Start button, click Start button and select All Programs → OpenOffice 4.1.4 → OpenOffice Impress. (Figure 12.1)

- If it is already pinned in the Start menu, just click and open it. (Figure 12.2)

12.4. Creating a new presentation

You can create a presentation by any one of the following methods.

1. By selecting an Empty presentation

2. By selecting From template
3. By selecting from Open existing presentation

12.4.1. Using Empty presentation

1. Select **Empty presentation** under Type. It creates a presentation from scratch.

2. Click **Next**. The Presentation Wizard Step 2 appears. **Figure 12.4** shows the Wizard.

3. Choose a design under **Select a slide design**. The slide design section gives you two main choices: Presentation Backgrounds and Presentations.

4. Select the output medium from the list of choices for slide design. Choose anyone from the list. The preview of the same will be shown in the preview pane.

![Figure 12.3 – Using the Presentation Wizard to choose the type of presentation](image1)

![Figure 12.4 Wizard showing the main choices](image2)
5. `<Original>` is an empty background. You can also select among three predefined Presentations: `<Original>`, *Introducing a New Product*, and *Recommendation of a Strategy*. (Figure 12.6).

6. Click an item to see a preview of the slide design in the Preview window.

7. Select how the presentation will be used under *Select an output medium*. Generally, presentations are created for computer screen display, so select *Screen option*. (Figure 12.6).

8. Click *Next*. The Presentation Wizard Step 3 appears (Figure 12.7). In this step, you can choose the desired slide transition from the *Effect* drop-down menu. Select the desired *speed* for the transition between the different slides in the presentation from the Speed drop-down menu. *Medium* is a good choice. Click *Create*. A new presentation is created. (Figure 12.8)

\[Figure 12.5\] Selecting a slide design using Presentation Backgrounds
Figure 12.6 Selecting a slide design using Presentations

Figure 12.7 Selecting a slide transition effect
12.4.2. Using Template

- If you choose the option **From template**, it uses a template design already created as the basis for a new presentation. The wizard changes to show a list of available templates. Choose the template that you want. (**Figure 12.9**).

- Introducing a New Product and Recommendation of a Strategy are pre-packaged presentation templates.

**Figure 12.8 New presentation**

![New presentation](image)

**Figure 12.9 Opening a new presentation using From template option**

![Opening a new presentation using From template option](image)
12.4.3. Using Open existing presentation

- If you choose the option **Open existing presentation**, it helps in continuing the work on a previously created presentation.
- You have to open a presentation already prepared by clicking **Open** button. The wizard changes to show a list of existing presentations, from which you can choose the one that you want. *(Figure 12.10).*

![Presentation Wizard](image1)

*Figure 12.10 Opening a new presentation using Open existing presentation option*

![New icon](image2)

*Figure 12.11 Opening a new presentation using New icon*
Various ways of Starting Impress:

You can start Impress in various methods.

1. You can select the presentation from the system menu or the OpenOffice. Quickstarter.

2. Or you can click the New icon and select Presentation from the drop-down menu (Figure 12.11).

3. Or else, choose File → New → Presentation. (Figure 12.12).

12.5. Parts of the Main Impress window

The main Impress window (Figure 12.13) has three parts: the Slides pane, the Workspace and the Task pane. Additionally, several toolbars can be displayed or hidden during the creation of a presentation.

You can remove the Slides pane or Tasks pane from view by clicking the Close (X) option in the upper right corner. You can also show or hide these panes using View → Slide Pane or View → Task Pane/Side bar.
12.5.1. Slides pane

- The Slides pane contains thumbnail pictures of the slides in your presentation, in the order of our insertion of slides.
- Clicking a slide in this pane selects it and places it in the Workspace. While it is there, you can apply any changes that are desired to that particular slide.

Several additional operations can be performed on one or more slides in the Slides pane:

- **Add new slides** at any place within the presentation after the first slide.
- **Mark a slide as hidden** so that it will not be shown as part of the slide show.
- **Delete a slide** from the presentation if it is no longer needed.
- **Rename a slide.**
- **Copy or move the contents** of one slide to another (copy and paste, or cut and paste, respectively).

It is also possible to perform the following operations, other than using the Slides pane:

- **Change the slide transition** following the selected slide or after each slide in a group of slides.
- **Change the sequence of slides** in the presentation.
- **Change the slide design.** (A window opens allowing you to load your own design.)
- **Change slide layout** for a group of slides simultaneously. (This requires using the Layouts section of the Tasks pane.)
12.5.2. Tasks pane

The Tasks pane has five sections:

1. Master Pages

You define the page style for your presentation using Master Pages. Impress contains pre-packaged Master Pages (slide masters). One of them by default is blank, and the rest have a specific background. (Figure 12.14)

2. Layout

Pre-packaged layouts are shown. You can choose the one you want, use it as it is or modify it to suit your own requirements. At present, it is not possible to create custom layouts. (Figure 12.15)

3. Table Design

Standard table styles are provided in this pane. You can further modify the appearance of a table with the selections to show or hide specific rows and columns, or to apply a banded appearance to the rows and columns. (Figure 12.16)
4. Custom Animation

A variety of animations for selected elements of a slide are listed here. Animation can be added to selected elements of a slide and it can also be changed or removed later. (Figure 12.17)

5. Slide Transition

Transitions are available, including No Transition. You can select the transition speed (slow, medium, fast). You can also choose between an automatic or manual transition, and how long you want the selected slide to be shown (automatic transition only). (Figure 12.18)
12.6. Window elements of Impress

Figure 12.19 shows the elements of the Impress Window Open source application.

The window elements of Impress include Title Bar, Menu Bar, Tool Bar, Ruler Bar and the Scroll Bar which are similar to the elements in Open Office writer.

12.6.1. View Buttons:

The Workspace has five tabs: Normal, Outline, Notes, Handout, and Slide Sorter, as seen in Figure 12.19. These five tabs are called View Buttons.

12.6.2. Status Bar:

Status Bar is present at the bottom of your window, which gives you some statistics about the file that you are viewing. It is a good practice to check the information shown there. In case you do not need the information in the Status Bar, you can hide it by selecting View → Status Bar from the main menu.

12.6.3. Navigator

The Navigator (Figure 12.20) displays all objects contained in a document. It provides another convenient way to move around a document and find items in it. The Navigator button is located on the Standard toolbar. You can also display the Navigator by choosing Edit → Navigator on the menu bar or pressing Ctrl+Shift+F5.

The Navigator is more useful if you give your objects (pictures, spreadsheets, and so on) meaningful names, instead of names as “Object 1” and “Picture 1” as shown in Figure 12.20.
The Workspace has five tabs: Normal, Outline, Notes, Handout and Slide Sorter, as seen in Figure 12.19. These five tabs are called View Buttons. There are many toolbars that can be used during the slide creation; they are revealed by selecting them with View → Toolbars.

The actual Workspace section is below the View Buttons. This is where you assemble the various parts of your selected slide. Each view is designed to ease the completion of certain tasks.

**Normal view** is the main view for creating individual slides. Use this view to format and design slides and to add text, graphics and animation effects.

**Outline view** shows topic titles, bulleted lists and numbered lists for each slide in outline format. Use this view to rearrange the order of slides, edit titles and headings, rearrange the order of items in a list and add new slides.

**Notes view** lets you add notes to each slide that are not seen when the presentation is shown.

**Slide Sorter view** shows a thumbnail of each slide in order. Use this view to rearrange the order of slides, produce a timed slide show, or add transitions between selected slides.

**Handout view** lets you print your slides for a handout. You can choose one, two, three, four, or six slides per page from Tasks pane → Layouts. Thumbnails can be re-arranged in this view by dragging and dropping them.

**12.7.1. Normal view**

There are two ways to place a slide in the Slide Design area of the Normal view: clicking the slide thumbnail in the Slides pane or using the Navigator.

To open the Navigator, click the Navigator button in the Standard Toolbar or press Ctrl+Shift+F5 and select a slide.
by scrolling down the Navigator list until you find the one that you want and then **double-click it.** (Figure 12.21).

### 12.7.2. Outline view

Outline view contains all the slides of the presentation in their numbered sequence. Only the text in each slide is shown. Slide names are not included.

Outline view serves for two purposes.

1) **Making changes in the text of a slide:**

- Add or delete text in a slide just as in the Normal view.
- Move the paragraphs of text in the selected slide up or down by using the up and down arrow buttons (Move Up or Move Down) on the Text Formatting toolbar.

Change the outline level for any of the paragraphs in a slide using the left and right arrow buttons (**Promote** or **Demote**).

Both move a paragraph and change its outline level using a combination of four arrow buttons.

2) Comparing the slides with your outline (if you have prepared one in advance). If you notice from your outline that another slide is needed, you can create it directly in the Outline view or you can return to the Normal view to create it, then return to review all the slides against your outline in the Outline view.

![Figure 12.21 Presentation in Normal view](image-url)
If a slide is not in the correct sequence, you can move it to its proper place:

a) Click the **slide icon** of the slide that you wish to move, as indicated in Figure 12.22.

b) **Drag and drop** it where you want.

12.7.3. Notes view

Use the Notes view to add notes to a slide:

1) Click the Notes tab in the **Workspace** (Figure 12.23).

2) Select the slide to which you will add notes.

---

**Figure 12.22** Presentation in Outline view

**Figure 12.23** Presentation in Notes view
• **Double-click** the slide in the Slide pane, or

• **Double-click** the slide’s name in the Navigator.

3) In the text box below the slide, click on the words **Click to add notes** and begin typing.

You can resize the notes text box using the **green resizing handles** and move it by placing the pointer on the border, then click and drag. To make changes in the text style, press the **F11** key to open the **Styles and Formatting window**.

### 12.7.4. Slide Sorter view

The Slide Sorter view contains all of the slide thumbnails ([Figure 12.24](#)).

Use this view to work with a group of slides or with only one slide.

Change the number of slides per row, if desired:

1) Check **View → Toolbars → Slide View** to show the Slide view toolbar ([Figure 12.24](#)).

2) Adjust the number of slides (up to a maximum of 15).

3) After you have adjusted the number of slides per row, **View → Toolbars → Slide**. View will remove this toolbar from view.

**To move a slide in a presentation using the Slide Sorter:**

1) **Click the slide.** A thick black border is drawn around it.

2) **Drag and drop** it to the location you want.

• **As you move the slide,** a black vertical line appears to one side of the slide.

• **Drag the slide** until this black vertical line is located where you want the slide to be moved

**To select a group of slides, use one of these methods:**

• **Use the Control (Ctrl) key:** Click on the first slide and, while pressing Control, select the other desired slides.
Use the Shift key: Click on the first slide, and while pressing the Shift key, select the final slide in the group. This selects all of the other slides in between the first and the last.

Use the cursor: Click on the first slide to be selected. Hold down the left mouse button.

Drag the cursor to the last slide thumbnail.

A dashed outline of a rectangle forms as you drag the cursor through the slide thumbnails and a thick black border is drawn around the selected slides. Make sure that this rectangle includes all the slides you want to select. (Figure 12.25)

To move a group of slides:

1) Select the group of slides.

2) Drag and drop the group to their new location. The same vertical black line appears to show you where the group of slides will go. You can work with slides in the Slide Sorter view as in the Slide pane.

To make changes, right-click a slide and do the following, using the pop-up menu:
• Add a new slide after the selected slide.

• Delete or rename the selected slide.

• Change the Slide Layout.

• Change the Slide Transition.
  – For one slide, click the slide to select it. Then add the desired transition.
  – For more than one slide, select the group of slides and add the desired transition.

• Mark a slide as hidden. Hidden slides will not be shown in the slide show.

• Copy or cut and paste a slide.

Figure 12.25 To move a slide in a presentation using the Slide Sorter

12.7.5. Handout view

Handout view is for setting up the layout of your slides for a printed handout. Click the Handout tab in the workspace, then choose Layout in the tasks pane (Figure 12.26). You can then choose to print one, two, three, four, or six slides per page.

To print a handout:

1) Select the slides using the Slide Sorter. (Use the steps listed in selecting a group of slides.)
2) Select File Print or press Ctrl+P to open the Print dialog box.
3) Select Options in the bottom left corner of the Print dialog box.
4) Check **Handouts** in the Contents section, and then click OK.

5) Click **OK** to close the Print dialog box.

![Figure 12.26 Presentation in Handout view](image)

**Tip Notes**

If you do not know the names for the pre-packaged layouts, you can use the tooltip feature. Position the cursor on an icon in the Layout section (or on any toolbar icon) and its name will be displayed in a small rectangle. If the tooltips are not enabled, you can enable them. From the main menu, select **Tools → Options → OpenOffice.org → General → Help** and mark the Tips checkbox. If the Extended tips checkbox is also marked, you will get more detailed tooltip information, but the tooltip names themselves will not be provided.
Student Activity

1. Open a presentation using
   - Empty presentation
   - From Template
   - Open Existing Presentation
2. Compare the difference on opening the presentation using the above three methods.
3. Open impress using different ways.

Teacher Activity

This entire chapter can be taught with the help of the following methodology.

1. Laboratory Activity – the teacher can make the entire class to go to the lab and can explain the concept using a projector in the lab.
2. Or else, the teacher can demonstrate the concept using a PC and a projector inside the classroom.
3. The teacher apart from this Open source software, can compare the elements of the windows and creating presentations in MS PowerPoint also.

Evaluation

Part I

Choose the correct Answer

1. Name the button in the picture?
   A) Compass   B) Navigator   C) Fill color   D) Page border
2. Which is the shortcut key to view the slideshow?
   A) F6   B) F9   C) F5   D) F10
3. In Impress, which views shows thumbnail versions of all your slides arranged in horizontal rows.
   A) Notes B) Outline C) Handout D) Slide Sorter

4. Identify the default view in Impress.
   A) Normal B) Slide Sorter C) Handout D) Notes

5. Which menu contains the Slide Transition option?
   A) Slide Show B) View C) Tools D) Format

6. Identify the extension of the Impress presentation.
   A) .odp B) .ppt C) .odb D) .ood

7. In presentation tools, the entry effect as one slide replaces another slide in a slide show. Identify the option that suits after reading the statement.
   A) Animation B) Slide Transition C) Custom animation D) Rehearse Timing

8. Vanya has made a presentation on “Global Warming”. She wants to progress her slide show automatically while speaks on the topic in the class. Which features of Impress would she use?
   A) Custom Animation B) Rehearse Timing C) Slide Transition D) Either (a) or (b).

Part II

Answer to all the questions (2 Marks)

1. What is the difference between a slide and a slide show?

2. How many in-built slide layouts does impress consist of?

3. What do you understand by a presentation?

4. Define a template in Impress.

5. What do you understand by the slide layout?
Part III

Answer to all the questions (3 Marks)

1. How many types of views are provided by Impress to its users?
2. Who uses the presentation software and why?
3. Define the Slide Sorter view and its significance.
4. What is a Normal view? Explain.
5. How are transition effects helpful in creating an effective presentation in Impress?

Part IV

Answer to all the questions (5 Marks)

1. Valarmathi’s teacher asks her to create a presentation in OpenOffice Impress. As Valarmathi has never worked in Impress before, help her to perform the following tasks:
   a. She wants that except for the first slide, all the slides should have the same design. For this, what does she need to do?
   b. To easily communicate with her audience, she wants to provide them with a hard copy of the slides of the presentation. What should she create for it?
   c. She wants to insert some pictures and movie files in some slides. How can she do that?
   d. Suggest her the view that would be the most suitable for showing the presentation to the audience.
   e. To make her presentation more attractive, she wants to add some effects in it. How can she do it? Suggest.

2. Explain how a presentation can help a sales person to promote his/her products.

3. Sivabalan created a presentation to be shown at his school’s Annual Function. Just 5 minutes before the presentation, he noticed that he has misspelt the name of the school, which is appearing in all the 30 slides of the presentation. How can he rectify this mistake in all the slides in one-shot?

4. List some advantages of using templates.
Learning Objectives

After learning this chapter, the students will be able to

- Know inserting and formatting text
- Know inserting and formatting shapes and pictures
- Insert tables and charts in a presentation
- Insert and edit organization charts
- Demonstrate inserting hyperlinks
- Explain inserting music and video
- Give various animation effects to the inserted objects
- Modify the slide transition
- Setup and control the slide show

13.1 Inserting text features

13.1.1. Inserting and formatting text

Pasting text

Text may be inserted into the text box by copying it from another document and pasting it into Impress. There are several ways to ensure consistency. These methods are explained below.

Pasting unformatted text

It is normally good practice to paste text without formatting and apply the formatting later. To paste without formatting, press Ctrl+Shift+V or select Unformatted text from the dialogbox that appears (Figure 13.1), or click on the small black triangle next to the paste symbol in the standard toolbar (Figure 13.2) and select Unformatted text.
Figure 13.1 dialog box to paste text

Figure 13.2 paste symbol in the standard toolbar to paste text

Formatting pasted text

If pasting the text into an AutoLayout area, then to give the pasted text the same look and feel of the rest of the presentation apply the appropriate outline style to the text. To do so:

1. Paste the text in the desired position.
2. Select the text you have just pasted.
3. Select **Format → Default formatting** from the menu bar. (Figure 13.3)
4. Use the four arrow buttons in the Text Formatting toolbar to move the text to the appropriate position.
Inserting special characters

To insert special characters, such as copyright, math, geometric, or monetary symbols, or characters from another language:

1. Click in the place in the text where you want to insert the character.

2. Choose Insert \(\rightarrow\) Special Character. The Special Characters dialog box appears. (Figure 13.4).

3. Choose the font and character subset from the Font and Subset drop-down menus.

4. Click the character you want to insert. You may have to scroll to find the one you want.

5. Click OK.
Figure 13.4 Inserting special characters

To show toolbar buttons that are not visible, click on the small down-arrow on the right end of the tool bar, move the cursor over Visible Buttons and then click on the icon you wish to make visible (Figure 13.5).

Figure 13.5 Making tool bar buttons visible

Formatting text

Formatting text can give a presentation a consistent look and a dynamic feel.

Modifying a style

In Impress there are two categories of styles: presentation styles and graphics styles. When inserting text in an Auto Layout area, the presentation styles become available. When inserting text in a text box or a graphic object it is possible to apply the graphic styles.
If you have selected a presentation style, the dialog box in Figure 13.6 will appear. The Presentation Style dialog box determines the formatting of the text.

![Figure 13.6 The Presentation Style dialog box](image)

The dialog box for making modifications to a graphics style is shown in Figure 13.7. Text must be selected before it can be formatted manually.

![Figure 13.7 The Graphics Style modification dialog box](image)

Formatting characters

To view the character formatting options, select **Format** → **Character** or click the Character button on the Text Formatting toolbar. (If a toolbar with the text icon is not visible, choose **View** → **Toolbars** → **Text Formatting**.) The Character dialog box appears.
Font page

Use the Font page, shown in Figure 13.8, to select the desired font type, its base attributes (Italic, Bold, etc.) as well as the size. A sample of the font is displayed in the lower part of the dialog box. You can also specify the language of this style. This page is available when creating or modifying a presentation style or a graphics style.

![Figure 13.8 The dialog box to set the basic font attributes](image)

When writing a presentation in multiple languages, you can make the best of the language setting by creating two styles that only differ in the language but are otherwise the same. This allows you to check the spelling of all of the contents without affecting the appearance.

Font Effects page

Use the Font Effects page, shown in Figure 13.9, to apply special effects to the text, such as underlining, color, shadow and so on. A sample of the text is displayed in the lower part of the dialog box allowing a quick visual check of the effects applied. This page is available when creating or modifying a presentation style or a graphics style.

![Figure 13.9 Applying special effects to the text](image)
Position page

The Position page, shown in Figure 13.10, has advanced options to customize text. This page is not available when creating or modifying a presentation style or a graphics style. Use this page to set the text position relative to the baseline when you need to insert subscripts or superscripts.

![Figure 13.10 Setting the character position attributes](image)

**Figure 13.10 Setting the character position attributes**

Formatting paragraphs

To view the paragraph formatting options, select Format → Paragraph or click the Paragraph button on the Text Formatting toolbar. If a toolbar with the text icon is not visible, choose View → Toolbars → Text Formatting. The Paragraph dialog box (Figure 13.11) is shown.

![Figure 13.11 The paragraph formatting dialog box](image)
Indents and Spacing page

The Indents and Spacing page, shown in Figure 13.12, has four sections:

- **Indent**: modifies the indentation of the text (before and after) as well as the indentation of the first line.
- **Spacing**: defines the space before and after each paragraph formatted with the style.
- **Line spacing**: determines the spacing between two lines

Alignment page

Use the Alignment page to determine the text alignment: **Left, Right, Center, or Justified**. A preview shows the effects of the changes. (Figure 13.12)

![Alignment option in paragraph formatting dialog box](image)

*Figure 13.12 The Alignment option in paragraph formatting dialog box*

Tabs page

Use the Tabs page, shown in Figure 13.13, to set tab stops. To delete one existing tab stop, select it in the list and click the Delete button. To delete all the tab stops, click the Delete All button.
Creating bulleted and numbered lists

You can customize the appearance of a list, changing the bullet type or numbering for the entire list or for single entry. All the changes can be made using the Bullets and Numbering dialog box. It is accessed by selecting **Format → Bullets and Numbering** or by clicking on the Bullets and Numbering icon on the text formatting toolbar. (**Figure 13.14**)
Workshop -1

1. Create a presentation using 8 slides and insert the following features in each slide.
   - Pasting using unformatted text
   - Formatting the text pasted
   - Inserting special characters
   - Formatting text (Changing font attributes)
   - Formatting characters
   - Formatting paragraphs
   - Creating bulleted and numbered lists

13.1.2 Inserting and formatting shapes and pictures

In order to insert an image in OpenOffice Impress, place the cursor in the place where you want the image to be inserted. Then, Click Insert → Select Picture → From File option from the Insert menu. Refer Figure 13.15.

    Figure 13.15 Inserting picture from Insert menu

OpenOffice Impress will display the dialog box, where you can select the image from the specific location and select open. The image will be inserted in the specified location. Refer Figure 13.16.
In order to format pictures, right click on the picture and select the option you want to do to that picture. Through the options, you can crop, resize, align, arrange, flip and so on.

Figure 13.17 Formatting pictures using right click
Inserting and formatting shapes

In order to insert shapes, make the Drawing tools visible by choosing View → Toolbars → Drawing option as shown in Figure 13.18. If it is already available, it will be in the bottom of the screen as in Figure 13.19. You can insert 2D as well 3D shapes. You can customise as per your need.

![Figure 13.18 Making the Drawing tool visible](image)

![Figure 13.19 Drawing toolbar](image)

13.1.3 Inserting tables and charts

To create a table proceed as follows:

1. Position the slide which will contain the table in the workarea. If necessary modify the slide layout in order to reserve the place for the table.

2. If the task pane is already open select Table Design. If the task pane is not visible, select View → Task pane, then select the Table Design task.

3. You can create a table directly by selecting Insert → Table from the main menu: the default style and settings are applied to the newly created table. (Figure 13.20)

4. Select one of the predefined styles. You will be able to change the color scheme.

5. Selecting a style opens the dialog box of Figure 13.21, where you can specify the number of rows and columns.
The table is placed at the center of the slide, but you can move it wherever it is more convenient by selecting it then dragging it in the new position.

Table toolbar

When a table is selected, the Table toolbar (Figure 13.22) should be displayed. If necessary, you can open the toolbar using View → Toolbars → Table. By default the toolbar will float, but you can fix it to the side or top of the work area wherever you want.
The Table toolbar contains the majority of the tools you need to manipulate a table.

Deleting a table

To delete a table, select it and then press the Delete key on the keyboard.

Inserting a chart

To creating a chart using the Insert Chart feature do the following:

1. Select Insert → Chart, or click the Insert Chart icon on the Standard toolbar. A chart appears that has been created using sample data. See Figure 13.23.

![Figure 13.23 Chart made with sample data](image)
2. To enter your own data in the chart, select **Chart Data Table** by right clicking the chart made with sample data. (Figure 13.24)

![Figure 13.24 Selecting Chart Data Table by right clicking](image)

3. A table with predefined data's will be seen. You can change the data as per your need. (Figure 13.25)

![Figure 13.25 Changing the Chart Data Table](image)

4. A wide range of chart types and variations are available. You can choose any chart. (Figure 13.26)
13.1.4 Inserting Hyperlinks

To insert a hyperlink, or to customize the appearance of a hyperlink, select Insert → Hyperlinks from the menu bar. The dialog box shown in Figure 13.27 will appear.

On the left hand side, select one of the four types of hyperlinks:

- **Internet**: a web address, normally starting with http://
- **Mail & News**: for example an email address.
• **Document**: the hyperlink points to another document or to another place in the presentation.

• **New document**: the hyperlink creates a new document.

### 13.1.5 Inserting music and video

Open Office Impress will let you insert audio files or movie files. The audio and movie files can be inserted by clicking **Insert → Movie and Sounds** option from the **Insert menu**. Refer **Figure 13.28**.

**Figure 13.28 Selecting Movies and Sound from Insert menu**

**Figure 13.29 Selecting Movies and Sound file from a folder**
Same as inserting images, a dialog box will be opened. Select the audio or movie file from the specified location and open. It will be opened in the slide as follows. Refer Figure 13.29. The movie or audio file inserted will be played during the slide show by clicking the mouse over it.

13.1.6. Inserting various animation effects to the inserted objects

Applying an animation effect

- In Normal View, display the desired slide.
- Select the text or object you want to animate.
- In the Tasks pane, choose Custom Animation (Figure 12.30). Click Add. The Custom Animation dialog box appears.
- Choose an effect from one of the pages of this dialog box and choose the speed or duration of that effect.
- To choose the animation to be applied when the object is placed on the screen, use an effect, for example Fly In or Dissolve In.
- Use the Emphasis page to apply an effect that changes the font color or applies special effects to the text such as blinking text.
- To choose the effect to be applied when the object is leaving the page, use the Exit page.

![Figure 13.30 Task pane, showing Custom Animation page](image-url)
If you want the object to move along a line or curve, select an animation from the Motion Paths page.

Click OK to save the effect and return to the Custom Animation page on the Task pane. Here you can choose how to start the animation, change the speed, and apply some additional properties of the selected effect.

Choices may vary depending on the selected object; for example, pictures and text have different Emphasis choices.

Starting an animation effect

You have three choices for starting an animation effect:

On click—the animation stops at this effect until the next mouse click.

With previous—the animation runs at the same time as the previous animation.

After previous—the animation runs as soon as the previous animation ends.
13.2. Modifying the slide transition

Slide transitions are the effects that take place when one slide gives way to the next one in the presentation, like Roll down from top or Fly in from left. They add dynamic style to a slideshow, smoothing the transition between slides.

You can add transitions while in Slide Sorter view or in Normal view. To see the effect of a selection, you need to be in Normal view and select the Automatic preview checkbox on the Slide Transition page of the Tasks pane.

You can apply a single type of transition to all slides in the presentation or apply a different transition to any single slide, even having a different transition for every slide in the show.

Applying a slide transition effect

- In the Tasks pane, choose Slide Transition (Figure 12.32).

- In the Slides pane or Slide Sorter view, select the slides to which you want to apply the transition.

- If you want the transition to apply to all slides, you do not need to select them first.

- In the Apply to selected slides list, select a transition.

- Modify the selected transition by changing the speed or adding a sound, in the Modify transition area.

- If you choose to play a sound, select it in the Sound list. The Loop until next sound checkbox now becomes active. Select this checkbox to play the sound repeatedly until another sound starts.

- Choose how to advance to the next slide: manually (on mouse click) or automatically. If you choose automatically, you can specify how long the slide remains visible before it automatically advances to the next slide.

- If you want the effect you just defined to apply to all slides in the show, click the Apply to All Slides button.

- To preview the transition effect, click the Play button.

- To start the slide show from the current slide (so you can see all the transitions), click the Slide Show button.
Removing a transition effect

1. Select the desired slides.

2. Choose No Transition in the list on the Slide Transition page of the Tasks pane.

   If you want most of the slides to have the same transition, but a few to be different, you may find it easiest to apply one transition to all slides and then change only the ones you want to be different.

13.3 Setting and Controlling the slide show - timer or mouse controlled

Running the slide show

To run the slide show, do one of the following:

- Click Slide Show > Slide Show on the main menu bar. (Refer Figure 12.33).

- Click the Slide Show button on the Presentation toolbar or the Slide Sorter toolbar (Refer Figure 12.34).

- Press F5 or F9.
If the slide transition is **Automatically**, after x seconds let the slide show run by itself.

If the slide transition is **On mouse click**, do one of the following to move from one slide to the next.

- Use the **arrow keys** on the keyboard to **go to the next slide** or to **go back to the previous one**.
- Click the mouse button to advance to the next slide.
- Press the **Spacebar** on the keyboard to advance to the next slide.
- When you advance past the last slide, the message “**Click to exit presentation...**” appears. Click the mouse or press any key to exit the presentation.
- To exit the slide show at any time, including at the end, press the **Esc key**.
Points to Remember:

- Inserting slide – Insert → Slide
- Deleting Slide – Edit → Delete slide
- Running slide show – Slide Show → slide show
- Save presentation - File → Save
- To view slide master – Click View → master → Slide Master
- To insert Graphic object - View → Toolbars → Drawings
- To insert picture – Insert → Select picture → From File
- To insert Audio & Video – Insert → move → Sounds.

Evaluation

Part I

Choose the correct answer

1) Which of the following is the default pre-packaged layout in a new presentation?
   A) Blank Slide layout    B) Title Slide layout
   C) Title Only layout    D) Title and content Layout

2) Which is not pre-packaged layout in presentation?
   A) Main Content layout   B) Title, 6 Content layout
   C) Blank Slide layout    D) Title, 2 content over content

3) What is the usage of Extended Tips option in Help Menu?
   A) Detailed Tool Tip Information   B) Helps to resize the Tips window
   C) To enable frequently ask question   D) To create Footer content

4) Which is the shortcut key for adjustment to formatting text
   A) F10   B) F7   C) F11   D) F5

5) .......... is the default pre-packaged layout for inserting additional slides
   A) Blank Slide layout    B) Title Slide layout
   C) Title, 6 Content layout    D) Centered Text Layout

6) Name of the button in the picture
   A) Create New Presentation   B) Create New layout
   C) Create New Layout   D) Create New additional Slides

7) Which element is not available in additional slides?
   A) Insert Chart   B) Inset Movie
   C) Insert Picture   D) Insert Grid

8) You can use the running slideshow option by clicking slide show button on the .......... 
   A) Tool bar   B) Menu Bar   C) Navigation Bar   D) Sliding Tool Bar
Part II

Answer to the following questions (2 Marks)
1) What do you understand by Save Auto Recovery Information?
2) Define Extended Tips option?
3) List out pre-packaged layouts
4) Define slide master
5) List out the presentation supported file types.

Part III

Answer to the following questions (3 Marks)
1) How to create first slide in presentation?
2) How to Deleting a Slide in presentation?
3) How to perform Saving a Presentation file?
4) Define Master slide?
5) What are the multimedia option are available in Drawing toolbar

Part IV

Answer the following questions (5 Marks)
1) Discuss in detail about Graphic Objects feature in Presentation
2) Explain methods to handle Multimedia files in presentation slides
3) List out and explain advantages of Master slides in presentation.
4) Create and perform the following presentation activity about school annual achievement
   1) Inserting the first slide using Title Slide layout
   2) Create additional slides and insert images and videos about school annual achievement
   3) Perform delete and rearrange operations in the existing presentation file
   4) Finally Running the slide show and start your presentation

GLOSSARY

1. Auto recovery : Recovering a damaged file automatically
2. Layout : Predefined design
3. Right Click : Pressing right mouse button
4. Rearrange : Changing original order of arrangement
5. Master slide : Primary slide contains predefined background design
6. Slide Masters : Contains 28 prepackaged master pages
Learning Objectives

By the end of this chapter, the students will be able to:

- Explain the evolution of Networking
- Types of Network Topologies
- To explain the types of Network
- To compare the types of Networks
- To identify the types of network in the lab
- To identify computers and users over a network
- To explain wireless mobile communication
- To explain internet applications
- To know Network security concepts
- To use a DNS server to connect it to a network resource/server

Computer Network

A computer network is an interconnection of various computers to share software, hardware, resources and data through a communication medium between them.

The computers on a computer network may be linked through cables, telephone lines, radio waves, satellites, or infrared light beams.

14.1. Evolution of Networking

Computers became able to exchange data in automatic mode, which, essentially, is the basic mechanism of any computer network. Developers of the first networks implemented services for file exchange, database synchronization, e-mail and other network services.

14.1.1. ARPANET

ARPANET was established by the Advanced Research Projects Agency (ARPA) in 1969 for two main reasons:

- To allow the transfer of data between various institutes of research.
- To answer the call of the U.S. Department of Defence for a technology to provide messaging capabilities to the government in the event of nuclear war.

14.1.2 World Wide Web (WWW)

The World Wide Web is a collection of documents and services. It is distributed across the Internet and linked together by hypertext links. The web is therefore a subset of the Internet.

World Wide Web was created by Timothy Berners Lee in 1989 at CERN in Geneva.

Web page is a document available on World Wide Web. A web page can contain...
information including text, graphics, audio, video and hyper links. These hyper links are the link to other web pages.

**Web Browser** is an application software that allows us to view and explore information on the web.

Following are the most common web browser available today:

<table>
<thead>
<tr>
<th><strong>Browser</strong></th>
<th><strong>Vendor</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Internet Explorer</td>
<td>Microsoft</td>
</tr>
<tr>
<td>Google Chrome</td>
<td>Google</td>
</tr>
<tr>
<td>Mozilla Firefox</td>
<td>Mozilla</td>
</tr>
<tr>
<td>Netscape Navigator</td>
<td>NetscapeCommunications Corp.</td>
</tr>
<tr>
<td>Opera</td>
<td>Opera Software</td>
</tr>
<tr>
<td>Safari</td>
<td>Apple</td>
</tr>
<tr>
<td>Sea Monkey</td>
<td>Mozilla Foundation</td>
</tr>
<tr>
<td>K-meleon</td>
<td>K-meleon</td>
</tr>
</tbody>
</table>

### Table 14.1

**WWW Operation**

**WWW** works on client- server approach. Following steps explains how the web works:

1. User enters the URL (say http://www.tngovernmentjobs.in/) of the web page in the address bar of web browser.
2. Then browser requests the Domain Name Server for the IP address corresponding to www.tngovernmentjobs.in.
3. After receiving IP address, browser sends the request to web page and web server using HTTP protocol.
4. Then web server receives request using HTTP protocol and checks for the requested web page. If found it returns it back to the web browser and close the HTTP connection.
5. Now the web browser receives the web page, it interprets and displays the contents of web page in web browser's window.

![Figure 14.1 WWW Operation](image)

Web server is a computer where the web content is stored. Basically web server is used to host the web sites.
Internet

- Internet is a world-wide global system of interconnected computer networks.

- Internet uses the standard Internet Protocol (TCP/IP).

- Every computer in internet is identified by a unique IP address.

- IP Address is a unique set of numbers (such as 110.22.33.114) which identifies a computer location.

- A special computer DNS (Domain Name Server) is used to give name to the IP Address so that user can locate a computer by a name.

- Internet is accessible to every user all over the world.

Evolution

- The origin of Internet is devised from the concept of Advanced Research Project Agency Network (ARPANET).

Advantages

- Internet allows us to communicate with the people sitting at remote locations. There are various apps available on the web that uses Internet as a medium for communication. One can find various social networking sites such as:
  - Facebook
  - Twitter
  - Yahoo
  - Google+
  - Flickr
  - Orkut

- One can surf for any kind of information over the internet with the help of a search engine.

- Apart from communication and source of information, internet also serves a medium for entertainment. Following are the various modes for entertainment over internet.
  - Online Television
  - Online Games
  - Songs
  - Videos
  - Social Networking Apps

- Internet allows us to use many services like:
  - Internet Banking
  - Online Educational Services
  - Online Shopping
  - Online Ticket Booking
  - Online Bill Payment
  - Data Sharing
  - E-mail

- Internet provides concept of electronic commerce, that allows the business deals to be conducted on electronic systems
Topology:

Topology describes the physical cabling layout and the logical way of moving data between components.

14.2. Network Topologies

Network Topology is the schematic description of a network arrangement, connecting various nodes (sender and receiver) through lines of connection.

14.2.1. BUS Topology

Bus topology is a network type in which every computer and network device is connected to a single cable. All devices are connected to a common backbone. Maximum nodes that can be attached are 30.

Features of Bus Topology

1. It transmits data only in one direction.
2. Every device is connected to a single cable.

![Bus Topology](image)

Figure 14.2 Bus Topology

Advantages of Bus Topology

1. It is cost effective.
2. Installation of device is easy.
3. Cable required is least compared to other network topology.
Disadvantages of Bus Topology

1. If backbone breaks then whole network fails.
2. It is difficult to isolate problems due to single cable.
3. If network traffic is heavy or nodes are more the performance of the network decreases.
4. Cable has a limited length.

STAR Topology

![STAR Topology Diagram]

*Figure 14.3 STAR Topology*

In this type of topology all the computers are connected to a single hub/switch through a cable. This hub is the central node and all others nodes are connected to the central node.

Features of Star Topology

1. In this type, every node has its own dedicated connection to the hub.
2. The hub acts as a repeater for data flow.
Advantages of Star Topology

1. The performance is fast with few nodes and low network traffic.
2. The hub can be upgraded easily.
3. It is easy to troubleshoot, to setup and modify.
4. Only the failed node will get affected, and the rest can work smoothly.

Disadvantages of Star Topology

1. If the hub fails then the whole network is stopped because all the nodes depend on the hub.
2. It requires more cable length.

TREE Topology

This type of topology is arranged in the form of a tree structure in which top level contains parent node (root node), which is connected with the child nodes in the second level of hierarchy. The second level nodes are connected to the third level nodes, which in turn are connected to the fourth level nodes and so on. Except the top-level nodes, each level node has a parent node. It is also called hierarchical topology.

Features of Tree Topology

1. It is ideal if workstations or nodes are located in groups.
2. It can be used in Wide Area Network.
Advantages of Tree Topology

1. The expansion of nodes is possible in this type.
2. It will be easily managed and maintained.
3. The error detection can be done easily.

Disadvantages of Tree Topology

1. If more nodes are added maintenance is difficult.
2. If the central hub fails, network fails.

Workshop-1

Go to your Computer laboratory and identify the type of topology followed there. Seek help from your teacher.

14.3. Types of Network

14.3.1. Computer Networks classified into three classes regarding the size, distance and the structure namely: LAN (Local Area Network), MAN (Metropolitan Area Network), WAN (Wide Area Network) and PAN (Personal Area Network).

Personal area network

- A personal area network, or PAN, is a computer network that enables communication between computer devices.
- PANs can be wired, such as USB or FireWire, or they can be wireless, such as infrared, ZigBee, Bluetooth and ultra wide band (UWB).
- The range of a PAN typically is a few meters. Examples of wireless PAN, or WPAN, devices include cell phone headsets, wireless keyboards, wireless mice, printers, bar code scanners and game consoles.

LAN (Local Area Network)

- A Local Area Network is a privately owned computer network covering a small Networks geographical area, like a home, office, or groups of buildings e.g. a school Network.
- We can use different types of topologies through LAN.
- LAN networks are also widely used to share resources like printers, shared hard-drive etc.
- The size of LAN is usually small. The various devices in LAN are connected to central devices called Hub or Switch using a cable.
- Now-a-days LANs are being installed using wireless technologies.
- LAN offers high speed communication of data rates between 4 to 16 megabits per second (Mbps).
Applications of LAN

- In this network one can become a server serving all the remaining computers called clients. Software can be stored on the server and it can be used by the remaining clients.

- Without internet access, it is possible to connect all the workstations in a building with each other locally.

- It is easy to share common resources like printers with LAN.

Disadvantages of LAN

- **Privacy Violations:** The LAN administrator has the rights to check personal data files of each and every LAN user. Moreover he can check the internet history and computer use history of the LAN user.

- **Data Security Threat:** Unauthorised users can access important data of an organization if centralized data repository is not secured properly by the LAN administrator.

- **Covers Limited Area:** Local Area Network covers a small area like one office, one building or a group of nearby buildings.

Metropolitan Area Network (MAN)

It is basically a bigger version of LAN. It is designed to extend over the entire city. MANs extend beyond 100 KM. MANs are usually owned by large organizations to interconnect its various branches across a city. MAN comprises combination of different hardware and transmission media. It can be single network such as a cable TV network, or it is a means of connecting a number of LANs into a larger network so that resources can be shared LAN to LAN as well as device to device.
Advantages of MAN

- It is extremely efficient and provides fast communication via high-speed carriers, such as fibre optic cables.
- It provides a good back bone for large network and provides greater access to WANs.
- The dual bus used in MAN helps the transmission of data in both directions simultaneously.
- A MAN usually encompasses several blocks of a city or an entire city.

Disadvantages of MAN

- More cable is required for a MAN connection from one place to another.
- It is difficult to make the system secure from hackers and spying.

Wide area network (WAN)

A wide area network (WAN) is a telecommunication network. WANs connect LANs that may be on opposite sides of a building, across the country or around the world. Computers connected to a Wide Area Networks are often connected through public networks, such as the telephone system. They can also be connected through leased lines or satellites. The largest WAN in existence is the Internet.
Advantages of WAN

- It covers a large geographical area.
- It shares software and resources with connecting workstations.
- Messages can be sent very quickly to anyone else on the network. These messages can have picture, sounds or data included with them (called attachments).
- Everyone on the network can use the same data. This avoids problems where some users may have older information than others.

Disadvantages of WAN

- It needs a good firewall to restrict outsiders from entering and disrupting the network.
- Once set up, maintaining a network is a full-time job which requires network supervisors and technicians to be employed.
- Security is a real issue when many different people have the ability to use information from other computers. Protection against hackers and viruses adds more complexity and expense.

Workshop-2

Go to your Computer laboratory and try to identify the type of computer network followed there. Seek help from your teacher.
14.4. Wired Technologies

The means through which data is transferred from one place to another is called transmission or communication media. There are two categories of transmission media used in computer communications.

- Wired/Bounded/Guided media
- Wireless/Unbounded/Unguided media

### Transmission modes

- **Bounded medium**
  - Coaxial
  - Baseband
  - Fibre optics
  - Twisted
  - Unshielded
  - Shielded
- **Unbounded medium**
  - Radio Transmission
  - Microwave Transmission

#### Figure 14.8 Wired Technologies

**Bounded/Guided Media**

There are three common types of bounded media in the data transmission. They are:

- Twisted-Pair Cable,
- Coaxial Cable, and
- Fibre-Optic Cable.

Twisted-pair and coaxial cable use metallic (copper) conductors that accept and transport signals in the form of electric current. Optical fibre is a cable that accepts and transports signals in the form of light.

14.4.1. Twisted Pair Cable

A twisted pair consists of two conductors (normally copper), each with its own plastic insulation, twisted together. One of these wires is used to carry signals to the receiver, and the other is used only as ground reference. In addition to the signal sent by the sender on one of the wires, interference (noise) and crosstalk may affect both wires and create unwanted signals.

**Twisted Pair is of two types:**

- Unshielded Twisted Pair (UTP)
- Shielded Twisted Pair (STP)
Unshielded Twisted Pair Cable

It consists of two insulating copper wires (1mm thick). The wires are twisted together in a helical form to reduce electrical interference from similar pair. Identification is the reason behind coloured plastic insulation.

Advantages
- It has high speed capacity.
- Higher grades of UTP are used in LAN technologies like Ethernet.

Disadvantages
- Bandwidth is low when compared with Coaxial Cable.
- Provides less protection from interference.

Shielded Twisted Pair Cable

This cable has a metal foil or braided-mesh. Electromagnetic noise penetration is prevented by metal casing. Shielding also eliminates crosstalk. It is faster than unshielded and coaxial cable.
Advantages

- It can be used for Analog or Digital transmission
- It increases the signalling rate.
- It eliminates crosstalk.

Disadvantages

- It is difficult to manufacture

Coaxial Cable

- Coaxial is called by this name because it contains two conductors that are parallel to each other.
- Copper is used in this as a central conductor. It is surrounded by PVC installation.
- Outer metallic wrapping is used as a shield against noise and as a second conductor which completes the circuit.
- The outer conductor is also encased in an insulating sheath. The outermost part is the plastic cover which protects the whole cable.
- The the most common coaxial standards are:
  - 50-Ohm RG-7 or RG-11 : used with thick Ethernet.
  - 50-Ohm RG-58 : used with thin Ethernet
  - 75-Ohm RG-59 : used with cable television
  - 93-Ohm RG-62 : used with ARCNET.

Figure 14.11 Coaxial Cable

Advantages

- It is used in long distance telephone lines.
- It transmits digital signals at a very high rate of 10Mbps.
• It has higher noise immunity.

• It transmits data without distortion.

• The can span to longer distance at higher speeds as they have better shielding when compared to twisted pair cable

Disadvantages

• Single cable failure can fail the entire network.

• If the shield is imperfect, it can lead to grounded loop.

Fiber Optical Cable

A fibre-optical cable is made of glass or plastic and transmits signals in the form of light. In fibre optical cable, light moves only in one direction. For two way communication to take place a second communication must be made between the two devices. Optical fibres use reflection to guide light through a channel. A glass or plastic core is surrounded by a cladding of less dense glass or plastic. The difference in density of the two materials must be such that a beam of light moving through the core is reflected off the cladding instead of being refracted into it.

Fibre-Optic Cable Connectors

There are three types of connectors for fibre-optic cables, as shown in the figure below.
The Subscriber Channel (SC) connector is used for cable TV. It uses push/pull locking system. The Straight-Tip (ST) connector is used for connecting cable to the networking devices. The MT-RJ connector utilizes two fibres and integrates them into a single design that looks similar to an RJ45 modular connector.

Advantages
Fibre optic has several advantages over metallic cable:
- It is resistant to corrosion.
- It shows greater immunity to tapping.

Disadvantages
- It has unidirectional light propagation.

Workshop-3
Go to your Computer laboratory. Identify the type of wired technology applicable there. Write a report on using the same.

14.5. Wireless Technologies

Wireless communication plays a significant role in day to day life. The term wireless refers to the communication or transmission of information over a distance without requiring wires, cables or any other electrical conductors.

The Communication is set and the information is transmitted through electromagnetic waves like radio frequencies, infrared, satellite, etc., in a wireless communication technology network.
Types of Wireless Communication Technologies

The devices used for wireless communication are cordless telephones, mobiles, GPS units, wireless computer parts, and satellite television.

14.5.1. Bluetooth

It is named after a Danish king named Harald Bluetooth. Bluetooth is used to connect different electronic devices wirelessly to a system for transferring and sharing data. Cell phones are connected to hands-free earpieces, wireless keyboard, mouse and mike to laptops with the help of Bluetooth as it transmits information from one device to other device.

Figure 14.14 Bluetooth Technology

Infrared

Infrared technology is a type of wireless communication technology to transfer data between two infrared enabled devices through infrared radiation. This technology plays very important role in wireless data communication. Infrared is used in devices such as the mouse, wireless keyboard and printers.

Unlike Wi-Fi and Bluetooth technologies, infrared network signals cannot penetrate walls or other obstructions and work only with a direct line of sight.

Due to its short-range communication system, the use of an infrared communication system in one room will not be affected by the use of another system in the next room. This is why using an infrared TV remote control in our home will not interfere with the use of our neighbour’s infrared TV remote control.

They also operate in diffuse mode, also called scatter mode. This means that the source and destination are not directly visible to each other. An example is a television remote-control box. The box does not have to be pointed directly at the set, although the box must be in the same room as the set, or just outside the room with the door open.

Line-of-sight transmission is a characteristic of electromagnetic radiation which means waves will travel in a direct path from the source to the receiver.
Wi-Fi

Wi-Fi is a low-cost wireless communication technology. A WiFi setup consists of a wireless router which serves a communication hub, linking portable device with an internet connection. This network facilitates connection of many devices depending on the router configuration. These networks are limited in range due to the low power transmission, allowing the user to connect only in the close proximity.

Figure 14.15 Line of Sight

Figure 14.16 wifi
Bluetooth is designed to connect two devices directly together by pairing them so they can communicate, usually for the purposes of relaying information (like sound or instructions) from one device to the other. The distance to which they will be able to connect is only short, usually several feet, while the range of Wi-Fi is greater.

Wi-Fi is generally used to connect many devices to one central device, typically a Wi-Fi enabled router, most often for the purposes of accessing the Internet. Wi-Fi is considered more stable and performs better when connecting for longer periods of time and transferring larger amounts of data.

**Radio link**

- A radio link is a wireless connection (also called wireless Point-to-Point connection) between two nodes, or radio units, in a data network.

- Each radio unit consists of a transceiver (a device that can both send and receive communication) and a highly directive antenna. The antenna only emits or receives power in the direction it is pointing.

- The two radio units are mounted and are directed towards each other with no obstacles, such as buildings, in between them that can hinder or disturb the transmission.

- As the connection is very directive it enables very high signal to noise ratio and thereby high data rates.

- The primary downside is that radio links require direct so called line-of-sight for optimum performance. Compared to fibre the connection is less stable as bad weather can interrupt the connection, in particular at higher frequencies.

**Microwave Link**

- Microwave is a line-of-sight wireless communication technology that uses high frequency beams of radio waves to provide high speed wireless connections that can send and receive voice, video and data information.

- One of the reasons microwave links are so adaptable is that they are broadband.

- They require no equipment or facilities between the two terminal points, so installing a microwave link is often faster and less costly than a cable connection.

- Microwaves are also able to penetrate rain, fog and snow, which means bad weather doesn’t disrupt transmission.

**Satellite link**

- Satellite communication is one of the wireless technologies, used to transfer the signals from the transmitter to a receiver with the help of satellites.

- It is widely spread all over the world allowing users to stay connected virtually anywhere on the Earth.

- The Satellites used in this mode of communication, communicate directly
with the orbiting satellites via radio signals.

- The process of satellite communication begins at an earth station. Here an installation is designed to transmit and receive signals from a satellite in orbit around the earth.

- The transmission system from the earth station to the satellite through a channel is called the uplink. The system from the satellite to the earth station through the channel is called the downlink.

Workshop-4
Identify the ways of pairing a mobile phone with other one using Bluetooth technology.

14.6. Network devices

Network devices are components used to connect computers or other electronic devices together so that they can share files or resources.

14.6.1. Hub

It is a common connection point for devices in a network. It joins together the workstations, printers, and servers on a network to communicate with each other. Each hub has a number of ports that connect it to the other devices via a network cable. A hub connects all the devices on its ports together. When data arrives at one port, it is sent to the other ports so that all the devices can see all the information, commonly called packets.

Figure 14.17 Hub

Switch

A switch is a hardware device that filters and forwards network packets. A network switch also connects computers to each other, like a hub. When a switch receives a packet of data, it determines what computer or device the packet is intended for and sends it to that computer only. It does not broadcast the packet to all computers as a hub. For this reason alone, switches are usually preferred over a hub.

Figure 14.18 Switch

Repeater

Repeaters remove the unwanted noise in an incoming signal. It increases a signal's strength, so it can be transmitted and received over a greater distance without a loss in quality. Network repeaters receive and retransmit incoming electrical, wireless or optical signals.

Whenever a repeater receives a signal through one of its ports, it repeats or sends the incoming signal onto the other port. Its main use is to amplify and regenerate signals.
Gateway

A network gateway joins two networks so the devices on one network can communicate with the devices on another network. Gateways serve as the entry and exit point of a network. For basic Internet connections at home, the gateway is the Internet Service Provider that gives you access to the entire Internet.

A gateway is often associated with a router. Routers can be gateways because a router can control the path through which information is sent in and out.

The default gateway is the machine IP number that you need to access to get to the rest of the network or the Internet.

14.7. Identifying computers and users over a network

14.7.1. Basic concept of domain name

- A domain name is a unique name that identifies a website. Each website has a domain name that serves as an address, which is used to access the website. For example, "google.com" is a domain name.
Whenever you visit a website, the domain name appears in the address bar of the web browser. Some domain names are preceded by "www" (which is not part of the domain name), while others omit the "www" prefix.

All domain names have a domain suffix, such as .com, .net, or .org. The domain suffix helps identify the type of website the domain name represents. There are only a limited number of such domains. For example:

- gov - Government agencies
- edu - Educational institutions
- org - Organizations (nonprofit)
- mil - Military
- com - commercial business
- net - Network organizations
- ca - Canada
- th - Thailand

Domain names are relatively cheap to register, though they must be renewed every year or every few years. Anyone can register a domain name, so you can purchase a unique domain name for your blog or website.

When you access a website, the domain name is actually translated to an IP address, which defines the server where the website located. This translation is performed dynamically by a service called DNS.

MAC Address

- MAC stands for "Media Access Control".

- A MAC address is a hardware identification number that uniquely identifies each device on a network.

- MAC addresses are made up of six two-digit hexadecimal numbers, separated by colons. For example, an Ethernet card may have a MAC address of 00:0d:83:b1:c0:8e. Fortunately, you do not need to know this address, since it is automatically recognized by most networks.

IP address

- IP stands for "Internet Protocol." An IP address, is a unique address that identifies a device on the Internet or a local network.

- It allows a system to be recognized by other systems connected by the Internet protocol. There are two primary types of IP address formats used today — IPv4 and IPv6.

- IPv4, the most common form of addresses, are written as four sets of numbers, each set having up to three digits, with each set separated by a dot. For example, "111.222.111.222" could be
a valid IPv4 IP address. With DNS, we map a name to that address so that you do not have to remember a complicated set of numbers for each place you wish to visit on a network.

A valid IP address must be in the form of xxx.xxx.xxx.xxx, where xxx is a number from 0-255. IPv6 is the sixth revision to the Internet Protocol and the successor to IPv4. It functions similarly to IPv4 in that it provides the unique, numerical IP addresses necessary for Internet-enabled devices to communicate. It utilizes 128-bit addresses. IPv4 uses 32 bits for its Internet addresses.

14.8. Wireless/Mobile Communication

Wireless communications is a type of data communication that is performed and delivered wirelessly. This is a broad term that incorporates all procedures and forms of connecting and communicating between two or more devices using a wireless signal through wireless communication technologies and devices.

14.8.1. GSM (Global System for Mobile Communication)

The Global System for Mobile Communications (GSM) is a second generation (2G) standard for mobile networks.

In the early 1980s, a group was formed by the European Telecommunications Standards Institute (ETSI) to develop a digital mobile communication system. Aptly named Groupe Speciale Mobile (GSM), its main task was to develop a single, consistent network for all of Europe and come up with a better and more efficient technical solution for wireless communication.
The GSM standard operates on three different carrier frequencies: the 900 MHz band, which was used by the original GSM system; the 1800 MHz band, which was added to support the swelling number of subscribers and the 1900 MHz frequency, which is used mainly in the U.S.

CDMA (Code Division Multiple Access)

CDMA (Code-Division Multiple Access) refers to a protocol used in second-generation (2G) and third-generation (3G) wireless communications. Code Division Multiple Access (CDMA) is a sort of multiplexing that facilitates various signals to occupy a single transmission channel. It optimizes the use of available bandwidth. The technology is commonly used in ultra-high-frequency (UHF) cellular telephone systems, bands ranging between the 800-MHz and 1.9-GHz.

GPRS (General Packet Radio Service)

General Packet Radio Service (GPRS) is a packet-switching communications protocol for cellular networks. Mobile phones that have the GPRS technology can be used to receive data and information, such as web pages and email. GPRS is an "always on" technology which means that the mobile phone is always ready to receive data.

Other features supported by GPRS include:

- Short Message Service (SMS) – It is a special-purpose communication protocols designed for text messaging
- Multimedia Messaging Service (MMS) – It is an extensions to SMS to enable transmission of videos in addition to text
- Wireless Application Protocol (WAP) – It is a specialized communication protocol for mobile browsers.

WLL (Wireless Local Loop)

WLL is a system that connects subscribers to the local telephone station wirelessly. Wireless local loop is used for wireless communication links which deliver plain old telephone services or broadband services to customers. This is an ideal application which provides telephone services remotely and is mostly used in developing countries where cable infrastructure is either expensive or speed is not fast. This wireless link can be a part of the connection between the subscribers and switch.

This system is based on radio networks which provide services like telephone in remote areas. Different types of wireless local loop include Broadband Wireless Access, Radio in the Loop, Fixed Radio Access and Fixed Wireless Access.
All 4G service is called 4G or 4G LTE (Long Term Evolution), the underlying technology is not the same with every carrier. Some use WiMax technology for their 4G network, while Verizon Wireless uses a technology called Long Term Evolution, or LTE (Long Term Evolution).

14.9. Internet Applications

14.9.1. SMS

SMS stands for Short Message Service. It is commonly referred to as “text messaging.” It is a service for sending short messages of up to 160 characters (224 characters if using a 5-bit mode) to mobile devices, including cellular phones, smartphones and PDAs.

Voice Mail System (VMS) and answering Machine

Voice mail system can be thought as a message box for phone user to store voice messages and retrieve it through telephone. User can divert all his calls to his voice mail system when he wishes so.

Main difference between answer machine and voice mail system is that voice mail system is a centralized system where voice mail boxes are managed for many users, while answering machine is an independent individual system connected to a telephone line. Many telephone instrument comes with built-in answering machine.

Messages stored in answering machine is played back on the answering machine equipment, cannot be accessed remotely. But voice mail messages can be accessed, listened and managed from anywhere in the world through telephone line.

Answering machine is usually suitable for home use for single line, while voice mail system is more suitable for office use where there are multiple telephone connections as well as extensions through EPABX.
E-Mail

E-mail (electronic mail) is the exchange of computer-stored messages by telecommunication. E-mail messages are usually encoded in ASCII text. However, you can also send non-text files, such as graphic images and sound files, as attachments sent in binary streams. E-mail was one of the first uses of the Internet and is still the most popular use. A large percentage of the total traffic over the Internet is e-mail. E-mail can also be exchanged between online service provider users and in networks other than the Internet, both public and private.

Chat

Chat is a text-based communication that is live or in real-time. For example, when talking to someone in chat any typed text is received by other participants immediately.

Video Conferencing

A video conference is a live, visual connection between two or more people residing in separate locations for the purpose of communication. At its simplest, video conferencing provides transmission of static images and text between two locations. It provides transmission of full-motion video images and high-quality audio between multiple locations.

For example, a point-to-point (two-person) video conferencing system works much like a video telephone. Each participant has a video camera, microphone and speakers mounted on his or her computer. As the two participants speak to one another, their voices are carried over the network and delivered to the other's speakers and whatever images appear in front of the video camera appear in a window on the other participant's monitor.

Multipoint videoconferencing allows three or more participants to sit in a virtual conference room and communicate as if they were sitting right next to each other.


14.10.1. Cyber Law

Cyber law is the part of the overall legal system that deals with the Internet, cyberspace, and their respective legal issues. Cyber law covers a fairly broad area including freedom of expression, access to and usage of the Internet and online privacy. Cyber law has been referred to as the Law of the Internet.

Figure 14.23 Cisco Hardware Firewall

A firewall is a network security system, either hardware- or software-based, that uses rules to control incoming and outgoing network traffic. A firewall acts as a barrier between a trusted network and an untrusted network.

A firewall controls access to the resources of a network through a positive control model. This means that the only traffic allowed onto the network is defined in the firewall policy all other traffic is denied.
Cookies

Cookies are small files which are stored on a user's computer. They are designed to hold a modest amount of data specific to a particular client and website, and can be accessed either by the web server or the client computer.

Hacking

Computer hacking refers to the practice of modifying or altering computer software and hardware to accomplish a goal that is considered to be outside of the creator's original objective. Those individuals who engage in computer hacking activities are typically referred to as “hackers.”

Crackers

A cracker is someone who breaks into someone else's computer system, often on a network; bypasses passwords or licenses in computer programs; or in other ways intentionally breaches computer security.

Points to Remember:

- A computer network is an interconnection of various computers
- ARPANET was established by the Advanced Research Projects Agency (ARPA) in 1969
- World Wide Web was created by Timothy Berners Lee in 1989 at CERN in Geneva.
- Web page is a document available on World Wide Web
- Web Browser is an application software that allows us to view and explore information on the web
- Web server is a computer where the web content is stored. Basically web server is used to host the web sites
- Internet is a world-wide global system of interconnected computer networks.
- Network Topology is the schematic description of a network arrangement, connecting various nodes (sender and receiver) through lines of connection.
- A personal area network, or PAN, is a computer network that enables communication between computer devices
- A Local Area Network is a privately owned computer network covering a small Networks geographical area, like a home, office, or groups of buildings e.g. a school Network
- MANs are usually owned by large organizations to interconnect its various branches across a city.
- Computers connected to a Wide Area Networks are often connected through public networks
- A fibre-optic cable is made of glass or plastic and transmits signals in the form of light.
• The term wireless refers to the communication or transmission of information over a distance without requiring wires, cables or any other electrical conductors.

• Bluetooth is used to connect different electronic devices wirelessly to a system for transferring and sharing data.

• Infrared technology is a type of wireless communication technology to transfer data between two infrared enabled devices through infrared radiation.

• A WiFi setup consists of a wireless router which serves a communication hub, linking portable device with an internet connection.

• Hub is a common connection point for devices in a network.

• A switch is a hardware device that filters and forwards network packets.

• Repeaters remove the unwanted noise in an incoming signal.

• Gateways serve as the entry and exit point of a network.

• A domain name is a unique name that identifies a website.

• MAC stands for "Media Access Control" Address.

• IP stands for "Internet Protocol." An IP address, is a unique address that identifies a device on the Internet or a local network.

• Wireless communications is a type of data communication that is performed and delivered wirelessly.

• The Global System for Mobile Communications (GSM) is a second generation (2G) standard for mobile networks.

• CDMA (Code-Division Multiple Access) refers to a protocol used in second-generation (2G) and third-generation (3G) wireless communications.

• General Packet Radio Service (GPRS) is a packet-switching communications protocol for cellular networks.

• WLL is a system that connects subscribers to the local telephone station wirelessly.

• Voice mail system can be thought as a message box for phone user to store voice messages and retrieve it through telephone.

• A video conference is a live, visual connection between two or more people residing in separate locations for the purpose of communication.

• Cyber law is the part of the overall legal system that deals with the Internet, cyberspace, and their respective legal issues.

• A firewall is a network security system, either hardware- or software-based, that uses rules to control incoming and outgoing network traffic.

• Cookies are small files which are stored on a user’s computer.

• A cracker is someone who breaks into someone else's computer system.
Student Activity
1. Identify the type of network in your computer lab.
2. Analyse the type of wired technologies in the computer lab.
3. Prepare a report on the types of cables used in your school. (Include the image of the cables in the report)
4. How will you change your computer’s IPv4 address? Write the steps.
5. Identify 10 domain names of famous educational websites.

Teacher Activity
1. The teacher should make the students to go to the lab for explaining the following concepts:
   a. Network Topologies
   b. Types of Networks
   c. Wired Technologies
   d. Wireless Technologies
   e. Network devices
2. The teacher can prepare a PPT for the same and explain the concepts.
3. The teacher can make use of real objects like types of cables, network devices to explain those concepts.
4. The teacher should demonstrate how to set/change the IPv4 address.
Answer the correct answer

1. Which one of the following is not used in media access control?
   A) ethernet    B) digital subscriber line
   C) fiber distributed data interface  D) none of the mentioned

2. Which is the first network used to exchange information?
   A) CNNET    B) NSFNET    C) ASAPNET    D) ARPANET

3. Which of the following type of network contains Bluetooth as its example?
   A) personal area network    B) local area network
   C) virtual private network    D) none of the mentioned

4. Identify the device that forwards packets between networks by processing the routing information included in the packet.
   A) bridge    B) firewall    C) router    D) all of the mentioned

5. Your company has a LAN in its downtown office and has now set up a LAN in the manufacturing plant in the suburbs. To enable everyone to share data and resources between the two LANs, what type of device(s) are needed to connect them? Choose the most correct answer.
   A) Modem    B) Cable    C) Hub    D) Router

6. Identify the data communication system within a building or campus.
   A) LAN    B) WAN    C) MAN    D) None of the mentioned

7. Identify the twisted pair cable in which metal casing improves penetration of noise or crosstalk.
   A) insulated twisted pair cable    B) Shielded twisted pair cable
   C) Unshielded twisted pair cable    D) Both A & B

8. ASCII stands for ------------------------------
   A) American Standard Code for Information Interchange
   B) American Scientific Code for International Interchange
   C) American Standard Code for Intelligence Interchange
   D) American Scientific Code for Information Interchange

9. Read the statements and identify the correct option.
   Statement A: Voice mail system is a centralized system where voice mail boxes are managed for many users.
   Statement B: voice mail messages can be accessed, listened and managed from anywhere in the world through telephone line.
   A) Statement A is correct    B) Statement B is correct
   C) Both the statements are correct    D) None of them
10. Identify the network security system that uses rules to control incoming and outgoing network traffic.
   A) Firewall  B) Cookies  C) Hacking  D) Crackers

Part II
Answer to all the questions (2 Marks)
1. Define Computer network.
2. What is electronic commerce?
3. What is spamming?
4. What do you understand by the term node in computer networks?
5. Differentiate 3G and 4G communication.

Part III
Answer to all the questions (3 Marks)
1. Differentiate Web page, Web browser and a Web Server.
2. Switches are usually preferred over a hub. Why?
3. Write short notes on the following: a) Hub  b) Switch  c) Gateway
4. Draw an outline for the following: a) Coaxial Cable  b) Fiber Optic Cable
5. Write the specific functions of a) Subscriber Channel (SC)  b) Straight-Tip (ST)  c) MT-RJ connector

Part IV
Answer to all the questions (5 Marks)
1. Define Topology. Explain different topologies using schematic diagram.
2. Explain the types of computer networks based on its size, distance and the structure.
3. Define wired technology. Explain the common types of bounded media in the data transmission.
4. Mention the types of wireless technologies we are using. Write in brief on each of them.
5. Explain the applications of internet.

References:
Web links
4. https://edurev.in/studytube/Chapter-8-COMMUNICATION-AND-ETWORK-CONCEPTS--Chapter-Notes--Class-12--Computer-Science/7e0d2043-f861-4e90-9a9c-5f5b800fb2c0_t
6. https://www.lifewire.com/what-is-3g-service-577592
7. https://www.lifewire.com/what-is-4g-wireless-577577
<table>
<thead>
<tr>
<th><strong>GLOSSARY</strong></th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th><strong>Routers</strong></th>
<th>Routers are small electronic devices that join multiple computer networks together via wired or wireless connections.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>World Wide Web (www)</strong></td>
<td>The World Wide Web is an information space where documents and other web resources are identified by Uniform Resource Locators (URLs).</td>
</tr>
<tr>
<td><strong>MILNET</strong></td>
<td>Military network was the name given to a network that split off from ARPANET in 1983 to create an internetwork designated for use by the U.S. Department of Defense. MILNET later became part of the DoD Defense Network (DDN).</td>
</tr>
<tr>
<td><strong>NSFNET</strong></td>
<td>The National Science Foundation Network (NSFNET) was a program of coordinated, evolving projects sponsored by the National Science Foundation (NSF).</td>
</tr>
<tr>
<td><strong>HTTP</strong></td>
<td>HTTP (Hypertext Transfer Protocol) is the set of rules for transferring files (text, graphic images, sound, video, and other multimedia files) on the World Wide Web.</td>
</tr>
<tr>
<td><strong>MTRJ Connector</strong></td>
<td>MT-RJ stands for Mechanical Transfer Registered Jack. MT-RJ is a fiber-optic Cable Connector that is very popular for small form factor devices due to its small size.</td>
</tr>
<tr>
<td><strong>RJ 45 Connector</strong></td>
<td>A registered jack (RJ) is a standardized physical network interface for connecting telecommunications or data equipment. RJ 45 is an 8-pin/8-position plug or jack and is commonly used to connect computers onto Ethernet-based local area networks (LAN).</td>
</tr>
<tr>
<td><strong>GSM (Global System for Mobile Communication)</strong></td>
<td>GSM (Global System for Mobile Communications) is a standard developed by the European Telecommunications Standards Institute (ETSI). Wireless communication, is the transfer of information or power between two or more points that are not connected by an electrical conductor. The most common wireless technologies use radio waves.</td>
</tr>
<tr>
<td><strong>CDMA (Code Division Multiple Access)</strong></td>
<td>Code-division multiple access (CDMA) is a channel access method used by various radio communication technologies.</td>
</tr>
<tr>
<td><strong>GPRS (General Packet Radio Service)</strong></td>
<td>General Packet Radio Service (GPRS) is a packet oriented mobile data service on the 2G and 3G cellular communication system’s global system for mobile communications (GSM).</td>
</tr>
<tr>
<td><strong>virtual private networks (VPNs)</strong></td>
<td>A virtual private network (VPN) extends a private network across a public network, and enables users to send and receive data across shared or public networks as if their computing devices were directly connected to the private network.</td>
</tr>
<tr>
<td><strong>Wireless Local Loop (WLL)</strong></td>
<td>Wireless local loop (WLL), is the use of a wireless communications link as the “last mile / first mile” connection for delivering plain old telephone service (POTS) or Internet access.</td>
</tr>
<tr>
<td><strong>Plain Old Telephone Service (POTS)</strong></td>
<td>Plain old telephone service (POTS) is a retronym for voice-grade telephone service employing analog signal transmission over copper loops.</td>
</tr>
<tr>
<td><strong>LTE(Long Term Evolution)</strong></td>
<td>Long Term Evolution (LTE) refers to a standard for smooth and efficient transition toward more advanced leading-edge technologies to increase the capacity and speed of wireless data networks. LTE is often used to refer to wireless broadband or mobile network technologies.</td>
</tr>
<tr>
<td><strong>WiMax technology</strong></td>
<td>WiMAX technology is a broadband wireless data communications technology based around the IEEE 802.16 standard providing high speed data over a wide area. The letters of WiMAX stand for Worldwide Interoperability for Microwave Access (AXess).</td>
</tr>
<tr>
<td><strong>Voice Mail System (VMS)</strong></td>
<td>A voicemail system (also known as voice message or voice bank) is a computer-based system that allows users and subscribers to exchange personal voice messages; to select and deliver voice information; and to process transactions relating to individuals, organizations, products and services, using an ordinary telephone.</td>
</tr>
</tbody>
</table>
Learning Objectives

- To learn about the Evolution of Internet
- To learn about the Services Available on the Internet
- To learn about the methodology and features of Search Engine
- To know the types of Social Media available on the Internet
- To learn about the network security threats and prevention measures to avoid the Threads.

15.1 Introduction to Internet:

The Internet is the global system of interconnected computer networks that use the Internet protocol suite to link devices worldwide. The purpose of the internet is to communicate between computers that are interconnected with each other. Internet is accessible to every user all over the world.

It is a network of networks that consists of private, public, academic, business, and government networks of local to global scope, linked by a broad array of electronic, wireless, and optical networking technologies.

The Internet carries a vast range of information resources and services, such as the inter-linked hypertext documents and applications of the World Wide Web (WWW), electronic mail, telephony and file sharing.

Browser is a tool used to access the internet using WWW (World Wide Web) and HTTP (Hyper Text Transfer Protocol). In the browser, if the user types the domain name such as www.tn.gov.in, the browser calls a protocol name DNS (Domain Name Server). DNS is used to get the IP address of the domain names.

15.1.1. Evolution of Internet:

Internet evolved in 1969 and evolved many changes in several technologies and Infrastructural levels.

- Internet was started by ARPANET (Advanced Research Project Agency Network), developed by United States. Department of Defence for communication among different government bodies, initially with four nodes.
In 1972, the four nodes has been developed and it grown to 23 nodes located in different countries making it Internet.

- Invented TCP/IP protocols, DNS, WWW, browsers scripting languages.
- Internet is used as a medium to publish and access the information.
- In 1985, The NSFNET was composed of multiple regional networks and peer networks.
- In 1986, the NSFNET created a three-tiered network architecture.
- In 1988, updated the links to make it faster.

In 1990, Merit, IBM, and MCI started a new organization known as Advanced Network and Services (ANS).

By 1991, data traffic had increased tremendously, which necessitated upgrading the NSFNET's backbone network service to T3 (45 Mbps) links.

Tip Notes
- The History of the Internet Began with the launch of the Evolution of Research Network (ERNET) in 1986.
- The first publicly available Internet Service in India was launched by state-owned videsh Sanchar Nigam Limited (VSNL) on 14th August 1995.

Internet Evaluation:

Figure 15.2 Internet History Timeline
Internet covers almost every aspect of life. Internet allows the users to communicate with the people sitting at remote locations. There are various applications available on the web that uses Internet as a medium for communication. One can find various social networking sites such as Facebook, Twitter, Yahoo, Google+, Flickr, Orkut. One can surf for any kind of information over the internet. Information regarding various topics such as Technology, Health and Science, Social Studies, Geographical Information, Information Technology and Products can be surfed with help of a search engine.

Apart from communication and source of information, internet also serves as a medium for entertainment. Internet also allows the users to use as many services as like E-mail, Internet Banking, Online Shopping, Online Ticket Booking, Online Bill Payment and Data Sharing. Internet provides concept of electronic commerce, that allows the business deals to be conducted on electronic systems.

15.2 Hardware and Software Requirements for Internet connection:

The following are the methods of connecting a computer to the Internet using software and hardware peripherals.

Three

- Connecting a computer using Wireless Broadband
- Connecting a computer using an Ethernet Cable
- Connecting a Computer Using Dial-Up Community

Hardware Requirement:

- To connect the Internet, any one of the following is mandatory.
- Modem is used to connect Internet through Telephone connection.
- NIC- Network Interface Card(wired/wireless) facility is the most important hardware required to connect Internet. For example, the Laptop can be connected Internet through the wired/wireless.
- Dongle is used to connect the Internet using cellular network
- Wi-Fi router or Hotspot is used to connect the Internet using wireless network
- Electronic device which supports cellular network
- Internet Connectivity such as Dial-up connection, ISDN, DSL, Cable TV, wired and wireless (Cellular) Network.

Software Requirement

- The operating system should support TCP (Transfer Control Protocol) / IP (Internet Protocol), SMTP (Simple Mail Transfer Protocol), FTP (File Transfer Protocol), HTTP (Hyper Text Transfer Protocol) and HTTPS (Hyper Text Transfer Protocol Secured) protocols.
- Browsers and other Internet clients access to the web applications such as Outlook, Gmail, Whatsapp, Facebook, Twitter and etc.

Connection Types:

The following methods are able to connect internet.
Dial-up Connection:

A dial-up connection is established when two or more data communication devices use a Public Switched Telephone Network (PSTN) to connect to an Internet Service Provider (ISP) from computers. Many remote locations depend on Internet dial-up connections because broadband and cable are rare in remote areas with low population. Internet Service Providers often provide dial-up connections, a feasible alternative for budget-conscious subscribers.

Figure 15.3 Dial-up Connection

ISDN

ISDN is the acronym of Integrated Services Digital Network. It establishes the connection using the phone lines (PSTN) which carry digital signals instead of analog signals. It is a set of communication standards for simultaneous digital transmission of data, voice, video, and other services over the traditional circuits of the public switched telephone network. There are two techniques to deliver ISDN services such as Basic Rate Interface (BRI) and Primary Rate Interface (PRI).

The following diagram shows accessing internet using ISDN connection:

Figure 15.4a Integrated Services Digital Network

DSL:

Digital Subscriber Line (DSL) is a high-speed Internet service for homes and businesses that competes with cable and other forms of broadband Internet. DSL provides high-speed networking over ordinary Telephone lines using broadband modem technology. The technology behind DSL enables Internet and telephone service to work over the same phone line without requiring customers to disconnect either their Voice or Internet connections.

Cable TV Internet Connection (setup box):

The cable TV network can be used for connecting a computer or a local network to the Internet, competing directly with DSL (Digital Subscriber Line) technology.

This type of network is classified as HFC (Hybrid Fiber-Coaxial), as it uses both fiber optics and coaxial cables. The connection between the cable TV company to the distribution points (Optical nodes) is made using fiber optics, with distances up to 25 miles (40 km). Each optical node is typically serves between 500 and 2,000 clients (customers).
The following diagram shows how internet is accessed using Cable TV connection:

![Cable TV Connection Diagram](image)

**Figure 15.4b Cable TV Connection**

**Satellite Internet Connection:**

Satellite Internet access is Internet access provided through satellite communication for domestic and enterprise usage. The facility of modern consumer grade satellite Internet service is typically provided to individual users through geostationary satellites. It provides fairly high data speeds, along with latest satellites using Ka-band to attain downstream data speeds up to 50 Mbps internet speed.

**Wireless Internet Connection:**

It is a technology for wireless local area networking with devices based on the IEEE 802.11 standards. Devices that can use Wi-Fi technology include personal computers, video-game consoles, phones and tablets, digital cameras, smart TVs, digital audio players and modern printers. Wi-Fi compatible devices can connect to the Internet via a WLAN and a wireless access point. Such an access point (or hotspot) has a range of about 20 meters (66 feet) indoors and a greater range of outdoors. Hotspot coverage can be as small as a single room with walls that block radio waves, or as large as many square kilometres achieved by using multiple overlapping access points.

15.3. Services Available on the Internet:

- Data Transfer
- Internet banking
- E-commerce
- E-Learning
- E-Governance
- Browsing and Chating
- E-Mail

**Data Transfer:**

Data transfer is the process of using computing techniques and technologies to transmit or transfer electronic or analog data from one computer node to another. Data is transferred in the form of bits and bytes over a internet digital or analog medium, and the process enables digital or analog communications and its movement between devices. Data transfer is also known as data transmission.

**Internet Banking:**

Traditionally, customers used to access banking services through Retail/corporate branch. But in this digital era Online Banking has taken vital role. The online banking is also called as internet banking, virtual banking or e-banking. This is a value added application to connecting the core banking system and provide the self service bank facilities for customers via online. The **Figure 15.5** is the Screen Shot of the login screen of internet banking.
Figure 15.5 login screen of internet banking

Features:

- A bank customer can perform transactional and non-transactional tasks through online banking, including
- Viewing account balances, transactions, statements of customer
- Viewing images of paid cheques, request for cheque books
- Funds transfers between the customer's linked accounts
- Paying third parties, including bill payments and third party fund transfers
- Register utility billers and make bill payments

Advantages

- Permanent online access for the banking transactions.
- Access anywhere using the application via mobile or computer
- Less time consuming, easy to use and safe
- Customer can manage their funds instantly and accurately

E-commerce:

E-commerce application is a transaction of buying or selling goods and services through online. Electronic commerce attraction technologies such as mobile commerce, electronic funds transfer, supply chain management, Internet marketing, online transaction processing, electronic data interchange (EDI), inventory management systems, and automated data collection systems.

E-commerce businesses may also employ some or all of the followings:

- Online shopping web sites for retail sales direct to consumers
- Providing or participating in online market places, which process third-party business-to-consumer or consumer-to-consumer sales
- Business-to-business buying and selling;
- Gathering and using demographic data through web contacts and social media
- **Business-to-business** (B2B) electronic data interchange
- Marketing to prospective and established customers by e-mail or fax (for example, with newsletters)
- Engaging in pretail for launching new products and services
• Online financial exchanges for currency exchanges or trading purposes.

**e-Marketing: (Electronic Marketing)**

E-Marketing is the process of marketing a product or service using the internet. It also includes marketing done via e-mail and wireless media. It also called Digital Marketing.

**Figure 15.6 e-Marketing**

Professionals working in e-marketing must design and implement Internet marketing plans. But they also must have a broad understanding of what makes these plans effective. Those working in e-marketing must be able to carry out many tasks:

• Following business market trends

• Consulting with companies about digital marketing needs

• Resolving issues businesses have in reaching customers oriented problems

• Creating e-marketing objectives for business challenges

• Developing marketing strategies competitive business model.

• Choosing cost-effective marketing methods

• Launching digital marketing campaigns and monitoring results

**E-Learning:**

A learning system based on electronic resources is known as E-learning. The use of computers and the Internet forms the major component of E-learning. The E-learning can also be termed as a network enabled transfer of skills and knowledge and the delivery of education is made to a large number of recipients at the same or different times.

**E-Governance:**

E-governance is the application of Information and Communication Technology (ICT) for delivering government services, exchange of information, communication transactions, integration of various stand-alone systems and services between government-to-citizen (G2C), Government-to-business (G2B), Government-to-Government (G2G), Government-to-Employees (G2E) as well as back office processes and interactions within the entire government framework. Through e-governance, government services will be made available to citizens in a convenient, efficient and transparent manner. The three main target groups that can be distinguished in governance concepts.
are government, citizens and businesses/interest groups. In e-governance there are no distinct boundaries.

It classify four basic models they are:

- Government-to-Citizen (customer)
- Government-to-Employees
- Government-to-Government
- Government-to-Business

Examples of e-Governance:

- Aadhaar Card is a 12-digit unique identity number issued to all Indian residents based on their biometric and demographic data.

- Inspector General of Registration portal - Tamil Nadu – [www.tnreginet.gov.in](http://www.tnreginet.gov.in) used for Land and legal registrations

Online Chatting:

Online chat refers to any kind of communication via the Internet that offers a real-time transmission of text messages from sender to receiver. The chat messages are generally short in order to enable other participants to respond quickly. Online chat may address point-to-point communications as well as multicast communications from one sender to many receivers and voice and video chat and web conferencing service.

15.4: The Role of WWW as a Service on the Internet:

The World Wide Web abbreviated as WWW or the Web. It is an information space where documents and other web resources are identified by Uniform Resource Locators (URLs), interlinked by hypertext links, and can be accessed through the Internet.

WWW Operation:

The World Wide Web is the universe of network-accessible information, an expression of human knowledge. All the resources and users on the Internet that are using the Hypertext Transfer Protocol HTTP.

It is a way of exchanging information between computers on the Internet, tying them together into a vast collection of interactive multimedia resources.

Internet and Web is not the same thing: Web uses internet to pass over the information.

Figure 15.8 World Wide Web Architecture

Web Page:

Webpage is a document commonly written in HyperText Markup Language (HTML) that is accessible through the Internet or other network using an Internet browser. A web page is accessed by entering a URL address and may contain text, graphics and hyperlinks to other web pages and files. The page you are reading now is an example of a web page.

Domain Name:

A domain name is an identification a string that defines a area of administrative autonomy,
authority or control within the Internet. Domain names are formed by the rules and procedures of the Domain Name System (DNS). Any name registered in the DNS is a domain name. Domain names are used in various networking backgrounds and application-specific naming and addressing purposes. In general, a domain name represents an Internet Protocol (IP) resource, such as a personal computer used to access the Internet, a server computer hosting a web site.

There are several domain names available:

- Generic domain names such as .com, .edu, .gov, .net.
- Country level domain names such as au, in, za, us.

The following table shows the Generic Top-Level Domain names:

Table 15.1 Top-Level Domain names

<table>
<thead>
<tr>
<th>Domain Name</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Com</td>
<td>Commercial business</td>
</tr>
<tr>
<td>edu</td>
<td>Education</td>
</tr>
<tr>
<td>gov</td>
<td>U.S. Government agency</td>
</tr>
<tr>
<td>int</td>
<td>International entity</td>
</tr>
<tr>
<td>mil</td>
<td>U.S. military</td>
</tr>
</tbody>
</table>

Web Browser:

A web browser also called browser. It is a software application for retrieving, presenting and traversing information resources on the World Wide Web. An information resource (web data) is identified by a Uniform Resource Identifier (URI/URL) that may be a web page, image, video or other piece of content available in web server. Browsers are primarily use the World Wide Web, they can also be used to access information provided by web servers in private networks or files in file systems.

Figure 15.9 Web Browser

Table 15.2 Browsers and Vendors

<table>
<thead>
<tr>
<th>Browser</th>
<th>Vendor</th>
</tr>
</thead>
<tbody>
<tr>
<td>Internet Explorer</td>
<td>Microsoft</td>
</tr>
<tr>
<td>Google Chrome</td>
<td>Google</td>
</tr>
<tr>
<td>Mozilla Firefox</td>
<td>Mozilla</td>
</tr>
<tr>
<td>Netscape Navigator</td>
<td>Netscape Communications Corp.</td>
</tr>
<tr>
<td>Opera</td>
<td>Opera Software</td>
</tr>
<tr>
<td>Safari</td>
<td>Apple</td>
</tr>
<tr>
<td>Sea Monkey</td>
<td>Mozilla Foundation</td>
</tr>
<tr>
<td>K-meleon</td>
<td>K-meleon</td>
</tr>
</tbody>
</table>

Web Server:

A web server is a computer system application that processes requests via HTTP, the basic network protocol used to distribute information on the World Wide Web. The term can refer to the entire system, or specifically to the software that accepts...
and supervises the HTTP requests

Following table describes the most leading web servers available today:

**Table 15.3 Web Server**

<table>
<thead>
<tr>
<th>S.N.</th>
<th>Web Server</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Apache HTTP Server.</td>
</tr>
<tr>
<td>2</td>
<td>Internet Information Services (IIS)</td>
</tr>
<tr>
<td>3</td>
<td>Sun Java System Web Server</td>
</tr>
</tbody>
</table>

Web Hosting:

Web Facilitating is an administration of give online space to capacity of site pages. These site pages are made accessible by means of WWW. The organizations which offer site facilitating are known as web host

**Examples of Web Hosting Companies:**

1) Go Daddy
2) Amazon Web service
3) Digital Ocean
4) Free webhostingarea.com

15.5: Working of Search Engine

A 'web search engine' is a software system that is designed to search for information on the World Wide Web. A huge information available on internet on various topics. The information may be a mix of web pages, images, and other types of files. Some search engines also mine data available in databases or open directories. Search engines also maintain real-time information by running an algorithm on a web crawler.

There are many different search engines available.

![Search Engines](image)

www.freewebhostingarea.com is a hosting company. It is providing Free Web Hosting Area provides unmetered traffic and free web space for domain or subdomain with php, mail, mysql, ftp support, no ads. In internet many other companies ready to provide free web hosting facilities.
Find quick answers in google:

For many searches, Google will do the work for you and show an answer to your question in the search results. Some features, like information about sports teams, aren't available in all regions.

Weather : Search weather to see the weather in your location or add a city name, like weather seattle, to find weather for a certain place.

Dictionary : Put define in front of any word to see its definition.

Calculations : Enter a math equation like 3*9123, or solve complex graphing equations.

Unit conversions: Enter any conversion, like 3 dollars in euros.

Sports: Search for the name of your team to see a schedule, game scores and more.

Quick facts: Search for the name of a celebrity, location, movie, or song to find related information.

15.6. Structure and Working of E-Mail:

Electronic Mail (email or e-mail) is a method of exchanging messages between people using electronic devices. Email first entered limited use in the 1960s and by the middle of 1970s had taken the form now recognized as email. Email operates across computer networks, which is primarily called as Internet.

Earlier email systems required the sender and the recipient to both be online at the same time, in common with instant messaging. Today's email systems are based on a store-and-forward model. Email servers accept, forward, deliver, and store messages.

The structure of the E-mail address is username@domain name

An example of E-mail address is raman@gmail.com

An E-mail address consists of two parts separated by @ symbol. The first part Raman is the user name that identifies the address and the second part gmail.com is the domain name of the E-mail server.
Sample E-mail Application

![Image of a Gmail inbox with various emails]

**Figure 15.11 Sample E-mail Application**

How Email works on the Internet:

To send Internet e-mail, requires an Internet connection and access to a mail server. The standard protocol used for sending Internet e-mail is called SMTP (Simple Mail Transfer Protocol). The SMTP protocol is used to both send and receive email messages over the Internet.

When a message is sent, the email client sends the message to the SMTP server. If the recipient of the email is local the message is kept on the server for accessing by the POP, IMAP or other mail services for later retrieval.

If the recipient is remote (i.e. at another domain), the SMTP server communicates with a Domain Name Server (DNS) to find the corresponding IP address for the domain being sent to. Once the IP address has been resolved, the SMTP server connects with the remote SMTP server and the mail is delivered to this server for handling.

If the SMTP server sending the mail is unable to connect with the remote SMTP server, then the message goes into a queue. Messages in this queue will be retried periodically. If the message is still undelivered after a certain amount of time (30 hours by default), the message will be returned to the sender as undelivered.
Structure of an Email message:

![Image of an email interface]

**To**: This field consists of the address to whom the message has to be sent. This is mandatory.

**CC**: Short for carbon copy. This is optional. The people who were mailed copies of the message. The recipients of the message will know to whom all the copies have been sent.

**BCC**: It stands for Black Carbon Copy. It is used when we do not want one or more of the recipients to know that someone else was copied on the message. This is optional.

**Subject**: The Subject field indicates the purpose of e-mail.

**Attachment**: Attachment contains files that you are sending, linked documents, pictures, etc. along with an e-mail.

**Body**: The email body is the main part of an email message. It contains the message’s text, images and other data (such as attachments). The email’s body is distinct from its header, which contains control information and data about the message (such as its sender, the recipient and the path an email took to reach its destination).

**Signature**: Name of the sender

Advantages and Disadvantages of Email:

**Advantages:**

- **Reliable**: Because it notifies the sender if not delivered.
- **Speed**: E-mail is very fast delivered in fraction of seconds.
- **Inexpensive**: It's very cheap.
- **Waste Reduction**: Helps in paperless communication thus eco-friendly.

**Disadvantages:**

- **Forgery**: Anyone who hacks the password of the sender can send a message to anyone.
- **Overload**: Because it is cheap loads and loads of messages keeps coming.
- **Junk**: Junk emails are not intended mails and is inappropriate also. Junk emails are sometimes referred to as spam.

**Tip Notes**

- V.A.ShivaAyyadurai, an Indian Born American Scientist and Entrepreneur invented E-mail.
- There are Three Types of E-mail Protocol Simple Mail Protocol (SMTP), Post Office Protocol (POP), Internet Mail Access Protocol (IMAP)
- 3. Email Service Gmail, Hotmail, yahoomail, icloudmail, ATMail, Shortmail

15.7. Different Types of Social Media:

Social media are computer-mediated technologies that facilitate the creation and sharing of information, ideas, career interests and other forms of expression via virtual communities and networks. The
variety of stand-alone and built-in social media services currently available introduces challenges of definition; however, there are some common features

- Social media are interactive Web Internet-based applications.
- User-generated content, such as text posts or comments, digital photos or videos, and data generated through all online interactions, is the lifeblood of social media.
- Users create service-specific profiles for the website or app that are designed and maintained by the social media organization.
- Social media facilitate the development of online social networks by connecting a user’s profile with those of other individuals or groups.

The following table shows some of the popular social media services:

**Table 15.4 Social Media Services**

<table>
<thead>
<tr>
<th>S. N.</th>
<th>Service Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Facebook: Allows to share text, photos, video etc. It also offers interesting online games.</td>
</tr>
<tr>
<td>2.</td>
<td>Google+: It is pronounced as Google Plus. It is owned and operated by Google.</td>
</tr>
<tr>
<td>3.</td>
<td>Twitter: Twitter allows the user to send and reply messages in form of tweets. These tweets are the small messages, generally include 140+ characters.</td>
</tr>
<tr>
<td>4.</td>
<td>Whatsapp: It is a mobile based messaging app. It allows to send text, documents, video, and audio messages</td>
</tr>
<tr>
<td>5.</td>
<td>Linkedin: Linkedin is a business and professional networking site.</td>
</tr>
</tbody>
</table>

**SOCIAL MEDIA ADVANTAGES AND DISADVANTAGES**

Advantages of Social Media for the Society:

**Connectivity** – The lifeline of the social media is connectivity. It connects with people living anywhere in the world.

**Education** – Nowadays lots of classes are taken online through Skype. Tuitions are taken through online. Even post graduation also done online.

**Information and Updates** – The boon of the social media is that getting updated on real time from the latest happenings around the world.

Disadvantages of Social Media for the Society:

**Addiction** – Though we have many advantages but the major drawback is that people get addicted to the social medias.

**Security Issues** – Since everything has become online, right from payment of bill to bank transaction, there are many possibilities to get hacked.

**Reputation** – Social media being viral it affects the reputation of others

- Instagram, Photo Sharing and Social Networking came into existence in 2010
- The inventor of Facebook is Mark Zuckerberg
- Google was invented by Larry Page and Sergey Brin

**15.8 Threats to Network Security:**

Network Security plays very critical factor in almost every field either it is an organization, a governmental entity, a country, or even
your house. Computers, mobile devices, and Internet are also facing surplus amount of network security challenges day by day.

As far as the security risks in mobiles/computers are concerned, virus attacks, stealing of data, deletion of data and damage to hardware can be taken into consideration.

Network security is not only that blocking unauthorized access, denial of service to an unauthorized user, but also includes the virus attack, hacking, trojans etc.

Network Security Threats
Types of threats

**Malware:**

Malware is a software designed by hackers to gain illegal access to software and cause damage.

**Viruses:**

A virus is a small piece of computer code that can repeat itself and spreads from one computer to another by attaching itself to another computer file.

**Worms:**

Worms are self-repeating and do not require a computer program to attach themselves. Worms continually look for vulnerabilities and report back to the author of the worm when weaknesses are discovered.

**Spyware/adware:**

Spyware/adware can be installed on the computer automatically when the attachments are open, by clicking on links or by downloading infected software.

**Trojans:**

A Trojan virus is a program that appears to perform one function (for example, virus removal) but actually performs hateful activity when executed.

**Botnet:**

A Botnet is a Group of computers connected to the Internet that have been compromised by hacker using a computer virus or Trojan Horse.

An Individual computer in the group is known as a Zombie computer.

**Tip Notes:**

1. Chang your password frequently to prevent password hacking.
2. Take a backup of important files and programs regularly.
3. Do not open the unknown or spam email without security.
4. Use antivirus program to detect and prevent from the viruses.
5. Uses strong encryption to perform daily transaction on the web when you transfer your personal data.
information, can use SSL (Digital Certificate) which being hard for intruders.

6. Using firewall, it is a machine between your system's network and internet that filtering the traffic which might be unsafe.

15.10: Guidelines for Using Internet and Computer Ethics:

Guidelines for Using on Internet:

- Do not use the computer in ways that may harm other people.
- Do not use computer technology to cause interference in other users' work.
- Do not peep into on another person's computer data.
- Do not steal information.
- Do not spread wrong information using computer technology.
- Do not copy software or buy pirated copies. Pay for software unless it is free.
- Do not use someone else's computer resources unless authorized to.
- Do not claim other's work to be yours.
- Before developing a software, think about the social impact it can have.
- In using computers for communication, be respectful and courteous with the fellow members.

Computer Ethics:

Computer ethics deals with the procedures, values and practices that govern the process of consuming computer technology and its related disciplines without damaging or violating the moral values and beliefs of any individual, organization or entity. It also promotes the discussion of how much influence areas such as Artificial Intelligence can have on the human society.

The following are the morals that society adheres to:

1. **Honesty**: A decent behavior, the user should be truthful while using the internet.
2. **Confidentiality**: The user maintains confidentiality and does not share any important information to unauthorized persons.
3. **Respect**: A user should respect the privacy of other users.
4. **Professionalism**: A user should maintain professional conduct and well-mannered approach.
5. **Obey The Law**: A user should strictly obey the law in computer usage.
6. **Responsibility**: The user should take ownership and responsibility to ensure authenticity and truth.
Points to Remember:

- Connecting more than one computer is called Network.
- Intranet—Connecting computers within the same organization or home
- Internet—Connecting computers World Wide irrespective of the network.
- The origin of Internet has started by Advanced Research Project Agency Network was developed by United States Department of Defense.
- Various Hardware required to connect the Internet are TCP/IP protocol, browser and other client applications.
- There are several services available on the Internet, they are Data transfer, Internet Banking, E-commerce, E-Learning, E-governance, Browsing and Chatting and E-mail.
- WWW stands for World Wide Web
- Web page—A document on website
- Web site—a collection of web pages
- Domain name—The last part of the Internet address is the domain name which is associated with IP Address.
- Web Browser—A software that enables us to look and search for their interested topic on the Internet.
- Web Server—A computer that stores all the information
- Search engine—A special program which functions on the keywords used.
- E-mail—A text message sent to a person in any part of the world in a fraction of a second.
- Social Media—A place where people are connected to share their thoughts, ideas with each other.
- Threads are those attacks on mobile or computers to steal the data or to damage others computers.
- Computer Ethics—Doing what is Right morally according to the standards of cyber world.

Evaluation

Part –I
Choose the correct answer
1) _______is connecting computers World Wide irrespective of the network.
   A) Internet    B) Extranet  
   C) Intranet    D) WWW
2) The origin of Internet has started by _______.
   A) Advanced Research Project Agency Network
   B) Advanced Reach Project Agency Network
3) Copying of data from storage device to memory is called-----
   A) Data transfer    B) Data model
   C) Data Transmitting D) Data Table
4) The main objective of _______ is to make paper less money Transaction easier
   a) E-cash    b) E-Wallet
   c) E-commerce  d) E-Learning
190

5) ------ is malicious software with which user is misdirected to fraudulent websites
   a) Pharming  b) Phishing  
   c) Virus   d) Trojans

6) ----- is an E-commerce transaction type with a low financial Amount
   A) Micro payment  
   B) Micro Finance  
   C) E-cash  
   D) E-wallet

7) ----- is not a special program which functions on the keyword used
   A) web server  
   B) web page  
   C) web browser  
   D) search engine

8) ----- is a term used to describe actions taken by someone to gain unauthorised access to computer
   A) Malware  
   B) Spyware  
   C) Hardware Hacking  
   D) Ransomware

9) ----- is used to access the Internet using www and http.
   A) web page  
   B) Browser  
   C) web site  
   D) web server

10) ----- is a software designed by hackers to gain illegal access to software and cause damage
    A) Malware  
    B) Spyware  
    C) Hardware  
    D) Ransomware

11) ----- is the mobile based messaging App
    A) Whatsapp  
    B) E-mail  
    C) facebook  
    D) twitter

12) The abbreviation for http------
    A) Hyper text transfer protocol  
    B) Hyper transmit transfer protocol  
    C) Hyper tech transfer protocol  
    D) Hyper text telnet protocol

13) ISDN is Acronym of -------
    A) Integrated services Digital Network  
    B) Intermediate service Digital Network  
    C) Information services digital network  
    D) Intellectual services Digital Network

14) ----- is used to connect Internet through Telephone connections
    a) Modem     b) NIC  
    c) Dongle    d) Hotspot

15) Which of the following is malware?
    a) Viruses  
    b) Worms  
    c) Trojan horses  
    d) All the above

Part-II
Answer to all the questions (2 Marks)
1. What is network? What are its types?
2. What is Digital cash?
3. What is E-marketing?
4. What is video conferencing?
5. What is Student networking?
6. What is Social Networking?
7. What are the preventing measures for network attacks?
8. What is computer Ethics?
9. What is Phishing?
10. What are viruses in computer?

Part- III
Answer to all the questions (3 Marks)
1. Differentiate between Intranet and Internet?
2. What are the Hardware /Software requirements for Internet connection?
3. What are the features of Internet Banking?
4. What is Electronic Wallets?
5. How does WWW work?
6. How does the search engine work?
7. What is Electronic Mail?
8. Advantages and Disadvantages of E-mail?
9. Advantages and Disadvantages of Social Media for the Society?
10. Explain Ransomware:
Part-IV

Answer to all the questions (5 Marks)
1. What are the services available on the Internet and Explain them?
2. Describe WWW with its components?
3. Describe the structure and working of E-mail?
4. What are the different types of Social Media and Explain them?
5. What are the Guidelines for working of Internet?
6. What are the morals that society adheres to?

List of Reference Books:
1. The Internet Book
   Author - Douglas E Comer
   Author - Preston Gralla
3. Introduction to Networking: How the Internet Works
   Author - Dr. Charles R Severance
4. Buy The Complete E-Commerce Book
   Author - Janice Reynolds

Websites:
1. https://www.gcflearnfree.org/internetbasics/
2. https://www.howstuffworks.com/
Human civilization developed with the innovation of computer in the twentieth century. Computer development began as the early calculating tool that was essential ingredient for gigantic growth for the existence of human life without computers.

It is true that any language will be outdated when it does not have the ability to adapt itself to the changing technologies. Tamil is the living language for thousands of years. Development of modern technologies, does not affect the growth of classical Tamil as it is ready to adopt the growing technological changes. Tamil is not just a language, it is our identity, our life and our sense.

“சாலையானாள், சாலையானாள் மகாரதாளிர்களுக்கு சாலையானாள்” – புரட்சி கேி.

16.2 Tamil in Internet

We know that the internet is a plays a vital role in every man’s life today. Internet is the best information technological device, through which we get know everything from Internet .

In 2017 a study conducted by KPMG a Singapore based organization along with google, reported that, Tamil topped the list, among the most widely used languages in India where 42% are using the Internet in Tamil.
Moreover in 2021 onwards, 74% of people in India will access internet using Tamil and it will be in the top usage of Internet in India.

These statistical data will be useful to improve internet services in Tamil.
16.3 Search Engines in Tamil

The “Search Engines” are used to search any information from the cyber space. Although there are many search engines, but only a few of them are frequently in use. In the top ten search engines, Google, Bing and Yahoo are takes first three places respectively. Google and Bing provide searching facilities in Tamil, which means you can search everything through Tamil. A Google search engine gives you an inbuilt Tamil virtual keyboard.

![Google Search Engine (India)](image1)

![Google Search Engine (Singapore)](image2)

Figure 16.1(a) Google Search Engine (India)

Figure 16.1(b) Google Search Engine (Singapore)
16.4 e – Governance:

Getting Government services through internet is known as e-Governance. Govt. of Tamilnadu has been giving its services through Internet. One can communicate with Govt. of Tamilnadu from any corner of the state. One can get important announcements, government orders, and government welfare schemes from the web portal of Govt. of Tamilnadu.
### E-Governance through Tamil

<table>
<thead>
<tr>
<th>Official Website of Govt. of Tamilnadu</th>
<th><a href="http://www.tn.gov.in/ta">http://www.tn.gov.in/ta</a></th>
</tr>
</thead>
<tbody>
<tr>
<td>Department of Agricultural Engineering</td>
<td><a href="http://www.aed.tn.gov.in/">http://www.aed.tn.gov.in/</a></td>
</tr>
<tr>
<td>Department of Environment</td>
<td><a href="http://www.environment.tn.nic.in/">http://www.environment.tn.nic.in/</a></td>
</tr>
<tr>
<td>Directorate of Govt. Examinations</td>
<td><a href="http://www.dge.tn.nic.in/">http://www.dge.tn.nic.in/</a></td>
</tr>
<tr>
<td>Tamilnadu Health Department</td>
<td><a href="http://www.tnhealth.org/">http://www.tnhealth.org/</a></td>
</tr>
<tr>
<td>Tamilnadu Micro, Small and Medium Enterprises Department</td>
<td><a href="http://www.msmeonline.tn.gov.in/">http://www.msmeonline.tn.gov.in/</a></td>
</tr>
<tr>
<td>Rural Development and Panchayat Raj Department</td>
<td><a href="http://www.tnrd.gov.in/">http://www.tnrd.gov.in/</a></td>
</tr>
<tr>
<td>Backward, Most Backward and Minorities Welfare Department</td>
<td><a href="http://www.bcmbcmw.tn.gov.in/">http://www.bcmbcmw.tn.gov.in/</a></td>
</tr>
<tr>
<td>Tamilnadu Forest Department</td>
<td><a href="https://www.forests.tn.gov.in/">https://www.forests.tn.gov.in/</a></td>
</tr>
<tr>
<td>Hindu Religious and Charitable Endowments Department</td>
<td><a href="http://www.tnhrce.org/">http://www.tnhrce.org/</a></td>
</tr>
<tr>
<td>Tamil Nadu Public Service Commission (TNPSC)</td>
<td><a href="http://www.tnpsc.gov.in/tamilversion/index.html">http://www.tnpsc.gov.in/tamilversion/index.html</a></td>
</tr>
<tr>
<td>Official Website of Govt. of Srilanka</td>
<td><a href="https://www.gov.lk/index.php">https://www.gov.lk/index.php</a></td>
</tr>
</tbody>
</table>

Outside India, Government of Srilanka provides all their services through the official website in Tamil.

#### 16.5 e-Library

E-Libraries are portal or website of collection of e-books. Tamil e-Library services provide thousands of Tamil Books as ebooks mostly at free of cost. It is the most useful service to Tamil people who live far away from their home land.

<table>
<thead>
<tr>
<th>Tamil e-Library</th>
<th>Website address</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tamilnadu School Education and Teacher Education Training Textbooks and Resource Books</td>
<td><a href="http://www.textbooksonline.tn.nic.in/">http://www.textbooksonline.tn.nic.in/</a></td>
</tr>
<tr>
<td>Tamil Virtual Academy</td>
<td><a href="http://www.tamilvu.org/library/libindex.htm">http://www.tamilvu.org/library/libindex.htm</a></td>
</tr>
<tr>
<td>Tamil Digital Library</td>
<td><a href="http://tamildigitallibrary.in/">http://tamildigitallibrary.in/</a></td>
</tr>
<tr>
<td>Chennai Library</td>
<td><a href="http://www.chennailibrary.com/">http://www.chennailibrary.com/</a></td>
</tr>
<tr>
<td>Thamizhagam</td>
<td><a href="http://www.thamizhagam.net/parithi/parithi.html">http://www.thamizhagam.net/parithi/parithi.html</a></td>
</tr>
<tr>
<td>Project Madurai</td>
<td><a href="http://www.projectmadurai.org/pmworks.html">http://www.projectmadurai.org/pmworks.html</a></td>
</tr>
<tr>
<td>Old Books and Manuscripts</td>
<td><a href="http://www.tamilheritage.org/old/text/ebook/ebook.html">http://www.tamilheritage.org/old/text/ebook/ebook.html</a></td>
</tr>
<tr>
<td>Anna Centenary Libraray</td>
<td><a href="http://www.annacentenarylibrary.org/">http://www.annacentenarylibrary.org/</a></td>
</tr>
</tbody>
</table>
16.6 Tamil Typing and Interface software

Tamil is mostly used to type documents in word processors and search information from internet. Typing Tamil using Tamil interface software is the familiar one among the different methods of typing. This is the simplest method of typing Tamil in both Computer and Smart phones.

16.6.1 Familiar Tamil Keyboard Interface:

- NHM Writer, E-Kalappai and Lippikar – are familiar Tamil keyboard interfaces software that is used for Tamil typing which works on Tamil Unicode, using phonetics.

- Sellinam and Ponmadal – are familiar Tamil keyboard layouts that works on Android operating system in Smart phone using phonetics.

![eKalappai Opening screen](http://thamizha.com)  

Created by: Mugunth, Sethu, Vijay Gupra, Arunam, Venkatesh, Ganasekar...

Figure 16.4 eKalappai Opening screen

16.7 Tamil Office Automation Applications

Famous Office automation software like Microsoft Office, Open Office etc., provides complete Tamil interface facility. These softwares are downloadable and installed in your computer. After installation, your office automation software environment will completely changed to Tamil. Menu bars, names of icons, dialog boxes will be shown in Tamil. Moreover, you can save files with Tamil names and create folders with Tamil names.
Apart from that Tamil Libra Office, Tamil Open Office, Azhagi Unicode Editor, Ponmozhi, Menthamiz, Kamban, Vani are office automation software working exclusively for Tamil. These applications are designed to work completely in Tamil.

16.8 Tamil Translation Applications

Thamizpori (தமிழ்பாறி) is a Tamil translation application having more than 30000 Tamil words equalent to English words. Using this application, we can transalte small english sentences into Tamil. Google also gives an online translation facility, using this online facility we can translate from Tamil to any other language vice versa.

16.9 Tamil Programming Language

Programming languages to develop software to computers and smart phones are available only in English. Now, efforts are taken to develop programming languages in Tamil. Based on Python programming language, the first Tamil programming language “Ezhil” (செழில்) is designed. With the help of this programming language, you can write simple programs in Tamil.
16.10 Tamil Information Interchange Coding Systems

TSCII (Tamil Script Code for Information Interchange)

Computers are handle data and information as binary system. Every data should be converted into binary while it is feed into a computer system. You learnt about all these things in the first unit of this text book. Computers use ASCII encoding system to handle data and information. The ASCII encoding system is applicable only for handling English language. Therefore, TSCII (Tamil Script Code for Information Interchange) is the first coding system to handle our Tamil language in an analysis of an encoding scheme that is easily handled in electronic devices, including non-English computers. This encoding scheme was registered in IANA (Internet Assigned Numbers Authority) unit of ICANN.

ISCII (Indian Script Code for Information Interchange)

This is one of the encoding schemes specially designed for Indian languages including Tamil. It was unified with Unicode.

Unicode:

Unicode is an encoding system, designed to handle various world languages, including Tamil. Its first version 1.0.0 was introduced on October 1991. While introduction of this scheme, can be able to handle nearly 23 languages including Tamil. Among the various encoding scheme, Unicode is the suitable to handle Tamil.

16.11 Tamil Operating System

An operating system is needed to access electronic systems such as computer and smart phone. Microsoft Windows is very popular operating system for personal computers. Linux is another popular open source operating system. Operating systems are used to access a computer easily. An operating system should be easy to work and its environment should be in understandable form. Thus, all operating systems used in computers and smart phones offered environment in Tamil.

Windows Tamil Environment interface should be downloaded and install from internet. It shows all windows elements such as Taskbar, desktop elements, names of icons, commands in Tamil.

16.12 Organisation and projects to develop Tamil

Tamil Virtual Academy:

With the objectives of spreading Tamil to the entire world through internet, Tamil Virtual University was established on 17th February 2001 by the Govt. of Tamilnadu. Now, this organisation functioning with the name “Tamil Virtual Academy”. This organisation offers different courses regarding Tamil language, Culture, heritage etc., from kindergarten to under graduation level.
Tamil Language Council, Singapore

With the objectives of promoting the awareness and greater use of Tamil among the Singaporeans, in 2001 the council of Tamil Language was formed by the ministry of Information Communications and Arts, Govt. of Singapore. The council is called as “மாண்டியக் கமண்டம்”.

Madurai Project

Project Madurai is an open and voluntary initiative to collect and publish free electronic editions of ancient tamil literary classics. This means either typing-in or scanning old books and archiving the text in one of the most readily accessible formats for use on all popular computer platforms.


Website: http://www.projectmadurai.org/

Tamil Wikipedia:

Wikipedia is a open source encyclopedia. Any person can write article about any subject. In Tamil Wikipedia has more than 1 lacks articles.
In order to make Tamil as a living language, it is the duty of every Tamilian to make participate Tamil in development of technology. Those who forgotten their values, they will be considered as “Nomads”. Learning of new technologies will be fulfilled only with a inclusion of our Tamil language which is our race. It is our duty to combine our world’s first language and language for more than five thousand years with growing technology.

Points to Remember:

- Tamil topped the list of the most widely used languages in India by the end of 2016, while 42% are using the Internet.
- Google and Bing provide searching facilities in Tamil.
- Getting Government services through internet is known as e-Governance.
- Tamil e-Library services provide thousands of Tamil Books as ebooks mostly at free of cost.
- Thamizpori (தமிழ்பாறி) is a Tamil translation application having more than 30000 Tamil words equalent to English words.
- The first Tamil programming language is “Ezhil” (எழில்)
- Unicode is an encoding system, designed to handle various world languages, including Tamil.
- Among the various encoding scheme, Unicode is the suitable to handle Tamil.
- Windows Tamil Environment interface should be downloading and install from internet.

Evaluation

Answer to the following questions
1. List of the search engines supporting Tamil.
2. What are the keyboard layouts used in Android?
3. Write a short note about Tamil Programming Language.
4. What TSCII?
5. Write a short note on Tamil Virtual Academy.

****
List of Authors and Reviewers

Domain Expert
Mrs. Sasikalaa K.
Associate Professor,
Dept. of Computer Science, Queen Mary's College, Chennai.

Reviewers
Dr. T.V. Gopal
Professor,
Dept. of Computer Science and Technology,
College of Engineering, Guindy, Anna University, Chennai.

Dr. Ranjani Parthasarathi
Professor,
Dept. of Info Science and Technology,
College of Engineering, Guindy, Anna University, Chennai.

Authors
Mr. Sreenivasan R.
Post Graduate Teacher,
Santhome Hr Sec School, Mylapore, Chennai.

Mr. Kannan K.
Post Graduate Teacher,
Chennai Girls Hr Sec School, Botlier Street, Chennai.

Mrs. Bindhu Mohandas
Post Graduate Teacher,
Vijayanta Model Hr Sec School, H V F Estate, Avadi, Chennai.

Dr. T.V . Gopal
Professor,
Dept. of Computer Science and Technology,
College of Engineering, Guindy, Anna University, Chennai.

Dr. Ranjani Parthasarathi
Professor,
Dept. of Info Science and Technology,
College of Engineering, Guindy, Anna University, Chennai.

Content Experts
Dr. Radha P.
Assistant Professor,
Dept. of Information Technology,
Govt. Arts & Science College (A), Coimbatore.

Dr. Nester Jayakumar M.
Associate Professor and Head of the Department,
Dept. of Computer Science, Loyola College, Chennai.

Dr. Srinivasa N.
Professor,
Dept. of Computer Science and Engineering,
Sathyabama Institute of Science & Technology, Chennai.

Mr. Sethuraman R.
Assistant Professor,
Dept. of Computer Science and Engineering,
Sathyabama Institute of Science & Technology, Chennai.

Art and Design Team

Layout
THY Designers and Computers
Chennai.

Wrapper Design
Kathir Arumugam

QC
Manohar Radhakrishnan

Gopu Rasuvel

Co-ordination
Ramesh Munisamy

Typist
T. Meena

SCERT, Chennai.

Academic Coordinators

Mr. Ravikumar Arumugam
Deputy Director,
State Council of Educational Research and Training, Chennai.

Mrs. Tamil Selvi R.
B.T. Assistant,
Government High School, Poonampalayam, Trichy District.

QR Code Team

R. Jaganathan,
S.G.T., PUMS, Ganesapuram - Polur, Thiruvannamalai Dist.

N. Jagan,
B.T. Asst., GBHSS, Uthiramerur, Kancheepuram Dist.

J.F. Paul Edwin Roy,
B.T. Asst., PUMS, Rakkipatti, Salem Dist.

This book has been printed on 80 G.S.M.
Elegant Maplitho paper.

Printed by offset at: